source: projects/specs/trunk/t/texlive-collection-genericrecommended/texlive-collection-genericrecommended-vl.spec @ 8744

Revision 8744, 6.0 KB checked in by munepi, 10 years ago (diff)

synced tlnet to 20140706

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2014-2:
3## tlpdb2rpmspec collection-genericrecommended
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9Summary: TeX Live: Generic recommended packages
10Summary(ja): TeX Live: Generic recommended packages
11Name: texlive-collection-genericrecommended
12Version: 2014
13Release: 2%{?_dist_release}
14License: Public Domain, GPL+, Freely redistributable without restriction, LPPL
15Group: Applications/Publishing
16URL:http://www.tug.org/texlive/
17
18Source0: epsf.doc.tar.xz
19Source1: epsf.tar.xz
20Source2: fontname.doc.tar.xz
21Source3: fontname.tar.xz
22Source4: genmisc.tar.xz
23Source5: kastrup.doc.tar.xz
24Source6: kastrup.source.tar.xz
25Source7: kastrup.tar.xz
26Source8: multido.doc.tar.xz
27Source9: multido.source.tar.xz
28Source10: multido.tar.xz
29Source11: path.doc.tar.xz
30Source12: path.tar.xz
31Source13: tex-ps.doc.tar.xz
32Source14: tex-ps.tar.xz
33Source15: ulem.doc.tar.xz
34Source16: ulem.tar.xz
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41
42BuildArch:      noarch
43Buildroot:      %{_tmppath}/%{name}-%{version}-root
44
45Vendor:         Project Vine
46Distribution:   Vine Linux
47Packager:       munepi
48
49%description
50The TeX Live software distribution offers a complete TeX system for a
51variety of Unix, Macintosh, Windows and other platforms. It
52encompasses programs for editing, typesetting, previewing and printing
53of TeX documents in many different languages, and a large collection
54of TeX macros and font libraries.
55
56The distribution includes extensive general documentation about TeX,
57as well as the documentation for the included software packages.
58
59This package is a collection of Generic recommended packages:
60Recommended packages that work with multiple formats.
61
62This package contains the following CTAN packages:
63epsf: Simple macros for EPS inclusion.
64fontname: Scheme for naming fonts in TeX.
65genmisc:
66kastrup: Convert numbers into binary, octal and hexadecimal.
67multido: A loop facility for Generic TeX.
68path: Typeset paths, making them breakable.
69tex-ps: TeX to PostScript generic macros and add-ons.
70ulem: Package for underlining.
71
72%description -l ja
73TeX Live ソフトウェアディストリビューションは、
74さまざまな Unix, Macintosh, Windows、および
75他のプラットホームに対して完全な TeX システムを提供します。
76多くの異なった言語を含む TeX ドキュメントの
77編集、組版、閲覧、印刷するためのプログラム、
78そして、TeX マクロやフォントライブラリの大きなコレクションを
79同梱しています。
80
81このディストリビューションは
82同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
83TeX に関するたくさんの一般的なドキュメントを含んでいます。
84
85このパッケージは以下のようなパッケージ集です。
86Generic recommended packages:
87Recommended packages that work with multiple formats.
88
89このパッケージは以下の CTAN パッケージを含んでいます:
90epsf: Simple macros for EPS inclusion.
91fontname: Scheme for naming fonts in TeX.
92genmisc:
93kastrup: Convert numbers into binary, octal and hexadecimal.
94multido: A loop facility for Generic TeX.
95path: Typeset paths, making them breakable.
96tex-ps: TeX to PostScript generic macros and add-ons.
97ulem: Package for underlining.
98
99%package doc
100Summary: TeX Live: Documentation files of %{name}
101Group: Applications/Publishing
102Requires: %{name} = %{version}-%{release}
103
104%description doc
105This package contains documentation files of %{name}.
106
107%prep
108%setup -c -n %{name}-%{version}
109%__tar -xvf %{SOURCE1}
110%__tar -xvf %{SOURCE2}
111%__tar -xvf %{SOURCE3}
112%__tar -xvf %{SOURCE4}
113%__tar -xvf %{SOURCE5}
114%__tar -xvf %{SOURCE6}
115%__tar -xvf %{SOURCE7}
116%__tar -xvf %{SOURCE8}
117%__tar -xvf %{SOURCE9}
118%__tar -xvf %{SOURCE10}
119%__tar -xvf %{SOURCE11}
120%__tar -xvf %{SOURCE12}
121%__tar -xvf %{SOURCE13}
122%__tar -xvf %{SOURCE14}
123%__tar -xvf %{SOURCE15}
124%__tar -xvf %{SOURCE16}
125
126%build
127
128%install
129[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
130
131%__mkdir_p %{buildroot}%{_datadir}
132
133## move texmf-dist to /usr/share/texmf-dist
134[ -d texmf-dist ] && %__mv texmf-dist %{buildroot}%{_tl_texmfdist}/ ||:
135
136## move texmf to /usr/share/texmf
137[ -d texmf ] && %__mv texmf %{buildroot}%{_tl_texmfmain}/ ||:
138
139## move tlpkg to /usr/share/tlpkg
140[ -d tlpkg ] && %__mv tlpkg %{buildroot}%{_datadir}/ ||:
141
142## move all non-arch binaries to /usr/bin
143[ -d bin ] && %__mv bin %{buildroot}%{_prefix}/ ||:
144
145## move others into /usr/share/texmf-dist
146%__mkdir_p %{buildroot}%{_tl_texmfdist}
147%__cp -a * %{buildroot}%{_tl_texmfdist}/ ||:
148%__rm -rf * ||:
149
150
151## remove duplicated files between texlive and texlive-collection-*
152## NOTE: We provides texmf.cnf and updmap{-hdr,}.cfg from texlive
153## remove unpacked files
154x=(
155scripts/texlive/fmtutil.sh
156texconfig/tcfmgr
157web2c/texmf.cnf
158web2c/updmap-hdr.cfg
159web2c/updmap.cfg
160install-tl
161)
162if [ -d %{buildroot}%{_tl_texmfdist} ]; then
163pushd %{buildroot}%{_tl_texmfdist}
164%__rm -f ${x[@]} ||:
165popd
166fi
167
168## Files list
169find %{buildroot} -type f -or -type l | \
170    %__sed -e "s|%{buildroot}||g" > filelist.full
171
172find %{buildroot}%{_tl_texmfdist} -type d | \
173    %__sed -e "s|^%{buildroot}|%dir |" \
174           -e "s|$|/|"             >> filelist.full
175
176## subpackages
177grep "/texmf-dist/doc/" filelist.full > filelist.doc
178cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
179%__mv -f filelist.tmp filelist.full
180
181%clean
182%__rm -rf %{buildroot}
183
184%post
185%_tl_touch_run texhash
186%_tl_touch_run mtxrun
187
188exit 0
189
190
191%postun
192if [ "$1" = 0 ]; then
193    %_tl_touch_run texhash
194
195fi
196
197exit 0
198
199%posttrans
200%{_tl_exec_texhash}
201%{_tl_exec_mtxrun}
202%{_tl_exec_updmap}
203%{_tl_exec_fmtutil}
204exit 0
205
206
207%files -f filelist.full
208%defattr(-,root,root,-)
209
210%files -f filelist.doc doc
211%defattr(-,root,root,-)
212
213%changelog
214* Sun Jul  6 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-2
215- synced tlnet to 20140706
216
217* Sun May 25 2014 Munehiro Yamamoto <munepi@vinelinux.org> 2014-1
218- synced tlnet to 20140524
Note: See TracBrowser for help on using the repository browser.