source: projects/specs/trunk/t/texlive-collection-genericrecommended/texlive-collection-genericrecommended-vl.spec @ 7148

Revision 7148, 24.0 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-genericrecommended
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Recommended generic packages
48Summary(ja): TeX Live: Recommended generic packages
49Name: texlive-collection-genericrecommended
50Version: 2012
51Release: 1%{?_dist_release}
52License: Public Domain, GPL+, LPPL, Freely redistributable without restriction
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
61#BuildRequires:         texlive-sources = %{version}
62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Recommended generic packages:
81Recommended packages that work with multiple formats.
82
83This package contains the following CTAN packages:
84epsf: Simple macros for EPS inclusion.
85fontname: Scheme for naming fonts in TeX.
86genmisc:
87kastrup:
88multido: A loop facility for Generic TeX.
89path: Typeset paths, making them breakable.
90tex-ps: TeX to PostScript generic macros and add-ons.
91ulem: Package for underlining.
92
93%description -l ja
94TeX Live ソフトウェアディストリビューションは、
95さまざまな Unix, Macintosh, Windows、および
96他のプラットホームに対して完全な TeX システムを提供します。
97多くの異なった言語を含む TeX ドキュメントの
98編集、組版、閲覧、印刷するためのプログラム、
99そして、TeX マクロやフォントライブラリの大きなコレクションを
100同梱しています。
101
102このディストリビューションは
103同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
104TeX に関するたくさんの一般的なドキュメントを含んでいます。
105
106このパッケージは以下のようなパッケージ集です。
107Recommended generic packages:
108Recommended packages that work with multiple formats.
109
110このパッケージは以下の CTAN パッケージを含んでいます:
111epsf: Simple macros for EPS inclusion.
112fontname: Scheme for naming fonts in TeX.
113genmisc:
114kastrup:
115multido: A loop facility for Generic TeX.
116path: Typeset paths, making them breakable.
117tex-ps: TeX to PostScript generic macros and add-ons.
118ulem: Package for underlining.
119
120%package doc
121Summary: TeX Live: Documentation files of %{name}
122Group: Applications/Publishing
123Requires: %{name} = %{version}-%{release}
124
125%description doc
126This package contains documentation files of %{name}.
127
128%prep
129
130%build
131
132%install
133[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
134
135PREF=%{buildroot}%{tex_destdir}
136
137manifest=(
138texmf-dist/doc/generic/epsf/LICENSE
139texmf-dist/doc/generic/epsf/Makefile
140texmf-dist/doc/generic/epsf/README
141texmf-dist/doc/generic/epsf/bboxgrid.ps
142texmf-dist/doc/generic/epsf/epsf-doc.pdf
143texmf-dist/doc/generic/epsf/epsf-doc.tex
144texmf-dist/doc/generic/epsf/fndbadps
145texmf-dist/doc/generic/epsf/okay/teps.eps
146texmf-dist/doc/generic/epsf/okay/tepsf.eps
147texmf-dist/doc/generic/epsf/okay/tepsf1.dvi
148texmf-dist/doc/generic/epsf/okay/tepsf2.dvi
149texmf-dist/doc/generic/epsf/okay/tepsf3.dvi
150texmf-dist/doc/generic/epsf/teps.eps
151texmf-dist/doc/generic/epsf/tepsf.eps
152texmf-dist/doc/generic/epsf/tepsf1.tex
153texmf-dist/doc/generic/epsf/tepsf2.ltx
154texmf-dist/doc/generic/epsf/tepsf3.tex
155texmf-dist/tex/generic/epsf/epsf.sty
156texmf-dist/tex/generic/epsf/epsf.tex
157texmf-dist/doc/fonts/fontname/8a.html
158texmf-dist/doc/fonts/fontname/8r.html
159texmf-dist/doc/fonts/fontname/Adobe-fonts.html
160texmf-dist/doc/fonts/fontname/Apple-fonts.html
161texmf-dist/doc/fonts/fontname/Bitstream-fonts.html
162texmf-dist/doc/fonts/fontname/ChangeLog
163texmf-dist/doc/fonts/fontname/DTC-fonts.html
164texmf-dist/doc/fonts/fontname/Encodings.html
165texmf-dist/doc/fonts/fontname/Filenames-for-fonts.html
166texmf-dist/doc/fonts/fontname/Font-legalities.html
167texmf-dist/doc/fonts/fontname/Font-name-lists.html
168texmf-dist/doc/fonts/fontname/History.html
169texmf-dist/doc/fonts/fontname/ITC-fonts.html
170texmf-dist/doc/fonts/fontname/Introduction.html
171texmf-dist/doc/fonts/fontname/Linotype-fonts.html
172texmf-dist/doc/fonts/fontname/Long-names.html
173texmf-dist/doc/fonts/fontname/Long-naming-scheme.html
174texmf-dist/doc/fonts/fontname/Makefile
175texmf-dist/doc/fonts/fontname/Monotype-fonts.html
176texmf-dist/doc/fonts/fontname/Name-mapping-file.html
177texmf-dist/doc/fonts/fontname/References.html
178texmf-dist/doc/fonts/fontname/Standard-PostScript-fonts.html
179texmf-dist/doc/fonts/fontname/Suppliers.html
180texmf-dist/doc/fonts/fontname/Typefaces.html
181texmf-dist/doc/fonts/fontname/URW-fonts.html
182texmf-dist/doc/fonts/fontname/Variants.html
183texmf-dist/doc/fonts/fontname/Weights.html
184texmf-dist/doc/fonts/fontname/Widths.html
185texmf-dist/doc/fonts/fontname/bitstrea.aka
186texmf-dist/doc/fonts/fontname/cork.html
187texmf-dist/doc/fonts/fontname/dvips.html
188texmf-dist/doc/fonts/fontname/fontname.aux
189texmf-dist/doc/fonts/fontname/fontname.cp
190texmf-dist/doc/fonts/fontname/fontname.html
191texmf-dist/doc/fonts/fontname/fontname.pdf
192texmf-dist/doc/fonts/fontname/fontname.texi
193texmf-dist/doc/fonts/fontname/fontname.toc
194texmf-dist/doc/fonts/fontname/index.html
195texmf-dist/doc/fonts/fontname/texmext.html
196texmf-dist/doc/fonts/fontname/texmital.html
197texmf-dist/doc/fonts/fontname/texmsym.html
198texmf-dist/doc/fonts/fontname/texnansi.html
199texmf-dist/doc/fonts/fontname/texnansx.html
200texmf-dist/doc/fonts/fontname/xl2.html
201texmf-dist/doc/fonts/fontname/xt2.html
202texmf-dist/fonts/map/fontname/adobe.map
203texmf-dist/fonts/map/fontname/apple.map
204texmf-dist/fonts/map/fontname/bitstrea.map
205texmf-dist/fonts/map/fontname/dtc.map
206texmf-dist/fonts/map/fontname/itc.map
207texmf-dist/fonts/map/fontname/linot-cd.map
208texmf-dist/fonts/map/fontname/linotype-cd.map
209texmf-dist/fonts/map/fontname/linotype.map
210texmf-dist/fonts/map/fontname/monotype.map
211texmf-dist/fonts/map/fontname/skey1250.map
212texmf-dist/fonts/map/fontname/skey1555.map
213texmf-dist/fonts/map/fontname/softkey-1250.map
214texmf-dist/fonts/map/fontname/softkey-1555.map
215texmf-dist/fonts/map/fontname/softkey.map
216texmf-dist/fonts/map/fontname/special.map
217texmf-dist/fonts/map/fontname/supplier.map
218texmf-dist/fonts/map/fontname/texfonts.map
219texmf-dist/fonts/map/fontname/typeface.map
220texmf-dist/fonts/map/fontname/urw.map
221texmf-dist/fonts/map/fontname/variant.map
222texmf-dist/fonts/map/fontname/weight.map
223texmf-dist/fonts/map/fontname/width.map
224texmf-dist/fonts/map/fontname/yandy.map
225texmf-dist/tex/generic/genmisc/anti.tex
226texmf-dist/tex/generic/genmisc/apldef.tex
227texmf-dist/tex/generic/genmisc/arabic.tex
228texmf-dist/tex/generic/genmisc/backgrnd.tex
229texmf-dist/tex/generic/genmisc/balancedquotes.sty
230texmf-dist/tex/generic/genmisc/chessmin.tex
231texmf-dist/tex/generic/genmisc/compare.tex
232texmf-dist/tex/generic/genmisc/cropmark.sty
233texmf-dist/tex/generic/genmisc/cropmark.tex
234texmf-dist/tex/generic/genmisc/croptest.tex
235texmf-dist/tex/generic/genmisc/dayofweek.tex
236texmf-dist/tex/generic/genmisc/daytime.sty
237texmf-dist/tex/generic/genmisc/default.sty
238texmf-dist/tex/generic/genmisc/dow.tex
239texmf-dist/tex/generic/genmisc/emtrees.tex
240texmf-dist/tex/generic/genmisc/endnote.tex
241texmf-dist/tex/generic/genmisc/fakebold.tex
242texmf-dist/tex/generic/genmisc/hep.tex
243texmf-dist/tex/generic/genmisc/hexdump.sty
244texmf-dist/tex/generic/genmisc/inscrutable.tex
245texmf-dist/tex/generic/genmisc/laps.tex
246texmf-dist/tex/generic/genmisc/letterspacing.tex
247texmf-dist/tex/generic/genmisc/longdiv.tex
248texmf-dist/tex/generic/genmisc/mandel.tex
249texmf-dist/tex/generic/genmisc/mathlig.tex
250texmf-dist/tex/generic/genmisc/nth.sty
251texmf-dist/tex/generic/genmisc/outerhbox.sty
252texmf-dist/tex/generic/genmisc/pagereference.tex
253texmf-dist/tex/generic/genmisc/quotation.tex
254texmf-dist/tex/generic/genmisc/ragged.sty
255texmf-dist/tex/generic/genmisc/random.tex
256texmf-dist/tex/generic/genmisc/ruler.tex
257texmf-dist/tex/generic/genmisc/selectpage.tex
258texmf-dist/tex/generic/genmisc/shadebox.tex
259texmf-dist/tex/generic/genmisc/swrule.sty
260texmf-dist/tex/generic/genmisc/underlin.tex
261texmf-dist/tex/generic/genmisc/undertilde.tex
262texmf-dist/tex/generic/genmisc/verbatim.tex
263texmf-dist/tex/generic/genmisc/weekday.sty
264texmf-dist/tex/generic/genmisc/wiggly.tex
265texmf-dist/tex/generic/genmisc/zip.tex
266texmf-dist/doc/generic/kastrup/binhex.pdf
267texmf-dist/source/generic/kastrup/binhex.drv
268texmf-dist/source/generic/kastrup/binhex.dtx
269texmf-dist/source/generic/kastrup/binhex.ins
270texmf-dist/tex/generic/kastrup/binhex.tex
271texmf-dist/doc/generic/multido/Changes
272texmf-dist/doc/generic/multido/multido-doc.pdf
273texmf-dist/doc/generic/multido/multido-doc.tex
274texmf-dist/doc/generic/multido/multido.pdf
275texmf-dist/source/generic/multido/Makefile
276texmf-dist/tex/generic/multido/multido.tex
277texmf-dist/tex/latex/multido/multido.sty
278texmf-dist/doc/generic/path/path-doc.pdf
279texmf-dist/doc/generic/path/path-doc.tex
280texmf-dist/tex/generic/path/path.sty
281texmf-dist/doc/generic/tex-ps/cmyk-hax/README
282texmf-dist/doc/generic/tex-ps/cmyk-hax/cmyk-doc.pdf
283texmf-dist/doc/generic/tex-ps/cmyk-hax/fountain.eps
284texmf-dist/doc/generic/tex-ps/cmyk-hax/gdansk.eps
285texmf-dist/doc/generic/tex-ps/cmyk-hax/rules.tex
286texmf-dist/doc/generic/tex-ps/cmyk-hax/sam1-sep.bat
287texmf-dist/doc/generic/tex-ps/cmyk-hax/sample1.tex
288texmf-dist/doc/generic/tex-ps/cmyk-hax/sample2.tex
289texmf-dist/doc/generic/tex-ps/cmyk-hax/sample3.tex
290texmf-dist/doc/generic/tex-ps/cmyk-hax/sample4.tex
291texmf-dist/doc/generic/tex-ps/cmyk-hax/screen.eps
292texmf-dist/doc/generic/tex-ps/poligraf/README
293texmf-dist/doc/generic/tex-ps/poligraf/kol-cmyk.eps
294texmf-dist/doc/generic/tex-ps/poligraf/sample.tex
295texmf-dist/doc/generic/tex-ps/poligraf/samplelx.tex
296texmf-dist/dvips/tex-ps/crops.pro
297texmf-dist/dvips/tex-ps/mirr.hd
298texmf-dist/dvips/tex-ps/separate.pro
299texmf-dist/tex/generic/tex-ps/cmyk-hax.tex
300texmf-dist/tex/generic/tex-ps/epsfx.tex
301texmf-dist/tex/generic/tex-ps/poligraf.sty
302texmf-dist/tex/generic/tex-ps/trans.tex
303texmf-dist/doc/generic/ulem/README
304texmf-dist/doc/generic/ulem/ulem.ltx
305texmf-dist/doc/generic/ulem/ulem.pdf
306texmf-dist/tex/generic/ulem/ulem.sty
307)
308
309%__mkdir_p ${PREF}/texmf-dist
310for i in "${manifest[@]}"; do
311    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
312done
313## make symlinks of core script utils
314mk_symlinks=(
315texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
316texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
317texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
318texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
319texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
320texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
321texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
322texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
323texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
324texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
325texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
326texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
327texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
328texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
329texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
330texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
331texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
332texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
333texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
334texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
335texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
336texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
337texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
338texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
339texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
340texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
341texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
342texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
343texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
344texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
345texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
346texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
347texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
348texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
349texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
350texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
351texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
352texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
353texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
354texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
355texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
356texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
357texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
358texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
359texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
360texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
361texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
362texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
363texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
364texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
365texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
366texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
367texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
368texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
369texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
370texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
371texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
372texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
373texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
374texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
375texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
376texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
377texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
378texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
379texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
380texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
381texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
382texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
383texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
384texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
385texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
386texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
387texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
388texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
389texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
390texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
391texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
392texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
393texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
394texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
395texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
396texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
397texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
398texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
399texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
400texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
401texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
402texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
403texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
404texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
405texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
406texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
407texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
408)
409%__mkdir_p %{buildroot}%{_bindir}
410pushd %{buildroot}%{_bindir}
411    for i in "${mk_symlinks[@]}"; do
412        tlc=$(/bin/echo $i | cut -f 1 -d",")
413        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
414        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
415
416        [ "%{name}" = "$tlc" ] || continue
417        [ -f $rlnk ] || exit 1
418        %__ln_s $rlnk $lnk || exit 1
419    done
420popd
421## Files list
422find %{buildroot} -type f -or -type l | \
423    %__sed -e "s|%{buildroot}||g" > filelist.full
424
425find %{buildroot}%{texmf}-dist -type d | \
426    %__sed -e "s|^%{buildroot}|%dir |" \
427           -e "s|$|/|"             >> filelist.full
428
429## subpackages
430grep "/texmf-dist/doc/" filelist.full > filelist.doc
431cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
432%__mv -f filelist.tmp filelist.full
433
434%clean
435%__rm -rf %{buildroot}
436
437%post
438%touch_run texhash
439%touch_run mtxrun
440
441exit 0
442
443
444%postun
445if [ "$1" = 0 ]; then
446    %touch_run texhash
447
448fi
449
450exit 0
451
452%posttrans
453%{exec_texhash}
454%{exec_mtxrun}
455%{exec_updmap}
456%{exec_fmtutil}
457exit 0
458
459
460%files -f filelist.full
461%defattr(-,root,root,-)
462
463%files -f filelist.doc doc
464%defattr(-,root,root,-)
465
466%changelog
467* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
468- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-genericrecommended
469
470* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
471- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-genericrecommended
472- set external dependencies (texlive-collection-binextra,
473  texlive-collection-fontutils)
474
475* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
476- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-genericrecommended
477
478* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
479- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-genericrecommended
480- make symlinks of core script utils (texlive-collection-binextra,
481  texlive-collection-context, texlive-collection-fontutils,
482  texlive-collection-langgreek, texlive-collection-langindic,
483  texlive-collection-latex, texlive-collection-latexextra,
484  texlive-collection-latexrecommended, texlive-collection-pictures,
485  texlive-collection-pstricks, texlive-collection-science)
486
487* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
488- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-genericrecommended
489- improved %%post
490
491* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
492- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-genericrecommended
493- removed arch dependent binaries (texlive-collection-latexextra)
494- fixed perl path
495- improved updmap process in %%post and %%postun
496
497* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
498- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-genericrecommended
Note: See TracBrowser for help on using the repository browser.