source: projects/specs/trunk/t/texlive-collection-genericextra/texlive-collection-genericextra-vl.spec @ 7148

Revision 7148, 31.6 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-genericextra
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Extra generic packages
48Summary(ja): TeX Live: Extra generic packages
49Name: texlive-collection-genericextra
50Version: 2012
51Release: 1%{?_dist_release}
52License: Public Domain, Freely redistributable without restriction, LPPL, LPPL 1.3, No Info, GPL+, Knuth
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
61#BuildRequires:         texlive-sources = %{version}
62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Extra generic packages:
81Extra packages that work with multiple formats, typically both
82TeX and LaTeX.
83
84This package contains the following CTAN packages:
85abbr: Simple macros supporting abreviations for Plain and LaTeX.
86abstyles: Adaptable BibTeX styles.
87barr: Diagram macros by Michael Barr.
88bitelist: Split list, in TeX's mouth.
89borceux: Diagram macros by Francois Borceux.
90c-pascal: Typeset Python, C and Pascal programs.
91chronosys: Drawing time-line diagrams.
92colorsep: Color separation.
93dinat: Bibliography style for German texts.
94dirtree: Display trees in the style of windows explorer.
95dowith:
96eijkhout: Victor Eijkhout's packages.
97encxvlna: Insert nonbreakable spaces, using encTeX.
98epigram: Display short quotations.
99fenixpar: One-shot changes to token registers such as everypar.
100fltpoint: Simple floating point arithmetic.
101fntproof: A programmable font test pattern generator.
102gates: Support for writing modular and customisable code.
103ifetex: Provides ifetex switch.
104iftex: Am I running under pdfTeX, XeTeX or LuaTeX?
105insbox: A TeX macro for inserting pictures/boxes into paragraphs.
106lecturer: On-screen presentations for (almost) all formats.
107librarian: Tools to create bibliographies in TeX.
108mathdots: Commands to produce dots in math that respect font size.
109metatex: Incorporate MetaFont pictures in TeX source.
110midnight: A set of useful macro tools.
111multi:
112navigator: PDF features across formats and engines.
113ofs: Macros for managing large font collections.
114pdf-trans: A set of macros for various transformations of TeX boxes.
115shade: Shade pieces of text.
116systeme: Format systems of equations.
117tabto-generic: "Tab" to a measured position in the line.
118texapi: Macros to write format-independent packages.
119upca:
120xlop: Calculates and displays arithmetic operations.
121yax: Yet Another Key System.
122
123%description -l ja
124TeX Live ソフトウェアディストリビューションは、
125さまざまな Unix, Macintosh, Windows、および
126他のプラットホームに対して完全な TeX システムを提供します。
127多くの異なった言語を含む TeX ドキュメントの
128編集、組版、閲覧、印刷するためのプログラム、
129そして、TeX マクロやフォントライブラリの大きなコレクションを
130同梱しています。
131
132このディストリビューションは
133同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
134TeX に関するたくさんの一般的なドキュメントを含んでいます。
135
136このパッケージは以下のようなパッケージ集です。
137Extra generic packages:
138Extra packages that work with multiple formats, typically both
139TeX and LaTeX.
140
141このパッケージは以下の CTAN パッケージを含んでいます:
142abbr: Simple macros supporting abreviations for Plain and LaTeX.
143abstyles: Adaptable BibTeX styles.
144barr: Diagram macros by Michael Barr.
145bitelist: Split list, in TeX's mouth.
146borceux: Diagram macros by Francois Borceux.
147c-pascal: Typeset Python, C and Pascal programs.
148chronosys: Drawing time-line diagrams.
149colorsep: Color separation.
150dinat: Bibliography style for German texts.
151dirtree: Display trees in the style of windows explorer.
152dowith:
153eijkhout: Victor Eijkhout's packages.
154encxvlna: Insert nonbreakable spaces, using encTeX.
155epigram: Display short quotations.
156fenixpar: One-shot changes to token registers such as everypar.
157fltpoint: Simple floating point arithmetic.
158fntproof: A programmable font test pattern generator.
159gates: Support for writing modular and customisable code.
160ifetex: Provides ifetex switch.
161iftex: Am I running under pdfTeX, XeTeX or LuaTeX?
162insbox: A TeX macro for inserting pictures/boxes into paragraphs.
163lecturer: On-screen presentations for (almost) all formats.
164librarian: Tools to create bibliographies in TeX.
165mathdots: Commands to produce dots in math that respect font size.
166metatex: Incorporate MetaFont pictures in TeX source.
167midnight: A set of useful macro tools.
168multi:
169navigator: PDF features across formats and engines.
170ofs: Macros for managing large font collections.
171pdf-trans: A set of macros for various transformations of TeX boxes.
172shade: Shade pieces of text.
173systeme: Format systems of equations.
174tabto-generic: "Tab" to a measured position in the line.
175texapi: Macros to write format-independent packages.
176upca:
177xlop: Calculates and displays arithmetic operations.
178yax: Yet Another Key System.
179
180%package doc
181Summary: TeX Live: Documentation files of %{name}
182Group: Applications/Publishing
183Requires: %{name} = %{version}-%{release}
184
185%description doc
186This package contains documentation files of %{name}.
187
188%prep
189
190%build
191
192%install
193[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
194
195PREF=%{buildroot}%{tex_destdir}
196
197manifest=(
198texmf-dist/doc/generic/abbr/README
199texmf-dist/tex/generic/abbr/abbr.tex
200texmf-dist/doc/bibtex/abstyles/README
201texmf-dist/doc/bibtex/abstyles/a4c.sty
202texmf-dist/doc/bibtex/abstyles/a4c.tex
203texmf-dist/doc/bibtex/abstyles/abstdok.pdf
204texmf-dist/doc/bibtex/abstyles/abstdok.tex
205texmf-dist/doc/bibtex/abstyles/apreambl.doc
206texmf-dist/doc/bibtex/abstyles/btxabst.doc
207texmf-dist/doc/bibtex/abstyles/docmac.doc
208texmf-dist/doc/bibtex/abstyles/docmac.tex
209texmf-dist/bibtex/bib/abstyles/acompat.bib
210texmf-dist/bibtex/bib/abstyles/jourabbr.bib
211texmf-dist/bibtex/bib/abstyles/jourfull.bib
212texmf-dist/bibtex/bst/abstyles/aabbrv.bst
213texmf-dist/bibtex/bst/abstyles/aalpha.bst
214texmf-dist/bibtex/bst/abstyles/anotit.bst
215texmf-dist/bibtex/bst/abstyles/aplain.bst
216texmf-dist/bibtex/bst/abstyles/aunsnot.bst
217texmf-dist/bibtex/bst/abstyles/aunsrt.bst
218texmf-dist/tex/generic/abstyles/apreambl.tex
219texmf-dist/doc/generic/barr/diaxydoc.pdf
220texmf-dist/doc/generic/barr/diaxydoc.tex
221texmf-dist/tex/generic/barr/diagxy.tex
222texmf-dist/doc/generic/bitelist/README
223texmf-dist/doc/generic/bitelist/bitelist.pdf
224texmf-dist/source/generic/bitelist/bitelist.tex
225texmf-dist/source/generic/bitelist/srcfiles.tex
226texmf-dist/tex/generic/bitelist/bitedemo.tex
227texmf-dist/tex/generic/bitelist/bitelist.sty
228texmf-dist/doc/generic/borceux/Diagram_Mode_d_Emploi
229texmf-dist/doc/generic/borceux/Diagram_Read_Me
230texmf-dist/doc/generic/borceux/README
231texmf-dist/doc/generic/borceux/compatibility/OldDiagram
232texmf-dist/doc/generic/borceux/compatibility/OldMaxiDiagram
233texmf-dist/doc/generic/borceux/compatibility/OldMicroDiagram
234texmf-dist/doc/generic/borceux/compatibility/OldMiniDiagram
235texmf-dist/doc/generic/borceux/compatibility/OldMultipleArrows
236texmf-dist/tex/generic/borceux/Diagram
237texmf-dist/tex/generic/borceux/MaxiDiagram
238texmf-dist/tex/generic/borceux/MicroDiagram
239texmf-dist/tex/generic/borceux/MiniDiagram
240texmf-dist/tex/generic/borceux/MultipleArrows
241texmf-dist/doc/generic/c-pascal/README.eng
242texmf-dist/doc/generic/c-pascal/README.pol
243texmf-dist/doc/generic/c-pascal/demo1.tex
244texmf-dist/doc/generic/c-pascal/demo2.tex
245texmf-dist/doc/generic/c-pascal/prog/fib.py
246texmf-dist/doc/generic/c-pascal/prog/guess.pas
247texmf-dist/doc/generic/c-pascal/prog/sun.c
248texmf-dist/tex/generic/c-pascal/cap.tex
249texmf-dist/tex/generic/c-pascal/cap_c.tex
250texmf-dist/tex/generic/c-pascal/cap_comm.tex
251texmf-dist/tex/generic/c-pascal/cap_pas.tex
252texmf-dist/tex/generic/c-pascal/cap_pyt.tex
253texmf-dist/doc/generic/chronosys/README
254texmf-dist/doc/generic/chronosys/docchronosys_en.pdf
255texmf-dist/doc/generic/chronosys/docchronosys_en.tex
256texmf-dist/doc/generic/chronosys/docchronosys_fr.pdf
257texmf-dist/doc/generic/chronosys/docchronosys_fr.tex
258texmf-dist/tex/generic/chronosys/chronosys.sty
259texmf-dist/tex/generic/chronosys/chronosys.tex
260texmf-dist/tex/generic/chronosys/chronosyschr.tex
261texmf-dist/tex/generic/chronosys/x-chronosys.tex
262texmf-dist/dvips/colorsep/colorsep.pro
263texmf-dist/doc/bibtex/dinat/dinat-index.html
264texmf-dist/doc/bibtex/dinat/history.html
265texmf-dist/bibtex/bst/dinat/dinat.bst
266texmf-dist/doc/generic/dirtree/README
267texmf-dist/doc/generic/dirtree/dirtree.pdf
268texmf-dist/source/generic/dirtree/dirtree.dtx
269texmf-dist/source/generic/dirtree/dirtree.ins
270texmf-dist/tex/generic/dirtree/dirtree.sty
271texmf-dist/tex/generic/dirtree/dirtree.tex
272texmf-dist/doc/generic/dowith/README
273texmf-dist/doc/generic/dowith/dowith.pdf
274texmf-dist/source/generic/dowith/SrcFILEs.txt
275texmf-dist/source/generic/dowith/dowith.tex
276texmf-dist/source/generic/dowith/srcfiles.tex
277texmf-dist/tex/generic/dowith/dowith.RLS
278texmf-dist/tex/generic/dowith/dowith.sty
279texmf-dist/tex/generic/eijkhout/CD_labeler.tex
280texmf-dist/tex/generic/eijkhout/CD_labeler_test.tex
281texmf-dist/tex/generic/eijkhout/DB_process.tex
282texmf-dist/tex/generic/eijkhout/repeat.tex
283texmf-dist/doc/generic/encxvlna/License.txt
284texmf-dist/doc/generic/encxvlna/README
285texmf-dist/doc/generic/encxvlna/encxvlna.pdf
286texmf-dist/doc/generic/encxvlna/encxvlna.tex
287texmf-dist/doc/generic/encxvlna/vlna-inc.tex
288texmf-dist/tex/latex/encxvlna/encxvlna.sty
289texmf-dist/tex/plain/encxvlna/encxvlna.tex
290texmf-dist/tex/generic/epigram/epigram.tex
291texmf-dist/doc/generic/fenixpar/README
292texmf-dist/tex/generic/fenixpar/fenixpar.sty
293texmf-dist/tex/generic/fenixpar/fenixtok.sty
294texmf-dist/doc/generic/fltpoint/README
295texmf-dist/doc/generic/fltpoint/fltpoint.pdf
296texmf-dist/source/generic/fltpoint/fltpoint.dtx
297texmf-dist/source/generic/fltpoint/fltpoint.ins
298texmf-dist/tex/generic/fltpoint/deccomma.sty
299texmf-dist/tex/generic/fltpoint/fltpoint.sty
300texmf-dist/tex/generic/fltpoint/fltpoint.tex
301texmf-dist/doc/generic/fntproof/README
302texmf-dist/doc/generic/fntproof/fntproof-doc.pdf
303texmf-dist/doc/generic/fntproof/fntproof-doc.tex
304texmf-dist/tex/generic/fntproof/fntproof.tex
305texmf-dist/doc/generic/gates/README
306texmf-dist/doc/generic/gates/gates-doc.pdf
307texmf-dist/doc/generic/gates/gates-doc.tex
308texmf-dist/doc/generic/gates/gates-doc.txt
309texmf-dist/doc/generic/gates/gates.tex
310texmf-dist/tex/generic/gates/gates.lua
311texmf-dist/tex/generic/gates/gates.sty
312texmf-dist/tex/generic/gates/t-gates.tex
313texmf-dist/doc/latex/ifetex/README
314texmf-dist/doc/latex/ifetex/ifetex.pdf
315texmf-dist/source/latex/ifetex/ifetex.dtx
316texmf-dist/source/latex/ifetex/ifetex.ins
317texmf-dist/tex/latex/ifetex/ifetex.sty
318texmf-dist/tex/plain/ifetex/ifetex.tex
319texmf-dist/doc/generic/iftex/README
320texmf-dist/doc/generic/iftex/iftex.pdf
321texmf-dist/doc/generic/iftex/iftex.tex
322texmf-dist/tex/generic/iftex/iftex.sty
323texmf-dist/doc/generic/insbox/demo.tex
324texmf-dist/doc/generic/insbox/pic1.eps
325texmf-dist/doc/generic/insbox/pic2.eps
326texmf-dist/tex/generic/insbox/insbox.tex
327texmf-dist/doc/generic/lecturer/LecturerDemo-BeamerCambridgeUS.pdf
328texmf-dist/doc/generic/lecturer/LecturerDemo-BeamerCambridgeUS.tex
329texmf-dist/doc/generic/lecturer/LecturerDemo-KitschScienceFiction.pdf
330texmf-dist/doc/generic/lecturer/LecturerDemo-KitschScienceFiction.tex
331texmf-dist/doc/generic/lecturer/LecturerDemo-Mondrian.pdf
332texmf-dist/doc/generic/lecturer/LecturerDemo-Mondrian.tex
333texmf-dist/doc/generic/lecturer/LecturerDemo-SimplePresentation.pdf
334texmf-dist/doc/generic/lecturer/LecturerDemo-SimplePresentation.tex
335texmf-dist/doc/generic/lecturer/LecturerDemo-SquaresOfAs.pdf
336texmf-dist/doc/generic/lecturer/LecturerDemo-SquaresOfAs.tex
337texmf-dist/doc/generic/lecturer/LecturerDemo-ThePoodleLectures.pdf
338texmf-dist/doc/generic/lecturer/LecturerDemo-ThePoodleLectures.tex
339texmf-dist/doc/generic/lecturer/LecturerDemo-VisualDoc.pdf
340texmf-dist/doc/generic/lecturer/LecturerDemo-VisualDoc.tex
341texmf-dist/doc/generic/lecturer/README
342texmf-dist/doc/generic/lecturer/lecturer-doc.pdf
343texmf-dist/doc/generic/lecturer/lecturer-doc.tex
344texmf-dist/doc/generic/lecturer/universe.jpg
345texmf-dist/tex/generic/lecturer/lecturer.sty
346texmf-dist/tex/generic/lecturer/lecturer.tex
347texmf-dist/tex/generic/lecturer/ltr-areas.tex
348texmf-dist/tex/generic/lecturer/ltr-graphics.tex
349texmf-dist/tex/generic/lecturer/ltr-job.tex
350texmf-dist/tex/generic/lecturer/ltr-navigation.tex
351texmf-dist/tex/generic/lecturer/ltr-slides.tex
352texmf-dist/tex/generic/lecturer/ltr-steps.tex
353texmf-dist/tex/generic/lecturer/t-lecturer.tex
354texmf-dist/doc/generic/librarian/README
355texmf-dist/doc/generic/librarian/authoryear.tex
356texmf-dist/doc/generic/librarian/librarian-doc.pdf
357texmf-dist/doc/generic/librarian/librarian-doc.tex
358texmf-dist/doc/generic/librarian/librarian.bib
359texmf-dist/tex/generic/librarian/librarian.sty
360texmf-dist/tex/generic/librarian/librarian.tex
361texmf-dist/tex/generic/librarian/t-librarian.tex
362texmf-dist/doc/generic/mathdots/README
363texmf-dist/doc/generic/mathdots/mathdots.pdf
364texmf-dist/doc/generic/mathdots/mdtest.tex
365texmf-dist/source/generic/mathdots/mathdots.dtx
366texmf-dist/source/generic/mathdots/mathdots.ins
367texmf-dist/tex/generic/mathdots/mathdots.sty
368texmf-dist/tex/generic/mathdots/mathdots.tex
369texmf-dist/doc/plain/metatex/README
370texmf-dist/doc/plain/metatex/gpl.txt
371texmf-dist/doc/plain/metatex/mtmp2pdf.tex
372texmf-dist/doc/plain/metatex/mtpaper.pdf
373texmf-dist/doc/plain/metatex/mtpaper/delay.mf
374texmf-dist/doc/plain/metatex/mtpaper/diagram.tex
375texmf-dist/doc/plain/metatex/mtpaper/frame.tex
376texmf-dist/doc/plain/metatex/mtpaper/mtpaper.tex
377texmf-dist/doc/plain/metatex/mtpaper/shadow.tex
378texmf-dist/tex/plain/metatex/metatex.tex
379texmf-dist/doc/generic/midnight/README
380texmf-dist/doc/generic/midnight/border.doc
381texmf-dist/doc/generic/midnight/dolines.doc
382texmf-dist/doc/generic/midnight/gloss.doc
383texmf-dist/doc/generic/midnight/labels.doc
384texmf-dist/doc/generic/midnight/loop.doc
385texmf-dist/doc/generic/midnight/midnight.pdf
386texmf-dist/doc/generic/midnight/quire.doc
387texmf-dist/doc/generic/midnight/styledef.doc
388texmf-dist/tex/generic/midnight/border.tex
389texmf-dist/tex/generic/midnight/dolines.tex
390texmf-dist/tex/generic/midnight/gloss.tex
391texmf-dist/tex/generic/midnight/labels.tex
392texmf-dist/tex/generic/midnight/loop.tex
393texmf-dist/tex/generic/midnight/quire.tex
394texmf-dist/tex/generic/midnight/styledef.tex
395texmf-dist/dvips/multi/2up.pro
396texmf-dist/dvips/multi/4up.pro
397texmf-dist/dvips/multi/multi.pro
398texmf-dist/doc/generic/navigator/README
399texmf-dist/doc/generic/navigator/navigator-doc.pdf
400texmf-dist/doc/generic/navigator/navigator-doc.tex
401texmf-dist/tex/generic/navigator/navigator.sty
402texmf-dist/tex/generic/navigator/navigator.tex
403texmf-dist/tex/generic/navigator/t-navigator.tex
404texmf-dist/doc/generic/ofs/changes.txt
405texmf-dist/doc/generic/ofs/eurotex2003-ofs.pdf
406texmf-dist/doc/generic/ofs/eurotex2003-ofs.tex
407texmf-dist/doc/generic/ofs/ofs-slt.pdf
408texmf-dist/doc/generic/ofs/ofsdoc-e.pdf
409texmf-dist/doc/generic/ofs/ofsdoc-e.tex
410texmf-dist/doc/generic/ofs/ofsdoc.pdf
411texmf-dist/doc/generic/ofs/ofsdoc.tex
412texmf-dist/doc/generic/ofs/ofsmtdef.tex
413texmf-dist/doc/generic/ofs/ofstest.tex
414texmf-dist/doc/generic/ofs/readme.ofs
415texmf-dist/tex/generic/ofs/a117.tex
416texmf-dist/tex/generic/ofs/a35.sty
417texmf-dist/tex/generic/ofs/a35.tex
418texmf-dist/tex/generic/ofs/allfonts.sty
419texmf-dist/tex/generic/ofs/allfonts.tex
420texmf-dist/tex/generic/ofs/amsfn.tex
421texmf-dist/tex/generic/ofs/mtfn.tex
422texmf-dist/tex/generic/ofs/ofs-6a.tex
423texmf-dist/tex/generic/ofs/ofs-6c.tex
424texmf-dist/tex/generic/ofs/ofs-6k.tex
425texmf-dist/tex/generic/ofs/ofs-6s.tex
426texmf-dist/tex/generic/ofs/ofs-6t.tex
427texmf-dist/tex/generic/ofs/ofs-6x.tex
428texmf-dist/tex/generic/ofs/ofs-6y.tex
429texmf-dist/tex/generic/ofs/ofs-8c.tex
430texmf-dist/tex/generic/ofs/ofs-8t.tex
431texmf-dist/tex/generic/ofs/ofs-8x.tex
432texmf-dist/tex/generic/ofs/ofs-8z.tex
433texmf-dist/tex/generic/ofs/ofs-ams.tex
434texmf-dist/tex/generic/ofs/ofs-cm.tex
435texmf-dist/tex/generic/ofs/ofs-mt.tex
436texmf-dist/tex/generic/ofs/ofs-ps.tex
437texmf-dist/tex/generic/ofs/ofs-px.tex
438texmf-dist/tex/generic/ofs/ofs-slt.tex
439texmf-dist/tex/generic/ofs/ofs-tx.tex
440texmf-dist/tex/generic/ofs/ofs.sty
441texmf-dist/tex/generic/ofs/ofs.tex
442texmf-dist/tex/generic/ofs/ofsdef.tex
443texmf-dist/tex/generic/ofs/pantyk.tex
444texmf-dist/tex/generic/ofs/txfn.tex
445texmf-dist/doc/generic/pdf-trans/example.pdf
446texmf-dist/doc/generic/pdf-trans/example.tex
447texmf-dist/tex/generic/pdf-trans/pdf-trans.tex
448texmf-dist/doc/generic/shade/README
449texmf-dist/doc/generic/shade/description.pdf
450texmf-dist/doc/generic/shade/description.tex
451texmf-dist/fonts/source/public/shade/shade.mf
452texmf-dist/tex/generic/shade/shade.tex
453texmf-dist/doc/generic/systeme/README
454texmf-dist/doc/generic/systeme/systeme_doc_fr.pdf
455texmf-dist/doc/generic/systeme/systeme_doc_fr.tex
456texmf-dist/tex/generic/systeme/systeme.sty
457texmf-dist/tex/generic/systeme/systeme.tex
458texmf-dist/tex/generic/tabto-generic/tabto.tex
459texmf-dist/doc/generic/texapi/README
460texmf-dist/doc/generic/texapi/texapi-doc.pdf
461texmf-dist/doc/generic/texapi/texapi-doc.tex
462texmf-dist/tex/generic/texapi/texapi.tex
463texmf-dist/doc/generic/upca/README
464texmf-dist/doc/generic/upca/test-upca.tex
465texmf-dist/tex/generic/upca/upca.tex
466texmf-dist/doc/generic/xlop/LISEZ.MOI
467texmf-dist/doc/generic/xlop/README
468texmf-dist/doc/generic/xlop/xlop-doc-fr.pdf
469texmf-dist/doc/generic/xlop/xlop-doc-fr.tex
470texmf-dist/doc/generic/xlop/xlop-doc.pdf
471texmf-dist/doc/generic/xlop/xlop-doc.tex
472texmf-dist/source/generic/xlop/manual.sty
473texmf-dist/tex/generic/xlop/xlop.sty
474texmf-dist/tex/generic/xlop/xlop.tex
475texmf-dist/doc/generic/yax/README
476texmf-dist/doc/generic/yax/yax-doc.pdf
477texmf-dist/doc/generic/yax/yax-doc.tex
478texmf-dist/tex/generic/yax/t-yax.tex
479texmf-dist/tex/generic/yax/yax.sty
480texmf-dist/tex/generic/yax/yax.tex
481)
482
483%__mkdir_p ${PREF}/texmf-dist
484for i in "${manifest[@]}"; do
485    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
486done
487## make symlinks of core script utils
488mk_symlinks=(
489texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
490texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
491texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
492texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
493texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
494texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
495texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
496texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
497texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
498texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
499texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
500texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
501texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
502texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
503texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
504texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
505texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
506texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
507texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
508texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
509texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
510texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
511texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
512texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
513texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
514texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
515texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
516texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
517texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
518texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
519texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
520texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
521texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
522texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
523texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
524texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
525texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
526texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
527texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
528texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
529texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
530texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
531texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
532texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
533texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
534texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
535texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
536texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
537texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
538texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
539texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
540texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
541texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
542texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
543texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
544texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
545texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
546texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
547texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
548texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
549texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
550texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
551texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
552texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
553texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
554texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
555texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
556texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
557texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
558texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
559texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
560texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
561texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
562texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
563texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
564texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
565texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
566texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
567texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
568texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
569texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
570texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
571texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
572texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
573texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
574texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
575texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
576texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
577texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
578texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
579texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
580texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
581texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
582)
583%__mkdir_p %{buildroot}%{_bindir}
584pushd %{buildroot}%{_bindir}
585    for i in "${mk_symlinks[@]}"; do
586        tlc=$(/bin/echo $i | cut -f 1 -d",")
587        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
588        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
589
590        [ "%{name}" = "$tlc" ] || continue
591        [ -f $rlnk ] || exit 1
592        %__ln_s $rlnk $lnk || exit 1
593    done
594popd
595## Files list
596find %{buildroot} -type f -or -type l | \
597    %__sed -e "s|%{buildroot}||g" > filelist.full
598
599find %{buildroot}%{texmf}-dist -type d | \
600    %__sed -e "s|^%{buildroot}|%dir |" \
601           -e "s|$|/|"             >> filelist.full
602
603## subpackages
604grep "/texmf-dist/doc/" filelist.full > filelist.doc
605cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
606%__mv -f filelist.tmp filelist.full
607
608%clean
609%__rm -rf %{buildroot}
610
611%post
612%touch_run texhash
613%touch_run mtxrun
614
615exit 0
616
617
618%postun
619if [ "$1" = 0 ]; then
620    %touch_run texhash
621
622fi
623
624exit 0
625
626%posttrans
627%{exec_texhash}
628%{exec_mtxrun}
629%{exec_updmap}
630%{exec_fmtutil}
631exit 0
632
633
634%files -f filelist.full
635%defattr(-,root,root,-)
636
637%files -f filelist.doc doc
638%defattr(-,root,root,-)
639
640%changelog
641* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
642- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-genericextra
643
644* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
645- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-genericextra
646- set external dependencies (texlive-collection-binextra,
647  texlive-collection-fontutils)
648
649* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
650- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-genericextra
651
652* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
653- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-genericextra
654- make symlinks of core script utils (texlive-collection-binextra,
655  texlive-collection-context, texlive-collection-fontutils,
656  texlive-collection-langgreek, texlive-collection-langindic,
657  texlive-collection-latex, texlive-collection-latexextra,
658  texlive-collection-latexrecommended, texlive-collection-pictures,
659  texlive-collection-pstricks, texlive-collection-science)
660
661* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
662- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-genericextra
663- improved %%post
664
665* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
666- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-genericextra
667- removed arch dependent binaries (texlive-collection-latexextra)
668- fixed perl path
669- improved updmap process in %%post and %%postun
670
671* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
672- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-genericextra
Note: See TracBrowser for help on using the repository browser.