source: projects/specs/trunk/t/texlive-collection-games/texlive-collection-games-vl.spec @ 1533

Revision 1533, 22.2 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Games typesetting
28Summary(ja): TeX Live: Games typesetting
29Name: texlive-collection-games
30Version: 2009
31Release: 1%{?_dist_release}
32License: No Info, Public Domain, Freely redistributable without restriction, LPPL, GPL+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-latex = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Games typesetting:
61Setups for typesetting various games, including chess.
62
63This package contains the following CTAN packages:
64cchess: Chinese chess.
65chess: Fonts for typesetting chess boards.
66chess-problem-diagrams: A package for typesetting chess problem diagrams.
67chessboard: Print chess boards.
68chessfss: A package to handle chess fonts.
69crossword: Typeset crossword puzzles.
70crosswrd: Macros for typesetting crossword puzzles.
71egameps: LaTeX package for typesetting extensive games.
72go: Fonts and macros for typesetting go games.
73hexgame: Provide an environment to draw a hexgame-board.
74jeopardy: Build a jeopardy game in LaTeX.
75othello: Create othello boards in LaTeX.
76psgo: Typeset go diagrams with PSTricks.
77sgame: LaTeX style for typesetting strategic games.
78skak: Fonts and macros for typesetting chess games.
79skaknew: The skak chess fonts redone in Adobe Type 1.
80sudoku: Create sudoku grids.
81sudokubundle: A set of sudoku-related packages.
82xq: Support for writing about xiangqi.
83xskak: An extension to the skak package for chess typesetting.
84
85%description -l ja
86TeX Live ソフトウェアディストリビューションは、
87さまざまな Unix, Macintosh, Windows、および
88他のプラットホームに対して完全な TeX システムを提供します。
89多くの異なった言語を含む TeX ドキュメントの
90編集、組版、閲覧、印刷するためのプログラム、
91そして、TeX マクロやフォントライブラリの大きなコレクションを
92同梱しています。
93
94このディストリビューションは
95同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
96TeX に関するたくさんの一般的なドキュメントを含んでいます。
97
98このパッケージは以下のようなパッケージ集です。
99Games typesetting:
100Setups for typesetting various games, including chess.
101
102このパッケージは以下の CTAN パッケージを含んでいます:
103cchess: Chinese chess.
104chess: Fonts for typesetting chess boards.
105chess-problem-diagrams: A package for typesetting chess problem diagrams.
106chessboard: Print chess boards.
107chessfss: A package to handle chess fonts.
108crossword: Typeset crossword puzzles.
109crosswrd: Macros for typesetting crossword puzzles.
110egameps: LaTeX package for typesetting extensive games.
111go: Fonts and macros for typesetting go games.
112hexgame: Provide an environment to draw a hexgame-board.
113jeopardy: Build a jeopardy game in LaTeX.
114othello: Create othello boards in LaTeX.
115psgo: Typeset go diagrams with PSTricks.
116sgame: LaTeX style for typesetting strategic games.
117skak: Fonts and macros for typesetting chess games.
118skaknew: The skak chess fonts redone in Adobe Type 1.
119sudoku: Create sudoku grids.
120sudokubundle: A set of sudoku-related packages.
121xq: Support for writing about xiangqi.
122xskak: An extension to the skak package for chess typesetting.
123
124%package doc
125Summary: TeX Live: Documentation files of %{name}
126Group: Applications/Publishing
127Requires: %{name} = %{version}-%{release}
128
129%description doc
130This package contains documentation files of %{name}.
131
132%prep
133
134%build
135
136%install
137[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
138
139PREF=%{buildroot}%{tex_destdir}
140
141manifest=(
142texmf-dist/fonts/source/public/cchess/cchess46.mf
143texmf-dist/fonts/source/public/cchess/ccpieces.mf
144texmf-dist/fonts/tfm/public/cchess/cchess46.tfm
145texmf-dist/tex/latex/cchess/cchess.sty
146texmf-dist/fonts/source/public/chess/chess10.mf
147texmf-dist/fonts/source/public/chess/chess20.mf
148texmf-dist/fonts/source/public/chess/chess30.mf
149texmf-dist/fonts/source/public/chess/chessbase.mf
150texmf-dist/fonts/source/public/chess/chessdiag.mf
151texmf-dist/fonts/source/public/chess/chessf10.mf
152texmf-dist/fonts/source/public/chess/chessfig10.mf
153texmf-dist/fonts/source/public/chess/chesspieces.mf
154texmf-dist/fonts/source/public/chess/empty.mf
155texmf-dist/tex/latex/chess/bdfchess.sty
156texmf-dist/tex/latex/chess/chess.sty
157texmf-dist/tex/latex/chess/chessboa.sty
158texmf-dist/tex/latex/chess/chesskey.sty
159texmf-dist/tex/latex/chess/chessmg.sty
160texmf-dist/doc/latex/chess-problem-diagrams/README
161texmf-dist/doc/latex/chess-problem-diagrams/diagram.pdf
162texmf-dist/doc/latex/chess-problem-diagrams/fonts.zip
163texmf-dist/source/latex/chess-problem-diagrams/diagram.dtx
164texmf-dist/source/latex/chess-problem-diagrams/diagram.ins
165texmf-dist/tex/latex/chess-problem-diagrams/diagram.sty
166texmf-dist/doc/latex/chessboard/README
167texmf-dist/doc/latex/chessboard/README.TEXLIVE
168texmf-dist/source/latex/chessboard/chessboard-src.dtx
169texmf-dist/source/latex/chessboard/chessboard.ins
170texmf-dist/tex/latex/chessboard/chessboard-keys-main.sty
171texmf-dist/tex/latex/chessboard/chessboard-keys-pgf.sty
172texmf-dist/tex/latex/chessboard/chessboard-pgf.sty
173texmf-dist/tex/latex/chessboard/chessboard.sty
174texmf-dist/doc/latex/chessfss/README
175texmf-dist/doc/latex/chessfss/README.TEXLIVE
176texmf-dist/source/latex/chessfss/chessfss-src.dtx
177texmf-dist/source/latex/chessfss/chessfss.ins
178texmf-dist/fonts/enc/dvips/chessfss/chess-board-example-enc.enc
179texmf-dist/fonts/enc/dvips/chessfss/chess-fig-example-enc.enc
180texmf-dist/tex/latex/chessfss/chessfss.sty
181texmf-dist/tex/latex/chessfss/lsb1enc.def
182texmf-dist/tex/latex/chessfss/lsb1skak.fd
183texmf-dist/tex/latex/chessfss/lsb1skaknew.fd
184texmf-dist/tex/latex/chessfss/lsb2enc.def
185texmf-dist/tex/latex/chessfss/lsb2skak.fd
186texmf-dist/tex/latex/chessfss/lsb2skaknew.fd
187texmf-dist/tex/latex/chessfss/lsb3enc.def
188texmf-dist/tex/latex/chessfss/lsb3skak.fd
189texmf-dist/tex/latex/chessfss/lsb3skaknew.fd
190texmf-dist/tex/latex/chessfss/lsbc1enc.def
191texmf-dist/tex/latex/chessfss/lsbc1skaknew.fd
192texmf-dist/tex/latex/chessfss/lsbc2enc.def
193texmf-dist/tex/latex/chessfss/lsbc2skaknew.fd
194texmf-dist/tex/latex/chessfss/lsbc3enc.def
195texmf-dist/tex/latex/chessfss/lsbc3skaknew.fd
196texmf-dist/tex/latex/chessfss/lsbc4enc.def
197texmf-dist/tex/latex/chessfss/lsbc4skaknew.fd
198texmf-dist/tex/latex/chessfss/lsbc5enc.def
199texmf-dist/tex/latex/chessfss/lsbc5skaknew.fd
200texmf-dist/tex/latex/chessfss/lsbenc.def
201texmf-dist/tex/latex/chessfss/lsbskak.fd
202texmf-dist/tex/latex/chessfss/lsbskaknew.fd
203texmf-dist/tex/latex/chessfss/lsfenc.def
204texmf-dist/tex/latex/chessfss/lsfskak.fd
205texmf-dist/tex/latex/chessfss/lsfskaknew.fd
206texmf-dist/tex/latex/chessfss/lsienc.def
207texmf-dist/tex/latex/chessfss/lsiskak.fd
208texmf-dist/tex/latex/chessfss/lsiskaknew.fd
209texmf-dist/doc/latex/crossword/README
210texmf-dist/doc/latex/crossword/cwpuzzle.pdf
211texmf-dist/source/latex/crossword/Makefile
212texmf-dist/source/latex/crossword/cwpuzzle.dtx
213texmf-dist/source/latex/crossword/cwpuzzle.ins
214texmf-dist/tex/latex/crossword/cwpuzzle.sty
215texmf-dist/doc/latex/crosswrd/README
216texmf-dist/doc/latex/crosswrd/crosswrd.pdf
217texmf-dist/doc/latex/crosswrd/grid0.tex
218texmf-dist/doc/latex/crosswrd/grid1.tex
219texmf-dist/doc/latex/crosswrd/test0.tex
220texmf-dist/doc/latex/crosswrd/test1.tex
221texmf-dist/source/latex/crosswrd/crosswrd.dtx
222texmf-dist/source/latex/crosswrd/crosswrd.ins
223texmf-dist/tex/latex/crosswrd/crosswrd.sty
224texmf-dist/doc/latex/egameps/README
225texmf-dist/doc/latex/egameps/egameps.pdf
226texmf-dist/doc/latex/egameps/egameps.tex
227texmf-dist/tex/latex/egameps/egameps.sty
228texmf-dist/source/latex/go/gomaps.ltx
229texmf-dist/fonts/source/public/go/go.mf
230texmf-dist/fonts/source/public/go/go10.mf
231texmf-dist/fonts/source/public/go/go15.mf
232texmf-dist/fonts/source/public/go/go1bla10.mf
233texmf-dist/fonts/source/public/go/go1bla15.mf
234texmf-dist/fonts/source/public/go/go1bla20.mf
235texmf-dist/fonts/source/public/go/go1black.mf
236texmf-dist/fonts/source/public/go/go1whi10.mf
237texmf-dist/fonts/source/public/go/go1whi15.mf
238texmf-dist/fonts/source/public/go/go1whi20.mf
239texmf-dist/fonts/source/public/go/go1white.mf
240texmf-dist/fonts/source/public/go/go20.mf
241texmf-dist/fonts/source/public/go/go2bla10.mf
242texmf-dist/fonts/source/public/go/go2bla15.mf
243texmf-dist/fonts/source/public/go/go2bla20.mf
244texmf-dist/fonts/source/public/go/go2black.mf
245texmf-dist/fonts/source/public/go/go2whi10.mf
246texmf-dist/fonts/source/public/go/go2whi15.mf
247texmf-dist/fonts/source/public/go/go2whi20.mf
248texmf-dist/fonts/source/public/go/go2white.mf
249texmf-dist/fonts/source/public/go/gosign50.mf
250texmf-dist/fonts/tfm/public/go/go10.tfm
251texmf-dist/fonts/tfm/public/go/go15.tfm
252texmf-dist/fonts/tfm/public/go/go1bla10.tfm
253texmf-dist/fonts/tfm/public/go/go1bla15.tfm
254texmf-dist/fonts/tfm/public/go/go1bla20.tfm
255texmf-dist/fonts/tfm/public/go/go1whi10.tfm
256texmf-dist/fonts/tfm/public/go/go1whi15.tfm
257texmf-dist/fonts/tfm/public/go/go1whi20.tfm
258texmf-dist/fonts/tfm/public/go/go20.tfm
259texmf-dist/fonts/tfm/public/go/go2bla10.tfm
260texmf-dist/fonts/tfm/public/go/go2bla15.tfm
261texmf-dist/fonts/tfm/public/go/go2bla20.tfm
262texmf-dist/fonts/tfm/public/go/go2whi10.tfm
263texmf-dist/fonts/tfm/public/go/go2whi15.tfm
264texmf-dist/fonts/tfm/public/go/go2whi20.tfm
265texmf-dist/fonts/tfm/public/go/gosign50.tfm
266texmf-dist/tex/latex/go/go.sty
267texmf-dist/doc/latex/hexgame/README
268texmf-dist/doc/latex/hexgame/hexgame.pdf
269texmf-dist/doc/latex/hexgame/hexgame.tex
270texmf-dist/tex/latex/hexgame/hexgame.sty
271texmf-dist/doc/latex/jeopardy/README
272texmf-dist/doc/latex/jeopardy/example/aleq.jpg
273texmf-dist/doc/latex/jeopardy/example/blackpanel.tex
274texmf-dist/doc/latex/jeopardy/example/game1-two.pdf
275texmf-dist/doc/latex/jeopardy/example/game1-two.tex
276texmf-dist/doc/latex/jeopardy/example/game1.pdf
277texmf-dist/doc/latex/jeopardy/example/game1.tex
278texmf-dist/doc/latex/jeopardy/example/game1a.pdf
279texmf-dist/doc/latex/jeopardy/example/game1a.tex
280texmf-dist/doc/latex/jeopardy/example/game2.pdf
281texmf-dist/doc/latex/jeopardy/example/game2.tex
282texmf-dist/doc/latex/jeopardy/example/game2a.pdf
283texmf-dist/doc/latex/jeopardy/example/game2a.tex
284texmf-dist/doc/latex/jeopardy/example/game3.pdf
285texmf-dist/doc/latex/jeopardy/example/game3.tex
286texmf-dist/doc/latex/jeopardy/example/game4.pdf
287texmf-dist/doc/latex/jeopardy/example/game4.tex
288texmf-dist/doc/latex/jeopardy/example/jeopardy-CZ.pdf
289texmf-dist/doc/latex/jeopardy/example/jeopardy-CZ.tex
290texmf-dist/doc/latex/jeopardy/example/joke.jpg
291texmf-dist/doc/latex/jeopardy/example/logo-bc.jpg
292texmf-dist/doc/latex/jeopardy/example/pdfscreen.cfg
293texmf-dist/doc/latex/jeopardy/example/picture.jpg
294texmf-dist/doc/latex/jeopardy/jeopardy.pdf
295texmf-dist/source/latex/jeopardy/jeopardy.dtx
296texmf-dist/source/latex/jeopardy/jeopardy.ins
297texmf-dist/tex/latex/jeopardy/jeopardy.cfg
298texmf-dist/tex/latex/jeopardy/jeopardy.sty
299texmf-dist/doc/latex/othello/boards.tex
300texmf-dist/doc/latex/othello/ot.bat
301texmf-dist/doc/latex/othello/ot1.bat.bat
302texmf-dist/doc/latex/othello/othello.tex
303texmf-dist/fonts/source/public/othello/ot.mf
304texmf-dist/fonts/source/public/othello/ot10.mf
305texmf-dist/fonts/source/public/othello/ot15.mf
306texmf-dist/fonts/source/public/othello/ot1bla10.mf
307texmf-dist/fonts/source/public/othello/ot1bla15.mf
308texmf-dist/fonts/source/public/othello/ot1bla20.mf
309texmf-dist/fonts/source/public/othello/ot1black.mf
310texmf-dist/fonts/source/public/othello/ot1neu.mf
311texmf-dist/fonts/source/public/othello/ot1neu10.mf
312texmf-dist/fonts/source/public/othello/ot1neu15.mf
313texmf-dist/fonts/source/public/othello/ot1neu20.mf
314texmf-dist/fonts/source/public/othello/ot1whi10.mf
315texmf-dist/fonts/source/public/othello/ot1whi15.mf
316texmf-dist/fonts/source/public/othello/ot1whi20.mf
317texmf-dist/fonts/source/public/othello/ot1white.mf
318texmf-dist/fonts/tfm/public/othello/ot10.tfm
319texmf-dist/fonts/tfm/public/othello/ot15.tfm
320texmf-dist/fonts/tfm/public/othello/ot1bla10.tfm
321texmf-dist/fonts/tfm/public/othello/ot1bla15.tfm
322texmf-dist/fonts/tfm/public/othello/ot1bla20.tfm
323texmf-dist/fonts/tfm/public/othello/ot1neu10.tfm
324texmf-dist/fonts/tfm/public/othello/ot1neu15.tfm
325texmf-dist/fonts/tfm/public/othello/ot1neu20.tfm
326texmf-dist/fonts/tfm/public/othello/ot1whi10.tfm
327texmf-dist/fonts/tfm/public/othello/ot1whi15.tfm
328texmf-dist/fonts/tfm/public/othello/ot1whi20.tfm
329texmf-dist/tex/latex/othello/othello.sty
330texmf-dist/doc/latex/psgo/Changes
331texmf-dist/doc/latex/psgo/README
332texmf-dist/doc/latex/psgo/psgomanual.pdf
333texmf-dist/doc/latex/psgo/psgomanual.tex
334texmf-dist/tex/latex/psgo/psgo.sty
335texmf-dist/doc/latex/sgame/README
336texmf-dist/doc/latex/sgame/sgame.pdf
337texmf-dist/doc/latex/sgame/sgame.tex
338texmf-dist/tex/latex/sgame/sgame.sty
339texmf-dist/tex/latex/sgame/sgamevar.sty
340texmf-dist/doc/latex/skak/README
341texmf-dist/doc/latex/skak/WC-2004-S-00007.tex
342texmf-dist/doc/latex/skak/_region_.tex
343texmf-dist/doc/latex/skak/andreas_wilm_1.tex
344texmf-dist/doc/latex/skak/angletst.tex
345texmf-dist/doc/latex/skak/debug_storegame.tex
346texmf-dist/doc/latex/skak/demo-symbols.tex
347texmf-dist/doc/latex/skak/fen_with_black.tex
348texmf-dist/doc/latex/skak/font.tex
349texmf-dist/doc/latex/skak/font2.tex
350texmf-dist/doc/latex/skak/hightest.tex
351texmf-dist/doc/latex/skak/informator.pdf
352texmf-dist/doc/latex/skak/informator.tex
353texmf-dist/doc/latex/skak/ingo-bug1.tex
354texmf-dist/doc/latex/skak/lambda.tex
355texmf-dist/doc/latex/skak/longmoves.tex
356texmf-dist/doc/latex/skak/makefile
357texmf-dist/doc/latex/skak/promotion_problem_Ulrike.tex
358texmf-dist/doc/latex/skak/refman.pdf
359texmf-dist/doc/latex/skak/refman.tex
360texmf-dist/doc/latex/skak/show.tex
361texmf-dist/doc/latex/skak/skakdoc.pdf
362texmf-dist/doc/latex/skak/skakdoc.tex
363texmf-dist/doc/latex/skak/syntax.tex
364texmf-dist/doc/latex/skak/test1.tex
365texmf-dist/doc/latex/skak/test2.tex
366texmf-dist/doc/latex/skak/test_capture.tex
367texmf-dist/doc/latex/skak/tuggame.pdf
368texmf-dist/doc/latex/skak/tuggame.tex
369texmf-dist/fonts/map/dvips/skak/special.map
370texmf-dist/fonts/source/public/skak/skak10.mf
371texmf-dist/fonts/source/public/skak/skak15.mf
372texmf-dist/fonts/source/public/skak/skak20.mf
373texmf-dist/fonts/source/public/skak/skak30.mf
374texmf-dist/fonts/source/public/skak/skakbase.mf
375texmf-dist/fonts/source/public/skak/skakbrikker.mf
376texmf-dist/fonts/source/public/skak/skakf10.mf
377texmf-dist/fonts/source/public/skak/skakf10b.mf
378texmf-dist/fonts/source/public/skak/skakinf.mf
379texmf-dist/fonts/tfm/public/skak/skak10.tfm
380texmf-dist/fonts/tfm/public/skak/skak15.tfm
381texmf-dist/fonts/tfm/public/skak/skak20.tfm
382texmf-dist/fonts/tfm/public/skak/skak30.tfm
383texmf-dist/fonts/tfm/public/skak/skakf10.tfm
384texmf-dist/fonts/tfm/public/skak/skakf10b.tfm
385texmf-dist/tex/latex/skak/chess-workshop-symbols.sty
386texmf-dist/tex/latex/skak/lambda.sty
387texmf-dist/tex/latex/skak/skak.fd
388texmf-dist/tex/latex/skak/skak.sty
389texmf-dist/tex/latex/skak/uskak.fd
390texmf-dist/doc/fonts/skaknew/README
391texmf-dist/doc/fonts/skaknew/SkakNew.pdf
392texmf-dist/doc/fonts/skaknew/SkakNew.tex
393texmf-dist/doc/fonts/skaknew/fonttables.pdf
394texmf-dist/doc/fonts/skaknew/install.vtex
395texmf-dist/fonts/afm/public/skaknew/AlphaDia.afm
396texmf-dist/fonts/afm/public/skaknew/SkakNew-Diagram.afm
397texmf-dist/fonts/afm/public/skaknew/SkakNew-DiagramT.afm
398texmf-dist/fonts/afm/public/skaknew/SkakNew-Figurine.afm
399texmf-dist/fonts/afm/public/skaknew/SkakNew-FigurineBold.afm
400texmf-dist/fonts/map/dvips/skaknew/SkakNew.map
401texmf-dist/fonts/opentype/public/skaknew/AlphaDia.otf
402texmf-dist/fonts/opentype/public/skaknew/SkakNew-Diagram.otf
403texmf-dist/fonts/opentype/public/skaknew/SkakNew-DiagramT.otf
404texmf-dist/fonts/opentype/public/skaknew/SkakNew-Figurine.otf
405texmf-dist/fonts/opentype/public/skaknew/SkakNew-FigurineBold.otf
406texmf-dist/fonts/tfm/public/skaknew/AlphaDia.tfm
407texmf-dist/fonts/tfm/public/skaknew/SkakNew-Diagram.tfm
408texmf-dist/fonts/tfm/public/skaknew/SkakNew-DiagramT.tfm
409texmf-dist/fonts/tfm/public/skaknew/SkakNew-Figurine.tfm
410texmf-dist/fonts/tfm/public/skaknew/SkakNew-FigurineBold.tfm
411texmf-dist/fonts/type1/public/skaknew/AlphaDia.inf
412texmf-dist/fonts/type1/public/skaknew/AlphaDia.pfb
413texmf-dist/fonts/type1/public/skaknew/AlphaDia.pfm
414texmf-dist/fonts/type1/public/skaknew/SkakNew-Diagram.inf
415texmf-dist/fonts/type1/public/skaknew/SkakNew-Diagram.pfb
416texmf-dist/fonts/type1/public/skaknew/SkakNew-Diagram.pfm
417texmf-dist/fonts/type1/public/skaknew/SkakNew-DiagramT.inf
418texmf-dist/fonts/type1/public/skaknew/SkakNew-DiagramT.pfb
419texmf-dist/fonts/type1/public/skaknew/SkakNew-DiagramT.pfm
420texmf-dist/fonts/type1/public/skaknew/SkakNew-Figurine.inf
421texmf-dist/fonts/type1/public/skaknew/SkakNew-Figurine.pfb
422texmf-dist/fonts/type1/public/skaknew/SkakNew-Figurine.pfm
423texmf-dist/fonts/type1/public/skaknew/SkakNew-FigurineBold.inf
424texmf-dist/fonts/type1/public/skaknew/SkakNew-FigurineBold.pfb
425texmf-dist/fonts/type1/public/skaknew/SkakNew-FigurineBold.pfm
426texmf-dist/doc/latex/sudoku/CHANGES
427texmf-dist/doc/latex/sudoku/README
428texmf-dist/doc/latex/sudoku/sudoku.pdf
429texmf-dist/source/latex/sudoku/sudoku.dtx
430texmf-dist/source/latex/sudoku/sudoku.ins
431texmf-dist/tex/latex/sudoku/sudoku.sty
432texmf-dist/doc/latex/sudokubundle/README
433texmf-dist/doc/latex/sudokubundle/somesudoku.tex
434texmf-dist/doc/latex/sudokubundle/sudokubundle.pdf
435texmf-dist/source/latex/sudokubundle/sudokubundle.dtx
436texmf-dist/source/latex/sudokubundle/sudokubundle.ins
437texmf-dist/tex/latex/sudokubundle/createsudoku.sty
438texmf-dist/tex/latex/sudokubundle/printsudoku.sty
439texmf-dist/tex/latex/sudokubundle/solvesudoku.sty
440texmf-dist/doc/fonts/xq/README
441texmf-dist/doc/fonts/xq/xqexample.pdf
442texmf-dist/doc/fonts/xq/xqexample.tex
443texmf-dist/fonts/source/public/xq/xqaddsignsbase.mf
444texmf-dist/fonts/source/public/xq/xqaddsignslarge.mf
445texmf-dist/fonts/source/public/xq/xqaddsignsnormal.mf
446texmf-dist/fonts/source/public/xq/xqbase.mf
447texmf-dist/fonts/source/public/xq/xqhints.mf
448texmf-dist/fonts/source/public/xq/xqlarge.mf
449texmf-dist/fonts/source/public/xq/xqnormal.mf
450texmf-dist/fonts/source/public/xq/xqwestbase.mf
451texmf-dist/fonts/source/public/xq/xqwestlarge.mf
452texmf-dist/fonts/source/public/xq/xqwestnormal.mf
453texmf-dist/fonts/tfm/public/xq/xqlarge.tfm
454texmf-dist/fonts/tfm/public/xq/xqnormal.tfm
455texmf-dist/tex/latex/xq/xq.sty
456texmf-dist/doc/latex/xskak/README
457texmf-dist/doc/latex/xskak/README.TEXLIVE
458texmf-dist/source/latex/xskak/xskak-src.dtx
459texmf-dist/source/latex/xskak/xskak.ins
460texmf-dist/tex/latex/xskak/xskak-keys.sty
461texmf-dist/tex/latex/xskak/xskak-nagdef.sty
462texmf-dist/tex/latex/xskak/xskak.sty
463)
464
465%__mkdir_p ${PREF}/texmf-dist
466for i in "${manifest[@]}"; do
467    %__install -D %{texlive_src}/$i ${PREF}/$i
468done
469
470## info
471%__rm -f %{buildroot}%{_infodir}/dir
472%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
473
474## man
475## man t1* files are provided by t1utils
476for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
477    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
478done
479
480## man some files are provided by psutils
481for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
482    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
483done
484
485## remove asymptote directries, which provides asymptote package
486find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
487# find %{buildroot} -name "Makefile" | xargs %__rm -f
488
489# ## remove xindy
490# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
491
492# ## remove tex4ht
493# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
494
495## remove unpackaging files
496find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
497find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
498
499## Files list
500find %{buildroot} -type f -or -type l | \
501    %__sed -e "s|%{buildroot}||g" > filelist.full
502
503find %{buildroot}%{texmf}-dist -type d | \
504    %__sed -e "s|^%{buildroot}|%dir |" \
505           -e "s|$|/|"             >> filelist.full
506
507## subpackages
508grep "/texmf-dist/doc/" filelist.full > filelist.doc
509cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
510%__mv -f filelist.tmp filelist.full
511
512%clean
513%__rm -rf %{buildroot}
514
515%post
516%{exec_texhash}
517
518[ -f %{texmf}/web2c/updmap.cfg ] || exit 0
519
520    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^#! Map SkakNew.map" && \
521        echo -n "    " && \
522        echo -n "Running updmap: enable SkakNew.map ... " && \
523        %{exec_updmap} --enable Map SkakNew.map >/dev/null 2>&1 && \
524        echo "done."
525
526exit 0
527
528
529%postun
530if [ "$1" = 0 ]; then
531    %{exec_texhash}
532
533    [ -f %{texmf}/web2c/updmap.cfg ] || exit 0
534
535    %{exec_updmap} --listmaps 2>/dev/null | egrep -q "^Map SkakNew.map" && \
536        echo -n "    " && \
537        echo -n "Running updmap: disable SkakNew.map ... " && \
538        %{exec_updmap} --disable SkakNew.map >/dev/null 2>&1 && \
539        echo "done."
540
541fi
542
543exit 0
544
545%files -f filelist.full
546%defattr(-,root,root)
547
548%files -f filelist.doc doc
549%defattr(-,root,root)
550
551%changelog
552* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
553- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-games
Note: See TracBrowser for help on using the repository browser.