source: projects/specs/trunk/t/texlive-collection-formatsextra/texlive-collection-formatsextra-vl.spec @ 7148

Revision 7148, 23.8 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-formatsextra
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Extra formats
48Summary(ja): TeX Live: Extra formats
49Name: texlive-collection-formatsextra
50Version: 2012
51Release: 1%{?_dist_release}
52License: LPPL, GPLv2+, Knuth, Public Domain
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
61#BuildRequires:         texlive-sources = %{version}
62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Extra formats:
81Collected TeX `formats', i.e., large-scale macro packages
82designed to be dumped into .fmt files, other than most common
83ones, such as latex and context.
84
85This package contains the following CTAN packages:
86edmac: Typeset scholarly edition.
87eplain: Extended plain tex macros.
88mltex: The MLTeX system.
89psizzl: A TeX format for physics papers.
90startex: An XML-inspired format for student use.
91texsis: Plain TeX macros for Physicists.
92
93%description -l ja
94TeX Live ソフトウェアディストリビューションは、
95さまざまな Unix, Macintosh, Windows、および
96他のプラットホームに対して完全な TeX システムを提供します。
97多くの異なった言語を含む TeX ドキュメントの
98編集、組版、閲覧、印刷するためのプログラム、
99そして、TeX マクロやフォントライブラリの大きなコレクションを
100同梱しています。
101
102このディストリビューションは
103同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
104TeX に関するたくさんの一般的なドキュメントを含んでいます。
105
106このパッケージは以下のようなパッケージ集です。
107Extra formats:
108Collected TeX `formats', i.e., large-scale macro packages
109designed to be dumped into .fmt files, other than most common
110ones, such as latex and context.
111
112このパッケージは以下の CTAN パッケージを含んでいます:
113edmac: Typeset scholarly edition.
114eplain: Extended plain tex macros.
115mltex: The MLTeX system.
116psizzl: A TeX format for physics papers.
117startex: An XML-inspired format for student use.
118texsis: Plain TeX macros for Physicists.
119
120%package doc
121Summary: TeX Live: Documentation files of %{name}
122Group: Applications/Publishing
123Requires: %{name} = %{version}-%{release}
124
125%description doc
126This package contains documentation files of %{name}.
127
128%prep
129
130%build
131
132%install
133[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
134
135PREF=%{buildroot}%{tex_destdir}
136
137manifest=(
138texmf-dist/doc/latex/edmac/COPYRIGHT
139texmf-dist/doc/latex/edmac/braonain.tex
140texmf-dist/doc/latex/edmac/copying
141texmf-dist/doc/latex/edmac/ed-nfss.txt
142texmf-dist/doc/latex/edmac/edmac.doc
143texmf-dist/doc/latex/edmac/edstanza.doc
144texmf-dist/doc/latex/edmac/edszadoc.tex
145texmf-dist/doc/latex/edmac/features.tex
146texmf-dist/doc/latex/edmac/readme
147texmf-dist/source/latex/edmac/edmac.drv
148texmf-dist/tex/generic/edmac/edmac.tex
149texmf-dist/tex/generic/edmac/edmacfss.sty
150texmf-dist/tex/generic/edmac/edstanza.tex
151texmf-dist/tex/generic/edmac/tabmac.tex
152texmf-dist/doc/eplain/AUTHORS
153texmf-dist/doc/eplain/COPYING
154texmf-dist/doc/eplain/ChangeLog
155texmf-dist/doc/eplain/INSTALL
156texmf-dist/doc/eplain/NEWS
157texmf-dist/doc/eplain/PROJECTS
158texmf-dist/doc/eplain/README
159texmf-dist/doc/eplain/README.TOP
160texmf-dist/doc/eplain/demo/Makefile
161texmf-dist/doc/eplain/demo/lscommnt.tex
162texmf-dist/doc/eplain/demo/xhyper.tex
163texmf-dist/doc/eplain/doc/eplain.html
164texmf-dist/doc/eplain/doc/eplain.pdf
165texmf-dist/doc/eplain/doc/lscommnt.jpg
166texmf-dist/doc/eplain/doc/xhyper.jpg
167texmf-dist/doc/eplain/util/idxuniq
168texmf-dist/doc/eplain/util/trimsee
169texmf-dist/source/eplain/eplain-source-3.4.zip
170texmf-dist/source/eplain/xeplain.tex
171texmf-dist/tex/eplain/arrow.tex
172texmf-dist/tex/eplain/btxmac.tex
173texmf-dist/tex/eplain/eplain.aux
174texmf-dist/tex/eplain/eplain.ini
175texmf-dist/tex/eplain/eplain.tex
176texmf-dist/doc/latex/mltex/README
177texmf-dist/doc/latex/mltex/mltex.txt
178texmf-dist/doc/latex/mltex/testmlft.dvi
179texmf-dist/doc/latex/mltex/testmlft.tex
180texmf-dist/doc/latex/mltex/testmlsw.dvi
181texmf-dist/doc/latex/mltex/testmlsw.tex
182texmf-dist/tex/latex/mltex/lo1enc.def
183texmf-dist/tex/latex/mltex/mlltxchg.def
184texmf-dist/tex/latex/mltex/mltex.sty
185texmf-dist/tex/mltex/config/mltex.ini
186texmf-dist/doc/otherformats/psizzl/base/psizzl.commands
187texmf-dist/doc/otherformats/psizzl/base/psizzl.doc
188texmf-dist/source/psizzl/base/aaaread.me
189texmf-dist/tex/psizzl/base/chapters.Psizzl
190texmf-dist/tex/psizzl/base/citation.Psizzl
191texmf-dist/tex/psizzl/base/fontdefs.Psizzl
192texmf-dist/tex/psizzl/base/index.Psizzl
193texmf-dist/tex/psizzl/base/institut.Psizzl
194texmf-dist/tex/psizzl/base/letter.Psizzl
195texmf-dist/tex/psizzl/base/lists.Psizzl
196texmf-dist/tex/psizzl/base/macros.Psizzl
197texmf-dist/tex/psizzl/base/memo.Psizzl
198texmf-dist/tex/psizzl/base/mypsizzl.tex
199texmf-dist/tex/psizzl/base/options.Psizzl
200texmf-dist/tex/psizzl/base/output.Psizzl
201texmf-dist/tex/psizzl/base/picture.Psizzl
202texmf-dist/tex/psizzl/base/psizzl.tex
203texmf-dist/tex/psizzl/base/publicat.Psizzl
204texmf-dist/tex/psizzl/base/symbols.Psizzl
205texmf-dist/tex/psizzl/base/thesis.Psizzl
206texmf-dist/tex/psizzl/config/psizzl.ini
207texmf-dist/doc/otherformats/startex/base/guide.pdf
208texmf-dist/doc/otherformats/startex/base/ideas.pdf
209texmf-dist/doc/otherformats/startex/base/startex.pdf
210texmf-dist/source/startex/base/INSTALL
211texmf-dist/source/startex/base/README
212texmf-dist/source/startex/base/startex.bib
213texmf-dist/source/startex/base/startex.dtx
214texmf-dist/source/startex/base/startex.ins
215texmf-dist/makeindex/startex/stxglo.ist
216texmf-dist/makeindex/startex/stxind.ist
217texmf-dist/tex/startex/base/a4-article.stx
218texmf-dist/tex/startex/base/article.stx
219texmf-dist/tex/startex/base/ifi-article.stx
220texmf-dist/tex/startex/base/ifi-artikkel.stx
221texmf-dist/tex/startex/base/startex.lan
222texmf-dist/tex/startex/base/startex.tex
223texmf-dist/doc/otherformats/texsis/base/COPYING
224texmf-dist/doc/otherformats/texsis/base/Example.tex
225texmf-dist/doc/otherformats/texsis/base/Fonts.tex
226texmf-dist/doc/otherformats/texsis/base/INSTALL
227texmf-dist/doc/otherformats/texsis/base/Install.tex
228texmf-dist/doc/otherformats/texsis/base/MANIFEST
229texmf-dist/doc/otherformats/texsis/base/Manual.fgl
230texmf-dist/doc/otherformats/texsis/base/Manual.ref
231texmf-dist/doc/otherformats/texsis/base/Manual.tbl
232texmf-dist/doc/otherformats/texsis/base/Manual.tex
233texmf-dist/doc/otherformats/texsis/base/NEWS
234texmf-dist/doc/otherformats/texsis/base/README
235texmf-dist/doc/otherformats/texsis/base/TXSapxF.doc
236texmf-dist/doc/otherformats/texsis/base/TXScover.doc
237texmf-dist/doc/otherformats/texsis/base/TXSdcol.doc
238texmf-dist/doc/otherformats/texsis/base/TXSdoc.doc
239texmf-dist/doc/otherformats/texsis/base/TXSdoc0.doc
240texmf-dist/doc/otherformats/texsis/base/TXSdocM.doc
241texmf-dist/doc/otherformats/texsis/base/TXSend.doc
242texmf-dist/doc/otherformats/texsis/base/TXSenvmt.doc
243texmf-dist/doc/otherformats/texsis/base/TXSeqns.doc
244texmf-dist/doc/otherformats/texsis/base/TXSfigs.doc
245texmf-dist/doc/otherformats/texsis/base/TXSfmts.doc
246texmf-dist/doc/otherformats/texsis/base/TXSfonts.doc
247texmf-dist/doc/otherformats/texsis/base/TXSinstl.doc
248texmf-dist/doc/otherformats/texsis/base/TXSintro.doc
249texmf-dist/doc/otherformats/texsis/base/TXSletr.doc
250texmf-dist/doc/otherformats/texsis/base/TXSmisc.doc
251texmf-dist/doc/otherformats/texsis/base/TXSprns.doc
252texmf-dist/doc/otherformats/texsis/base/TXSrefs.doc
253texmf-dist/doc/otherformats/texsis/base/TXSrevs.doc
254texmf-dist/doc/otherformats/texsis/base/TXSruled.doc
255texmf-dist/doc/otherformats/texsis/base/TXSsects.doc
256texmf-dist/doc/otherformats/texsis/base/TXSsite.000
257texmf-dist/doc/otherformats/texsis/base/TXSsymb.doc
258texmf-dist/doc/otherformats/texsis/base/TXStags.doc
259texmf-dist/doc/otherformats/texsis/base/index.tex
260texmf-dist/doc/otherformats/texsis/base/letr
261texmf-dist/doc/otherformats/texsis/base/penguin.eps
262texmf-dist/doc/otherformats/texsis/base/penguin2.eps
263texmf-dist/doc/otherformats/texsis/base/texsis.1
264texmf-dist/doc/otherformats/texsis/base/texsis.el
265texmf-dist/doc/otherformats/texsis/base/texsis.lsm
266texmf-dist/bibtex/bst/texsis/texsis.bst
267texmf-dist/tex/texsis/base/AIP.txs
268texmf-dist/tex/texsis/base/CVformat.txs
269texmf-dist/tex/texsis/base/Elsevier.txs
270texmf-dist/tex/texsis/base/Exam.txs
271texmf-dist/tex/texsis/base/Formletr.txs
272texmf-dist/tex/texsis/base/IEEE.txs
273texmf-dist/tex/texsis/base/PhysRev.txs
274texmf-dist/tex/texsis/base/Spanish.txs
275texmf-dist/tex/texsis/base/Swedish.txs
276texmf-dist/tex/texsis/base/TXSconts.tex
277texmf-dist/tex/texsis/base/TXSdcol.tex
278texmf-dist/tex/texsis/base/TXSenvmt.tex
279texmf-dist/tex/texsis/base/TXSeqns.tex
280texmf-dist/tex/texsis/base/TXSfigs.tex
281texmf-dist/tex/texsis/base/TXSfmts.tex
282texmf-dist/tex/texsis/base/TXSfonts.tex
283texmf-dist/tex/texsis/base/TXShead.tex
284texmf-dist/tex/texsis/base/TXSinit.tex
285texmf-dist/tex/texsis/base/TXSletr.tex
286texmf-dist/tex/texsis/base/TXSmacs.tex
287texmf-dist/tex/texsis/base/TXSmemo.tex
288texmf-dist/tex/texsis/base/TXSprns.tex
289texmf-dist/tex/texsis/base/TXSrefs.tex
290texmf-dist/tex/texsis/base/TXSruled.tex
291texmf-dist/tex/texsis/base/TXSsects.tex
292texmf-dist/tex/texsis/base/TXSsite.tex
293texmf-dist/tex/texsis/base/TXSsymb.tex
294texmf-dist/tex/texsis/base/TXStags.tex
295texmf-dist/tex/texsis/base/TXStitle.tex
296texmf-dist/tex/texsis/base/Tablebod.txs
297texmf-dist/tex/texsis/base/WorldSci.txs
298texmf-dist/tex/texsis/base/color.txs
299texmf-dist/tex/texsis/base/nuclproc.txs
300texmf-dist/tex/texsis/base/printfont.txs
301texmf-dist/tex/texsis/base/spine.txs
302texmf-dist/tex/texsis/base/texsis.tex
303texmf-dist/tex/texsis/base/thesis.txs
304texmf-dist/tex/texsis/base/twin.txs
305texmf-dist/tex/texsis/config/texsis.ini
306)
307
308%__mkdir_p ${PREF}/texmf-dist
309for i in "${manifest[@]}"; do
310    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
311done
312## make symlinks of core script utils
313mk_symlinks=(
314texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
315texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
316texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
317texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
318texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
319texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
320texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
321texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
322texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
323texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
324texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
325texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
326texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
327texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
328texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
329texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
330texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
331texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
332texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
333texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
334texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
335texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
336texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
337texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
338texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
339texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
340texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
341texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
342texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
343texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
344texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
345texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
346texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
347texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
348texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
349texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
350texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
351texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
352texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
353texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
354texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
355texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
356texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
357texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
358texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
359texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
360texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
361texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
362texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
363texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
364texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
365texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
366texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
367texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
368texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
369texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
370texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
371texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
372texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
373texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
374texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
375texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
376texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
377texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
378texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
379texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
380texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
381texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
382texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
383texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
384texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
385texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
386texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
387texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
388texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
389texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
390texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
391texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
392texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
393texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
394texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
395texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
396texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
397texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
398texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
399texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
400texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
401texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
402texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
403texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
404texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
405texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
406texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
407)
408%__mkdir_p %{buildroot}%{_bindir}
409pushd %{buildroot}%{_bindir}
410    for i in "${mk_symlinks[@]}"; do
411        tlc=$(/bin/echo $i | cut -f 1 -d",")
412        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
413        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
414
415        [ "%{name}" = "$tlc" ] || continue
416        [ -f $rlnk ] || exit 1
417        %__ln_s $rlnk $lnk || exit 1
418    done
419popd
420## Files list
421find %{buildroot} -type f -or -type l | \
422    %__sed -e "s|%{buildroot}||g" > filelist.full
423
424find %{buildroot}%{texmf}-dist -type d | \
425    %__sed -e "s|^%{buildroot}|%dir |" \
426           -e "s|$|/|"             >> filelist.full
427
428## subpackages
429grep "/texmf-dist/doc/" filelist.full > filelist.doc
430cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
431%__mv -f filelist.tmp filelist.full
432
433%clean
434%__rm -rf %{buildroot}
435
436%post
437%touch_run texhash
438%touch_run mtxrun
439
440%touch_run fmtutil
441
442exit 0
443
444
445%postun
446if [ "$1" = 0 ]; then
447    %touch_run texhash
448
449fi
450
451exit 0
452
453%posttrans
454%{exec_texhash}
455%{exec_mtxrun}
456%{exec_updmap}
457%{exec_fmtutil}
458exit 0
459
460
461%files -f filelist.full
462%defattr(-,root,root,-)
463
464%files -f filelist.doc doc
465%defattr(-,root,root,-)
466
467%changelog
468* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
469- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-formatsextra
470
471* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
472- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-formatsextra
473- set external dependencies (texlive-collection-binextra,
474  texlive-collection-fontutils)
475
476* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
477- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-formatsextra
478
479* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
480- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-formatsextra
481- make symlinks of core script utils (texlive-collection-binextra,
482  texlive-collection-context, texlive-collection-fontutils,
483  texlive-collection-langgreek, texlive-collection-langindic,
484  texlive-collection-latex, texlive-collection-latexextra,
485  texlive-collection-latexrecommended, texlive-collection-pictures,
486  texlive-collection-pstricks, texlive-collection-science)
487
488* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
489- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-formatsextra
490- improved %%post
491
492* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
493- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-formatsextra
494- removed arch dependent binaries (texlive-collection-latexextra)
495- fixed perl path
496- improved updmap process in %%post and %%postun
497
498* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
499- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-formatsextra
Note: See TracBrowser for help on using the repository browser.