source: projects/specs/trunk/t/texlive-collection-formatsextra/texlive-collection-formatsextra-vl.spec @ 5207

Revision 5207, 21.3 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
3## tlpdb2rpmspec collection-formatsextra
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
22%define vartexfonts %{_var}/lib/texmf/fonts
23
24Summary: TeX Live: Extra formats
25Summary(ja): TeX Live: Extra formats
26Name: texlive-collection-formatsextra
27Version: 2011
28Release: 1%{?_dist_release}
29License: LPPL, GPLv2+, Knuth, Public Domain
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34Requires: texlive-collection-basic = %{version}
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Extra formats:
58Collected TeX `formats', i.e., large-scale macro packages
59designed to be dumped into .fmt files, other than most common
60ones, such as latex and context.
61
62This package contains the following CTAN packages:
63edmac: Typeset scholarly edition.
64eplain: Extended plain tex macros.
65mltex: The MLTeX system.
66psizzl: A TeX format for physics papers.
67startex: An XML-inspired format for student use.
68texsis: Plain TeX macros for Physicists.
69
70%description -l ja
71TeX Live ソフトウェアディストリビューションは、
72さまざまな Unix, Macintosh, Windows、および
73他のプラットホームに対して完全な TeX システムを提供します。
74多くの異なった言語を含む TeX ドキュメントの
75編集、組版、閲覧、印刷するためのプログラム、
76そして、TeX マクロやフォントライブラリの大きなコレクションを
77同梱しています。
78
79このディストリビューションは
80同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
81TeX に関するたくさんの一般的なドキュメントを含んでいます。
82
83このパッケージは以下のようなパッケージ集です。
84Extra formats:
85Collected TeX `formats', i.e., large-scale macro packages
86designed to be dumped into .fmt files, other than most common
87ones, such as latex and context.
88
89このパッケージは以下の CTAN パッケージを含んでいます:
90edmac: Typeset scholarly edition.
91eplain: Extended plain tex macros.
92mltex: The MLTeX system.
93psizzl: A TeX format for physics papers.
94startex: An XML-inspired format for student use.
95texsis: Plain TeX macros for Physicists.
96
97%package doc
98Summary: TeX Live: Documentation files of %{name}
99Group: Applications/Publishing
100Requires: %{name} = %{version}-%{release}
101
102%description doc
103This package contains documentation files of %{name}.
104
105%prep
106
107%build
108
109%install
110[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
111
112PREF=%{buildroot}%{tex_destdir}
113
114manifest=(
115texmf-dist/doc/latex/edmac/COPYRIGHT
116texmf-dist/doc/latex/edmac/braonain.tex
117texmf-dist/doc/latex/edmac/copying
118texmf-dist/doc/latex/edmac/ed-nfss.txt
119texmf-dist/doc/latex/edmac/edmac.doc
120texmf-dist/doc/latex/edmac/edstanza.doc
121texmf-dist/doc/latex/edmac/edszadoc.tex
122texmf-dist/doc/latex/edmac/features.tex
123texmf-dist/doc/latex/edmac/readme
124texmf-dist/source/latex/edmac/edmac.drv
125texmf-dist/tex/generic/edmac/edmac.tex
126texmf-dist/tex/generic/edmac/edmacfss.sty
127texmf-dist/tex/generic/edmac/edstanza.tex
128texmf-dist/tex/generic/edmac/tabmac.tex
129texmf-dist/doc/eplain/AUTHORS
130texmf-dist/doc/eplain/COPYING
131texmf-dist/doc/eplain/ChangeLog
132texmf-dist/doc/eplain/INSTALL
133texmf-dist/doc/eplain/NEWS
134texmf-dist/doc/eplain/PROJECTS
135texmf-dist/doc/eplain/README
136texmf-dist/doc/eplain/README.TOP
137texmf-dist/doc/eplain/demo/Makefile
138texmf-dist/doc/eplain/demo/lscommnt.tex
139texmf-dist/doc/eplain/demo/xhyper.tex
140texmf-dist/doc/eplain/doc/eplain.html
141texmf-dist/doc/eplain/doc/eplain.pdf
142texmf-dist/doc/eplain/doc/lscommnt.jpg
143texmf-dist/doc/eplain/doc/xhyper.jpg
144texmf-dist/doc/eplain/util/idxuniq
145texmf-dist/doc/eplain/util/trimsee
146texmf-dist/source/eplain/eplain-source-3.4.zip
147texmf-dist/source/eplain/xeplain.tex
148texmf-dist/tex/eplain/arrow.tex
149texmf-dist/tex/eplain/btxmac.tex
150texmf-dist/tex/eplain/eplain.aux
151texmf-dist/tex/eplain/eplain.ini
152texmf-dist/tex/eplain/eplain.tex
153texmf-dist/doc/latex/mltex/README
154texmf-dist/doc/latex/mltex/mltex.txt
155texmf-dist/doc/latex/mltex/testmlft.dvi
156texmf-dist/doc/latex/mltex/testmlft.tex
157texmf-dist/doc/latex/mltex/testmlsw.dvi
158texmf-dist/doc/latex/mltex/testmlsw.tex
159texmf-dist/tex/latex/mltex/lo1enc.def
160texmf-dist/tex/latex/mltex/mlltxchg.def
161texmf-dist/tex/latex/mltex/mltex.sty
162texmf-dist/tex/mltex/config/mltex.ini
163texmf-dist/doc/otherformats/psizzl/base/psizzl.commands
164texmf-dist/doc/otherformats/psizzl/base/psizzl.doc
165texmf-dist/source/psizzl/base/aaaread.me
166texmf-dist/tex/psizzl/base/chapters.Psizzl
167texmf-dist/tex/psizzl/base/citation.Psizzl
168texmf-dist/tex/psizzl/base/fontdefs.Psizzl
169texmf-dist/tex/psizzl/base/index.Psizzl
170texmf-dist/tex/psizzl/base/institut.Psizzl
171texmf-dist/tex/psizzl/base/letter.Psizzl
172texmf-dist/tex/psizzl/base/lists.Psizzl
173texmf-dist/tex/psizzl/base/macros.Psizzl
174texmf-dist/tex/psizzl/base/memo.Psizzl
175texmf-dist/tex/psizzl/base/mypsizzl.tex
176texmf-dist/tex/psizzl/base/options.Psizzl
177texmf-dist/tex/psizzl/base/output.Psizzl
178texmf-dist/tex/psizzl/base/picture.Psizzl
179texmf-dist/tex/psizzl/base/psizzl.tex
180texmf-dist/tex/psizzl/base/publicat.Psizzl
181texmf-dist/tex/psizzl/base/symbols.Psizzl
182texmf-dist/tex/psizzl/base/thesis.Psizzl
183texmf-dist/tex/psizzl/config/psizzl.ini
184texmf-dist/doc/otherformats/startex/base/guide.pdf
185texmf-dist/doc/otherformats/startex/base/ideas.pdf
186texmf-dist/doc/otherformats/startex/base/startex.pdf
187texmf-dist/source/startex/base/INSTALL
188texmf-dist/source/startex/base/README
189texmf-dist/source/startex/base/startex.bib
190texmf-dist/source/startex/base/startex.dtx
191texmf-dist/source/startex/base/startex.ins
192texmf-dist/makeindex/startex/stxglo.ist
193texmf-dist/makeindex/startex/stxind.ist
194texmf-dist/tex/startex/base/a4-article.stx
195texmf-dist/tex/startex/base/article.stx
196texmf-dist/tex/startex/base/ifi-article.stx
197texmf-dist/tex/startex/base/ifi-artikkel.stx
198texmf-dist/tex/startex/base/startex.lan
199texmf-dist/tex/startex/base/startex.tex
200texmf-dist/doc/otherformats/texsis/base/COPYING
201texmf-dist/doc/otherformats/texsis/base/Example.tex
202texmf-dist/doc/otherformats/texsis/base/Fonts.tex
203texmf-dist/doc/otherformats/texsis/base/INSTALL
204texmf-dist/doc/otherformats/texsis/base/Install.tex
205texmf-dist/doc/otherformats/texsis/base/MANIFEST
206texmf-dist/doc/otherformats/texsis/base/Manual.fgl
207texmf-dist/doc/otherformats/texsis/base/Manual.ref
208texmf-dist/doc/otherformats/texsis/base/Manual.tbl
209texmf-dist/doc/otherformats/texsis/base/Manual.tex
210texmf-dist/doc/otherformats/texsis/base/NEWS
211texmf-dist/doc/otherformats/texsis/base/README
212texmf-dist/doc/otherformats/texsis/base/TXSapxF.doc
213texmf-dist/doc/otherformats/texsis/base/TXScover.doc
214texmf-dist/doc/otherformats/texsis/base/TXSdcol.doc
215texmf-dist/doc/otherformats/texsis/base/TXSdoc.doc
216texmf-dist/doc/otherformats/texsis/base/TXSdoc0.doc
217texmf-dist/doc/otherformats/texsis/base/TXSdocM.doc
218texmf-dist/doc/otherformats/texsis/base/TXSend.doc
219texmf-dist/doc/otherformats/texsis/base/TXSenvmt.doc
220texmf-dist/doc/otherformats/texsis/base/TXSeqns.doc
221texmf-dist/doc/otherformats/texsis/base/TXSfigs.doc
222texmf-dist/doc/otherformats/texsis/base/TXSfmts.doc
223texmf-dist/doc/otherformats/texsis/base/TXSfonts.doc
224texmf-dist/doc/otherformats/texsis/base/TXSinstl.doc
225texmf-dist/doc/otherformats/texsis/base/TXSintro.doc
226texmf-dist/doc/otherformats/texsis/base/TXSletr.doc
227texmf-dist/doc/otherformats/texsis/base/TXSmisc.doc
228texmf-dist/doc/otherformats/texsis/base/TXSprns.doc
229texmf-dist/doc/otherformats/texsis/base/TXSrefs.doc
230texmf-dist/doc/otherformats/texsis/base/TXSrevs.doc
231texmf-dist/doc/otherformats/texsis/base/TXSruled.doc
232texmf-dist/doc/otherformats/texsis/base/TXSsects.doc
233texmf-dist/doc/otherformats/texsis/base/TXSsite.000
234texmf-dist/doc/otherformats/texsis/base/TXSsymb.doc
235texmf-dist/doc/otherformats/texsis/base/TXStags.doc
236texmf-dist/doc/otherformats/texsis/base/index.tex
237texmf-dist/doc/otherformats/texsis/base/letr
238texmf-dist/doc/otherformats/texsis/base/penguin.eps
239texmf-dist/doc/otherformats/texsis/base/penguin2.eps
240texmf-dist/doc/otherformats/texsis/base/texsis.1
241texmf-dist/doc/otherformats/texsis/base/texsis.el
242texmf-dist/doc/otherformats/texsis/base/texsis.lsm
243texmf-dist/bibtex/bst/texsis/texsis.bst
244texmf-dist/tex/texsis/base/AIP.txs
245texmf-dist/tex/texsis/base/CVformat.txs
246texmf-dist/tex/texsis/base/Elsevier.txs
247texmf-dist/tex/texsis/base/Exam.txs
248texmf-dist/tex/texsis/base/Formletr.txs
249texmf-dist/tex/texsis/base/IEEE.txs
250texmf-dist/tex/texsis/base/PhysRev.txs
251texmf-dist/tex/texsis/base/Spanish.txs
252texmf-dist/tex/texsis/base/Swedish.txs
253texmf-dist/tex/texsis/base/TXSconts.tex
254texmf-dist/tex/texsis/base/TXSdcol.tex
255texmf-dist/tex/texsis/base/TXSenvmt.tex
256texmf-dist/tex/texsis/base/TXSeqns.tex
257texmf-dist/tex/texsis/base/TXSfigs.tex
258texmf-dist/tex/texsis/base/TXSfmts.tex
259texmf-dist/tex/texsis/base/TXSfonts.tex
260texmf-dist/tex/texsis/base/TXShead.tex
261texmf-dist/tex/texsis/base/TXSinit.tex
262texmf-dist/tex/texsis/base/TXSletr.tex
263texmf-dist/tex/texsis/base/TXSmacs.tex
264texmf-dist/tex/texsis/base/TXSmemo.tex
265texmf-dist/tex/texsis/base/TXSprns.tex
266texmf-dist/tex/texsis/base/TXSrefs.tex
267texmf-dist/tex/texsis/base/TXSruled.tex
268texmf-dist/tex/texsis/base/TXSsects.tex
269texmf-dist/tex/texsis/base/TXSsite.tex
270texmf-dist/tex/texsis/base/TXSsymb.tex
271texmf-dist/tex/texsis/base/TXStags.tex
272texmf-dist/tex/texsis/base/TXStitle.tex
273texmf-dist/tex/texsis/base/Tablebod.txs
274texmf-dist/tex/texsis/base/WorldSci.txs
275texmf-dist/tex/texsis/base/color.txs
276texmf-dist/tex/texsis/base/nuclproc.txs
277texmf-dist/tex/texsis/base/printfont.txs
278texmf-dist/tex/texsis/base/spine.txs
279texmf-dist/tex/texsis/base/texsis.tex
280texmf-dist/tex/texsis/base/thesis.txs
281texmf-dist/tex/texsis/base/twin.txs
282texmf-dist/tex/texsis/config/texsis.ini
283)
284
285%__mkdir_p ${PREF}/texmf-dist
286for i in "${manifest[@]}"; do
287    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
288done
289## make symlinks of core script utils
290mk_symlinks=(
291texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
292texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
293texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
294texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
295texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
296texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
297texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
298texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
299texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
300texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
301texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
302texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
303texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
304texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
305texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
306texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
307texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
308texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
309texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
310texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
311texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
312texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
313texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
314texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
315texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
316texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
317texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
318texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
319texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
320texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
321texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
322texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
323texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
324texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
325texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
326texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
327texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
328texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
329texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
330texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
331texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
332texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
333texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
334texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
335texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
336texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
337texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
338texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
339texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
340texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
341texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
342texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
343texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
344texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
345texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
346texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
347texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
348texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
349texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
350texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
351texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
352texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
353texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
354texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
355texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
356texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
357texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
358texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
359texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
360texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
361texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
362texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
363texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
364texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
365texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
366texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
367texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
368texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
369texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
370texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
371texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
372texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
373)
374%__mkdir_p %{buildroot}%{_bindir}
375pushd %{buildroot}%{_bindir}
376    for i in "${mk_symlinks[@]}"; do
377        tlc=$(echo $i | cut -f 1 -d",")
378        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
379        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
380
381        [ "%{name}" = "$tlc" ] || continue
382        [ -f $rlnk ] || exit 1
383        %__ln_s $rlnk $lnk || exit 1
384    done
385popd
386## Files list
387find %{buildroot} -type f -or -type l | \
388    %__sed -e "s|%{buildroot}||g" > filelist.full
389
390find %{buildroot}%{texmf}-dist -type d | \
391    %__sed -e "s|^%{buildroot}|%dir |" \
392           -e "s|$|/|"             >> filelist.full
393
394## subpackages
395grep "/texmf-dist/doc/" filelist.full > filelist.doc
396cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
397%__mv -f filelist.tmp filelist.full
398
399%clean
400%__rm -rf %{buildroot}
401
402%post
403%{exec_texhash}
404
405rpm -q --quiet texlive-common || exit 0
406
407echo -n "    "
408echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
409
410exit 0
411
412
413%postun
414if [ "$1" = 0 ]; then
415    %{exec_texhash}
416
417fi
418
419exit 0
420
421%files -f filelist.full
422%defattr(-,root,root,-)
423
424%files -f filelist.doc doc
425%defattr(-,root,root,-)
426
427%changelog
428* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
429- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-formatsextra
430
431* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
432- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-formatsextra
433- make symlinks of core script utils (texlive-collection-binextra,
434  texlive-collection-context, texlive-collection-fontutils,
435  texlive-collection-langgreek, texlive-collection-langindic,
436  texlive-collection-latex, texlive-collection-latexextra,
437  texlive-collection-latexrecommended, texlive-collection-pictures,
438  texlive-collection-pstricks, texlive-collection-science)
439
440* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
441- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-formatsextra
442- improved %%post
443
444* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
445- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-formatsextra
446- removed arch dependent binaries (texlive-collection-latexextra)
447- fixed perl path
448- improved updmap process in %%post and %%postun
449
450* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
451- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-formatsextra
Note: See TracBrowser for help on using the repository browser.