source: projects/specs/trunk/t/texlive-collection-formatsextra/texlive-collection-formatsextra-vl.spec @ 1533

Revision 1533, 14.6 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Extra formats
28Summary(ja): TeX Live: Extra formats
29Name: texlive-collection-formatsextra
30Version: 2009
31Release: 1%{?_dist_release}
32License: GPL+, LPPL, Freely redistributable without restriction, Knuth, No Info, Public Domain
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37Requires: texlive-collection-basic = %{version}
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Extra formats:
61A collection of TeX `formats', ie large-scale macro packages
62designed to be dumped into .fmt file
63
64This package contains the following CTAN packages:
65alatex: Abstract LaTeX.
66edmac: Typeset scholarly edition.
67eplain: Extended plain tex macros.
68mltex: The MLTeX system.
69physe: The PHYSE format.
70phyzzx: A TeX format for physicists.
71psizzl: A TeX format for physics papers.
72startex: An XML-inspired format for student use.
73texsis: Plain TeX macros for Physicists.
74ytex: Macro package developed at MIT.
75
76%description -l ja
77TeX Live ソフトウェアディストリビューションは、
78さまざまな Unix, Macintosh, Windows、および
79他のプラットホームに対して完全な TeX システムを提供します。
80多くの異なった言語を含む TeX ドキュメントの
81編集、組版、閲覧、印刷するためのプログラム、
82そして、TeX マクロやフォントライブラリの大きなコレクションを
83同梱しています。
84
85このディストリビューションは
86同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
87TeX に関するたくさんの一般的なドキュメントを含んでいます。
88
89このパッケージは以下のようなパッケージ集です。
90Extra formats:
91A collection of TeX `formats', ie large-scale macro packages
92designed to be dumped into .fmt file
93
94このパッケージは以下の CTAN パッケージを含んでいます:
95alatex: Abstract LaTeX.
96edmac: Typeset scholarly edition.
97eplain: Extended plain tex macros.
98mltex: The MLTeX system.
99physe: The PHYSE format.
100phyzzx: A TeX format for physicists.
101psizzl: A TeX format for physics papers.
102startex: An XML-inspired format for student use.
103texsis: Plain TeX macros for Physicists.
104ytex: Macro package developed at MIT.
105
106%package doc
107Summary: TeX Live: Documentation files of %{name}
108Group: Applications/Publishing
109Requires: %{name} = %{version}-%{release}
110
111%description doc
112This package contains documentation files of %{name}.
113
114%prep
115
116%build
117
118%install
119[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
120
121PREF=%{buildroot}%{tex_destdir}
122
123manifest=(
124texmf-dist/doc/otherformats/alatex/base/alatex.tex
125texmf-dist/source/alatex/base/0areadme.txt
126texmf-dist/source/alatex/base/COPYING
127texmf-dist/source/alatex/base/Makefile
128texmf-dist/source/alatex/base/README
129texmf-dist/source/alatex/base/VERSION-1.0
130texmf-dist/source/alatex/base/abugs.txt
131texmf-dist/source/alatex/base/ainstall.txt
132texmf-dist/source/alatex/base/alatex.dtx
133texmf-dist/source/alatex/base/alatex.ltx
134texmf-dist/source/alatex/base/amanifst.txt
135texmf-dist/source/alatex/base/aunpack.ins
136texmf-dist/source/alatex/base/aunpcked.txt
137texmf-dist/source/alatex/base/testdist.dtx
138texmf-dist/tex/alatex/base/metaclas.cfg
139texmf-dist/doc/latex/edmac/COPYRIGHT
140texmf-dist/doc/latex/edmac/braonain.tex
141texmf-dist/doc/latex/edmac/copying
142texmf-dist/doc/latex/edmac/ed-nfss.txt
143texmf-dist/doc/latex/edmac/edmac.doc
144texmf-dist/doc/latex/edmac/edstanza.doc
145texmf-dist/doc/latex/edmac/edszadoc.tex
146texmf-dist/doc/latex/edmac/features.tex
147texmf-dist/doc/latex/edmac/readme
148texmf-dist/source/latex/edmac/edmac.drv
149texmf-dist/tex/generic/edmac/edmac.tex
150texmf-dist/tex/generic/edmac/edmacfss.sty
151texmf-dist/tex/generic/edmac/edstanza.tex
152texmf-dist/tex/generic/edmac/tabmac.tex
153texmf-dist/doc/eplain/AUTHORS
154texmf-dist/doc/eplain/COPYING
155texmf-dist/doc/eplain/ChangeLog
156texmf-dist/doc/eplain/INSTALL
157texmf-dist/doc/eplain/NEWS
158texmf-dist/doc/eplain/PROJECTS
159texmf-dist/doc/eplain/README
160texmf-dist/doc/eplain/README.TOP
161texmf-dist/doc/eplain/demo/Makefile
162texmf-dist/doc/eplain/demo/lscommnt.tex
163texmf-dist/doc/eplain/demo/xhyper.tex
164texmf-dist/doc/eplain/doc/eplain.html
165texmf-dist/doc/eplain/doc/eplain.pdf
166texmf-dist/doc/eplain/doc/lscommnt.jpg
167texmf-dist/doc/eplain/doc/xhyper.jpg
168texmf-dist/doc/eplain/util/idxuniq
169texmf-dist/doc/eplain/util/trimsee
170texmf-dist/source/eplain/eplain-source-3.3.zip
171texmf-dist/source/eplain/xeplain.tex
172texmf-dist/tex/eplain/arrow.tex
173texmf-dist/tex/eplain/btxmac.tex
174texmf-dist/tex/eplain/eplain.aux
175texmf-dist/tex/eplain/eplain.ini
176texmf-dist/tex/eplain/eplain.tex
177texmf-dist/doc/latex/mltex/README
178texmf-dist/doc/latex/mltex/mltex.txt
179texmf-dist/doc/latex/mltex/testmlft.dvi
180texmf-dist/doc/latex/mltex/testmlft.tex
181texmf-dist/doc/latex/mltex/testmlsw.dvi
182texmf-dist/doc/latex/mltex/testmlsw.tex
183texmf-dist/tex/latex/mltex/lo1enc.def
184texmf-dist/tex/latex/mltex/mlltxchg.def
185texmf-dist/tex/latex/mltex/mltex.sty
186texmf-dist/tex/mltex/config/mltex.ini
187texmf-dist/tex/physe/base/physe.tex
188texmf-dist/tex/physe/base/physupdt.tex
189texmf-dist/tex/physe/config/physe.ini
190texmf-dist/doc/otherformats/phyzzx/base/phyzdoc.dvi
191texmf-dist/doc/otherformats/phyzzx/base/phyzdoc.tex
192texmf-dist/tex/phyzzx/base/myphyx.tex
193texmf-dist/tex/phyzzx/base/phyzzx.fonts
194texmf-dist/tex/phyzzx/base/phyzzx.local
195texmf-dist/tex/phyzzx/base/phyzzx.plus
196texmf-dist/tex/phyzzx/base/phyzzx.tex
197texmf-dist/tex/phyzzx/config/phyzzx.ini
198texmf-dist/doc/otherformats/psizzl/base/psizzl.commands
199texmf-dist/doc/otherformats/psizzl/base/psizzl.doc
200texmf-dist/source/psizzl/base/aaaread.me
201texmf-dist/tex/psizzl/base/chapters.Psizzl
202texmf-dist/tex/psizzl/base/citation.Psizzl
203texmf-dist/tex/psizzl/base/fontdefs.Psizzl
204texmf-dist/tex/psizzl/base/index.Psizzl
205texmf-dist/tex/psizzl/base/institut.Psizzl
206texmf-dist/tex/psizzl/base/letter.Psizzl
207texmf-dist/tex/psizzl/base/lists.Psizzl
208texmf-dist/tex/psizzl/base/macros.Psizzl
209texmf-dist/tex/psizzl/base/memo.Psizzl
210texmf-dist/tex/psizzl/base/mypsizzl.tex
211texmf-dist/tex/psizzl/base/options.Psizzl
212texmf-dist/tex/psizzl/base/output.Psizzl
213texmf-dist/tex/psizzl/base/picture.Psizzl
214texmf-dist/tex/psizzl/base/psizzl.tex
215texmf-dist/tex/psizzl/base/publicat.Psizzl
216texmf-dist/tex/psizzl/base/symbols.Psizzl
217texmf-dist/tex/psizzl/base/thesis.Psizzl
218texmf-dist/tex/psizzl/config/psizzl.ini
219texmf-dist/doc/otherformats/startex/base/guide.pdf
220texmf-dist/doc/otherformats/startex/base/ideas.pdf
221texmf-dist/doc/otherformats/startex/base/startex.pdf
222texmf-dist/source/startex/base/INSTALL
223texmf-dist/source/startex/base/README
224texmf-dist/source/startex/base/startex.bib
225texmf-dist/source/startex/base/startex.dtx
226texmf-dist/source/startex/base/startex.ins
227texmf-dist/makeindex/startex/stxglo.ist
228texmf-dist/makeindex/startex/stxind.ist
229texmf-dist/tex/startex/base/a4-article.stx
230texmf-dist/tex/startex/base/article.stx
231texmf-dist/tex/startex/base/ifi-article.stx
232texmf-dist/tex/startex/base/ifi-artikkel.stx
233texmf-dist/tex/startex/base/startex.lan
234texmf-dist/tex/startex/base/startex.tex
235texmf-dist/doc/otherformats/texsis/base/COPYING
236texmf-dist/doc/otherformats/texsis/base/Example.tex
237texmf-dist/doc/otherformats/texsis/base/Fonts.tex
238texmf-dist/doc/otherformats/texsis/base/INSTALL
239texmf-dist/doc/otherformats/texsis/base/Install.tex
240texmf-dist/doc/otherformats/texsis/base/MANIFEST
241texmf-dist/doc/otherformats/texsis/base/Manual.fgl
242texmf-dist/doc/otherformats/texsis/base/Manual.ref
243texmf-dist/doc/otherformats/texsis/base/Manual.tbl
244texmf-dist/doc/otherformats/texsis/base/Manual.tex
245texmf-dist/doc/otherformats/texsis/base/NEWS
246texmf-dist/doc/otherformats/texsis/base/README
247texmf-dist/doc/otherformats/texsis/base/TXSapxF.doc
248texmf-dist/doc/otherformats/texsis/base/TXScover.doc
249texmf-dist/doc/otherformats/texsis/base/TXSdcol.doc
250texmf-dist/doc/otherformats/texsis/base/TXSdoc.doc
251texmf-dist/doc/otherformats/texsis/base/TXSdoc0.doc
252texmf-dist/doc/otherformats/texsis/base/TXSdocM.doc
253texmf-dist/doc/otherformats/texsis/base/TXSend.doc
254texmf-dist/doc/otherformats/texsis/base/TXSenvmt.doc
255texmf-dist/doc/otherformats/texsis/base/TXSeqns.doc
256texmf-dist/doc/otherformats/texsis/base/TXSfigs.doc
257texmf-dist/doc/otherformats/texsis/base/TXSfmts.doc
258texmf-dist/doc/otherformats/texsis/base/TXSfonts.doc
259texmf-dist/doc/otherformats/texsis/base/TXSinstl.doc
260texmf-dist/doc/otherformats/texsis/base/TXSintro.doc
261texmf-dist/doc/otherformats/texsis/base/TXSletr.doc
262texmf-dist/doc/otherformats/texsis/base/TXSmisc.doc
263texmf-dist/doc/otherformats/texsis/base/TXSprns.doc
264texmf-dist/doc/otherformats/texsis/base/TXSrefs.doc
265texmf-dist/doc/otherformats/texsis/base/TXSrevs.doc
266texmf-dist/doc/otherformats/texsis/base/TXSruled.doc
267texmf-dist/doc/otherformats/texsis/base/TXSsects.doc
268texmf-dist/doc/otherformats/texsis/base/TXSsite.000
269texmf-dist/doc/otherformats/texsis/base/TXSsymb.doc
270texmf-dist/doc/otherformats/texsis/base/TXStags.doc
271texmf-dist/doc/otherformats/texsis/base/index.tex
272texmf-dist/doc/otherformats/texsis/base/letr
273texmf-dist/doc/otherformats/texsis/base/penguin.eps
274texmf-dist/doc/otherformats/texsis/base/penguin2.eps
275texmf-dist/doc/otherformats/texsis/base/texsis.1
276texmf-dist/doc/otherformats/texsis/base/texsis.el
277texmf-dist/doc/otherformats/texsis/base/texsis.lsm
278texmf-dist/bibtex/bst/texsis/texsis.bst
279texmf-dist/tex/texsis/base/AIP.txs
280texmf-dist/tex/texsis/base/CVformat.txs
281texmf-dist/tex/texsis/base/Elsevier.txs
282texmf-dist/tex/texsis/base/Exam.txs
283texmf-dist/tex/texsis/base/Formletr.txs
284texmf-dist/tex/texsis/base/IEEE.txs
285texmf-dist/tex/texsis/base/PhysRev.txs
286texmf-dist/tex/texsis/base/Spanish.txs
287texmf-dist/tex/texsis/base/Swedish.txs
288texmf-dist/tex/texsis/base/TXSconts.tex
289texmf-dist/tex/texsis/base/TXSdcol.tex
290texmf-dist/tex/texsis/base/TXSenvmt.tex
291texmf-dist/tex/texsis/base/TXSeqns.tex
292texmf-dist/tex/texsis/base/TXSfigs.tex
293texmf-dist/tex/texsis/base/TXSfmts.tex
294texmf-dist/tex/texsis/base/TXSfonts.tex
295texmf-dist/tex/texsis/base/TXShead.tex
296texmf-dist/tex/texsis/base/TXSinit.tex
297texmf-dist/tex/texsis/base/TXSletr.tex
298texmf-dist/tex/texsis/base/TXSmacs.tex
299texmf-dist/tex/texsis/base/TXSmemo.tex
300texmf-dist/tex/texsis/base/TXSprns.tex
301texmf-dist/tex/texsis/base/TXSrefs.tex
302texmf-dist/tex/texsis/base/TXSruled.tex
303texmf-dist/tex/texsis/base/TXSsects.tex
304texmf-dist/tex/texsis/base/TXSsite.tex
305texmf-dist/tex/texsis/base/TXSsymb.tex
306texmf-dist/tex/texsis/base/TXStags.tex
307texmf-dist/tex/texsis/base/TXStitle.tex
308texmf-dist/tex/texsis/base/Tablebod.txs
309texmf-dist/tex/texsis/base/WorldSci.txs
310texmf-dist/tex/texsis/base/color.txs
311texmf-dist/tex/texsis/base/nuclproc.txs
312texmf-dist/tex/texsis/base/printfont.txs
313texmf-dist/tex/texsis/base/spine.txs
314texmf-dist/tex/texsis/base/texsis.tex
315texmf-dist/tex/texsis/base/thesis.txs
316texmf-dist/tex/texsis/base/twin.txs
317texmf-dist/tex/texsis/config/texsis.ini
318texmf-dist/tex/ytex/base/ybase.mac
319texmf-dist/tex/ytex/base/yfonts.mac
320texmf-dist/tex/ytex/base/ylog.mac
321texmf-dist/tex/ytex/base/ysite.mac
322texmf-dist/tex/ytex/base/ytex-cm.tex
323texmf-dist/tex/ytex/base/ytex.ieee
324texmf-dist/tex/ytex/base/ytex.mac
325texmf-dist/tex/ytex/base/ytex.mail
326texmf-dist/tex/ytex/base/yusage.lst
327texmf-dist/tex/ytex/base/yusage.tex
328texmf-dist/tex/ytex/base/yuser.mac
329)
330
331%__mkdir_p ${PREF}/texmf-dist
332for i in "${manifest[@]}"; do
333    %__install -D %{texlive_src}/$i ${PREF}/$i
334done
335
336## info
337%__rm -f %{buildroot}%{_infodir}/dir
338%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
339
340## man
341## man t1* files are provided by t1utils
342for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
343    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
344done
345
346## man some files are provided by psutils
347for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
348    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
349done
350
351## remove asymptote directries, which provides asymptote package
352find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
353# find %{buildroot} -name "Makefile" | xargs %__rm -f
354
355# ## remove xindy
356# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
357
358# ## remove tex4ht
359# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
360
361## remove unpackaging files
362find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
363find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
364
365## Files list
366find %{buildroot} -type f -or -type l | \
367    %__sed -e "s|%{buildroot}||g" > filelist.full
368
369find %{buildroot}%{texmf}-dist -type d | \
370    %__sed -e "s|^%{buildroot}|%dir |" \
371           -e "s|$|/|"             >> filelist.full
372
373## subpackages
374grep "/texmf-dist/doc/" filelist.full > filelist.doc
375cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
376%__mv -f filelist.tmp filelist.full
377
378%clean
379%__rm -rf %{buildroot}
380
381%post
382%{exec_texhash}
383
384echo -n "    "
385echo -n "Running fmtutil ... " && %{exec_fmtutil} && echo "done."
386
387exit 0
388
389
390%postun
391if [ "$1" = 0 ]; then
392    %{exec_texhash}
393
394fi
395
396exit 0
397
398%files -f filelist.full
399%defattr(-,root,root)
400
401%files -f filelist.doc doc
402%defattr(-,root,root)
403
404%changelog
405* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
406- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-formatsextra
Note: See TracBrowser for help on using the repository browser.