source: projects/specs/trunk/t/texlive-collection-documentation-ukrainian/texlive-collection-documentation-ukrainian-vl.spec @ 1974

Revision 1974, 5.8 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-documentation-ukrainian
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Ukrainian documentation
28Summary(ja): TeX Live: Ukrainian documentation
29Name: texlive-collection-documentation-ukrainian
30Version: 2009
31Release: 2%{?_dist_release}
32License: Freely redistributable without restriction
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Ukrainian documentation:
61
62
63This package contains the following CTAN packages:
64lshort-ukr: Ukrainian version of the LaTeX introduction.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Ukrainian documentation:
81
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84lshort-ukr: Ukrainian version of the LaTeX introduction.
85
86%prep
87
88%build
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
92
93PREF=%{buildroot}%{tex_destdir}
94
95manifest=(
96texmf-dist/doc/latex/lshort-ukr/lshort-ukr-4.12.src.tar.gz
97texmf-dist/doc/latex/lshort-ukr/lshort-ukr.pdf
98)
99
100%__mkdir_p ${PREF}/texmf-dist
101for i in "${manifest[@]}"; do
102    %__install -D %{texlive_src}/$i ${PREF}/$i
103done
104
105## info
106%__rm -f %{buildroot}%{_infodir}/dir
107%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
108
109## man
110## man t1* files are provided by t1utils
111for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
112    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
113done
114
115## man some files are provided by psutils
116for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
117    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
118done
119
120## fix perl path
121for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
122    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
123done
124
125## remove asymptote directries, which provides asymptote package
126find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
127# find %{buildroot} -name "Makefile" | xargs %__rm -f
128
129# ## remove xindy
130# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
131
132# ## remove tex4ht
133# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
134
135## remove arch dependent binaries
136%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
137
138## remove unpackaging files
139find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
140find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
141
142## Files list
143find %{buildroot} -type f -or -type l | \
144    %__sed -e "s|%{buildroot}||g" > filelist.full
145
146find %{buildroot}%{texmf}-dist -type d | \
147    %__sed -e "s|^%{buildroot}|%dir |" \
148           -e "s|$|/|"             >> filelist.full
149
150%clean
151%__rm -rf %{buildroot}
152
153%post
154%{exec_texhash}
155
156exit 0
157
158
159%postun
160if [ "$1" = 0 ]; then
161    %{exec_texhash}
162
163fi
164
165exit 0
166
167%files -f filelist.full
168%defattr(-,root,root)
169
170%changelog
171* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
172- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-ukrainian
173- removed arch dependent binaries (texlive-collection-latexextra)
174- fixed perl path
175- improved updmap process in %%post and %%postun
176
177* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
178- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-ukrainian
Note: See TracBrowser for help on using the repository browser.