source: projects/specs/trunk/t/texlive-collection-documentation-ukrainian/texlive-collection-documentation-ukrainian-vl.spec @ 7148

Revision 7148, 16.0 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2012

RevLine 
[1533]1## -*- coding: utf-8-unix -*-
[7148]2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
[1974]3## tlpdb2rpmspec collection-documentation-ukrainian
[1533]4
[5207]5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
[7148]9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
[1533]13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
[7148]20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
[1533]46
47Summary: TeX Live: Ukrainian documentation
48Summary(ja): TeX Live: Ukrainian documentation
49Name: texlive-collection-documentation-ukrainian
[7148]50Version: 2012
[5207]51Release: 1%{?_dist_release}
[1533]52License: Freely redistributable without restriction
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
[7148]61#BuildRequires:         texlive-sources = %{version}
[1533]62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Ukrainian documentation:
81
82
83This package contains the following CTAN packages:
84lshort-ukr: Ukrainian version of the LaTeX introduction.
85
86%description -l ja
87TeX Live ソフトウェアディストリビューションは、
88さまざまな Unix, Macintosh, Windows、および
89他のプラットホームに対して完全な TeX システムを提供します。
90多くの異なった言語を含む TeX ドキュメントの
91編集、組版、閲覧、印刷するためのプログラム、
92そして、TeX マクロやフォントライブラリの大きなコレクションを
93同梱しています。
94
95このディストリビューションは
96同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
97TeX に関するたくさんの一般的なドキュメントを含んでいます。
98
99このパッケージは以下のようなパッケージ集です。
100Ukrainian documentation:
101
102
103このパッケージは以下の CTAN パッケージを含んでいます:
104lshort-ukr: Ukrainian version of the LaTeX introduction.
105
106%prep
107
108%build
109
110%install
111[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
112
113PREF=%{buildroot}%{tex_destdir}
114
115manifest=(
116texmf-dist/doc/latex/lshort-ukr/lshort-ukr-4.12.src.tar.gz
117texmf-dist/doc/latex/lshort-ukr/lshort-ukr.pdf
118)
119
120%__mkdir_p ${PREF}/texmf-dist
121for i in "${manifest[@]}"; do
[5207]122    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
[1533]123done
[5207]124## make symlinks of core script utils
125mk_symlinks=(
126texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
[7148]127texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
128texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
[5207]129texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
130texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
[7148]131texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
132texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
[5207]133texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
134texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
135texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
136texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
137texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
138texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
139texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
140texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
[7148]141texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
[5207]142texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
143texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
144texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
[7148]145texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
[5207]146texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
147texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
148texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
149texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
150texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
151texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
152texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
153texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
154texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
155texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
156texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
157texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
158texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
159texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
160texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
161texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
162texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
163texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
164texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
165texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
166texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
167texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
[7148]168texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
[5207]169texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
[7148]170texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
[5207]171texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
172texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
[7148]173texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
[5207]174texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
[7148]175texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
[5207]176texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
177texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
178texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
179texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
180texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
181texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
182texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
183texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
184texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
185texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
186texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
187texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
188texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
[7148]189texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
190texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
[5207]191texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
192texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
193texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
194texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
195texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
[7148]196texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
[5207]197texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
198texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
199texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
200texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
201texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
202texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
203texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
204texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
[7148]205texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
[5207]206texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
[7148]207texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
[5207]208texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
209texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
[7148]210texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
[5207]211texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
212texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
213texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
214texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
215texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
[7148]216texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
[5207]217texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
218texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
219)
220%__mkdir_p %{buildroot}%{_bindir}
221pushd %{buildroot}%{_bindir}
222    for i in "${mk_symlinks[@]}"; do
[7148]223        tlc=$(/bin/echo $i | cut -f 1 -d",")
224        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
225        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
[1533]226
[5207]227        [ "%{name}" = "$tlc" ] || continue
228        [ -f $rlnk ] || exit 1
229        %__ln_s $rlnk $lnk || exit 1
230    done
231popd
[1533]232## Files list
233find %{buildroot} -type f -or -type l | \
234    %__sed -e "s|%{buildroot}||g" > filelist.full
235
236find %{buildroot}%{texmf}-dist -type d | \
237    %__sed -e "s|^%{buildroot}|%dir |" \
238           -e "s|$|/|"             >> filelist.full
239
240%clean
241%__rm -rf %{buildroot}
242
243%post
[7148]244%touch_run texhash
245%touch_run mtxrun
[1533]246
247exit 0
248
249
250%postun
251if [ "$1" = 0 ]; then
[7148]252    %touch_run texhash
[1533]253
254fi
255
256exit 0
257
[7148]258%posttrans
259%{exec_texhash}
260%{exec_mtxrun}
261%{exec_updmap}
262%{exec_fmtutil}
263exit 0
264
265
[1533]266%files -f filelist.full
[5207]267%defattr(-,root,root,-)
[1533]268
269%changelog
[7148]270* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
271- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-documentation-ukrainian
272
273* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
274- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-documentation-ukrainian
275- set external dependencies (texlive-collection-binextra,
276  texlive-collection-fontutils)
277
[5207]278* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
279- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-ukrainian
280
281* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
282- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-ukrainian
283- make symlinks of core script utils (texlive-collection-binextra,
284  texlive-collection-context, texlive-collection-fontutils,
285  texlive-collection-langgreek, texlive-collection-langindic,
286  texlive-collection-latex, texlive-collection-latexextra,
287  texlive-collection-latexrecommended, texlive-collection-pictures,
288  texlive-collection-pstricks, texlive-collection-science)
289
[2505]290* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
291- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-ukrainian
292- improved %%post
293
[1974]294* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
295- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-ukrainian
296- removed arch dependent binaries (texlive-collection-latexextra)
297- fixed perl path
298- improved updmap process in %%post and %%postun
299
[1533]300* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
301- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-ukrainian
Note: See TracBrowser for help on using the repository browser.