source: projects/specs/trunk/t/texlive-collection-documentation-turkish/texlive-collection-documentation-turkish-vl.spec @ 1974

Revision 1974, 5.8 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-documentation-turkish
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Turkish documentation
28Summary(ja): TeX Live: Turkish documentation
29Name: texlive-collection-documentation-turkish
30Version: 2009
31Release: 2%{?_dist_release}
32License: Public Domain
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Turkish documentation:
61
62
63This package contains the following CTAN packages:
64lshort-turkish: Turkish introduction to LaTeX.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Turkish documentation:
81
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84lshort-turkish: Turkish introduction to LaTeX.
85
86%prep
87
88%build
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
92
93PREF=%{buildroot}%{tex_destdir}
94
95manifest=(
96texmf-dist/doc/latex/lshort-turkish/README
97texmf-dist/doc/latex/lshort-turkish/lshort-tr.pdf
98texmf-dist/doc/latex/lshort-turkish/trlshort-src.zip
99)
100
101%__mkdir_p ${PREF}/texmf-dist
102for i in "${manifest[@]}"; do
103    %__install -D %{texlive_src}/$i ${PREF}/$i
104done
105
106## info
107%__rm -f %{buildroot}%{_infodir}/dir
108%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
109
110## man
111## man t1* files are provided by t1utils
112for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
113    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
114done
115
116## man some files are provided by psutils
117for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
118    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
119done
120
121## fix perl path
122for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
123    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
124done
125
126## remove asymptote directries, which provides asymptote package
127find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
128# find %{buildroot} -name "Makefile" | xargs %__rm -f
129
130# ## remove xindy
131# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
132
133# ## remove tex4ht
134# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
135
136## remove arch dependent binaries
137%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
138
139## remove unpackaging files
140find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
141find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
142
143## Files list
144find %{buildroot} -type f -or -type l | \
145    %__sed -e "s|%{buildroot}||g" > filelist.full
146
147find %{buildroot}%{texmf}-dist -type d | \
148    %__sed -e "s|^%{buildroot}|%dir |" \
149           -e "s|$|/|"             >> filelist.full
150
151%clean
152%__rm -rf %{buildroot}
153
154%post
155%{exec_texhash}
156
157exit 0
158
159
160%postun
161if [ "$1" = 0 ]; then
162    %{exec_texhash}
163
164fi
165
166exit 0
167
168%files -f filelist.full
169%defattr(-,root,root)
170
171%changelog
172* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
173- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-turkish
174- removed arch dependent binaries (texlive-collection-latexextra)
175- fixed perl path
176- improved updmap process in %%post and %%postun
177
178* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
179- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-turkish
Note: See TracBrowser for help on using the repository browser.