source: projects/specs/trunk/t/texlive-collection-documentation-spanish/texlive-collection-documentation-spanish-vl.spec @ 1533

Revision 1533, 6.1 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Spanish documentation
28Summary(ja): TeX Live: Spanish documentation
29Name: texlive-collection-documentation-spanish
30Version: 2009
31Release: 1%{?_dist_release}
32License: LPPL, Public Domain, Freely redistributable without restriction
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Spanish documentation:
61
62
63This package contains the following CTAN packages:
64es-tex-faq: CervanTeX (Spanish TeX Group) FAQ
65l2tabu-spanish: Spanish translation of "Obsolete packages and commands".
66lshort-spanish: Short introduction to LaTeX, Spanish translation.
67
68%description -l ja
69TeX Live ソフトウェアディストリビューションは、
70さまざまな Unix, Macintosh, Windows、および
71他のプラットホームに対して完全な TeX システムを提供します。
72多くの異なった言語を含む TeX ドキュメントの
73編集、組版、閲覧、印刷するためのプログラム、
74そして、TeX マクロやフォントライブラリの大きなコレクションを
75同梱しています。
76
77このディストリビューションは
78同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
79TeX に関するたくさんの一般的なドキュメントを含んでいます。
80
81このパッケージは以下のようなパッケージ集です。
82Spanish documentation:
83
84
85このパッケージは以下の CTAN パッケージを含んでいます:
86es-tex-faq: CervanTeX (Spanish TeX Group) FAQ
87l2tabu-spanish: Spanish translation of "Obsolete packages and commands".
88lshort-spanish: Short introduction to LaTeX, Spanish translation.
89
90%prep
91
92%build
93
94%install
95[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
96
97PREF=%{buildroot}%{tex_destdir}
98
99manifest=(
100texmf-dist/doc/generic/es-tex-faq/FAQ-CervanTeX.html
101texmf-dist/doc/generic/es-tex-faq/FAQ-CervanTeX.latin1
102texmf-dist/doc/generic/es-tex-faq/FAQ-CervanTeX.pdf
103texmf-dist/doc/generic/es-tex-faq/FAQ-CervanTeX.sgml
104texmf-dist/doc/generic/es-tex-faq/FAQ-CervanTeX.tex
105texmf-dist/doc/latex/l2tabu-spanish/README
106texmf-dist/doc/latex/l2tabu-spanish/l2tabues.pdf
107texmf-dist/doc/latex/l2tabu-spanish/l2tabues.tex
108texmf-dist/doc/latex/lshort-spanish/fuente/CAMBIOS
109texmf-dist/doc/latex/lshort-spanish/fuente/LEAME.latin1
110texmf-dist/doc/latex/lshort-spanish/fuente/LEAME.utf8
111texmf-dist/doc/latex/lshort-spanish/fuente/MANIFEST
112texmf-dist/doc/latex/lshort-spanish/fuente/Makefile
113texmf-dist/doc/latex/lshort-spanish/fuente/fixdate.pl
114texmf-dist/doc/latex/lshort-spanish/fuente/src.zip
115texmf-dist/doc/latex/lshort-spanish/lshort.pdf
116)
117
118%__mkdir_p ${PREF}/texmf-dist
119for i in "${manifest[@]}"; do
120    %__install -D %{texlive_src}/$i ${PREF}/$i
121done
122
123## info
124%__rm -f %{buildroot}%{_infodir}/dir
125%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
126
127## man
128## man t1* files are provided by t1utils
129for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
130    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
131done
132
133## man some files are provided by psutils
134for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
135    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
136done
137
138## remove asymptote directries, which provides asymptote package
139find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
140# find %{buildroot} -name "Makefile" | xargs %__rm -f
141
142# ## remove xindy
143# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
144
145# ## remove tex4ht
146# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
147
148## remove unpackaging files
149find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
150find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
151
152## Files list
153find %{buildroot} -type f -or -type l | \
154    %__sed -e "s|%{buildroot}||g" > filelist.full
155
156find %{buildroot}%{texmf}-dist -type d | \
157    %__sed -e "s|^%{buildroot}|%dir |" \
158           -e "s|$|/|"             >> filelist.full
159
160%clean
161%__rm -rf %{buildroot}
162
163%post
164%{exec_texhash}
165
166exit 0
167
168
169%postun
170if [ "$1" = 0 ]; then
171    %{exec_texhash}
172
173fi
174
175exit 0
176
177%files -f filelist.full
178%defattr(-,root,root)
179
180%changelog
181* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
182- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-spanish
Note: See TracBrowser for help on using the repository browser.