source: projects/specs/trunk/t/texlive-collection-documentation-serbian/texlive-collection-documentation-serbian-vl.spec @ 7148

Revision 7148, 15.8 KB checked in by munepi, 11 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-documentation-serbian
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Serbian documentation
48Summary(ja): TeX Live: Serbian documentation
49Name: texlive-collection-documentation-serbian
50Version: 2012
51Release: 1%{?_dist_release}
52License: distributable
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57
58
59Requires(post):         texlive = %{version}
60Requires(postun):       texlive = %{version}
61#BuildRequires:         texlive-sources = %{version}
62
63BuildArch:      noarch
64Buildroot:      %{_tmppath}/%{name}-%{version}-root
65
66Vendor:         Project Vine
67Distribution:   Vine Linux
68Packager:       munepi
69
70%description
71The TeX Live software distribution offers a complete TeX system for a
72variety of Unix, Macintosh, Windows and other platforms. It
73encompasses programs for editing, typesetting, previewing and printing
74of TeX documents in many different languages, and a large collection
75of TeX macros and font libraries.
76
77The distribution includes extensive general documentation about TeX,
78as well as the documentation for the included software packages.
79
80This package is a collection of Serbian documentation:
81
82
83This package contains the following CTAN packages:
84texlive-sr: TeX Live manual (Serbian)
85
86%description -l ja
87TeX Live ソフトウェアディストリビューションは、
88さまざまな Unix, Macintosh, Windows、および
89他のプラットホームに対して完全な TeX システムを提供します。
90多くの異なった言語を含む TeX ドキュメントの
91編集、組版、閲覧、印刷するためのプログラム、
92そして、TeX マクロやフォントライブラリの大きなコレクションを
93同梱しています。
94
95このディストリビューションは
96同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
97TeX に関するたくさんの一般的なドキュメントを含んでいます。
98
99このパッケージは以下のようなパッケージ集です。
100Serbian documentation:
101
102
103このパッケージは以下の CTAN パッケージを含んでいます:
104texlive-sr: TeX Live manual (Serbian)
105
106%prep
107
108%build
109
110%install
111[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
112
113PREF=%{buildroot}%{tex_destdir}
114
115manifest=(
116
117)
118
119%__mkdir_p ${PREF}/texmf-dist
120for i in "${manifest[@]}"; do
121    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
122done
123## make symlinks of core script utils
124mk_symlinks=(
125texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
126texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
127texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
128texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
129texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
130texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
131texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
132texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
133texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
134texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
135texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
136texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
137texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
138texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
139texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
140texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
141texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
142texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
143texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
144texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
145texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
146texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
147texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
148texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
149texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
150texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
151texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
152texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
153texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
154texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
155texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
156texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
157texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
158texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
159texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
160texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
161texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
162texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
163texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
164texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
165texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
166texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
167texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
168texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
169texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
170texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
171texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
172texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
173texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
174texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
175texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
176texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
177texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
178texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
179texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
180texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
181texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
182texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
183texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
184texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
185texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
186texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
187texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
188texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
189texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
190texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
191texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
192texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
193texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
194texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
195texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
196texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
197texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
198texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
199texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
200texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
201texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
202texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
203texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
204texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
205texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
206texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
207texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
208texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
209texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
210texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
211texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
212texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
213texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
214texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
215texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
216texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
217texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
218)
219%__mkdir_p %{buildroot}%{_bindir}
220pushd %{buildroot}%{_bindir}
221    for i in "${mk_symlinks[@]}"; do
222        tlc=$(/bin/echo $i | cut -f 1 -d",")
223        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
224        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
225
226        [ "%{name}" = "$tlc" ] || continue
227        [ -f $rlnk ] || exit 1
228        %__ln_s $rlnk $lnk || exit 1
229    done
230popd
231## Files list
232find %{buildroot} -type f -or -type l | \
233    %__sed -e "s|%{buildroot}||g" > filelist.full
234
235find %{buildroot}%{texmf}-dist -type d | \
236    %__sed -e "s|^%{buildroot}|%dir |" \
237           -e "s|$|/|"             >> filelist.full
238
239%clean
240%__rm -rf %{buildroot}
241
242%post
243%touch_run texhash
244%touch_run mtxrun
245
246exit 0
247
248
249%postun
250if [ "$1" = 0 ]; then
251    %touch_run texhash
252
253fi
254
255exit 0
256
257%posttrans
258%{exec_texhash}
259%{exec_mtxrun}
260%{exec_updmap}
261%{exec_fmtutil}
262exit 0
263
264
265%files -f filelist.full
266%defattr(-,root,root,-)
267
268%changelog
269* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
270- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-documentation-serbian
271
272* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
273- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-documentation-serbian
274- set external dependencies (texlive-collection-binextra,
275  texlive-collection-fontutils)
276
277* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
278- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-serbian
279
280* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
281- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-serbian
282- make symlinks of core script utils (texlive-collection-binextra,
283  texlive-collection-context, texlive-collection-fontutils,
284  texlive-collection-langgreek, texlive-collection-langindic,
285  texlive-collection-latex, texlive-collection-latexextra,
286  texlive-collection-latexrecommended, texlive-collection-pictures,
287  texlive-collection-pstricks, texlive-collection-science)
288
289* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
290- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-serbian
291- improved %%post
292
293* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
294- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-serbian
295- removed arch dependent binaries (texlive-collection-latexextra)
296- fixed perl path
297- improved updmap process in %%post and %%postun
298
299* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
300- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-serbian
Note: See TracBrowser for help on using the repository browser.