source: projects/specs/trunk/t/texlive-collection-documentation-mongolian/texlive-collection-documentation-mongolian-vl.spec @ 5207

Revision 5207, 14.5 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
3## tlpdb2rpmspec collection-documentation-mongolian
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
22%define vartexfonts %{_var}/lib/texmf/fonts
23
24Summary: TeX Live: Mongolian documentation
25Summary(ja): TeX Live: Mongolian documentation
26Name: texlive-collection-documentation-mongolian
27Version: 2011
28Release: 1%{?_dist_release}
29License: LPPL
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Mongolian documentation:
58
59
60This package contains the following CTAN packages:
61lshort-mongol: Short introduction to LaTeX, in Mongolian.
62
63%description -l ja
64TeX Live ソフトウェアディストリビューションは、
65さまざまな Unix, Macintosh, Windows、および
66他のプラットホームに対して完全な TeX システムを提供します。
67多くの異なった言語を含む TeX ドキュメントの
68編集、組版、閲覧、印刷するためのプログラム、
69そして、TeX マクロやフォントライブラリの大きなコレクションを
70同梱しています。
71
72このディストリビューションは
73同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
74TeX に関するたくさんの一般的なドキュメントを含んでいます。
75
76このパッケージは以下のようなパッケージ集です。
77Mongolian documentation:
78
79
80このパッケージは以下の CTAN パッケージを含んでいます:
81lshort-mongol: Short introduction to LaTeX, in Mongolian.
82
83%prep
84
85%build
86
87%install
88[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
89
90PREF=%{buildroot}%{tex_destdir}
91
92manifest=(
93texmf-dist/doc/latex/lshort-mongol/00README
94texmf-dist/doc/latex/lshort-mongol/CHANGES
95texmf-dist/doc/latex/lshort-mongol/MANIFEST
96texmf-dist/doc/latex/lshort-mongol/Makefile
97texmf-dist/doc/latex/lshort-mongol/README
98texmf-dist/doc/latex/lshort-mongol/TODO
99texmf-dist/doc/latex/lshort-mongol/TRANSLATIONS
100texmf-dist/doc/latex/lshort-mongol/fixdate.pl
101texmf-dist/doc/latex/lshort-mongol/lshort-mn.pdf
102texmf-dist/doc/latex/lshort-mongol/src/appendix.tex
103texmf-dist/doc/latex/lshort-mongol/src/biblio.tex
104texmf-dist/doc/latex/lshort-mongol/src/contrib.tex
105texmf-dist/doc/latex/lshort-mongol/src/custom.tex
106texmf-dist/doc/latex/lshort-mongol/src/fancyhea.sty
107texmf-dist/doc/latex/lshort-mongol/src/graphic.tex
108texmf-dist/doc/latex/lshort-mongol/src/lshort-a5.tex
109texmf-dist/doc/latex/lshort-mongol/src/lshort-base.tex
110texmf-dist/doc/latex/lshort-mongol/src/lshort-mn.tex
111texmf-dist/doc/latex/lshort-mongol/src/lshort.sty
112texmf-dist/doc/latex/lshort-mongol/src/lssym.tex
113texmf-dist/doc/latex/lshort-mongol/src/math.tex
114texmf-dist/doc/latex/lshort-mongol/src/mylayout.sty
115texmf-dist/doc/latex/lshort-mongol/src/overview.tex
116texmf-dist/doc/latex/lshort-mongol/src/spec.tex
117texmf-dist/doc/latex/lshort-mongol/src/things.tex
118texmf-dist/doc/latex/lshort-mongol/src/title.tex
119texmf-dist/doc/latex/lshort-mongol/src/typeset.tex
120)
121
122%__mkdir_p ${PREF}/texmf-dist
123for i in "${manifest[@]}"; do
124    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
125done
126## make symlinks of core script utils
127mk_symlinks=(
128texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
129texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
130texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
131texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
132texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
133texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
134texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
135texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
136texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
137texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
138texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
139texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
140texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
141texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
142texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
143texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
144texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
145texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
146texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
147texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
148texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
149texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
150texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
151texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
152texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
153texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
154texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
155texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
156texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
157texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
158texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
159texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
160texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
161texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
162texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
163texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
164texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
165texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
166texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
167texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
168texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
169texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
170texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
171texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
172texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
173texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
174texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
175texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
176texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
177texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
178texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
179texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
180texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
181texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
182texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
183texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
184texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
185texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
186texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
187texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
188texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
189texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
190texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
191texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
192texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
193texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
194texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
195texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
196texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
197texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
198texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
199texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
200texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
201texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
202texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
203texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
204texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
205texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
206texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
207texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
208texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
209texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
210)
211%__mkdir_p %{buildroot}%{_bindir}
212pushd %{buildroot}%{_bindir}
213    for i in "${mk_symlinks[@]}"; do
214        tlc=$(echo $i | cut -f 1 -d",")
215        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
216        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
217
218        [ "%{name}" = "$tlc" ] || continue
219        [ -f $rlnk ] || exit 1
220        %__ln_s $rlnk $lnk || exit 1
221    done
222popd
223## Files list
224find %{buildroot} -type f -or -type l | \
225    %__sed -e "s|%{buildroot}||g" > filelist.full
226
227find %{buildroot}%{texmf}-dist -type d | \
228    %__sed -e "s|^%{buildroot}|%dir |" \
229           -e "s|$|/|"             >> filelist.full
230
231%clean
232%__rm -rf %{buildroot}
233
234%post
235%{exec_texhash}
236
237exit 0
238
239
240%postun
241if [ "$1" = 0 ]; then
242    %{exec_texhash}
243
244fi
245
246exit 0
247
248%files -f filelist.full
249%defattr(-,root,root,-)
250
251%changelog
252* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
253- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-mongolian
254
255* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
256- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-mongolian
257- make symlinks of core script utils (texlive-collection-binextra,
258  texlive-collection-context, texlive-collection-fontutils,
259  texlive-collection-langgreek, texlive-collection-langindic,
260  texlive-collection-latex, texlive-collection-latexextra,
261  texlive-collection-latexrecommended, texlive-collection-pictures,
262  texlive-collection-pstricks, texlive-collection-science)
263
264* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
265- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-mongolian
266- improved %%post
267
268* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
269- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-mongolian
270- removed arch dependent binaries (texlive-collection-latexextra)
271- fixed perl path
272- improved updmap process in %%post and %%postun
273
274* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
275- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-mongolian
Note: See TracBrowser for help on using the repository browser.