source: projects/specs/trunk/t/texlive-collection-documentation-japanese/texlive-collection-documentation-japanese-vl.spec @ 1533

Revision 1533, 5.2 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Japanese documentation
28Summary(ja): TeX Live: Japanese documentation
29Name: texlive-collection-documentation-japanese
30Version: 2009
31Release: 1%{?_dist_release}
32License: GPL+
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Japanese documentation:
61
62
63This package contains the following CTAN packages:
64lshort-japanese: Japanese version of A Short Introduction to LaTeX2e
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Japanese documentation:
81
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84lshort-japanese: Japanese version of A Short Introduction to LaTeX2e
85
86%prep
87
88%build
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
92
93PREF=%{buildroot}%{tex_destdir}
94
95manifest=(
96texmf-dist/doc/latex/lshort-japanese/00README
97texmf-dist/doc/latex/lshort-japanese/CHANGES.jp
98texmf-dist/doc/latex/lshort-japanese/READ.ME
99texmf-dist/doc/latex/lshort-japanese/jlshort-1.00.src.tar.gz
100texmf-dist/doc/latex/lshort-japanese/jlshort.pdf
101)
102
103%__mkdir_p ${PREF}/texmf-dist
104for i in "${manifest[@]}"; do
105    %__install -D %{texlive_src}/$i ${PREF}/$i
106done
107
108## info
109%__rm -f %{buildroot}%{_infodir}/dir
110%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
111
112## man
113## man t1* files are provided by t1utils
114for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
115    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
116done
117
118## man some files are provided by psutils
119for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
120    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
121done
122
123## remove asymptote directries, which provides asymptote package
124find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
125# find %{buildroot} -name "Makefile" | xargs %__rm -f
126
127# ## remove xindy
128# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
129
130# ## remove tex4ht
131# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
132
133## remove unpackaging files
134find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
135find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
136
137## Files list
138find %{buildroot} -type f -or -type l | \
139    %__sed -e "s|%{buildroot}||g" > filelist.full
140
141find %{buildroot}%{texmf}-dist -type d | \
142    %__sed -e "s|^%{buildroot}|%dir |" \
143           -e "s|$|/|"             >> filelist.full
144
145%clean
146%__rm -rf %{buildroot}
147
148%post
149%{exec_texhash}
150
151exit 0
152
153
154%postun
155if [ "$1" = 0 ]; then
156    %{exec_texhash}
157
158fi
159
160exit 0
161
162%files -f filelist.full
163%defattr(-,root,root)
164
165%changelog
166* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
167- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-japanese
Note: See TracBrowser for help on using the repository browser.