source: projects/specs/trunk/t/texlive-collection-documentation-finnish/texlive-collection-documentation-finnish-vl.spec @ 5207

Revision 5207, 14.1 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

RevLine 
[1533]1## -*- coding: utf-8-unix -*-
[5207]2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
[1974]3## tlpdb2rpmspec collection-documentation-finnish
[1533]4
[5207]5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
[1533]9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
[5207]19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
[1533]20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
[5207]22%define vartexfonts %{_var}/lib/texmf/fonts
[1533]23
24Summary: TeX Live: Finnish documentation
25Summary(ja): TeX Live: Finnish documentation
26Name: texlive-collection-documentation-finnish
[5207]27Version: 2011
28Release: 1%{?_dist_release}
[1533]29License: Public Domain
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Finnish documentation:
58
59
60This package contains the following CTAN packages:
61lshort-finnish: Finnish introduction to LaTeX.
62
63%description -l ja
64TeX Live ソフトウェアディストリビューションは、
65さまざまな Unix, Macintosh, Windows、および
66他のプラットホームに対して完全な TeX システムを提供します。
67多くの異なった言語を含む TeX ドキュメントの
68編集、組版、閲覧、印刷するためのプログラム、
69そして、TeX マクロやフォントライブラリの大きなコレクションを
70同梱しています。
71
72このディストリビューションは
73同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
74TeX に関するたくさんの一般的なドキュメントを含んでいます。
75
76このパッケージは以下のようなパッケージ集です。
77Finnish documentation:
78
79
80このパッケージは以下の CTAN パッケージを含んでいます:
81lshort-finnish: Finnish introduction to LaTeX.
82
83%prep
84
85%build
86
87%install
88[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
89
90PREF=%{buildroot}%{tex_destdir}
91
92manifest=(
93texmf-dist/doc/latex/lshort-finnish/README
94texmf-dist/doc/latex/lshort-finnish/lyhyt2e.pdf
95texmf-dist/doc/latex/lshort-finnish/src/asiat.tex
96texmf-dist/doc/latex/lshort-finnish/src/erikois.tex
97texmf-dist/doc/latex/lshort-finnish/src/esipuhe.tex
98texmf-dist/doc/latex/lshort-finnish/src/grafiikka.tex
99texmf-dist/doc/latex/lshort-finnish/src/kiitokset.tex
100texmf-dist/doc/latex/lshort-finnish/src/kirjallisuus.tex
101texmf-dist/doc/latex/lshort-finnish/src/ladonta.tex
102texmf-dist/doc/latex/lshort-finnish/src/llyhyt2e.sty
103texmf-dist/doc/latex/lshort-finnish/src/lyhyt2e.ind
104texmf-dist/doc/latex/lshort-finnish/src/lyhyt2e.tex
105texmf-dist/doc/latex/lshort-finnish/src/matikka.tex
106texmf-dist/doc/latex/lshort-finnish/src/mylayout.sty
107texmf-dist/doc/latex/lshort-finnish/src/otsikko.tex
108texmf-dist/doc/latex/lshort-finnish/src/symbolit.tex
109texmf-dist/doc/latex/lshort-finnish/src/typeset.tex
110texmf-dist/doc/latex/lshort-finnish/src/viritys.tex
111)
112
113%__mkdir_p ${PREF}/texmf-dist
114for i in "${manifest[@]}"; do
[5207]115    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
[1533]116done
[5207]117## make symlinks of core script utils
118mk_symlinks=(
119texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
120texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
121texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
122texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
123texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
124texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
125texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
126texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
127texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
128texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
129texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
130texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
131texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
132texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
133texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
134texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
135texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
136texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
137texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
138texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
139texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
140texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
141texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
142texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
143texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
144texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
145texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
146texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
147texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
148texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
149texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
150texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
151texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
152texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
153texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
154texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
155texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
156texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
157texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
158texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
159texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
160texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
161texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
162texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
163texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
164texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
165texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
166texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
167texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
168texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
169texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
170texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
171texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
172texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
173texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
174texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
175texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
176texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
177texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
178texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
179texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
180texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
181texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
182texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
183texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
184texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
185texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
186texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
187texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
188texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
189texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
190texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
191texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
192texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
193texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
194texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
195texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
196texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
197texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
198texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
199texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
200texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
201)
202%__mkdir_p %{buildroot}%{_bindir}
203pushd %{buildroot}%{_bindir}
204    for i in "${mk_symlinks[@]}"; do
205        tlc=$(echo $i | cut -f 1 -d",")
206        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
207        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
[1533]208
[5207]209        [ "%{name}" = "$tlc" ] || continue
210        [ -f $rlnk ] || exit 1
211        %__ln_s $rlnk $lnk || exit 1
212    done
213popd
[1533]214## Files list
215find %{buildroot} -type f -or -type l | \
216    %__sed -e "s|%{buildroot}||g" > filelist.full
217
218find %{buildroot}%{texmf}-dist -type d | \
219    %__sed -e "s|^%{buildroot}|%dir |" \
220           -e "s|$|/|"             >> filelist.full
221
222%clean
223%__rm -rf %{buildroot}
224
225%post
226%{exec_texhash}
227
228exit 0
229
230
231%postun
232if [ "$1" = 0 ]; then
233    %{exec_texhash}
234
235fi
236
237exit 0
238
239%files -f filelist.full
[5207]240%defattr(-,root,root,-)
[1533]241
242%changelog
[5207]243* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
244- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-finnish
245
246* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
247- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-finnish
248- make symlinks of core script utils (texlive-collection-binextra,
249  texlive-collection-context, texlive-collection-fontutils,
250  texlive-collection-langgreek, texlive-collection-langindic,
251  texlive-collection-latex, texlive-collection-latexextra,
252  texlive-collection-latexrecommended, texlive-collection-pictures,
253  texlive-collection-pstricks, texlive-collection-science)
254
[2505]255* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
256- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-finnish
257- improved %%post
258
[1974]259* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
260- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-finnish
261- removed arch dependent binaries (texlive-collection-latexextra)
262- fixed perl path
263- improved updmap process in %%post and %%postun
264
[1533]265* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
266- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-finnish
Note: See TracBrowser for help on using the repository browser.