source: projects/specs/trunk/t/texlive-collection-documentation-dutch/texlive-collection-documentation-dutch-vl.spec @ 5207

Revision 5207, 13.4 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2011

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2011-1:
3## tlpdb2rpmspec collection-documentation-dutch
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%bcond_with firstbuild
10
11%define tex_destdir     %{_datadir}
12%define texmf           %{tex_destdir}/texmf
13%define texlive_src     %{tex_destdir}/texlive-sources
14%define build_tex_destdir       %{buildroot}%{tex_destdir}
15%define build_texmf     %{buildroot}%{texmf}
16
17%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
18%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
19%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys
20%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
21%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
22%define vartexfonts %{_var}/lib/texmf/fonts
23
24Summary: TeX Live: Dutch documentation
25Summary(ja): TeX Live: Dutch documentation
26Name: texlive-collection-documentation-dutch
27Version: 2011
28Release: 1%{?_dist_release}
29License: GPL+
30Group: Applications/Publishing
31URL:http://www.tug.org/texlive/
32
33Requires: texlive = %{version}
34
35
36Requires(post):         texlive = %{version}
37Requires(postun):       texlive = %{version}
38BuildRequires:          texlive-sources = %{version}
39
40BuildArch:      noarch
41Buildroot:      %{_tmppath}/%{name}-%{version}-root
42
43Vendor:         Project Vine
44Distribution:   Vine Linux
45Packager:       munepi
46
47%description
48The TeX Live software distribution offers a complete TeX system for a
49variety of Unix, Macintosh, Windows and other platforms. It
50encompasses programs for editing, typesetting, previewing and printing
51of TeX documents in many different languages, and a large collection
52of TeX macros and font libraries.
53
54The distribution includes extensive general documentation about TeX,
55as well as the documentation for the included software packages.
56
57This package is a collection of Dutch documentation:
58
59
60This package contains the following CTAN packages:
61lshort-dutch: Introduction to LaTeX in Dutch.
62
63%description -l ja
64TeX Live ソフトウェアディストリビューションは、
65さまざまな Unix, Macintosh, Windows、および
66他のプラットホームに対して完全な TeX システムを提供します。
67多くの異なった言語を含む TeX ドキュメントの
68編集、組版、閲覧、印刷するためのプログラム、
69そして、TeX マクロやフォントライブラリの大きなコレクションを
70同梱しています。
71
72このディストリビューションは
73同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
74TeX に関するたくさんの一般的なドキュメントを含んでいます。
75
76このパッケージは以下のようなパッケージ集です。
77Dutch documentation:
78
79
80このパッケージは以下の CTAN パッケージを含んでいます:
81lshort-dutch: Introduction to LaTeX in Dutch.
82
83%prep
84
85%build
86
87%install
88[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
89
90PREF=%{buildroot}%{tex_destdir}
91
92manifest=(
93texmf-dist/doc/latex/lshort-dutch/LEESMIJ
94texmf-dist/doc/latex/lshort-dutch/README
95texmf-dist/doc/latex/lshort-dutch/WIJZIGINGEN
96texmf-dist/doc/latex/lshort-dutch/lshort-nl-1.3.pdf
97texmf-dist/doc/latex/lshort-dutch/lshort-nl-1.3.src.zip
98)
99
100%__mkdir_p ${PREF}/texmf-dist
101for i in "${manifest[@]}"; do
102    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
103done
104## make symlinks of core script utils
105mk_symlinks=(
106texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
107texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
108texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
109texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
110texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
111texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
112texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
113texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
114texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
115texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
116texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
117texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
118texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
119texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
120texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
121texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
122texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
123texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
124texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
125texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
126texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
127texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
128texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
129texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
130texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
131texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
132texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
133texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
134texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
135texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
136texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
137texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
138texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
139texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
140texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
141texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
142texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
143texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
144texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
145texlive-collection-fontutils,/usr/bin/cmap2enc,/usr/share/texmf-dist/scripts/fontools/cmap2enc
146texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
147texlive-collection-fontutils,/usr/bin/font2afm,/usr/share/texmf-dist/scripts/fontools/font2afm
148texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
149texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
150texlive-collection-fontutils,/usr/bin/pfm2kpx,/usr/share/texmf-dist/scripts/fontools/pfm2kpx
151texlive-collection-fontutils,/usr/bin/showglyphs,/usr/share/texmf-dist/scripts/fontools/showglyphs
152texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
153texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
154texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
155texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
156texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
157texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
158texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
159texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
160texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
161texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
162texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
163texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
164texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
165texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
166texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
167texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
168texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
169texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
170texlive-collection-latexextra,/usr/bin/pdfthumb,/usr/share/texmf-dist/scripts/ppower4/pdfthumb.tlu
171texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
172texlive-collection-latexextra,/usr/bin/ppower4,/usr/share/texmf-dist/scripts/ppower4/ppower4.tlu
173texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
174texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
175texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
176texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
177texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
178texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
179texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
180texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
181texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
182texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
183texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
184texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
185texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
186texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
187texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
188)
189%__mkdir_p %{buildroot}%{_bindir}
190pushd %{buildroot}%{_bindir}
191    for i in "${mk_symlinks[@]}"; do
192        tlc=$(echo $i | cut -f 1 -d",")
193        lnk=$(echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
194        rlnk=$(echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
195
196        [ "%{name}" = "$tlc" ] || continue
197        [ -f $rlnk ] || exit 1
198        %__ln_s $rlnk $lnk || exit 1
199    done
200popd
201## Files list
202find %{buildroot} -type f -or -type l | \
203    %__sed -e "s|%{buildroot}||g" > filelist.full
204
205find %{buildroot}%{texmf}-dist -type d | \
206    %__sed -e "s|^%{buildroot}|%dir |" \
207           -e "s|$|/|"             >> filelist.full
208
209%clean
210%__rm -rf %{buildroot}
211
212%post
213%{exec_texhash}
214
215exit 0
216
217
218%postun
219if [ "$1" = 0 ]; then
220    %{exec_texhash}
221
222fi
223
224exit 0
225
226%files -f filelist.full
227%defattr(-,root,root,-)
228
229%changelog
230* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
231- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-dutch
232
233* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
234- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-dutch
235- make symlinks of core script utils (texlive-collection-binextra,
236  texlive-collection-context, texlive-collection-fontutils,
237  texlive-collection-langgreek, texlive-collection-langindic,
238  texlive-collection-latex, texlive-collection-latexextra,
239  texlive-collection-latexrecommended, texlive-collection-pictures,
240  texlive-collection-pstricks, texlive-collection-science)
241
242* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
243- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-dutch
244- improved %%post
245
246* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
247- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-dutch
248- removed arch dependent binaries (texlive-collection-latexextra)
249- fixed perl path
250- improved updmap process in %%post and %%postun
251
252* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
253- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-dutch
Note: See TracBrowser for help on using the repository browser.