source: projects/specs/trunk/t/texlive-collection-documentation-czechslovak/texlive-collection-documentation-czechslovak-vl.spec @ 1974

Revision 1974, 5.8 KB checked in by munepi, 14 years ago (diff)

updated all texlive-collection packages: generated by tlpdb2rpmspec 2009-2; removed arch dependent binaries (for rpm-4.8.1); fixed perl path (for rpm-4.8.1); improved updmap process in %%post and %%postun

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2009-2:
3## tlpdb2rpmspec collection-documentation-czechslovak
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Czech/Slovak documentation
28Summary(ja): TeX Live: Czech/Slovak documentation
29Name: texlive-collection-documentation-czechslovak
30Version: 2009
31Release: 2%{?_dist_release}
32License: LPPL
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Czech/Slovak documentation:
61
62
63This package contains the following CTAN packages:
64lshort-slovak: Slovak introduction to LaTeX.
65texlive-cz: TeX Live manual (Czech/Slovak)
66
67%description -l ja
68TeX Live ソフトウェアディストリビューションは、
69さまざまな Unix, Macintosh, Windows、および
70他のプラットホームに対して完全な TeX システムを提供します。
71多くの異なった言語を含む TeX ドキュメントの
72編集、組版、閲覧、印刷するためのプログラム、
73そして、TeX マクロやフォントライブラリの大きなコレクションを
74同梱しています。
75
76このディストリビューションは
77同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
78TeX に関するたくさんの一般的なドキュメントを含んでいます。
79
80このパッケージは以下のようなパッケージ集です。
81Czech/Slovak documentation:
82
83
84このパッケージは以下の CTAN パッケージを含んでいます:
85lshort-slovak: Slovak introduction to LaTeX.
86texlive-cz: TeX Live manual (Czech/Slovak)
87
88%prep
89
90%build
91
92%install
93[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
94
95PREF=%{buildroot}%{tex_destdir}
96
97manifest=(
98texmf-dist/doc/latex/lshort-slovak/slshorte.pdf
99texmf-dist/doc/latex/lshort-slovak/src.zip
100)
101
102%__mkdir_p ${PREF}/texmf-dist
103for i in "${manifest[@]}"; do
104    %__install -D %{texlive_src}/$i ${PREF}/$i
105done
106
107## info
108%__rm -f %{buildroot}%{_infodir}/dir
109%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
110
111## man
112## man t1* files are provided by t1utils
113for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
114    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
115done
116
117## man some files are provided by psutils
118for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
119    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
120done
121
122## fix perl path
123for i in source/metapost/expressg/expressg.dtx          doc/metapost/expressg/n2mpsprl.prl          doc/latex/songbook/contrib/crd2sb/crd2sb; do
124    [ -f %{build_texmf}-dist/${i} ] &&         %__sed -i -e "s|^#!/usr/local/bin/perl|#!%{__perl}|" %{build_texmf}-dist/${i}
125done
126
127## remove asymptote directries, which provides asymptote package
128find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
129# find %{buildroot} -name "Makefile" | xargs %__rm -f
130
131# ## remove xindy
132# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
133
134# ## remove tex4ht
135# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
136
137## remove arch dependent binaries
138%__rm -f %{build_texmf}-dist/source/latex/splitindex/splitindex-{OpenBSD,Linux}-i386
139
140## remove unpackaging files
141find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
142find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
143
144## Files list
145find %{buildroot} -type f -or -type l | \
146    %__sed -e "s|%{buildroot}||g" > filelist.full
147
148find %{buildroot}%{texmf}-dist -type d | \
149    %__sed -e "s|^%{buildroot}|%dir |" \
150           -e "s|$|/|"             >> filelist.full
151
152%clean
153%__rm -rf %{buildroot}
154
155%post
156%{exec_texhash}
157
158exit 0
159
160
161%postun
162if [ "$1" = 0 ]; then
163    %{exec_texhash}
164
165fi
166
167exit 0
168
169%files -f filelist.full
170%defattr(-,root,root)
171
172%changelog
173* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
174- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-czechslovak
175- removed arch dependent binaries (texlive-collection-latexextra)
176- fixed perl path
177- improved updmap process in %%post and %%postun
178
179* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
180- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-czechslovak
Note: See TracBrowser for help on using the repository browser.