source: projects/specs/trunk/t/texlive-collection-documentation-chinese/texlive-collection-documentation-chinese-vl.spec @ 7148

Revision 7148, 30.1 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-documentation-chinese
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: Chinese documentation
48Summary(ja): TeX Live: Chinese documentation
49Name: texlive-collection-documentation-chinese
50Version: 2012
51Release: 1%{?_dist_release}
52License: LPPL, GPL+, LGPLv2+, GFDL, LPPL 1.3
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57
58Requires: asymptote
59
60Requires(post):         texlive = %{version}
61Requires(postun):       texlive = %{version}
62#BuildRequires:         texlive-sources = %{version}
63
64BuildArch:      noarch
65Buildroot:      %{_tmppath}/%{name}-%{version}-root
66
67Vendor:         Project Vine
68Distribution:   Vine Linux
69Packager:       munepi
70
71%description
72The TeX Live software distribution offers a complete TeX system for a
73variety of Unix, Macintosh, Windows and other platforms. It
74encompasses programs for editing, typesetting, previewing and printing
75of TeX documents in many different languages, and a large collection
76of TeX macros and font libraries.
77
78The distribution includes extensive general documentation about TeX,
79as well as the documentation for the included software packages.
80
81This package is a collection of Chinese documentation:
82
83
84This package contains the following CTAN packages:
85asymptote-faq-zh-cn: Asymptote FAQ (Chinese translation).
86asymptote-by-example-zh-cn: Asymptote by example.
87asymptote-manual-zh-cn: A Chinese translation of the asymptote manual.
88ctex-faq: LaTeX FAQ by the Chinese TeX Society (ctex.org).
89latex-notes-zh-cn: Chinese Introduction to TeX and LaTeX.
90lshort-chinese: Introduction to LaTeX, in Chinese.
91texlive-zh-cn: TeX Live manual (Chinese)
92
93%description -l ja
94TeX Live ソフトウェアディストリビューションは、
95さまざまな Unix, Macintosh, Windows、および
96他のプラットホームに対して完全な TeX システムを提供します。
97多くの異なった言語を含む TeX ドキュメントの
98編集、組版、閲覧、印刷するためのプログラム、
99そして、TeX マクロやフォントライブラリの大きなコレクションを
100同梱しています。
101
102このディストリビューションは
103同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
104TeX に関するたくさんの一般的なドキュメントを含んでいます。
105
106このパッケージは以下のようなパッケージ集です。
107Chinese documentation:
108
109
110このパッケージは以下の CTAN パッケージを含んでいます:
111asymptote-faq-zh-cn: Asymptote FAQ (Chinese translation).
112asymptote-by-example-zh-cn: Asymptote by example.
113asymptote-manual-zh-cn: A Chinese translation of the asymptote manual.
114ctex-faq: LaTeX FAQ by the Chinese TeX Society (ctex.org).
115latex-notes-zh-cn: Chinese Introduction to TeX and LaTeX.
116lshort-chinese: Introduction to LaTeX, in Chinese.
117texlive-zh-cn: TeX Live manual (Chinese)
118
119%prep
120
121%build
122
123%install
124[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
125
126PREF=%{buildroot}%{tex_destdir}
127
128manifest=(
129texmf-dist/doc/support/asymptote-faq-zh-cn/README
130texmf-dist/doc/support/asymptote-faq-zh-cn/asymptote-faq-zh-cn.pdf
131texmf-dist/doc/support/asymptote-faq-zh-cn/src/asy-faq.tex
132texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-1.asy
133texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-1.pdf
134texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-2.asy
135texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-2.pdf
136texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-7.asy
137texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-7.pdf
138texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-8.asy
139texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-8.pdf
140texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-9.asy
141texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/4-9.pdf
142texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/5-1a.asy
143texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/5-1a.pdf
144texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/5-2.asy
145texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/5-2.pdf
146texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/5-4.asy
147texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/5-4.pdf
148texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-1.asy
149texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-1.pdf
150texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-11a.asy
151texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-11a.pdf
152texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-11b.asy
153texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-11b.pdf
154texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-12.asy
155texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-12.pdf
156texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-14.asy
157texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-14.pdf
158texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-15.asy
159texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-15.pdf
160texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-19.asy
161texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-19.pdf
162texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-2.asy
163texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-2.pdf
164texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-3.asy
165texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-3.pdf
166texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-4.asy
167texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-4.pdf
168texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-5.asy
169texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-5.pdf
170texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-6.asy
171texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-6.pdf
172texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-7b.asy
173texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-7b.pdf
174texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-7c.asy
175texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-7c.pdf
176texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-8b.asy
177texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-8b.pdf
178texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-8c.asy
179texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-8c.pdf
180texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-9.asy
181texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/6-9.pdf
182texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-4.asy
183texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-4.pdf
184texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8a.asy
185texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8a.pdf
186texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8b.asy
187texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8b.pdf
188texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8c.asy
189texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8c.pdf
190texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8d.asy
191texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-8d.pdf
192texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-9a.asy
193texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-9a.pdf
194texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-9b.asy
195texmf-dist/doc/support/asymptote-faq-zh-cn/src/figures/8-9b.pdf
196texmf-dist/doc/support/asymptote-faq-zh-cn/src/preamble_newnew.tex
197texmf-dist/doc/support/asymptote-by-example-zh-cn/README
198texmf-dist/doc/support/asymptote-by-example-zh-cn/asymptote-by-example-zh-cn.pdf
199texmf-dist/doc/support/asymptote-by-example-zh-cn/src/CLEAN.bat
200texmf-dist/doc/support/asymptote-by-example-zh-cn/src/MAKEPDF.bat
201texmf-dist/doc/support/asymptote-by-example-zh-cn/src/asy.bib
202texmf-dist/doc/support/asymptote-by-example-zh-cn/src/asymptote.sty
203texmf-dist/doc/support/asymptote-by-example-zh-cn/src/asysyntex.sty
204texmf-dist/doc/support/asymptote-by-example-zh-cn/src/cleantmp
205texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/CJKmove.sty
206texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/area.asy
207texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/hanoi.asy
208texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/hyper.asy
209texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/movie15.sty
210texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/recplot.asy
211texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/stars.asy
212texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/tiling.asy
213texmf-dist/doc/support/asymptote-by-example-zh-cn/src/figure-src/xiantu.asy
214texmf-dist/doc/support/asymptote-by-example-zh-cn/src/gpl-3.0.tex
215texmf-dist/doc/support/asymptote-by-example-zh-cn/src/main.tex
216texmf-dist/doc/support/asymptote-by-example-zh-cn/src/makepdf
217texmf-dist/doc/support/asymptote-by-example-zh-cn/src/myfonts.sty
218texmf-dist/doc/support/asymptote-by-example-zh-cn/src/tiling.pdf
219texmf-dist/doc/support/asymptote-by-example-zh-cn/src/tiling.tex
220texmf-dist/doc/support/asymptote-by-example-zh-cn/src/xiantu-ancient.pdf
221texmf-dist/doc/support/asymptote-by-example-zh-cn/src/xiantu.pdf
222texmf-dist/doc/support/asymptote-by-example-zh-cn/src/xiantu.tex
223texmf-dist/doc/support/asymptote-manual-zh-cn/README
224texmf-dist/doc/support/asymptote-manual-zh-cn/asymptote-manual-zh-cn.pdf
225texmf-dist/doc/support/asymptote-manual-zh-cn/src/CDlabel.asy
226texmf-dist/doc/support/asymptote-manual-zh-cn/src/CLEAN.bat
227texmf-dist/doc/support/asymptote-manual-zh-cn/src/Coons.asy
228texmf-dist/doc/support/asymptote-manual-zh-cn/src/Gouraud.asy
229texmf-dist/doc/support/asymptote-manual-zh-cn/src/MAKEPDF.bat
230texmf-dist/doc/support/asymptote-manual-zh-cn/src/Pythagoras.asy
231texmf-dist/doc/support/asymptote-manual-zh-cn/src/adobefonts.tex
232texmf-dist/doc/support/asymptote-manual-zh-cn/src/asycolors.sty
233texmf-dist/doc/support/asymptote-manual-zh-cn/src/asysyntex.tex
234texmf-dist/doc/support/asymptote-manual-zh-cn/src/axialshade.asy
235texmf-dist/doc/support/asymptote-manual-zh-cn/src/bezier2.asy
236texmf-dist/doc/support/asymptote-manual-zh-cn/src/beziercurve.asy
237texmf-dist/doc/support/asymptote-manual-zh-cn/src/bigsquare.asy
238texmf-dist/doc/support/asymptote-manual-zh-cn/src/cleantmp
239texmf-dist/doc/support/asymptote-manual-zh-cn/src/clippath.asy
240texmf-dist/doc/support/asymptote-manual-zh-cn/src/colons.asy
241texmf-dist/doc/support/asymptote-manual-zh-cn/src/colors.asy
242texmf-dist/doc/support/asymptote-manual-zh-cn/src/cube.asy
243texmf-dist/doc/support/asymptote-manual-zh-cn/src/diagonal.asy
244texmf-dist/doc/support/asymptote-manual-zh-cn/src/dots.asy
245texmf-dist/doc/support/asymptote-manual-zh-cn/src/fzfonts.tex
246texmf-dist/doc/support/asymptote-manual-zh-cn/src/hatch.asy
247texmf-dist/doc/support/asymptote-manual-zh-cn/src/join.asy
248texmf-dist/doc/support/asymptote-manual-zh-cn/src/labelalign.asy
249texmf-dist/doc/support/asymptote-manual-zh-cn/src/labelsquare.asy
250texmf-dist/doc/support/asymptote-manual-zh-cn/src/latticeshading.asy
251texmf-dist/doc/support/asymptote-manual-zh-cn/src/linecap.asy
252texmf-dist/doc/support/asymptote-manual-zh-cn/src/linejoin.asy
253texmf-dist/doc/support/asymptote-manual-zh-cn/src/linetype.asy
254texmf-dist/doc/support/asymptote-manual-zh-cn/src/logo.asy
255texmf-dist/doc/support/asymptote-manual-zh-cn/src/main.tex
256texmf-dist/doc/support/asymptote-manual-zh-cn/src/makepdf
257texmf-dist/doc/support/asymptote-manual-zh-cn/src/makepen.asy
258texmf-dist/doc/support/asymptote-manual-zh-cn/src/mexicanhat.asy
259texmf-dist/doc/support/asymptote-manual-zh-cn/src/quartercircle.asy
260texmf-dist/doc/support/asymptote-manual-zh-cn/src/shadedtiling.asy
261texmf-dist/doc/support/asymptote-manual-zh-cn/src/shadestroke.asy
262texmf-dist/doc/support/asymptote-manual-zh-cn/src/square.asy
263texmf-dist/doc/support/asymptote-manual-zh-cn/src/subpictures.asy
264texmf-dist/doc/support/asymptote-manual-zh-cn/src/superpath.asy
265texmf-dist/doc/support/asymptote-manual-zh-cn/src/tile.asy
266texmf-dist/doc/support/asymptote-manual-zh-cn/src/transparency.asy
267texmf-dist/doc/support/asymptote-manual-zh-cn/src/windingnumber.asy
268texmf-dist/doc/support/asymptote-manual-zh-cn/src/winfonts.tex
269texmf-dist/doc/latex/ctex-faq/README
270texmf-dist/doc/latex/ctex-faq/ctex-faq.pdf
271texmf-dist/doc/latex/ctex-faq/src/ctex-faq.sty
272texmf-dist/doc/latex/ctex-faq/src/ctex-faq.tex
273texmf-dist/doc/latex/ctex-faq/src/make.bat
274texmf-dist/doc/generic/latex-notes-zh-cn/README
275texmf-dist/doc/generic/latex-notes-zh-cn/history.txt
276texmf-dist/doc/generic/latex-notes-zh-cn/latex-notes-zh-cn.pdf
277texmf-dist/doc/generic/latex-notes-zh-cn/license.txt
278texmf-dist/doc/generic/latex-notes-zh-cn/src/basics.tex
279texmf-dist/doc/generic/latex-notes-zh-cn/src/dscf4684.jpg
280texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/arrow.mps
281texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/color.mps
282texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/colors.mps
283texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/curve.mps
284texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/dashed.mps
285texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/dot.mps
286texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/fill.mps
287texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/label.mps
288texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/line.mps
289texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/loop.mps
290texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/path.mps
291texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/predefined.mps
292texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_arc.eps
293texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_arrow.eps
294texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_axis.eps
295texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_bezier.eps
296texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_circle.eps
297texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_color.eps
298texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_curve.eps
299texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_dot.eps
300texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_fill.eps
301texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_frame.eps
302texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_grid.eps
303texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_label.eps
304texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_line.eps
305texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_linestyle.eps
306texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_origin.eps
307texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_parabola.eps
308texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_polygon.eps
309texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_rput.eps
310texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/pst_uput.eps
311texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/subfig.mps
312texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/subfig_left.mps
313texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/subfig_right.mps
314texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/transform.mps
315texmf-dist/doc/generic/latex-notes-zh-cn/src/examples/uline.mps
316texmf-dist/doc/generic/latex-notes-zh-cn/src/fonts.tex
317texmf-dist/doc/generic/latex-notes-zh-cn/src/graphics.tex
318texmf-dist/doc/generic/latex-notes-zh-cn/src/i18n.tex
319texmf-dist/doc/generic/latex-notes-zh-cn/src/introduction.tex
320texmf-dist/doc/generic/latex-notes-zh-cn/src/lnotes.tex
321texmf-dist/doc/generic/latex-notes-zh-cn/src/math.tex
322texmf-dist/doc/generic/latex-notes-zh-cn/src/misc.tex
323texmf-dist/doc/generic/latex-notes-zh-cn/src/postcript.tex
324texmf-dist/doc/generic/latex-notes-zh-cn/src/preface.tex
325texmf-dist/doc/generic/latex-notes-zh-cn/src/reading.bib
326texmf-dist/doc/generic/latex-notes-zh-cn/src/tables.tex
327texmf-dist/doc/latex/lshort-chinese/README
328texmf-dist/doc/latex/lshort-chinese/lshort-zh-cn.pdf
329texmf-dist/doc/latex/lshort-chinese/src/biblio.tex
330texmf-dist/doc/latex/lshort-chinese/src/contrib.tex
331texmf-dist/doc/latex/lshort-chinese/src/custom.tex
332texmf-dist/doc/latex/lshort-chinese/src/fancyhea.sty
333texmf-dist/doc/latex/lshort-chinese/src/graphic.tex
334texmf-dist/doc/latex/lshort-chinese/src/lshort-a5.tex
335texmf-dist/doc/latex/lshort-chinese/src/lshort-base.tex
336texmf-dist/doc/latex/lshort-chinese/src/lshort.sty
337texmf-dist/doc/latex/lshort-chinese/src/lshort.tex
338texmf-dist/doc/latex/lshort-chinese/src/lssym.tex
339texmf-dist/doc/latex/lshort-chinese/src/math.tex
340texmf-dist/doc/latex/lshort-chinese/src/myclass.sty
341texmf-dist/doc/latex/lshort-chinese/src/mylayout.sty
342texmf-dist/doc/latex/lshort-chinese/src/overview.tex
343texmf-dist/doc/latex/lshort-chinese/src/spec.tex
344texmf-dist/doc/latex/lshort-chinese/src/test.tex
345texmf-dist/doc/latex/lshort-chinese/src/things.tex
346texmf-dist/doc/latex/lshort-chinese/src/title.tex
347texmf-dist/doc/latex/lshort-chinese/src/typeset.tex
348texmf-dist/doc/latex/lshort-chinese/src/usefulmacros.sty
349texmf-dist/doc/latex/lshort-chinese/src/zhfont.sty
350texmf-dist/doc/latex/lshort-chinese/src/zhmath.sty
351texmf-dist/doc/latex/lshort-chinese/src/zhspacing.sty
352texmf-dist/doc/latex/lshort-chinese/src/zhulem.sty
353)
354
355%__mkdir_p ${PREF}/texmf-dist
356for i in "${manifest[@]}"; do
357    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
358done
359## make symlinks of core script utils
360mk_symlinks=(
361texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
362texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
363texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
364texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
365texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
366texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
367texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
368texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
369texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
370texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
371texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
372texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
373texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
374texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
375texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
376texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
377texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
378texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
379texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
380texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
381texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
382texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
383texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
384texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
385texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
386texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
387texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
388texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
389texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
390texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
391texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
392texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
393texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
394texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
395texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
396texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
397texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
398texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
399texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
400texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
401texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
402texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
403texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
404texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
405texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
406texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
407texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
408texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
409texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
410texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
411texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
412texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
413texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
414texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
415texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
416texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
417texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
418texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
419texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
420texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
421texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
422texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
423texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
424texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
425texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
426texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
427texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
428texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
429texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
430texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
431texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
432texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
433texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
434texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
435texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
436texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
437texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
438texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
439texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
440texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
441texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
442texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
443texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
444texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
445texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
446texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
447texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
448texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
449texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
450texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
451texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
452texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
453texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
454)
455%__mkdir_p %{buildroot}%{_bindir}
456pushd %{buildroot}%{_bindir}
457    for i in "${mk_symlinks[@]}"; do
458        tlc=$(/bin/echo $i | cut -f 1 -d",")
459        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
460        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
461
462        [ "%{name}" = "$tlc" ] || continue
463        [ -f $rlnk ] || exit 1
464        %__ln_s $rlnk $lnk || exit 1
465    done
466popd
467## Files list
468find %{buildroot} -type f -or -type l | \
469    %__sed -e "s|%{buildroot}||g" > filelist.full
470
471find %{buildroot}%{texmf}-dist -type d | \
472    %__sed -e "s|^%{buildroot}|%dir |" \
473           -e "s|$|/|"             >> filelist.full
474
475%clean
476%__rm -rf %{buildroot}
477
478%post
479%touch_run texhash
480%touch_run mtxrun
481
482exit 0
483
484
485%postun
486if [ "$1" = 0 ]; then
487    %touch_run texhash
488
489fi
490
491exit 0
492
493%posttrans
494%{exec_texhash}
495%{exec_mtxrun}
496%{exec_updmap}
497%{exec_fmtutil}
498exit 0
499
500
501%files -f filelist.full
502%defattr(-,root,root,-)
503
504%changelog
505* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
506- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-documentation-chinese
507
508* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
509- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-documentation-chinese
510- set external dependencies (texlive-collection-binextra,
511  texlive-collection-fontutils)
512
513* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
514- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-documentation-chinese
515
516* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
517- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-documentation-chinese
518- make symlinks of core script utils (texlive-collection-binextra,
519  texlive-collection-context, texlive-collection-fontutils,
520  texlive-collection-langgreek, texlive-collection-langindic,
521  texlive-collection-latex, texlive-collection-latexextra,
522  texlive-collection-latexrecommended, texlive-collection-pictures,
523  texlive-collection-pstricks, texlive-collection-science)
524
525* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
526- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-documentation-chinese
527- improved %%post
528
529* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
530- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-documentation-chinese
531- removed arch dependent binaries (texlive-collection-latexextra)
532- fixed perl path
533- improved updmap process in %%post and %%postun
534
535* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
536- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-chinese
Note: See TracBrowser for help on using the repository browser.