source: projects/specs/trunk/t/texlive-collection-documentation-arabic/texlive-collection-documentation-arabic-vl.spec @ 1533

Revision 1533, 5.9 KB checked in by munepi, 14 years ago (diff)

NEW texlive and its related packages: replacement of teTeX

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec.sh 2009-1:
3## tlpdb2rpmspec.sh collection-basic
4
5%bcond_with firstbuild
6
7%define tex_destdir     %{_datadir}
8%define texmf           %{tex_destdir}/texmf
9%define texlive_src     %{tex_destdir}/texlive-sources
10%define build_tex_destdir       %{buildroot}%{tex_destdir}
11%define build_texmf     %{buildroot}%{texmf}
12
13%define exec_mktexlsr  [ -x %{_bindir}/texconfig-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/texconfig-sys rehash
14%define exec_texhash  [ -x %{_bindir}/texhash ] && PATH=%{_bindir}:$PATH %{_bindir}/texhash
15%define exec_updmap   [ -x %{_bindir}/updmap-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/updmap-sys --nostop
16%define exec_fmtutil  [ -x %{_bindir}/fmtutil-sys ] && PATH=%{_bindir}:$PATH %{_bindir}/fmtutil-sys --all >/dev/null 2>&1
17%define exec_upddeffont    [ -x %{_sbindir}/update-defaultfont ] && %{_sbindir}/update-defaultfont 2> /dev/null
18%define vartexfonts %{_var}/lib/texmf
19
20%define __find_provides %{nil}
21%define __find_requires %{nil}
22%define __perl_provides %{nil}
23%define __perl_requires %{nil}
24
25Autoreq: 0
26
27Summary: TeX Live: Arabic documentation
28Summary(ja): TeX Live: Arabic documentation
29Name: texlive-collection-documentation-arabic
30Version: 2009
31Release: 1%{?_dist_release}
32License: Public Domain
33Group: Applications/Publishing
34URL:http://www.tug.org/texlive/
35
36Requires: texlive = %{version}
37
38
39Requires(post):         texlive = %{version}
40Requires(postun):       texlive = %{version}
41BuildRequires:          texlive-sources = %{version}
42
43BuildArch:      noarch
44Buildroot:      %{_tmppath}/%{name}-%{version}-root
45
46Vendor:         Project Vine
47Distribution:   Vine Linux
48Packager:       munepi
49
50%description
51The TeX Live software distribution offers a complete TeX system for a
52variety of Unix, Macintosh, Windows and other platforms. It
53encompasses programs for editing, typesetting, previewing and printing
54of TeX documents in many different languages, and a large collection
55of TeX macros and font libraries.
56
57The distribution includes extensive general documentation about TeX,
58as well as the documentation for the included software packages.
59
60This package is a collection of Arabic documentation:
61
62
63This package contains the following CTAN packages:
64lshort-persian: Persian (Farsi) introduction to LaTeX.
65
66%description -l ja
67TeX Live ソフトウェアディストリビューションは、
68さまざまな Unix, Macintosh, Windows、および
69他のプラットホームに対して完全な TeX システムを提供します。
70多くの異なった言語を含む TeX ドキュメントの
71編集、組版、閲覧、印刷するためのプログラム、
72そして、TeX マクロやフォントライブラリの大きなコレクションを
73同梱しています。
74
75このディストリビューションは
76同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
77TeX に関するたくさんの一般的なドキュメントを含んでいます。
78
79このパッケージは以下のようなパッケージ集です。
80Arabic documentation:
81
82
83このパッケージは以下の CTAN パッケージを含んでいます:
84lshort-persian: Persian (Farsi) introduction to LaTeX.
85
86%prep
87
88%build
89
90%install
91[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
92
93PREF=%{buildroot}%{tex_destdir}
94
95manifest=(
96texmf-dist/doc/latex/lshort-persian/README
97texmf-dist/doc/latex/lshort-persian/appendix.tex
98texmf-dist/doc/latex/lshort-persian/biblio.tex
99texmf-dist/doc/latex/lshort-persian/contrib.tex
100texmf-dist/doc/latex/lshort-persian/custom.tex
101texmf-dist/doc/latex/lshort-persian/graphic.tex
102texmf-dist/doc/latex/lshort-persian/lshort-a5.tex
103texmf-dist/doc/latex/lshort-persian/lshort-base.tex
104texmf-dist/doc/latex/lshort-persian/lshort.pdf
105texmf-dist/doc/latex/lshort-persian/lshort.sty
106texmf-dist/doc/latex/lshort-persian/lshort.tex
107texmf-dist/doc/latex/lshort-persian/lssym.tex
108texmf-dist/doc/latex/lshort-persian/math.tex
109texmf-dist/doc/latex/lshort-persian/mylayout.sty
110texmf-dist/doc/latex/lshort-persian/overview.tex
111texmf-dist/doc/latex/lshort-persian/preface.tex
112texmf-dist/doc/latex/lshort-persian/spec.tex
113texmf-dist/doc/latex/lshort-persian/things.tex
114texmf-dist/doc/latex/lshort-persian/title.tex
115texmf-dist/doc/latex/lshort-persian/transpreface.tex
116texmf-dist/doc/latex/lshort-persian/typeset.tex
117)
118
119%__mkdir_p ${PREF}/texmf-dist
120for i in "${manifest[@]}"; do
121    %__install -D %{texlive_src}/$i ${PREF}/$i
122done
123
124## info
125%__rm -f %{buildroot}%{_infodir}/dir
126%__gzip -9nf %{buildroot}%{_infodir}/*info* ||:
127
128## man
129## man t1* files are provided by t1utils
130for i in t1ascii t1asm t1binary t1disasm t1mac t1unmac; do
131    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
132done
133
134## man some files are provided by psutils
135for i in epsffit extractres fixdlsrps fixfmps fixmacps fixpsditps fixpspps fixscribeps fixtpps fixwfwps fixwpps fixwwps getafm includeres psbook psmerge psnup psresize psselect pstops; do
136    %__rm %{buildroot}%{_mandir}/man*/${i}.* ||:
137done
138
139## remove asymptote directries, which provides asymptote package
140find %{buildroot} -regex ".*asymptote.*" | xargs %__rm -rf
141# find %{buildroot} -name "Makefile" | xargs %__rm -f
142
143# ## remove xindy
144# find %{buildroot} -regex ".*xindy.*" | xargs %__rm -rf
145
146# ## remove tex4ht
147# find %{buildroot} -regex ".*tex4ht.*" | xargs %__rm -rf
148
149## remove unpackaging files
150find %{buildroot} | %__grep -e "\.\(la\|a\)$" | xargs %__rm -f
151find %{buildroot} | %__grep -e "\.\(diff\|patch\)$" | xargs %__rm -f
152
153## Files list
154find %{buildroot} -type f -or -type l | \
155    %__sed -e "s|%{buildroot}||g" > filelist.full
156
157find %{buildroot}%{texmf}-dist -type d | \
158    %__sed -e "s|^%{buildroot}|%dir |" \
159           -e "s|$|/|"             >> filelist.full
160
161%clean
162%__rm -rf %{buildroot}
163
164%post
165%{exec_texhash}
166
167exit 0
168
169
170%postun
171if [ "$1" = 0 ]; then
172    %{exec_texhash}
173
174fi
175
176exit 0
177
178%files -f filelist.full
179%defattr(-,root,root)
180
181%changelog
182* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
183- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-documentation-arabic
Note: See TracBrowser for help on using the repository browser.