source: projects/specs/trunk/t/texlive-collection-binextra/texlive-collection-binextra-vl.spec @ 7148

Revision 7148, 33.7 KB checked in by munepi, 12 years ago (diff)

upgrade to TeX Live 2012

Line 
1## -*- coding: utf-8-unix -*-
2## NOTE: This spec file is generated by tlpdb2rpmspec 2012-1:
3## tlpdb2rpmspec collection-binextra
4
5%global _use_internal_dependency_generator 0
6%global __find_provides %{nil}
7%global __find_requires %{nil}
8
9%define aliasttfdir     %{texmfsysvar}/fonts/truetype/vine
10%define texmfsysconfig  %{_sysconfdir}/texmf
11%define texmfsysvar     %{_var}/lib/texmf
12%define vartexfonts     %{texmfsysvar}/fonts
13
14%define tex_destdir     %{_datadir}
15%define texmf           %{tex_destdir}/texmf
16%define texlive_src     %{tex_destdir}/texlive-sources
17%define build_tex_destdir       %{buildroot}%{tex_destdir}
18%define build_texmf     %{buildroot}%{texmf}
19
20## use some macros for %post, %posttrans
21%define touch_run(%1)   %{expand:( %__mkdir_p /var/run/texlive; touch /var/run/texlive/run-%1; )
22}
23%define exec_upddeffont [ -x %{_sbindir}/update-defaultfont ] && \\\
24    %{_sbindir}/update-defaultfont 2> /dev/null
25%define exec_texhash    [ -e /var/run/texlive/run-texhash ] && ( \\\
26    [ -x %{_bindir}/texhash ] && \\\
27    echo -n "    "; echo -n "Running texhash... "; \\\
28    %{_bindir}/texhash 2> /dev/null; \\\
29    echo "done." ) && %__rm -f /var/run/texlive/run-texhash;
30%define exec_mtxrun     [ -e /var/run/texlive/run-mtxrun ] && ( \\\
31    [ -x %{_bindir}/mtxrun ] && \\\
32    echo -n "    "; echo -n "Running mtxrun... "; \\\
33    export TEXMF=%{texmf}-dist TEXMFCNF=%{texmf}/web2c TEXMFCACHE=%{texmfsysvar}; \\\
34    %{_bindir}/mtxrun --generate &> /dev/null; \\\
35    echo "done." ) && %__rm -f /var/run/texlive/run-mtxrun;
36%define exec_fmtutil    [ -e /var/run/texlive/run-fmtutil ] && ( \\\
37    [ -x %{_bindir}/fmtutil-sys ] && \\\
38    echo -n "    "; echo -n "Running fmtutil-sys... "; \\\
39    %{_bindir}/fmtutil-sys --all &> /dev/null; \\\
40    echo "done." ) && %__rm -f /var/run/texlive/run-fmtutil;
41%define exec_updmap     [ -e /var/run/texlive/run-updmap ] && ( \\\
42    [ -x %{_bindir}/updmap-sys ] && \\\
43    echo -n "    "; echo -n "Running updmap-sys... "; \\\
44    %{_bindir}/updmap-sys --nohash --quiet &> /dev/null; \\\
45    echo "done." ) && %__rm -f /var/run/texlive/run-updmap;
46
47Summary: TeX Live: TeX auxiliary programs
48Summary(ja): TeX Live: TeX auxiliary programs
49Name: texlive-collection-binextra
50Version: 2012
51Release: 1%{?_dist_release}
52License: GPL+, LGPLv2+, LPPL, GPLv3+, Knuth, Freely redistributable without restriction, Public Domain, LPPL 1.2, Artistic, LPPL 1.3
53Group: Applications/Publishing
54URL:http://www.tug.org/texlive/
55
56Requires: texlive = %{version}
57Requires: texlive-collection-basic = %{version}
58Requires: asymptote
59Requires: detex
60Requires: dvipng
61Requires: latexmk
62
63Requires(post):         texlive = %{version}
64Requires(postun):       texlive = %{version}
65#BuildRequires:         texlive-sources = %{version}
66
67BuildArch:      noarch
68Buildroot:      %{_tmppath}/%{name}-%{version}-root
69
70Vendor:         Project Vine
71Distribution:   Vine Linux
72Packager:       munepi
73
74%description
75The TeX Live software distribution offers a complete TeX system for a
76variety of Unix, Macintosh, Windows and other platforms. It
77encompasses programs for editing, typesetting, previewing and printing
78of TeX documents in many different languages, and a large collection
79of TeX macros and font libraries.
80
81The distribution includes extensive general documentation about TeX,
82as well as the documentation for the included software packages.
83
84This package is a collection of TeX auxiliary programs:
85Various useful, but non-essential, support programs. Includes
86programs and macros for DVI file manipulation, literate
87programming, patgen, and the TeX Works Editor.
88
89This package contains the following CTAN packages:
90a2ping: Advanced PS, PDF, EPS converter.
91asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
92bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
93bibtexu:
94bundledoc: Bundle together all the files needed to build a LaTeX document.
95chktex: Check for errors in LaTeX documents.
96ctanify: Prepare a package for upload to CTAN.
97ctanupload: Support for users uploading to CTAN.
98ctie: C version of tie (merging Web change files).
99cweb: A Web system in C.
100de-macro: Expand private macros in a document.
101detex: Strip TeX from a source file.
102dtl: Tools to dis-assemble and re-assemble DVI files.
103dvi2tty: Produce ASCII from DVI.
104dviasm: A utility for editing DVI files.
105dvicopy: Copy DVI files, flattening VFs.
106dvidvi: Convert one DVI file into another.
107dviljk: DVI to Laserjet output.
108dvipng: A fast DVI to PNG/GIF converter.
109dvipos:
110dvisvgm: Converts DVI files to Scalable Vector Graphics format (SVG).
111findhyph: Find hyphenated words in a document.
112fragmaster: Using psfrag with PDFLaTeX.
113hyphenex: Generate a hyphenation exceptions file.
114installfont: A bash script for installing a LaTeX font family.
115lacheck: LaTeX checker.
116latex2man: Translate LaTeX-based manual pages into Unix man format.
117latexdiff: Determine and mark up significant differences between latex files.
118latexfileversion: Prints the version and date of a LaTeX class or style file.
119latexmk: Fully automated LaTeX document generation routine.
120listings-ext: Automated input of source.
121match_parens: Easily detect mismatched parens.
122mkjobtexmf: Generate a texmf tree for a particular job.
123patgen: Generate hyphenation patterns.
124pdfcrop: Crop PDF graphics.
125pdfjam: Shell scripts interfacing to pdfpages.
126pdftools: PDF-related utilities, including PostScript-to-PDF conversion
127pkfix: Replace pk fonts in PostScript with Type 1 fonts.
128pkfix-helper: Make PostScript files accessible to pkfix.
129purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
130seetexk: Utilities for manipulating DVI files.
131sty2dtx: Create a .dtx file from a .sty file.
132synctex:
133texcount: Count words in a LaTeX document.
134texdef: Display the definitions of TeX commands.
135texdiff: Compare documents and produce tagged merge.
136texdirflatten: Collect files related to a LaTeX job in a single directory.
137texdoc: Documentation access for TeX distributions.
138texliveonfly: On-the-fly download of missing TeX live packages.
139texloganalyser: Analyse TeX logs.
140texware: Utility programs for use with TeX.
141tie: Allow multiple web change files.
142tpic2pdftex: Use tpic commands in PDFTeX.
143typeoutfileinfo: Display class/package/file information.
144web: original web programs tangle and weave
145xindy: A general-purpose index processor.
146
147%description -l ja
148TeX Live ソフトウェアディストリビューションは、
149さまざまな Unix, Macintosh, Windows、および
150他のプラットホームに対して完全な TeX システムを提供します。
151多くの異なった言語を含む TeX ドキュメントの
152編集、組版、閲覧、印刷するためのプログラム、
153そして、TeX マクロやフォントライブラリの大きなコレクションを
154同梱しています。
155
156このディストリビューションは
157同梱しているソフトウェアパッケージのためのドキュメントばかりでなく、
158TeX に関するたくさんの一般的なドキュメントを含んでいます。
159
160このパッケージは以下のようなパッケージ集です。
161TeX auxiliary programs:
162Various useful, but non-essential, support programs. Includes
163programs and macros for DVI file manipulation, literate
164programming, patgen, and the TeX Works Editor.
165
166このパッケージは以下の CTAN パッケージを含んでいます:
167a2ping: Advanced PS, PDF, EPS converter.
168asymptote: 2D and 3D TeX-Aware Vector Graphics Language.
169bibtex8: A fully 8-bit adaptation of BibTeX 0.99.
170bibtexu:
171bundledoc: Bundle together all the files needed to build a LaTeX document.
172chktex: Check for errors in LaTeX documents.
173ctanify: Prepare a package for upload to CTAN.
174ctanupload: Support for users uploading to CTAN.
175ctie: C version of tie (merging Web change files).
176cweb: A Web system in C.
177de-macro: Expand private macros in a document.
178detex: Strip TeX from a source file.
179dtl: Tools to dis-assemble and re-assemble DVI files.
180dvi2tty: Produce ASCII from DVI.
181dviasm: A utility for editing DVI files.
182dvicopy: Copy DVI files, flattening VFs.
183dvidvi: Convert one DVI file into another.
184dviljk: DVI to Laserjet output.
185dvipng: A fast DVI to PNG/GIF converter.
186dvipos:
187dvisvgm: Converts DVI files to Scalable Vector Graphics format (SVG).
188findhyph: Find hyphenated words in a document.
189fragmaster: Using psfrag with PDFLaTeX.
190hyphenex: Generate a hyphenation exceptions file.
191installfont: A bash script for installing a LaTeX font family.
192lacheck: LaTeX checker.
193latex2man: Translate LaTeX-based manual pages into Unix man format.
194latexdiff: Determine and mark up significant differences between latex files.
195latexfileversion: Prints the version and date of a LaTeX class or style file.
196latexmk: Fully automated LaTeX document generation routine.
197listings-ext: Automated input of source.
198match_parens: Easily detect mismatched parens.
199mkjobtexmf: Generate a texmf tree for a particular job.
200patgen: Generate hyphenation patterns.
201pdfcrop: Crop PDF graphics.
202pdfjam: Shell scripts interfacing to pdfpages.
203pdftools: PDF-related utilities, including PostScript-to-PDF conversion
204pkfix: Replace pk fonts in PostScript with Type 1 fonts.
205pkfix-helper: Make PostScript files accessible to pkfix.
206purifyeps: Make EPS work with both LaTeX/dvips and pdfLaTeX.
207seetexk: Utilities for manipulating DVI files.
208sty2dtx: Create a .dtx file from a .sty file.
209synctex:
210texcount: Count words in a LaTeX document.
211texdef: Display the definitions of TeX commands.
212texdiff: Compare documents and produce tagged merge.
213texdirflatten: Collect files related to a LaTeX job in a single directory.
214texdoc: Documentation access for TeX distributions.
215texliveonfly: On-the-fly download of missing TeX live packages.
216texloganalyser: Analyse TeX logs.
217texware: Utility programs for use with TeX.
218tie: Allow multiple web change files.
219tpic2pdftex: Use tpic commands in PDFTeX.
220typeoutfileinfo: Display class/package/file information.
221web: original web programs tangle and weave
222xindy: A general-purpose index processor.
223
224%package doc
225Summary: TeX Live: Documentation files of %{name}
226Group: Applications/Publishing
227Requires: %{name} = %{version}-%{release}
228
229%description doc
230This package contains documentation files of %{name}.
231
232%prep
233
234%build
235
236%install
237[ -n "%{buildroot}" -a "%{buildroot}" != / ] && %__rm -rf %{buildroot}
238
239PREF=%{buildroot}%{tex_destdir}
240
241manifest=(
242texmf-dist/bibtex/csf/base/88591lat.csf
243texmf-dist/bibtex/csf/base/88591sca.csf
244texmf-dist/bibtex/csf/base/README.TEXLIVE
245texmf-dist/bibtex/csf/base/ascii.csf
246texmf-dist/bibtex/csf/base/cp437lat.csf
247texmf-dist/bibtex/csf/base/cp850lat.csf
248texmf-dist/bibtex/csf/base/cp850sca.csf
249texmf-dist/bibtex/csf/base/cp866rus.csf
250texmf-dist/bibtex/csf/base/csfile.txt
251texmf-dist/bibtex/csf/polish-csf/88592pl.csf
252texmf-dist/bibtex/csf/polish-csf/cp1250pl.csf
253texmf-dist/bibtex/csf/polish-csf/cp852pl.csf
254texmf-dist/bibtex/csf/polish-csf/iso8859-7.csf
255texmf-dist/doc/support/bundledoc/README
256texmf-dist/scripts/bundledoc/arlatex
257texmf-dist/scripts/bundledoc/bundledoc
258texmf-dist/tex/latex/bundledoc/miktex.cfg
259texmf-dist/tex/latex/bundledoc/texlive-unix.cfg
260texmf-dist/doc/support/ctanify/README
261texmf-dist/doc/support/ctanify/ctanify.pdf
262texmf-dist/scripts/ctanify/ctanify
263texmf-dist/doc/support/ctanupload/Makefile.example
264texmf-dist/doc/support/ctanupload/README
265texmf-dist/doc/support/ctanupload/ctanupload.pdf
266texmf-dist/doc/support/ctanupload/ctanupload.tex
267texmf-dist/scripts/ctanupload/ctanupload.pl
268texmf-dist/doc/plain/cweb/cwebman.dvi
269texmf-dist/tex/plain/cweb/cwebmac.tex
270texmf-dist/tex/plain/cweb/pdfXcwebmac.tex
271texmf-dist/tex/plain/cweb/pdfcwebmac.tex
272texmf-dist/tex/plain/cweb/pdfdcwebmac.tex
273texmf-dist/tex/plain/cweb/pdffcwebmac.tex
274texmf-dist/tex/plain/cweb/pdficwebmac.tex
275texmf-dist/tex/plain/cweb/pdfwebmac.tex
276texmf-dist/doc/support/de-macro/README
277texmf-dist/doc/support/de-macro/user-guide.pdf
278texmf-dist/doc/support/de-macro/user-guide.tex
279texmf-dist/scripts/de-macro/de-macro
280texmf-dist/scripts/dviasm/dviasm.py
281texmf-dist/doc/support/findhyph/Makefile.doc
282texmf-dist/doc/support/findhyph/README
283texmf-dist/doc/support/findhyph/findhyph.bat
284texmf-dist/doc/support/findhyph/findhyph.txt
285texmf-dist/scripts/findhyph/findhyph
286texmf-dist/doc/support/fragmaster/AUTHORS
287texmf-dist/doc/support/fragmaster/COPYING
288texmf-dist/doc/support/fragmaster/CREDITS
289texmf-dist/doc/support/fragmaster/Changes
290texmf-dist/doc/support/fragmaster/README
291texmf-dist/doc/support/fragmaster/README.de
292texmf-dist/doc/support/fragmaster/example/document.pdf
293texmf-dist/doc/support/fragmaster/example/document.ps
294texmf-dist/doc/support/fragmaster/example/document.tex
295texmf-dist/doc/support/fragmaster/example/parabel.eps
296texmf-dist/doc/support/fragmaster/example/parabel.pdf
297texmf-dist/doc/support/fragmaster/example/parabel_fm
298texmf-dist/doc/support/fragmaster/example/parabel_fm.eps
299texmf-dist/doc/support/fragmaster/example/parabel_fm.gp
300texmf-dist/doc/support/fragmaster/example/parabel_fm.pdf
301texmf-dist/doc/support/fragmaster/fragmaster.pdf
302texmf-dist/scripts/fragmaster/fragmaster.pl
303texmf-dist/source/generic/hyphenex/GNUmakefile
304texmf-dist/source/generic/hyphenex/README
305texmf-dist/source/generic/hyphenex/hyphenex.pl
306texmf-dist/source/generic/hyphenex/hyphenex.sh
307texmf-dist/source/generic/hyphenex/tb0hyf.pdf
308texmf-dist/source/generic/hyphenex/tb0hyf.tex
309texmf-dist/source/generic/hyphenex/test.tex
310texmf-dist/tex/generic/hyphenex/ushyphex.tex
311texmf-dist/doc/support/installfont/LICENSE
312texmf-dist/doc/support/installfont/README
313texmf-dist/doc/support/installfont/installfont
314texmf-dist/doc/support/installfont/installfont.pdf
315texmf-dist/doc/support/installfont/installfont.tex
316texmf-dist/doc/support/installfont/manifest.txt
317texmf-dist/scripts/installfont/installfont-tl
318texmf-dist/doc/support/latex2man/CHANGES
319texmf-dist/doc/support/latex2man/INSTALL
320texmf-dist/doc/support/latex2man/Makefile
321texmf-dist/doc/support/latex2man/README
322texmf-dist/doc/support/latex2man/THIS-IS-VERSION-1.24
323texmf-dist/doc/support/latex2man/latex2man-CHANGES.html
324texmf-dist/doc/support/latex2man/latex2man.1
325texmf-dist/doc/support/latex2man/latex2man.css
326texmf-dist/doc/support/latex2man/latex2man.html
327texmf-dist/doc/support/latex2man/latex2man.pdf
328texmf-dist/doc/support/latex2man/latex2man.tex
329texmf-dist/doc/support/latex2man/latex2man.texi
330texmf-dist/doc/support/latex2man/latex2man.trans
331texmf-dist/doc/support/latex2man/latex2man.txt
332texmf-dist/scripts/latex2man/latex2man
333texmf-dist/tex/latex/latex2man/latex2man.cfg
334texmf-dist/tex/latex/latex2man/latex2man.sty
335texmf-dist/doc/latex/latexdiff/CHANGES
336texmf-dist/doc/latex/latexdiff/LICENSE
337texmf-dist/doc/latex/latexdiff/Makefile
338texmf-dist/doc/latex/latexdiff/README
339texmf-dist/doc/latex/latexdiff/contrib/latexdiff-wrap
340texmf-dist/doc/latex/latexdiff/contrib/latexdiff.spec
341texmf-dist/doc/latex/latexdiff/example/example-draft.tex
342texmf-dist/doc/latex/latexdiff/example/example-rev.tex
343texmf-dist/doc/latex/latexdiff/latexdiff
344texmf-dist/doc/latex/latexdiff/latexdiff-fast
345texmf-dist/doc/latex/latexdiff/latexdiff-man.pdf
346texmf-dist/scripts/latexdiff/latexdiff-vc.pl
347texmf-dist/scripts/latexdiff/latexdiff.pl
348texmf-dist/scripts/latexdiff/latexrevise.pl
349texmf-dist/doc/support/latexfileversion/ChangeLog
350texmf-dist/doc/support/latexfileversion/README
351texmf-dist/scripts/latexfileversion/latexfileversion
352texmf-dist/doc/support/latexmk/CHANGES
353texmf-dist/doc/support/latexmk/COPYING
354texmf-dist/doc/support/latexmk/INSTALL
355texmf-dist/doc/support/latexmk/README
356texmf-dist/doc/support/latexmk/example_rcfiles/README
357texmf-dist/doc/support/latexmk/example_rcfiles/Sweave_latexmkrc
358texmf-dist/doc/support/latexmk/example_rcfiles/asymptote_latexmkrc
359texmf-dist/doc/support/latexmk/example_rcfiles/glossary_latexmkrc
360texmf-dist/doc/support/latexmk/example_rcfiles/mpost_latexmkrc
361texmf-dist/doc/support/latexmk/example_rcfiles/pdflatexmkrc
362texmf-dist/doc/support/latexmk/example_rcfiles/sagetex_latexmkrc
363texmf-dist/doc/support/latexmk/example_rcfiles/xelatex_latexmkrc
364texmf-dist/doc/support/latexmk/extra-scripts/README1
365texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call
366texmf-dist/doc/support/latexmk/extra-scripts/dvipdfm_call.bat
367texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call
368texmf-dist/doc/support/latexmk/extra-scripts/dvipdfmx_call.bat
369texmf-dist/doc/support/latexmk/extra-scripts/kickxdvi
370texmf-dist/doc/support/latexmk/extra-scripts/l1
371texmf-dist/doc/support/latexmk/extra-scripts/l2
372texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk
373texmf-dist/doc/support/latexmk/extra-scripts/pst2pdf_for_latexmk_README.txt
374texmf-dist/doc/support/latexmk/extra-scripts/startacroread
375texmf-dist/doc/support/latexmk/latexmk.pdf
376texmf-dist/doc/support/latexmk/latexmk.txt
377texmf-dist/source/support/latexmk/latexmk.bat
378texmf-dist/scripts/latexmk/latexmk.pl
379texmf-dist/doc/latex/listings-ext/README
380texmf-dist/doc/latex/listings-ext/THIS_IS_VERSION_v67
381texmf-dist/doc/latex/listings-ext/getversion.tex
382texmf-dist/doc/latex/listings-ext/hyperref.cfg
383texmf-dist/doc/latex/listings-ext/listings-ext.bib
384texmf-dist/doc/latex/listings-ext/listings-ext.el
385texmf-dist/doc/latex/listings-ext/listings-ext.makemake
386texmf-dist/doc/latex/listings-ext/listings-ext.mk
387texmf-dist/doc/latex/listings-ext/listings-ext.pdf
388texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_a.java
389texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_b.java
390texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_c.java
391texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_d.java
392texmf-dist/doc/latex/listings-ext/listings-ext_exmpl_e.java
393texmf-dist/doc/latex/listings-ext/listings-ext_test_a.tex
394texmf-dist/doc/latex/listings-ext/listings-ext_test_d.tex
395texmf-dist/doc/latex/listings-ext/listings.cfg
396texmf-dist/source/latex/listings-ext/listings-ext.dtx
397texmf-dist/source/latex/listings-ext/listings-ext.ins
398texmf-dist/scripts/listings-ext/listings-ext.sh
399texmf-dist/tex/latex/listings-ext/listings-ext.sty
400texmf-dist/doc/support/match_parens/Object.html
401texmf-dist/doc/support/match_parens/README
402texmf-dist/doc/support/match_parens/add.png
403texmf-dist/doc/support/match_parens/brick.png
404texmf-dist/doc/support/match_parens/brick_link.png
405texmf-dist/doc/support/match_parens/bug.png
406texmf-dist/doc/support/match_parens/bullet_black.png
407texmf-dist/doc/support/match_parens/bullet_toggle_minus.png
408texmf-dist/doc/support/match_parens/bullet_toggle_plus.png
409texmf-dist/doc/support/match_parens/created.rid
410texmf-dist/doc/support/match_parens/darkfish.js
411texmf-dist/doc/support/match_parens/date.png
412texmf-dist/doc/support/match_parens/delete.png
413texmf-dist/doc/support/match_parens/find.png
414texmf-dist/doc/support/match_parens/index.html
415texmf-dist/doc/support/match_parens/jquery.js
416texmf-dist/doc/support/match_parens/loadingAnimation.gif
417texmf-dist/doc/support/match_parens/macFFBgHack.png
418texmf-dist/doc/support/match_parens/navigation.js
419texmf-dist/doc/support/match_parens/package.png
420texmf-dist/doc/support/match_parens/page_green.png
421texmf-dist/doc/support/match_parens/page_white_text.png
422texmf-dist/doc/support/match_parens/page_white_width.png
423texmf-dist/doc/support/match_parens/plugin.png
424texmf-dist/doc/support/match_parens/rdoc.css
425texmf-dist/doc/support/match_parens/ruby.png
426texmf-dist/doc/support/match_parens/search.js
427texmf-dist/doc/support/match_parens/search_index.js
428texmf-dist/doc/support/match_parens/searcher.js
429texmf-dist/doc/support/match_parens/table_of_contents.html
430texmf-dist/doc/support/match_parens/tag_blue.png
431texmf-dist/doc/support/match_parens/tag_green.png
432texmf-dist/doc/support/match_parens/transparent.png
433texmf-dist/doc/support/match_parens/wrench.png
434texmf-dist/doc/support/match_parens/wrench_orange.png
435texmf-dist/doc/support/match_parens/zoom.png
436texmf-dist/scripts/match_parens/match_parens
437texmf-dist/doc/generic/mkjobtexmf/README
438texmf-dist/doc/generic/mkjobtexmf/clean-case.pl
439texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.html
440texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.ltx
441texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.pdf
442texmf-dist/doc/generic/mkjobtexmf/mkjobtexmf.txt
443texmf-dist/doc/generic/mkjobtexmf/version.pl
444texmf-dist/source/generic/mkjobtexmf/Makefile.in
445texmf-dist/source/generic/mkjobtexmf/configure
446texmf-dist/source/generic/mkjobtexmf/configure.ac
447texmf-dist/source/generic/mkjobtexmf/install-sh
448texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
449texmf-dist/doc/support/pdfcrop/README
450texmf-dist/scripts/pdfcrop/pdfcrop.pl
451texmf-dist/doc/support/pdfjam/COPYING
452texmf-dist/doc/support/pdfjam/PDFjam-README.html
453texmf-dist/doc/support/pdfjam/VERSION
454texmf-dist/doc/support/pdfjam/pdfdroplets.png
455texmf-dist/doc/support/pdfjam/pdfjam.conf
456texmf-dist/doc/support/pdfjam/tests.zip
457texmf-dist/scripts/pdfjam/pdf180
458texmf-dist/scripts/pdfjam/pdf270
459texmf-dist/scripts/pdfjam/pdf90
460texmf-dist/scripts/pdfjam/pdfbook
461texmf-dist/scripts/pdfjam/pdfflip
462texmf-dist/scripts/pdfjam/pdfjam
463texmf-dist/scripts/pdfjam/pdfjam-pocketmod
464texmf-dist/scripts/pdfjam/pdfjam-slides3up
465texmf-dist/scripts/pdfjam/pdfjam-slides6up
466texmf-dist/scripts/pdfjam/pdfjoin
467texmf-dist/scripts/pdfjam/pdfnup
468texmf-dist/scripts/pdfjam/pdfpun
469texmf-dist/doc/support/pkfix/README
470texmf-dist/scripts/pkfix/pkfix.pl
471texmf-dist/doc/support/pkfix-helper/README
472texmf-dist/doc/support/pkfix-helper/encoding-samples.pdf
473texmf-dist/doc/support/pkfix-helper/encoding-samples.tex
474texmf-dist/scripts/pkfix-helper/pkfix-helper
475texmf-dist/doc/support/purifyeps/README
476texmf-dist/scripts/purifyeps/purifyeps
477texmf-dist/doc/support/sty2dtx/README
478texmf-dist/scripts/sty2dtx/sty2dtx.pl
479texmf-dist/doc/support/texcount/QuickReference.pdf
480texmf-dist/doc/support/texcount/QuickReference.tex
481texmf-dist/doc/support/texcount/README
482texmf-dist/doc/support/texcount/TeXcount.pdf
483texmf-dist/doc/support/texcount/TeXcount.tex
484texmf-dist/doc/support/texcount/macros.tex
485texmf-dist/doc/support/texcount/sub_addrules.tex
486texmf-dist/doc/support/texcount/sub_options.tex
487texmf-dist/doc/support/texcount/sub_tc_other.tex
488texmf-dist/scripts/texcount/texcount.pl
489texmf-dist/doc/support/texdef/INSTALL
490texmf-dist/doc/support/texdef/README
491texmf-dist/doc/support/texdef/texdef.pdf
492texmf-dist/source/support/texdef/texdef.tex
493texmf-dist/scripts/texdef/texdef.pl
494texmf-dist/doc/support/texdiff/README
495texmf-dist/scripts/texdiff/texdiff
496texmf-dist/scripts/texdirflatten/texdirflatten
497texmf-dist/texdoc/texdoc.cnf
498texmf-dist/doc/support/texliveonfly/README
499texmf-dist/scripts/texliveonfly/texliveonfly.py
500texmf-dist/doc/support/texloganalyser/README
501texmf-dist/scripts/texloganalyser/texloganalyser
502texmf-dist/doc/support/typeoutfileinfo/README
503texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
504)
505
506%__mkdir_p ${PREF}/texmf-dist
507for i in "${manifest[@]}"; do
508    %__install -m $(stat -c %a %{texlive_src}/$i) -p -D %{texlive_src}/$i ${PREF}/$i
509done
510## make symlinks of core script utils
511mk_symlinks=(
512texlive-collection-bibtexextra,/usr/bin/bibexport,/usr/share/texmf-dist/scripts/bibexport/bibexport.sh
513texlive-collection-bibtexextra,/usr/bin/listbib,/usr/share/texmf-dist/scripts/listbib/listbib
514texlive-collection-bibtexextra,/usr/bin/urlbst,/usr/share/texmf-dist/scripts/urlbst/urlbst
515texlive-collection-binextra,/usr/bin/arlatex,/usr/share/texmf-dist/scripts/bundledoc/arlatex
516texlive-collection-binextra,/usr/bin/bundledoc,/usr/share/texmf-dist/scripts/bundledoc/bundledoc
517texlive-collection-binextra,/usr/bin/ctanify,/usr/share/texmf-dist/scripts/ctanify/ctanify
518texlive-collection-binextra,/usr/bin/ctanupload,/usr/share/texmf-dist/scripts/ctanupload/ctanupload.pl
519texlive-collection-binextra,/usr/bin/de-macro,/usr/share/texmf-dist/scripts/de-macro/de-macro
520texlive-collection-binextra,/usr/bin/dviasm,/usr/share/texmf-dist/scripts/dviasm/dviasm.py
521texlive-collection-binextra,/usr/bin/findhyph,/usr/share/texmf-dist/scripts/findhyph/findhyph
522texlive-collection-binextra,/usr/bin/fragmaster,/usr/share/texmf-dist/scripts/fragmaster/fragmaster.pl
523texlive-collection-binextra,/usr/bin/installfont-tl,/usr/share/texmf-dist/scripts/installfont/installfont-tl
524texlive-collection-binextra,/usr/bin/latex2man,/usr/share/texmf-dist/scripts/latex2man/latex2man
525texlive-collection-binextra,/usr/bin/latexdiff,/usr/share/texmf-dist/scripts/latexdiff/latexdiff.pl
526texlive-collection-binextra,/usr/bin/latexdiff-vc,/usr/share/texmf-dist/scripts/latexdiff/latexdiff-vc.pl
527texlive-collection-binextra,/usr/bin/latexfileversion,/usr/share/texmf-dist/scripts/latexfileversion/latexfileversion
528texlive-collection-binextra,/usr/bin/latexmk,/usr/share/texmf-dist/scripts/latexmk/latexmk.pl
529texlive-collection-binextra,/usr/bin/latexrevise,/usr/share/texmf-dist/scripts/latexdiff/latexrevise.pl
530texlive-collection-binextra,/usr/bin/listings-ext.sh,/usr/share/texmf-dist/scripts/listings-ext/listings-ext.sh
531texlive-collection-binextra,/usr/bin/match_parens,/usr/share/texmf-dist/scripts/match_parens/match_parens
532texlive-collection-binextra,/usr/bin/mkjobtexmf,/usr/share/texmf-dist/scripts/mkjobtexmf/mkjobtexmf.pl
533texlive-collection-binextra,/usr/bin/pdf180,/usr/share/texmf-dist/scripts/pdfjam/pdf180
534texlive-collection-binextra,/usr/bin/pdf270,/usr/share/texmf-dist/scripts/pdfjam/pdf270
535texlive-collection-binextra,/usr/bin/pdf90,/usr/share/texmf-dist/scripts/pdfjam/pdf90
536texlive-collection-binextra,/usr/bin/pdfbook,/usr/share/texmf-dist/scripts/pdfjam/pdfbook
537texlive-collection-binextra,/usr/bin/pdfcrop,/usr/share/texmf-dist/scripts/pdfcrop/pdfcrop.pl
538texlive-collection-binextra,/usr/bin/pdfflip,/usr/share/texmf-dist/scripts/pdfjam/pdfflip
539texlive-collection-binextra,/usr/bin/pdfjam,/usr/share/texmf-dist/scripts/pdfjam/pdfjam
540texlive-collection-binextra,/usr/bin/pdfjam-pocketmod,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-pocketmod
541texlive-collection-binextra,/usr/bin/pdfjam-slides3up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides3up
542texlive-collection-binextra,/usr/bin/pdfjam-slides6up,/usr/share/texmf-dist/scripts/pdfjam/pdfjam-slides6up
543texlive-collection-binextra,/usr/bin/pdfjoin,/usr/share/texmf-dist/scripts/pdfjam/pdfjoin
544texlive-collection-binextra,/usr/bin/pdfnup,/usr/share/texmf-dist/scripts/pdfjam/pdfnup
545texlive-collection-binextra,/usr/bin/pdfpun,/usr/share/texmf-dist/scripts/pdfjam/pdfpun
546texlive-collection-binextra,/usr/bin/pkfix,/usr/share/texmf-dist/scripts/pkfix/pkfix.pl
547texlive-collection-binextra,/usr/bin/pkfix-helper,/usr/share/texmf-dist/scripts/pkfix-helper/pkfix-helper
548texlive-collection-binextra,/usr/bin/purifyeps,/usr/share/texmf-dist/scripts/purifyeps/purifyeps
549texlive-collection-binextra,/usr/bin/sty2dtx,/usr/share/texmf-dist/scripts/sty2dtx/sty2dtx.pl
550texlive-collection-binextra,/usr/bin/texcount,/usr/share/texmf-dist/scripts/texcount/texcount.pl
551texlive-collection-binextra,/usr/bin/texdef,/usr/share/texmf-dist/scripts/texdef/texdef.pl
552texlive-collection-binextra,/usr/bin/texdiff,/usr/share/texmf-dist/scripts/texdiff/texdiff
553texlive-collection-binextra,/usr/bin/texdirflatten,/usr/share/texmf-dist/scripts/texdirflatten/texdirflatten
554texlive-collection-binextra,/usr/bin/texliveonfly,/usr/share/texmf-dist/scripts/texliveonfly/texliveonfly.py
555texlive-collection-binextra,/usr/bin/texloganalyser,/usr/share/texmf-dist/scripts/texloganalyser/texloganalyser
556texlive-collection-binextra,/usr/bin/typeoutfileinfo,/usr/share/texmf-dist/scripts/typeoutfileinfo/typeoutfileinfo.sh
557texlive-collection-fontutils,/usr/bin/afm2afm,/usr/share/texmf-dist/scripts/fontools/afm2afm
558texlive-collection-fontutils,/usr/bin/autoinst,/usr/share/texmf-dist/scripts/fontools/autoinst
559texlive-collection-fontutils,/usr/bin/dosepsbin,/usr/share/texmf-dist/scripts/dosepsbin/dosepsbin.pl
560texlive-collection-fontutils,/usr/bin/epstopdf,/usr/share/texmf-dist/scripts/epstopdf/epstopdf.pl
561texlive-collection-fontutils,/usr/bin/mf2pt1,/usr/share/texmf-dist/scripts/mf2pt1/mf2pt1.pl
562texlive-collection-fontutils,/usr/bin/mkt1font,/usr/share/texmf-dist/scripts/accfonts/mkt1font
563texlive-collection-fontutils,/usr/bin/ot2kpx,/usr/share/texmf-dist/scripts/fontools/ot2kpx
564texlive-collection-fontutils,/usr/bin/vpl2ovp,/usr/share/texmf-dist/scripts/accfonts/vpl2ovp
565texlive-collection-fontutils,/usr/bin/vpl2vpl,/usr/share/texmf-dist/scripts/accfonts/vpl2vpl
566texlive-collection-htmlxml,/usr/bin/ht,/usr/share/texmf-dist/scripts/tex4ht/ht.sh
567texlive-collection-htmlxml,/usr/bin/htcontext,/usr/share/texmf-dist/scripts/tex4ht/htcontext.sh
568texlive-collection-htmlxml,/usr/bin/htlatex,/usr/share/texmf-dist/scripts/tex4ht/htlatex.sh
569texlive-collection-htmlxml,/usr/bin/htmex,/usr/share/texmf-dist/scripts/tex4ht/htmex.sh
570texlive-collection-htmlxml,/usr/bin/httex,/usr/share/texmf-dist/scripts/tex4ht/httex.sh
571texlive-collection-htmlxml,/usr/bin/httexi,/usr/share/texmf-dist/scripts/tex4ht/httexi.sh
572texlive-collection-htmlxml,/usr/bin/htxelatex,/usr/share/texmf-dist/scripts/tex4ht/htxelatex.sh
573texlive-collection-htmlxml,/usr/bin/htxetex,/usr/share/texmf-dist/scripts/tex4ht/htxetex.sh
574texlive-collection-htmlxml,/usr/bin/mk4ht,/usr/share/texmf-dist/scripts/tex4ht/mk4ht.pl
575texlive-collection-langcjk,/usr/bin/convbkmk,/usr/share/texmf-dist/scripts/uptex/convbkmk.rb
576texlive-collection-langcjk,/usr/bin/updmap-setup-kanji,/usr/share/texmf-dist/scripts/jfontmaps/updmap-setup-kanji.pl
577texlive-collection-langgreek,/usr/bin/mkgrkindex,/usr/share/texmf-dist/scripts/mkgrkindex/mkgrkindex
578texlive-collection-langindic,/usr/bin/ebong,/usr/share/texmf-dist/scripts/ebong/ebong.py
579texlive-collection-latex,/usr/bin/mptopdf,/usr/share/texmf-dist/scripts/context/perl/mptopdf.pl
580texlive-collection-latex,/usr/bin/pdfatfi,/usr/share/texmf-dist/scripts/oberdiek/pdfatfi.pl
581texlive-collection-latexextra,/usr/bin/authorindex,/usr/share/texmf-dist/scripts/authorindex/authorindex
582texlive-collection-latexextra,/usr/bin/exceltex,/usr/share/texmf-dist/scripts/exceltex/exceltex
583texlive-collection-latexextra,/usr/bin/makeglossaries,/usr/share/texmf-dist/scripts/glossaries/makeglossaries
584texlive-collection-latexextra,/usr/bin/pdfannotextractor,/usr/share/texmf-dist/scripts/pax/pdfannotextractor.pl
585texlive-collection-latexextra,/usr/bin/perltex,/usr/share/texmf-dist/scripts/perltex/perltex.pl
586texlive-collection-latexextra,/usr/bin/ps4pdf,/usr/share/texmf-dist/scripts/pst-pdf/ps4pdf
587texlive-collection-latexextra,/usr/bin/splitindex,/usr/share/texmf-dist/scripts/splitindex/perl/splitindex.pl
588texlive-collection-latexextra,/usr/bin/svn-multi,/usr/share/texmf-dist/scripts/svn-multi/svn-multi.pl
589texlive-collection-latexextra,/usr/bin/vpe,/usr/share/texmf-dist/scripts/vpe/vpe.pl
590texlive-collection-latexrecommended,/usr/bin/thumbpdf,/usr/share/texmf-dist/scripts/thumbpdf/thumbpdf.pl
591texlive-collection-luatex,/usr/bin/checkcites,/usr/share/texmf-dist/scripts/checkcites/checkcites.lua
592texlive-collection-luatex,/usr/bin/mkluatexfontdb,/usr/share/texmf-dist/scripts/luaotfload/mkluatexfontdb.lua
593texlive-collection-music,/usr/bin/m-tx,/usr/share/texmf-dist/scripts/m-tx/m-tx.lua
594texlive-collection-music,/usr/bin/musixflx,/usr/share/texmf-dist/scripts/musixtex/musixflx.lua
595texlive-collection-music,/usr/bin/musixtex,/usr/share/texmf-dist/scripts/musixtex/musixtex.lua
596texlive-collection-music,/usr/bin/pmx2pdf,/usr/share/texmf-dist/scripts/pmx/pmx2pdf.lua
597texlive-collection-pictures,/usr/bin/cachepic,/usr/share/texmf-dist/scripts/cachepic/cachepic.tlu
598texlive-collection-pictures,/usr/bin/epspdf,/usr/share/texmf-dist/scripts/epspdf/epspdf.rb
599texlive-collection-pictures,/usr/bin/epspdftk,/usr/share/texmf-dist/scripts/epspdf/epspdftk.tcl
600texlive-collection-pictures,/usr/bin/fig4latex,/usr/share/texmf-dist/scripts/fig4latex/fig4latex
601texlive-collection-pictures,/usr/bin/mathspic,/usr/share/texmf-dist/scripts/mathspic/mathspic.pl
602texlive-collection-pstricks,/usr/bin/pedigree,/usr/share/texmf-dist/scripts/pedigree-perl/pedigree.pl
603texlive-collection-pstricks,/usr/bin/pst2pdf,/usr/share/texmf-dist/scripts/pst2pdf/pst2pdf
604texlive-collection-science,/usr/bin/ulqda,/usr/share/texmf-dist/scripts/ulqda/ulqda.pl
605)
606%__mkdir_p %{buildroot}%{_bindir}
607pushd %{buildroot}%{_bindir}
608    for i in "${mk_symlinks[@]}"; do
609        tlc=$(/bin/echo $i | cut -f 1 -d",")
610        lnk=$(/bin/echo $i | cut -f 2 -d"," | %__sed -e "s|/usr/bin/||")
611        rlnk=$(/bin/echo $i | cut -f 3 -d"," | %__sed -e "s|/usr/|../|")
612
613        [ "%{name}" = "$tlc" ] || continue
614        [ -f $rlnk ] || exit 1
615        %__ln_s $rlnk $lnk || exit 1
616    done
617popd
618## use external packages
619%__rm %{buildroot}/usr/bin/latexmk || exit 1
620
621## Files list
622find %{buildroot} -type f -or -type l | \
623    %__sed -e "s|%{buildroot}||g" > filelist.full
624
625find %{buildroot}%{texmf}-dist -type d | \
626    %__sed -e "s|^%{buildroot}|%dir |" \
627           -e "s|$|/|"             >> filelist.full
628
629## subpackages
630grep "/texmf-dist/doc/" filelist.full > filelist.doc
631cat filelist.doc filelist.full | sort | uniq -u > filelist.tmp
632%__mv -f filelist.tmp filelist.full
633
634%clean
635%__rm -rf %{buildroot}
636
637%post
638%touch_run texhash
639%touch_run mtxrun
640
641exit 0
642
643
644%postun
645if [ "$1" = 0 ]; then
646    %touch_run texhash
647
648fi
649
650exit 0
651
652%posttrans
653%{exec_texhash}
654%{exec_mtxrun}
655%{exec_updmap}
656%{exec_fmtutil}
657exit 0
658
659
660%files -f filelist.full
661%defattr(-,root,root,-)
662
663%files -f filelist.doc doc
664%defattr(-,root,root,-)
665
666%changelog
667* Fri Nov 23 2012 Munehiro Yamamoto <munepi@vinelinux.org> 2012-1
668- generated by tlpdb2rpmspec 2012-1: tlpdb2rpmspec collection-binextra
669
670* Sat Dec  3 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-2
671- generated by tlpdb2rpmspec 2011-2: tlpdb2rpmspec collection-binextra
672- set external dependencies (texlive-collection-binextra,
673  texlive-collection-fontutils)
674
675* Sun Oct 30 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2011-1
676- generated by tlpdb2rpmspec 2011-1: tlpdb2rpmspec collection-binextra
677
678* Mon Mar 23 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-4
679- generated by tlpdb2rpmspec 2009-4: tlpdb2rpmspec collection-binextra
680- make symlinks of core script utils (texlive-collection-binextra,
681  texlive-collection-context, texlive-collection-fontutils,
682  texlive-collection-langgreek, texlive-collection-langindic,
683  texlive-collection-latex, texlive-collection-latexextra,
684  texlive-collection-latexrecommended, texlive-collection-pictures,
685  texlive-collection-pstricks, texlive-collection-science)
686
687* Fri Jan 14 2011 Munehiro Yamamoto <munepi@vinelinux.org> 2009-3
688- generated by tlpdb2rpmspec 2009-3: tlpdb2rpmspec collection-binextra
689- improved %%post
690
691* Fri Oct 01 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-2
692- generated by tlpdb2rpmspec 2009-2: tlpdb2rpmspec collection-binextra
693- removed arch dependent binaries (texlive-collection-latexextra)
694- fixed perl path
695- improved updmap process in %%post and %%postun
696
697* Sat Aug 07 2010 Munehiro Yamamoto <munepi@vinelinux.org> 2009-1
698- generated by tlpdb2rpmspec 2009-1: tlpdb2rpmspec collection-binextra
Note: See TracBrowser for help on using the repository browser.