source: projects/specs/trunk/t/telepathy-farsight/telepathy-farsight-vl.spec @ 521

Revision 521, 4.3 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define dbus_ver        0.60
4%define tp_glib_ver     0.7.34
5%define farsight2_ver   0.0.14
6
7Name:           telepathy-farsight
8Version:        0.0.13
9Release:        2%{?_dist_release}
10Summary:        Telepathy client to handle media streaming channels
11
12Group:          System Environment/Libraries
13License:        LGPLv2+
14URL:            http://telepathy.freedesktop.org/wiki/
15Source0:        http://telepathy.freedesktop.org/releases/%{name}/%{name}-%{version}.tar.gz
16# Workaround broken private require. https://bugzilla.redhat.com/show_bug.cgi?id=426106
17# Patch0:         %{name}-broken-pkgconfig.patch
18BuildRoot:      %{_tmppath}/%{name}-%{version}-root
19
20BuildRequires:  glib2-devel
21BuildRequires:  dbus-devel >= %{dbus_ver}
22BuildRequires:  dbus-glib-devel >= %{dbus_ver}
23BuildRequires:  telepathy-glib-devel >= %{tp_glib_ver}
24BuildRequires:  farsight2-devel >= %{farsight2_ver}
25BuildRequires:  gstreamer-python >= 0.10.10
26# Needed to remove rpath
27BuildRequires:  chrpath
28BuildRequires:  python-devel
29BuildRequires:  pygobject-devel
30
31%description
32%{name} is a Telepathy client that uses Farsight and GStreamer to
33handle media streaming channels. It's used as a background process
34by other Telepathy clients, rather than presenting any user interface
35of its own.
36
37%package        python
38Summary:        Python binding for %{name}
39Group:          Development/Libraries
40Requires:       %{name} = %{version}-%{release}
41
42%description    python
43Python bindings for %{name}.
44
45%package devel
46Summary:        Development files for %{name}
47Group:          Development/Libraries
48Requires:       %{name} = %{version}-%{release}
49Requires:       %{name}-python = %{version}-%{release}
50Requires:       glib2-devel
51Requires:       dbus-glib-devel >= %{dbus_ver}
52Requires:       farsight2-devel >= %{farsight2_ver}
53Requires:       telepathy-filesystem
54Requires:       pkgconfig
55
56%description    devel
57The %{name}-devel package contains libraries and header files for
58developing applications that use %{name}.
59
60
61%prep
62%setup -q
63# %patch0 -p1 -b .pkgconfig
64
65%build
66%configure --disable-static
67make %{?_smp_mflags}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
72find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
73# Remove rpath
74chrpath --delete $RPM_BUILD_ROOT%{python_sitearch}/*.so
75
76%clean
77rm -rf $RPM_BUILD_ROOT
78
79
80%post -p /sbin/ldconfig
81
82%postun -p /sbin/ldconfig
83
84
85%files
86%defattr(-,root,root,-)
87%doc COPYING NEWS
88%{_libdir}/*.so.*
89
90%files python
91%defattr(-,root,root,-)
92%{python_sitearch}/*.so
93
94%files devel
95%defattr(-,root,root,-)
96%{_libdir}/*.so
97%{_libdir}/pkgconfig/*.pc
98%{_includedir}/telepathy-1.0/%{name}/
99%{_datadir}/gtk-doc/html/%{name}
100
101%changelog
102* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.13-2
103- add BuildRequires: python-devel, pygobject-devel
104
105* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.13-1
106- new upstream release
107
108* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.12-3
109- rebuild with python-2.6
110
111* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.12-2
112- initial build for Vine Linux
113
114* Mon Oct 19 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-1
115- Update to 0.0.12.
116
117* Thu Sep 10 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.11-1
118- Update to 0.0.11.
119
120* Tue Sep  8 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-1
121- Update to 0.0.10.
122
123* Tue Aug 25 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
124- Update to 0.0.9.
125
126* Thu Aug  6 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.8-1
127- Update to 0.0.8.
128
129* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-2
130- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
131
132* Thu May  7 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-1
133- Update to 0.0.7.
134
135* Tue Mar 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-1
136- Update to 0.0.6.
137- Bump min version of tp-glib needed.
138
139* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-3
140- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
141
142* Tue Feb 10 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-2
143- Add devel requires on telepathy-filesystem.
144
145* Sat Jan 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-1
146- Initial spec.
147
Note: See TracBrowser for help on using the repository browser.