source: projects/specs/trunk/t/telepathy-farsight/telepathy-farsight-vl.spec @ 4616

Revision 4616, 4.7 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3%define dbus_ver        1.4.0
4%define dbus_glib_ver   0.88
5%define tp_glib_ver     0.13.0
6%define farsight2_ver   0.0.29
7
8Name:           telepathy-farsight
9Version:        0.0.19
10Release:        1%{?_dist_release}
11Summary:        Telepathy client to handle media streaming channels
12
13Group:          System Environment/Libraries
14License:        LGPLv2+
15URL:            http://telepathy.freedesktop.org/wiki/
16Source0:        http://telepathy.freedesktop.org/releases/%{name}/%{name}-%{version}.tar.gz
17# Workaround broken private require. https://bugzilla.redhat.com/show_bug.cgi?id=426106
18# Patch0:         %{name}-broken-pkgconfig.patch
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  glib2-devel
22BuildRequires:  dbus-devel >= %{dbus_ver}
23BuildRequires:  dbus-glib-devel >= %{dbus_glib_ver}
24BuildRequires:  telepathy-glib-devel >= %{tp_glib_ver}
25BuildRequires:  farsight2-devel >= %{farsight2_ver}
26BuildRequires:  gstreamer-python >= 0.10.10
27# Needed to remove rpath
28BuildRequires:  chrpath
29BuildRequires:  python-devel
30BuildRequires:  pygobject-devel
31BuildRequires:  gstreamer-python-devel
32
33Vendor: Project Vine
34Distribution: Vine Linux
35
36%description
37%{name} is a Telepathy client that uses Farsight and GStreamer to
38handle media streaming channels. It's used as a background process
39by other Telepathy clients, rather than presenting any user interface
40of its own.
41
42%package        python
43Summary:        Python binding for %{name}
44Group:          Development/Libraries
45Requires:       %{name} = %{version}-%{release}
46
47%description    python
48Python bindings for %{name}.
49
50%package devel
51Summary:        Development files for %{name}
52Group:          Development/Libraries
53Requires:       %{name} = %{version}-%{release}
54Requires:       %{name}-python = %{version}-%{release}
55Requires:       glib2-devel
56Requires:       dbus-glib-devel >= %{dbus_glib_ver}
57Requires:       farsight2-devel >= %{farsight2_ver}
58Requires:       telepathy-filesystem
59Requires:       pkgconfig
60
61%description    devel
62The %{name}-devel package contains libraries and header files for
63developing applications that use %{name}.
64
65
66%prep
67%setup -q
68# %patch0 -p1 -b .pkgconfig
69
70%build
71%configure --disable-static
72make %{?_smp_mflags}
73
74%install
75rm -rf $RPM_BUILD_ROOT
76make install DESTDIR=$RPM_BUILD_ROOT INSTALL="install -p"
77find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
78# Remove rpath
79chrpath --delete $RPM_BUILD_ROOT%{python_sitearch}/*.so
80
81%clean
82rm -rf $RPM_BUILD_ROOT
83
84
85%post -p /sbin/ldconfig
86
87%postun -p /sbin/ldconfig
88
89
90%files
91%defattr(-,root,root,-)
92%doc COPYING NEWS
93%{_libdir}/*.so.*
94
95%files python
96%defattr(-,root,root,-)
97%{python_sitearch}/*.so
98
99%files devel
100%defattr(-,root,root,-)
101%{_libdir}/*.so
102%{_libdir}/pkgconfig/*.pc
103%{_includedir}/telepathy-1.0/%{name}/
104%{_datadir}/gtk-doc/html/%{name}
105
106%changelog
107* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.19-1
108- new upstream release
109- add BuildRequires: gstreamer-python-devel
110
111* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.0.15-1
112- new upstream release
113
114* Sat Oct 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.13-3
115- rebuilt with rpm-4.8.1 for pkg-config
116
117* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.13-2
118- add BuildRequires: python-devel, pygobject-devel
119
120* Sat Feb  6 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.13-1
121- new upstream release
122
123* Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 0.0.12-3
124- rebuild with python-2.6
125
126* Sat Nov  7 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 0.0.12-2
127- initial build for Vine Linux
128
129* Mon Oct 19 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.12-1
130- Update to 0.0.12.
131
132* Thu Sep 10 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.11-1
133- Update to 0.0.11.
134
135* Tue Sep  8 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.10-1
136- Update to 0.0.10.
137
138* Tue Aug 25 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.9-1
139- Update to 0.0.9.
140
141* Thu Aug  6 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.8-1
142- Update to 0.0.8.
143
144* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.7-2
145- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
146
147* Thu May  7 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.7-1
148- Update to 0.0.7.
149
150* Tue Mar 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.6-1
151- Update to 0.0.6.
152- Bump min version of tp-glib needed.
153
154* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.4-3
155- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
156
157* Tue Feb 10 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-2
158- Add devel requires on telepathy-filesystem.
159
160* Sat Jan 17 2009 Brian Pepple <bpepple@fedoraproject.org> - 0.0.4-1
161- Initial spec.
162
Note: See TracBrowser for help on using the repository browser.