source: projects/specs/trunk/t/tcpdump/tcpdump-vl.spec @ 5945

Revision 5945, 16.0 KB checked in by shaolin, 12 years ago (diff)
  • tcpdump: rebuild
  • libpcap: rebuild; remove *.a file
Line 
1%define tcpdump_ver     4.1.1
2%define libpcap_ver     1.1.1
3
4Summary: A network traffic monitoring tool.
5Summary(ja): ネットワークのトラフィックをモニタするツール
6Name: tcpdump
7Version: %{tcpdump_ver}
8%define tcpdump_dir     tcpdump-%{tcpdump_ver}
9%define tcpslice_dir    tcpslice
10Release: 4%{?_dist_release}
11Epoch: 1
12
13Group: Applications/System
14# XXX epoch is necessary to obsolete tcpdump-3.4a5
15License: BSD
16URL: http://www.tcpdump.org/
17
18Source0: http://www.tcpdump.org/release/tcpdump-%{tcpdump_ver}.tar.gz
19Source4: tcpslice-CVS.20010207.tar.gz
20
21Patch5: tcpdump-3.6.2-tcpslice-time.patch
22Patch10: tcpdump-4.1.1-portnumbers.patch
23Patch15: tcpdump-3.6.2-ip6opts.patch
24Patch16: tcpdump-3.8.1-sctp.patch
25Patch17: tcpdump-3.7.2-sctpdef.patch
26Patch19: tcpdump-3.8.2-rsvp-dos.patch
27Patch21: tcpdump-3.8.2-isis-dos.patch
28Patch22: tcpdump-3.9.1-ethbuf.patch
29
30Patch70: tcpslice-CVS.20010207-bpf.patch
31
32BuildRoot: %{_tmppath}/%{name}-%{version}-root
33BuildRequires: glibc-kernheaders >= 2.2.0
34BuildRequires: openssl-devel
35BuildRequires: libpcap-devel >= %{libpcap_ver}
36BuildRequires: autoconf, automake
37# Requires: kernel >= 2.2.0
38# Requires: libpcap >= %{libpcap_ver}
39
40
41Vendor: Project Vine
42Distribution: Vine Linux
43Packager: daisuke, shaolin
44
45
46%description
47Tcpdump is a command-line tool for monitoring network traffic.
48Tcpdump can capture and display the packet headers on a particular
49network interface or on all interfaces. Tcpdump can display all of the
50packet headers, or just the ones that match particular criteria.
51
52Install tcpdump if you need a program to monitor network traffic.
53
54%description -l ja
55tcpdump はネットワークのトラフィックをモニタする、コマンドライン
56ベースのツールです。tcpdump はあるネットワークインターフェイス
57もしくは全てのネットワークインターフェイス上のパケットのヘッダを
58キャプチャして表示することができます。tcpdump は全てのパケットの
59ヘッダを表示することもできますし、ある規則に合致するものだけを
60表示することもできます。
61
62ネットワークのトラフィックをモニタする必要がある場合、tcpdump を
63インストールしてください。
64
65
66%prep
67%setup -q -c -a 4
68
69%patch5 -p1 -b .tcpslicetime
70
71pushd %tcpdump_dir
72%patch10 -p1 -b .portnumbers
73%patch15 -p1 -b .ip6opts
74%patch16 -p1 -b .sctp
75%patch17 -p1 -b .sctpdef
76%patch19 -p1 -b .rsvp-dos
77%patch21 -p1 -b .isis-dos
78#patch22 -p1 -b .ethbuf
79popd
80
81pushd tcpslice
82%patch70 -p1 -b .bpf
83popd
84
85%build
86pushd %tcpslice_dir
87%configure
88make
89popd
90
91pushd %tcpdump_dir
92%define optflags $RPM_OPT_FLAGS -DIP_MAX_MEMBERSHIPS=20
93%configure --enable-ipv6
94%undefine optflags
95
96DEFS="-g -D_U_=\"\" -DHAVE_CONFIG_H -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE"
97%ifarch alpha sparc sparc64
98DEFS="$DEFS -DHAVE_ETHER_HOSTTON=1 -DLBL_ALIGN=1 -DHAVE_ETHER_NTOA=1"
99%endif
100%ifarch sparc sparc64
101DEFS="$DEFS -DWORDS_BIGENDIAN"
102%endif
103
104make DEFS="$DEFS"
105popd
106
107%install
108rm -rf %{buildroot}
109mkdir -p %{buildroot}%{_libdir}
110mkdir -p %{buildroot}%{_mandir}/man{3,8}
111mkdir -p %{buildroot}%{_sbindir}
112
113pushd %tcpslice_dir
114install -m755 -s tcpslice %{buildroot}%{_sbindir}
115install -m644 tcpslice.1 %{buildroot}%{_mandir}/man8/tcpslice.8
116popd
117
118pushd %tcpdump_dir
119install -m755 -s tcpdump %{buildroot}%{_sbindir}
120install -m644 tcpdump.1 %{buildroot}%{_mandir}/man8/tcpdump.8
121popd
122
123
124%clean
125rm -rf %{buildroot}
126
127
128%files
129%defattr(-,root,root)
130%doc tcpdump-%{tcpdump_ver}/README
131%doc tcpdump-%{tcpdump_ver}/CHANGES
132%doc tcpdump-%{tcpdump_ver}/LICENSE
133%{_sbindir}/tcpdump
134%{_sbindir}/tcpslice
135%{_mandir}/man8/tcpslice.8*
136%{_mandir}/man8/tcpdump.8*
137
138
139%changelog
140* Thu Mar 22 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1:4.1.1-4
141- rebuild
142
143* Sat Jan 29 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:4.1.1-3
144- rebuild with openssl-1.0.0c
145
146* Sat Sep 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-2
147- removed pcap header direction
148- added URL tag
149
150* Sun May 23 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.1.1-1
151- new upstream release
152- updated Patch10
153- built with new toolchain
154
155* Sat Apr 25 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:4.0.0-2
156- spec in UTF-8
157- added BuildRequires: libpcap-devel instead of libpcap
158- changed Group to Applications/System
159
160* Thu Oct 30 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1:4.0.0-1
161- new upstream release with libpcap 1.0.0
162
163* Mon Apr 14 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.8-2
164- built again with libpcap-0.9.8 for sure this time
165
166* Sat Apr 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.8-1vl5
167- new upstream release
168
169* Sat Sep  1 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.7-0vl1
170- new upstream release
171
172* Sat Jul  7 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.6-0vl1
173- new upstream release
174
175* Mon May 21 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:3.9.3-0vl3
176- rebuilt with new toolchain
177
178* Fri Aug 26 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl2
179- dropped --with-user option
180
181* Mon Aug 22 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.9.3-0vl1
182- new upstream release
183- some patches are imported from fedora package
184- build with libpcap 0.9.3
185- changed BuildRequire kernel-headers to glibc-kernheaders
186
187* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.8.3-0vl1
188- new upstream release
189- some patches are imported from fedora package
190
191* Sat Oct 11 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:3.7.2-0vl1
192- updated to 3.7.2
193- fixed patches based on Redhat Rawhide
194- rebuild with libpcap-0.7.2
195- s/Copyright/License/
196
197* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl2
198- split out libpcap, Requires: libpcap
199
200* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.7.1-0vl1
201- update to new upstream release tcpdump 3.7.1, arpwatch 0.7.1
202- drop unneeded patches
203- use autoconf213, automake14
204- split out arpwatch
205
206* Fri Feb 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl2
207- add patch16 to fix  print_bgp security bug
208  - errata 20030221-3
209
210* Wed Jun 12 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1:3.6.2-13vl1
211- merged with 3.6.2-13
212- fix buffer overflow for errata
213  * Thu May 16 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-13
214  - added official 3.6.3 fix
215  - fixed 6.2 compat #63113
216  * Wed Jan 23 2002 Harald Hoyer <harald@redhat.de> 12:3.6.2-12
217  - tcpdump-3.6.2-snaplen.patch added to fix #55145
218  * Tue Dec 18 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-10
219  - took old purge patch for filters
220  - fixed #54225,#58346
221  - drop root by default #49635
222  - fixed #54593
223  - fixed #57711
224
225* Thu Oct 25 2001 IWAI Masaharu <iwaim@cc.mbn.or.jp>
226- 3.6.2-9vl1
227- used PRM macros
228- changed File Name to Package Name in Prereq tag
229- marged 3.6.2-9 (RedHat7.2)
230
231  * Tue Jan 23 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
232  - 3.4-19vl2
233  - use better macros
234 
235  * Thu Sep 21 2000 Yoshihiro Kajiki <kajiki@ylug.org>
236  - add libpcap-0.4-guy-gerald.patch to fix the timeout problem (by Ethereal)
237  - add Japanese summarys and descriptions
238  - modify spec file to build as a normal user
239 
240  * Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
241  - Compile shared libpcap with -fPIC (Bug #6342)
242 
243  * Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
244  - fix descriptions
245  - man pages are compressed
246 
247  * Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
248  - remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
249  - upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
250  - add getprotobyname lookup (#6725).
251  - getservbyname port lookup appears functional (#7569).
252  - remove uid 2090 backdoor (sorry Dave) (#7116).
253 
254  * Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
255  - fox the pcap.h header
256 
257  * Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
258  - prevent segfault on obscure spoofed ip header (#4634).
259 
260  * Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
261  - add defattr to arpwatch (#4591).
262 
263  * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
264  - initscript munging
265
266  * Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
267  - add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
268 
269  * Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
270  - include A. Kuznetsov's patches to libpcap/tcpdump.
271  - added arpsnmp to package (#3258).
272  - arp2ethers written for different of awk (#4326).
273
274  * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
275  - auto rebuild in the new build environment (release 10)
276
277  * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
278  - strip binaries.
279 
280  * Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
281  - autoconf fixes for arm
282
283  * Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
284  - libpcap description typo.
285
286  * Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
287  - fix arpwatch summary line.
288 
289  * Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
290  - enable arpwatch
291 
292  * Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
293  - separate package for libpcap.
294  - update tcpdump to 3.4, libpcap to 0.4.
295  - added arpwatch (but disabled for now)
296 
297  * Thu May 07 1998 Prospector System <bugs@redhat.com>
298  - translations modified for de, fr, tr
299 
300  * Sat May  2 1998 Alan Cox <alan@rehat.com>
301  - Added the SACK printing fix so you can dump Linux 2.1+.
302 
303  * Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
304  - updated to release 3.4a5
305  - uses a buildroot and %attr
306 
307  * Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
308  - built against glibc
309
310* Fri Aug 31 2001 Harald Hoyer <harald@redhat.de> 12:3.6.2-9
311- took better fix for #52654 from tcpdump cvs
312
313* Thu Aug 30 2001 Harald Hoyer <harald@redhat.de> 11:3.6.2-8
314- fixed #52654
315
316* Thu Jul 19 2001 Harald Hoyer <harald@redhat.de> 10:3.6.2-7
317- added shared library to libpcap (#47174)
318- afs printing security patch (#49294)
319
320* Wed Jun 20 2001 Harald Hoyer <harald@redhat.de>
321- use initgroups, instead of setgroups
322
323* Mon Jun 18 2001 Harald Hoyer <harald@redhat.de>
324- added dropgroup patches (#44563)
325
326* Mon May 07 2001 Harald Hoyer <harald@redhat.de>
327- switched to Pekka's tcpdump-3.6.2 package
328- incremented epoch
329
330* Sat Apr 14 2001 Pekka Savola <pekkas@netcore.fi>
331- fix building of tcpslice on glibc 2.2.2 (time.h)
332- disable /etc/init.d requirement and fix %post scripts in arpwatch
333
334* Wed Feb 14 2001 Harald Hoyer <harald@redhat.de>
335- glibc sys/time -> time include patch
336
337* Wed Feb  7 2001 Trond Eivind Glomsr <teg@redhat.com>
338- Add space to this check
339
340* Wed Feb 07 2001 Harald Hoyer <harald@redhat.com>
341- added check for presence of /etc/sysconfig/arpwatch (#23172)
342
343* Wed Feb  7 2001 Pekka Savola <pekkas@netcore.fi>
344- update to 3.6.2, 0.6.2 and new CVS of tcpslice.
345- i18n'ize arpwatch init script
346
347* Fri Feb  2 2001 Trond Eivind Glomsr <teg@redhat.com>
348- i18nize initscript
349
350* Mon Jan 29 2001 Harald Hoyer <harald@redhat.com>
351- fixed EINTR stopping for e.g. SIGSTOP. (#22008)
352- added -u option for tcpdump (#20231)
353- new arpwatch version (#23172)
354- added "all" and "one" interface for -i (#20907)
355- added arpwatch sysconfig (#23172)
356
357* Mon Jan 22 2001 Harald Hoyer <harald@redhat.com>
358- more (potential) overflows in libpcap. #21373
359- documentation fix for #20906
360
361* Sun Jan 14 2001 Pekka Savola <pekkas@netcore.fi>
362- use --enable-ipv6
363- Add two patches from CVS to enhance 802.2 printing, and more importantly,
364  to be able to specify 'no stp'
365
366* Sat Jan 13 2001 Pekka Savola <pekkas@netcore.fi>
367- Make SMB printing output a lot more quiet unless in verbose mode.
368- Make -n resolve port/protocol numbers but not hostnames, -nn for no
369  resolving at all
370- Separate droproot patch from a more generic man/usage fix one
371- Add non-promiscuous mode -by default patch, but don't apply it by default
372
373* Thu Jan 11 2001 Pekka Savola <pekkas@netcore.fi>
374- Update to tcpdump 3.6.1 and libpcap 0.6.1 releases.
375
376* Mon Jan  8 2001 Pekka Savola <pekkas@netcore.fi>
377- Update to 20010108 CVS, disable some upstreamed patches.
378- Change some additional .1 pages to .8.
379- Add droproot patch, some --usage and man page fixes.
380
381* Mon Jan  1 2001 Pekka Savola <pekkas@netcore.fi>
382- Initial packaging with latest tcpdump.org CVS tcpdump-3.6 and libpcap-0.6.
383- add earlier print-domain.c, the latest is segfaulting
384- don't unnecesessarily include snprintf.o, it didn't compile with gcc 2.96 anyway
385- don't use savestr, require openssl, tweak tweak tweak
386- add tcpslice, patch it a bit for egcs detection
387
388* Sun Dec 31 2000 Pekka Savola <pekkas@netcore.fi>
389- tcpdump: spice up the manpage about interfaces
390- tcpdump: add 'all' and 'any' keywords to -i, saner default behaviour.
391- upgrade arpwatch to 2.1a10
392
393* Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
394- more (potential) overflows in libpcap.
395
396* Sun Nov 12 2000 Jeff Johnson <jbj@redhat.com>
397- eliminate still more buffer overflows (from FreeBSD) (#20069).
398
399* Thu Nov  2 2000 Jeff Johnson <jbj@redhat.com>
400- eliminate more buffer overflows (from FreeBSD) (#20069).
401- 802.1q ether type incorrect (#19850).
402- add -u flag to drop arpwatch privs (#19696).
403
404* Sun Oct 15 2000 Jeff Johnson <jbj@redhat.com>
405- updated ethercodes.dat
406
407* Thu Oct 12 2000 Jeff Johnson <jbj@redhat.com>
408- fix arpwatch tmp race (#18943).
409
410* Fri Aug 11 2000 Bill Nottingham <notting@redhat.com>
411- fix condrestart
412
413* Fri Aug 11 2000 Jeff Johnson <jbj@redhat.com>
414- correct arpsnmp man pages (#15442).
415- don't print harmless ENOPROTOOPT message (#13518).
416
417* Fri Aug  4 2000 Jeff Johnson <jbj@redhat.com>
418- rebuild with final kernel headers (#13518).
419
420* Sat Jul 22 2000 Jeff Johnson <jbj@redhat.com>
421- add STP patch (#14112).
422
423* Fri Jul 14 2000 Matt Wilson <msw@redhat.com>
424- source /etc/init.d/functions
425- back out /etc/init.d/arpwatch, place file in /etc/rc.d
426- move initscript to /etc/init.d
427- changed initscript to use start() and stop() functions
428- added condrestart to init script
429- added %%post %%preun %%postun scripts to register arpwatch script
430- added Prereq: for all things needed in post/preun/postun
431
432* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
433- automatic rebuild
434
435* Tue Jul 11 2000 Jeff Johnson <jbj@redhat.com>
436- updated man page and help (pekkas@netcore.fi) (#10739 et al).
437
438* Sun Jun 18 2000 Jeff Johnson <jbj@redhat/com>
439- FHS packaging.
440
441* Tue May  9 2000 Bill Nottingham <notting@redhat.com>
442- minor tweaks for ia64 (prototypes)
443
444* Thu Feb 17 2000 Bernhard Rosenkraenzer <bero@redhat.com>
445- Compile shared libpcap with -fPIC (Bug #6342)
446
447* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
448- fix descriptions
449- man pages are compressed
450
451* Wed Dec 22 1999 Jeff Johnson <jbj@redhat.com>
452- remove sparc64 SIOCGIFNAME hack, not needed with (at least) kernel 2.2.12-40.
453- upgrade to ANK ss991030 snapshot with pcap magic fix (#6773).
454- add getprotobyname lookup (#6725).
455- getservbyname port lookup appears functional (#7569).
456- remove uid 2090 backdoor (sorry Dave) (#7116).
457
458* Thu Sep 09 1999 Cristian Gafton <gafton@redhat.com>
459- fox the pcap.h header
460
461* Fri Aug 20 1999 Jeff Johnson <jbj@redhat.com>
462- prevent segfault on obscure spoofed ip header (#4634).
463
464* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
465- add defattr to arpwatch (#4591).
466
467* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
468- initscript munging
469
470* Sun Aug  8 1999 Jeff Johnson <jbj@redhat.com>
471- add -DWORDS_BIGINDIAN to tcpdump compile on sparc sparc61.
472
473* Tue Aug  3 1999 Jeff Johnson <jbj@redhat.com>
474- include A. Kuznetsov's patches to libpcap/tcpdump.
475- added arpsnmp to package (#3258).
476- arp2ethers written for different of awk (#4326).
477
478* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
479- auto rebuild in the new build environment (release 10)
480
481* Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
482- strip binaries.
483
484* Wed Jan 13 1999 Bill Nottingham <notting@redhat.com>
485- autoconf fixes for arm
486
487* Tue Sep 29 1998 Jeff Johnson <jbj@redhat.com>
488- libpcap description typo.
489
490* Sat Sep 19 1998 Jeff Johnson <jbj@redhat.com>
491- fix arpwatch summary line.
492
493* Mon Aug 17 1998 Jeff Johnson <jbj@redhat.com>
494- enable arpwatch
495
496* Mon Aug  3 1998 Jeff Johnson <jbj@redhat.com>
497- separate package for libpcap.
498- update tcpdump to 3.4, libpcap to 0.4.
499- added arpwatch (but disabled for now)
500
501* Thu May 07 1998 Prospector System <bugs@redhat.com>
502- translations modified for de, fr, tr
503
504* Sat May  2 1998 Alan Cox <alan@rehat.com>
505- Added the SACK printing fix so you can dump Linux 2.1+.
506
507* Tue Oct 21 1997 Erik Troan <ewt@redhat.com>
508- updated to release 3.4a5
509- uses a buildroot and %attr
510
511* Thu Jul 17 1997 Erik Troan <ewt@redhat.com>
512- built against glibc
Note: See TracBrowser for help on using the repository browser.