source: projects/specs/trunk/t/tc-el/tc-el-vl.spec @ 521

Revision 521, 3.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: Yet another Japanese input method for Emacsen
2Name: tc-el
3Version: 2.3.1
4Release: 1%{?_dist_release}
5License: GPL
6Group: Applications/Editors/Emacs
7Source0: http://openlab.jp/tcode/resources/soft/tc-%{version}.tar.gz
8Source1: %{name}-install.sh
9Source2: %{name}-remove.sh
10Patch0: tc-2.3.1-shebang.patch
11Patch1: tc-2.3.1-datadir.patch
12URL: http://openlab.jp/tcode/tc2/index.html
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14BuildPreReq: autoconf, libtool, emacs
15PreReq: emacsen, emacsen-common >= 0.1
16Requires: bash
17
18%description
19T-Code is Japanese input method that doesn't use Kana-to-Kanji convertion.
20You can input Kanji characters directly in the same way of inputting
21Hiragana.  This packages also provides TUT-Code input method (the
22alternative of T-Code).
23
24%prep
25
26%setup -q -c
27cd tc-%{version}
28%patch0 -p0
29%patch1 -p0
30cd ..
31
32%build
33cd tc-%{version}
34
35%configure --with-lispdir=%{_datadir}/emacs/site-lisp/tc-el
36make -C bushu-util
37make -C doc
38make -C etc
39make -C kinput2
40make -C mazegaki
41make -C skkinput3
42
43cd ..
44
45%install
46cd tc-%{version}
47
48[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
49[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
50
51mkdir -p ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name}
52mkdir -p ${RPM_BUILD_ROOT}/%{_prefix}/lib/emacsen-common/packages/install
53mkdir -p ${RPM_BUILD_ROOT}/%{_prefix}/lib/emacsen-common/packages/remove
54
55make -C bushu-util DESTDIR=${RPM_BUILD_ROOT} install
56make -C doc        DESTDIR=${RPM_BUILD_ROOT} install
57make -C etc        DESTDIR=${RPM_BUILD_ROOT} install
58make -C kinput2    DESTDIR=${RPM_BUILD_ROOT} install
59make -C mazegaki   DESTDIR=${RPM_BUILD_ROOT} install
60make -C skkinput3  DESTDIR=${RPM_BUILD_ROOT} install
61
62(cd lisp && \
63 install -m 644 *.el ${RPM_BUILD_ROOT}/%{_datadir}/emacs/site-lisp/%{name})
64
65rm -f $RPM_BUILD_ROOT%{_bindir}/tcinput
66
67%_installemacsenscript %{name} %{SOURCE1}
68
69%_removeemacsenscript  %{name} %{SOURCE2}
70
71cd ..
72
73%post
74/sbin/install-info %{_infodir}/tc.info.gz %{_infodir}/dir \
75  --section="T-Code Driver for Emacsen"
76
77if [ "$1" = 2 ]; then
78  %_emacsenPackageRemove tc-el
79
80fi
81
82%_addemacsenlist tc-el
83
84%_emacsenPackageInstall tc-el
85
86%preun
87/sbin/install-info --delete %{_infodir}/tc.info.gz %{_infodir}/dir \
88  --section="T-Code Driver for Emacsen"
89
90if [ "$1" = 0 ]; then
91  %_emacsenPackageRemove tc-el
92
93  %_removeemacsenlist tc-el
94
95fi
96
97%clean
98[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
99
100%files
101%defattr(-, root, root)
102%{_datadir}/tc
103%{_infodir}/*.info.gz
104#%{_libdir}/emacsen-common/packages/install/%{name}
105#%{_libdir}/emacsen-common/packages/remove/%{name}
106%{_prefix}/lib/emacsen-common/packages/install/%{name}
107%{_prefix}/lib/emacsen-common/packages/remove/%{name}
108%{_datadir}/emacs/site-lisp/%{name}/
109%doc tc-%{version}/AUTHORS
110%doc tc-%{version}/COPYING
111%doc tc-%{version}/ChangeLog*
112%doc tc-%{version}/NEWS
113%doc tc-%{version}/README
114%doc tc-%{version}/skkinput3/tcinput
115
116%changelog
117* Mon Aug 18 2008 Shu KONNO <owa@bg.wakwak.com> 2.3.1-1vl5
118- applied new versioning policy
119- fixed path of emacsen-common
120
121* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.3.1-0vl2
122- changed Group to Appliations/Editors/Emacs
123- s/Copyright/License/
124
125* Wed Dec  3 2003 akira yamada <akira@vinelinux.org> 2.3.1-0vl1
126- new upstream version.
127- BuildPreReq: emacs-beta -> emacs
128
129* Tue Feb 12 2002 akira yamada <akira@vinelinux.org> 2.2-0vl4
130- rewrote summary field.
131- .tc-bitmap-8x16 is in %{_datadir}/tc, fixed tc-el-install.sh.
132
133* Mon Feb 11 2002 akira yamada <akira@vinelinux.org> 2.2-0vl3
134- install .tc-bitmap-8x16 to datadir.
135
136* Wed Feb 06 2002 akira yamada <akira@vinelinux.org> 2.2-0vl2
137- BuildArch is not noarch. /usr/lib/tc/{reduce,combine} are elf-binary.
138
139* Mon Feb 04 2002 akira yamada <akira@vinelinux.org> 2.2-0vl1
140- new upstream release.
141- added autoconf, libtool and emacs-beta to BuildPreReq.
142- emacsen-common is in PreReq, not in Requires.
143- BuildArch is now noarch.
144
145* Fri Dec 14 2001 akira yamada <akira@vinelinux.org> 2.1+2.2pre2-0vl1
146- Initial packaging.
Note: See TracBrowser for help on using the repository browser.