source: projects/specs/trunk/t/tar/tar-vl.spec @ 521

Revision 521, 10.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A GNU file archiving program.
2Summary(ja): GNU ファイルアーカイブプログラム
3Name: tar
4Version: 1.22
5Release: 3%{?_dist_release}
6License: GPLv3+
7Group: Applications/Archiving
8Source: ftp://ftp.gnu.org/pub/gnu/tar/tar-%{version}.tar.gz
9Patch0: tar-1.13.18-manpage.patch
10Patch8: tar-1.20-loneZeroWarning.patch
11Patch10: tar-1.15.1-gcc4.patch
12# adhoc but useful patch for z option accepts bzip2ed tarball.
13Patch100: tar-1.13.6-barterly.patch
14Requires(post,postun): install-info
15Buildroot: %{_tmppath}/%{name}-%{version}-root
16
17
18%description
19The GNU tar program saves many files together in one archive and can
20restore individual files (or all of the files) from that archive. Tar
21can also be used to add supplemental files to an archive and to update
22or list files in the archive. Tar includes multivolume support,
23automatic archive compression/decompression, the ability to perform
24remote archives, and the ability to perform incremental and full
25backups.
26
27If you want to use tar for remote backups, you also need to install
28the rmt package.
29
30
31%description -l ja
32GNU tar プログラムは多くのファイルを一つのファイルにまとめたりアーカイブ
33から個々のファイルを(または全てのファイルを)リストアしたりする。tarはまた
34追加ファイルを加えたりアーカイブファイル中のリストを更新したりするために
35使われる。
36
37tar はマルチボリュームサポート、自動アーカイブ圧縮/伸長、リモート
38アーカイブの取り扱う機能、そして差分バックアップとフルバックアップをする
39機能を含んでいる。
40
41もしリモートバックアップのために tar をインストールするなら、rmt パッケージ
42もまたインストールする必要がある。
43
44
45%prep
46%setup -q
47%patch0 -p1 -b .manpage
48%patch8 -p1 -b .loneZeroWarning
49%patch100 -p1 -b .accept-bz2
50
51
52
53%build
54%configure --bindir=/bin --libexecdir=/sbin
55make LIBS=-lbsd %{?_smp_mflags}
56
57
58%install
59rm -rf $RPM_BUILD_ROOT
60
61make prefix=${RPM_BUILD_ROOT}%{_prefix} \
62    localedir=${RPM_BUILD_ROOT}%{_prefix}/share/locale \
63    bindir=${RPM_BUILD_ROOT}/bin \
64    libexecdir=${RPM_BUILD_ROOT}/sbin \
65    mandir=${RPM_BUILD_ROOT}%{_mandir} \
66    infodir=${RPM_BUILD_ROOT}%{_infodir} \
67        install
68ln -s tar ${RPM_BUILD_ROOT}/bin/gtar
69
70( cd $RPM_BUILD_ROOT
71  for dir in ./bin ./sbin .%{_prefix}/bin .%{_prefix}/libexec
72  do
73    [ -d $dir ] || continue
74    strip $dir/* || :
75  done
76  gzip -9nf .%{_infodir}/tar.info*
77  rm -f .%{_infodir}/dir
78)
79
80mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man1
81install -c -m644 tar.1 ${RPM_BUILD_ROOT}%{_mandir}/man1
82
83rm -f ${RPM_BUILD_ROOT}/sbin/rmt
84
85%find_lang %name
86
87
88%post
89/sbin/install-info %{_infodir}/tar.info.gz %{_infodir}/dir
90
91
92%preun
93if [ $1 = 0 ]; then
94   /sbin/install-info --delete %{_infodir}/tar.info.gz %{_infodir}/dir
95fi
96
97
98%clean
99rm -rf ${RPM_BUILD_ROOT}
100
101
102%files -f %{name}.lang
103%defattr(-,root,root)
104%doc AUTHORS COPYING ChangeLog* NEWS README THANKS TODO
105/bin/tar
106/bin/gtar
107%{_mandir}/man1/tar.1*
108%{_infodir}/tar.info*
109
110
111%changelog
112* Thu Apr 30 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.22-3
113- add missing documents
114
115* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.22-2
116- spec in utf-8
117
118* Mon Mar 16 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.22-1
119- new upstream release
120- improved tar-1.20-loneZeroWarning.patch (refer to Fedora package)
121
122* Thu Apr 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.20-1
123- new upstream release
124- remove unneeded patches
125
126* Mon Dec 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.15.1-0vl3
127- rebuilt for VineSeed
128
129* Thu Nov 30 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2.1
130- add patch120 for fix CVE-2006-6097
131
132* Sun Sep 17 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.15.1-0vl2
133- add patch110 for fix CVE-2006-0300
134
135* Mon May 02 2005 Satoshi MACHINO <machino@vinelinux.org> 1.15.1-0vl1
136- new upstream release
137- fixed patch6 and patch7 for new upstream release
138- some patches are imported from fedora package. and fixed
139        -- stop issuing lone zero block warnings(patch8)
140        -- fixed testsuite(patch9)
141        -- don't applyed(patch10)
142        -- fixed offset had incorrect type(patch11)
143
144* Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 1.14-0vl1
145- new upstream release
146- some patches are imported from fedora package.
147
148* Fri May  2 2003 IWAI Masaharu <iwai@alib.jp> 1.3.25-8vl4
149- rebuild with new toolchain
150  - update BuildRequire (autoconf253 -> autoconf)
151
152* Thu Oct 31 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.25-8vl3
153- add adhoc but useful patch100 for "z" option to accepts bz2 tarball.
154
155* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl2
156- Oops the spec was in Shift-JIS. Fixed.
157
158* Wed Oct 30 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.3.25-8vl1
159- based on 1.3.25-8 from Rawhide and built for Vine Linux
160- the previous Vine package was 1.3.18-0vl2. Vine's changelog was as follows:
161
162  - Wed Feb 20 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 1.13.18-0vl2
163  - rebuild to remove rpmlib dependancy
164
165  - Sat May 26 2001 <sagami@vinelinux.org>
166  - 1.13.18-0vl1: based on 1.13.18-1 and added Japanese summary and description
167  - added barterly patch
168
169* Fri Aug 23 2002 Phil Knirsch <pknirsch@redhat.com> 1.13.25-8
170- Included security patch from errata release.
171
172* Mon Jul  1 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-7
173- Fix argv NULL termination (#64869)
174
175* Thu May 23 2002 Tim Powers <timp@redhat.com>
176- automated rebuild
177
178* Tue Apr  9 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-4
179- Fix build with autoconf253 (LIBOBJ change; autoconf252 worked)
180
181* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
182- automated rebuild
183
184* Tue Oct 23 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-2
185- Don't include hardlinks to sockets in a tar file (#54827)
186
187* Thu Sep 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.25-1
188- 1.13.25
189
190* Tue Sep 18 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.22-1
191- Update to 1.13.22, adapt patches
192
193* Mon Aug 27 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-6
194- Fix #52084
195
196* Thu May 17 2001 Bernhard Rosenkraenzer <bero@redhat.com> 1.13.19-5
197- Fix build with current autoconf (stricter checking on AC_DEFINE)
198- Fix segfault when tarring directories without having read permissions
199  (#40802)
200
201* Tue Mar  6 2001 Bernhard Rosenkraenzer <bero@redhat.com>
202- Don't depend on librt.
203
204* Fri Feb 23 2001 Trond Eivind Glomsr <teg@redhat.com>
205- langify
206
207* Thu Feb 22 2001 Bernhard Rosenkraenzer <bero@redhat.com>
208- Fix up the man page (#28915)
209
210* Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
211- 1.3.19, nukes -I and fixes up -N
212- Add -I back in as an alias to -j with a nice loud warning
213
214* Mon Oct 30 2000 Bernhard Rosenkraenzer <bero@redhat.com>
215- 1.3.18
216- Update man page to reflect changes
217
218* Thu Oct  5 2000 Bernhard Rosenkraenzer <bero@redhat.com>
219- Fix the "ignore failed read" option (Bug #8330)
220
221* Mon Sep 25 2000 Bernhard Rosenkraenzer <bero@redhat.com>
222- fix hang on tar tvzf - <something.tar.gz, introduced by
223  exit code fix (Bug #15448), Patch from Tim Waugh <twaugh@redhat.com>
224
225* Fri Aug 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
226- really fix exit code (Bug #15448)
227
228* Mon Aug  7 2000 Bernhard Rosenkraenzer <bero@redhat.com>
229- fix exit code (Bug #15448), patch from Tim Waugh <twaugh@redhat.com>
230
231* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
232- automatic rebuild
233
234* Mon Jun 19 2000 Bernhard Rosenkraenzer <bero@redhat.com>
235- FHSify
236
237* Fri Apr 28 2000 Bill Nottingham <notting@redhat.com>
238- fix for ia64
239
240* Wed Feb  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
241- Fix the exclude bug (#9201)
242
243* Wed Feb 02 2000 Cristian Gafton <gafton@redhat.com>
244- man pages are compressed
245- fix description
246- fix fnmatch build problems
247
248* Sun Jan  9 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
249- 1.13.17
250- remove dotbug patch (fixed in base)
251- update download URL
252
253* Fri Jan  7 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
254- Fix a severe bug (tar xf any_package_containing_. would delete the
255  current directory)
256
257* Wed Jan  5 2000 Bernhard Rosenkr舅zer <bero@redhat.com>
258- 1.3.16
259- unset LINGUAS before running configure
260
261* Tue Nov  9 1999 Bernhard Rosenkr舅zer <bero@redhat.com>
262- 1.13.14
263- Update man page to know about -I / --bzip
264- Remove dependancy on rmt - tar can be used for anything local
265  without it.
266
267* Fri Aug 27 1999 Preston Brown <pbrown@redhat.com>
268- upgrade to 1.13.11.
269
270* Wed Aug 18 1999 Jeff Johnson <jbj@redhat.com>
271- update to 1.13.9.
272
273* Thu Aug 12 1999 Jeff Johnson <jbj@redhat.com>
274- update to 1.13.6.
275- support -y --bzip2 options for bzip2 compression (#2415).
276
277* Fri Jul 23 1999 Jeff Johnson <jbj@redhat.com>
278- update to 1.13.5.
279
280* Tue Jul 13 1999 Bill Nottingham <notting@redhat.com>
281- update to 1.13
282
283* Sat Jun 26 1999 Jeff Johnson <jbj@redhat.com>
284- update to 1.12.64014.
285- pipe patch corrected for remote tars now merged in.
286
287* Sun Jun 20 1999 Jeff Johnson <jbj@redhat.com>
288- update to tar-1.12.64013.
289- subtract (and reopen #2415) bzip2 support using -y.
290- move gtar to /bin.
291
292* Tue Jun 15 1999 Jeff Johnson <jbj@redhat.com>
293- upgrade to tar-1.12.64011 to
294-   add bzip2 support (#2415)
295-   fix filename bug (#3479)
296
297* Mon Mar 29 1999 Jeff Johnson <jbj@redhat.com>
298- fix suspended tar with compression over pipe produces error (#390).
299
300* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
301- auto rebuild in the new build environment (release 8)
302
303* Mon Mar 08 1999 Michael Maher <mike@redhat.com>
304- added patch for bad name cache.
305- FIXES BUG 320
306
307* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
308- Injected new description and group.
309
310* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
311- bumped spec number for initial rh 6.0 build
312
313* Tue Aug  4 1998 Jeff Johnson <jbj@redhat.com>
314- add /usr/bin/gtar symlink (change #421)
315
316* Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
317- Fiddle bindir/libexecdir to get RH install correct.
318- Don't include /sbin/rmt -- use the rmt from dump.
319- Turn on nls.
320
321* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
322- translations modified for de, fr, tr
323
324* Thu Oct 16 1997 Donnie Barnes <djb@redhat.com>
325- updated from 1.11.8 to 1.12
326- various spec file cleanups
327- /sbin/install-info support
328
329* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
330- built against glibc
331
332* Thu May 29 1997 Michael Fulbright <msf@redhat.com>
333- Fixed to include rmt
Note: See TracBrowser for help on using the repository browser.