source: projects/specs/trunk/t/tamago/tamago-vl.spec @ 965

Revision 965, 7.8 KB checked in by daisuke, 14 years ago (diff)

tamago:

  • update vine-default-tamago.el to support emacs >= 23.1.96
  • add vine-default-tamago.el to svn.
Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define _libdir %{_prefix}/lib
4%define       origver       4.0.6
5%define       origname      tamago
6
7
8Summary:      Tamago Version 4 -- EGG Input Method Architecture for Emacsen
9Summary(ja):  たまご第4版
10Name:         %{origname}
11Version:      %{origver}
12Release:      8%{?_dist_release}
13
14Source0:      ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
15Source1:      %{origname}-install.sh
16Source2:      %{origname}-remove.sh
17Source3:      http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
18Source4:      egg-anthy.tar.gz
19%define egg_anthy_version 20060606-2
20
21Source10:     vine-default-%{origname}.el
22Source11:     %{origname}-init.el
23
24Patch0:       tamago-4.0.6-cvshead.patch
25Patch3:       tamago-4.0.6-eggrc.patch
26Patch4:       tamago-4.0.6-makefile.patch
27Patch5:       tamago-4.0.6-canna-unix-domain-socket.patch
28
29Patch10:      tamago-emcws.patch
30Patch20:      tamago-4.0.6-vine-romakana.patch
31Patch30:      tamago-4.0.6-egg-helper-path.patch
32Patch40:      tamago-4.0.6-wnn8_rev2.patch
33
34### for emacs
35### from  http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
36Patch50:      tamago-4.0.6-emacs23.patch
37
38License:      GPL
39Group:        Applications/Editors/Emacs
40BuildRoot:    %{_tmppath}/%{name}-%{version}-root
41
42Requires:     emacsen
43Requires:     emacsen-common
44BuildPreReq:  apel
45%prereq_ge    apel
46Obsoletes:    tamago-el
47
48Vendor:       Project Vine
49Distribution: Vine Linux
50
51%description
52EGG Emacs20(Emacs21) Input Method Architecture.
53All is written only with Emacs Lisp.
54Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
55character string conversion with the back end.
56And can convert mixed sentence of Japanese and Chinese into.
57.
58There is the part which is not implemented yet.
59
60
61%description -l ja
62すべてのソースが Emacs Lisp で実現されており、GNU Emacs 20.5 以降で
63多言語入力環境を提供します。バックエンドサーバとしては、FreeWnn (jserver,
64cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応しています。
65
66
67
68%prep
69%setup -n %{origname}-%{origver} -a 4
70%patch0 -p1
71%patch3 -p1
72#% patch4 -p1
73%patch5 -p1
74# cp %{SOURCE3} .
75%__cp -a %{SOURCE10} %{SOURCE11} .
76
77#% patch10 -p1
78%patch20 -p1
79%patch30 -p1
80%patch40 -p1
81%patch50 -p1
82
83# rename canna stuff
84#mv egg/canna.el egg/canna-tamago.el
85
86# copy egg-anthy stuff
87cp egg-anthy-%{egg_anthy_version}/*.el egg/
88
89%build
90
91%configure
92
93gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
94
95
96%install
97
98[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
99[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
100
101mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
102mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
103mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
104
105
106#
107# install el files
108#
109
110cp -r eggrc *.el egg its* Makefile \
111        $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
112
113#
114# install egg-helper
115#
116install -d $RPM_BUILD_ROOT%{_libexecdir}
117install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
118
119
120#
121# install  script( bytecompile el and install elc , remove )   
122#
123
124%_installemacsenscript %{origname} %{SOURCE1}
125
126%_removeemacsenscript  %{origname} %{SOURCE2}
127
128
129#
130# install info file
131#
132
133mkdir -p ${RPM_BUILD_ROOT}/usr/info
134
135
136%post
137#
138# bytecompile and install
139#
140
141if [ "$1" = 2 ]; then
142
143%_emacsenPackageRemove %{origname}
144
145fi
146
147%_addemacsenlist %{origname}
148
149%_emacsenPackageInstall %{origname}
150
151
152%preun
153
154if [ "$1" = 0 ]; then
155
156%_emacsenPackageRemove %{origname}
157
158%_removeemacsenlist %{origname}
159
160fi
161
162
163
164%clean
165[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
166
167
168%files
169%defattr(-,root,root)
170%doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
171%doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
172%{_datadir}/emacs/site-lisp/%{origname}/
173%{_libdir}/emacsen-common/packages/install/%{origname}
174%{_libdir}/emacsen-common/packages/remove/%{origname}
175%{_libexecdir}/egg-helper
176 
177
178%changelog
179* Sat May 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-8
180- update vine-default-tamago.el to support emacs >= 23.1.96
181
182* Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
183- update patch40 (tamago-4.0.6--wnn8_rev2.patch)
184  - fix bugs on 64bit architecture.
185
186* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
187- applied tamago-4.0.6-emacs23.patch
188
189* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
190- updated tamago-install.sh
191  - *-init.el: changed from hard copy to symbolic link
192    on /etc/emacs-XX.YY/site-start.d
193
194* Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
195- no applied:
196  - egg-canna.el
197  - tamago-4.0.6-makefile.patch
198  - tamago-emcws.patch
199- added vine-default-tamago.el and tamago-init.el
200- updated tamago-install.sh for vine-default-tamago.el
201
202* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
203- change from noarch to per-arch for egg-helper.
204
205* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
206- applied new versioning policy
207- added %%define _libdir %%{_prefix}/lib
208
209* Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
210- add Patch40 to support wnn7 and wnn8 (taken from debian package)
211
212* Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
213- restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
214
215* Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
216- add Patch5
217  tamago-canna backend connect to cannaserver using UNIX domain
218  socket by default. (taken from debian package)
219- add Patch30 to change egg-helper path.
220
221* Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
222- modified its/hira.el to add some roma-kana conversion map.
223
224* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
225- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
226
227* Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
228- update to cvs head
229- add egg-anthy
230  http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
231- add documents to %%files
232- use License: instead of Copyright:
233
234* Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
235- update tamago-install.sh
236-   rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
237-   rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
238
239* Fri May  9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
240- update tamago-remove.sh: delete ${SITELISP}/egg
241
242* Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
243- rebuild
244
245* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
246- add patch10 to use with emcws
247
248* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
249- remove conflicts to emacs-dl-*
250- rename canna.el to canna-tamago.el (we use emcws for canna)
251
252* Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
253- modified patch3 for Canna-3.5b2-41
254
255* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
256- added patch4
257
258* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
259- update source3
260
261* Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
262- added patch3
263
264* Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
265- update patch2
266- added source3
267
268* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
269- tamago-el -> tamago again
270- spec file cleaned up
271
272* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
273- fixed install time no-compile bug( edit tamago-{install,remove}.sh )
274
275* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
276- support emacsen
277
278* Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
279- canna support patch upgrade.
280
281* Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
282- version 4.0.6
283- merge  canna support patch.
284
285* Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
286- version 4.0.5
287
Note: See TracBrowser for help on using the repository browser.