source: projects/specs/trunk/t/tamago/tamago-vl.spec @ 521

Revision 521, 7.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define _libdir %{_prefix}/lib
4%define       origver       4.0.6
5%define       origname      tamago
6
7
8Summary:      Tamago Version 4 -- EGG Input Method Architecture for Emacsen
9Summary(ja):  たまご第4版
10Name:         %{origname}
11Version:      %{origver}
12Release:      7%{?_dist_release}
13
14Source0:      ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
15Source1:      %{origname}-install.sh
16Source2:      %{origname}-remove.sh
17Source3:      http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
18Source4:      egg-anthy.tar.gz
19%define egg_anthy_version 20060606-2
20
21Source10:     vine-default-%{origname}.el
22Source11:     %{origname}-init.el
23
24Patch0:       tamago-4.0.6-cvshead.patch
25Patch3:       tamago-4.0.6-eggrc.patch
26Patch4:       tamago-4.0.6-makefile.patch
27Patch5:       tamago-4.0.6-canna-unix-domain-socket.patch
28
29Patch10:      tamago-emcws.patch
30Patch20:      tamago-4.0.6-vine-romakana.patch
31Patch30:      tamago-4.0.6-egg-helper-path.patch
32Patch40:      tamago-4.0.6-wnn8_rev2.patch
33
34### for emacs
35### from  http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
36Patch50:      tamago-4.0.6-emacs23.patch
37
38License:      GPL
39Group:        Applications/Editors/Emacs
40BuildRoot:    %{_tmppath}/%{name}-%{version}-root
41
42Requires:     emacsen
43Requires:     emacsen-common
44BuildPreReq:  apel
45%prereq_ge    apel
46Obsoletes:    tamago-el
47
48Vendor:       Project Vine
49Distribution: Vine Linux
50
51%description
52EGG Emacs20(Emacs21) Input Method Architecture.
53All is written only with Emacs Lisp.
54Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
55character string conversion with the back end.
56And can convert mixed sentence of Japanese and Chinese into.
57.
58There is the part which is not implemented yet.
59
60
61%description -l ja
62すべてのソースが Emacs Lisp で実現されており、GNU Emacs 20.5 以降で
63多言語入力環境を提供します。バックエンドサーバとしては、FreeWnn (jserver,
64cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応しています。
65
66
67
68%prep
69%setup -n %{origname}-%{origver} -a 4
70%patch0 -p1
71%patch3 -p1
72#% patch4 -p1
73%patch5 -p1
74# cp %{SOURCE3} .
75%__cp -a %{SOURCE10} %{SOURCE11} .
76
77#% patch10 -p1
78%patch20 -p1
79%patch30 -p1
80%patch40 -p1
81%patch50 -p1
82
83# rename canna stuff
84#mv egg/canna.el egg/canna-tamago.el
85
86# copy egg-anthy stuff
87cp egg-anthy-%{egg_anthy_version}/*.el egg/
88
89%build
90
91%configure
92
93gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
94
95
96%install
97
98[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
99[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
100
101mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
102mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
103mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
104
105
106#
107# install el files
108#
109
110cp -r eggrc *.el egg its* Makefile \
111        $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
112
113#
114# install egg-helper
115#
116install -d $RPM_BUILD_ROOT%{_libexecdir}
117install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
118
119
120#
121# install  script( bytecompile el and install elc , remove )   
122#
123
124%_installemacsenscript %{origname} %{SOURCE1}
125
126%_removeemacsenscript  %{origname} %{SOURCE2}
127
128
129#
130# install info file
131#
132
133mkdir -p ${RPM_BUILD_ROOT}/usr/info
134
135
136%post
137#
138# bytecompile and install
139#
140
141if [ "$1" = 2 ]; then
142
143%_emacsenPackageRemove %{origname}
144
145fi
146
147%_addemacsenlist %{origname}
148
149%_emacsenPackageInstall %{origname}
150
151
152%preun
153
154if [ "$1" = 0 ]; then
155
156%_emacsenPackageRemove %{origname}
157
158%_removeemacsenlist %{origname}
159
160fi
161
162
163
164%clean
165[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
166
167
168%files
169%defattr(-,root,root)
170%doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
171%doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
172%{_datadir}/emacs/site-lisp/%{origname}/
173%{_libdir}/emacsen-common/packages/install/%{origname}
174%{_libdir}/emacsen-common/packages/remove/%{origname}
175%{_libexecdir}/egg-helper
176 
177
178%changelog
179* Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
180- update patch40 (tamago-4.0.6--wnn8_rev2.patch)
181  - fix bugs on 64bit architecture.
182
183* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
184- applied tamago-4.0.6-emacs23.patch
185
186* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
187- updated tamago-install.sh
188  - *-init.el: changed from hard copy to symbolic link
189    on /etc/emacs-XX.YY/site-start.d
190
191* Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
192- no applied:
193  - egg-canna.el
194  - tamago-4.0.6-makefile.patch
195  - tamago-emcws.patch
196- added vine-default-tamago.el and tamago-init.el
197- updated tamago-install.sh for vine-default-tamago.el
198
199* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
200- change from noarch to per-arch for egg-helper.
201
202* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
203- applied new versioning policy
204- added %%define _libdir %%{_prefix}/lib
205
206* Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
207- add Patch40 to support wnn7 and wnn8 (taken from debian package)
208
209* Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
210- restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
211
212* Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
213- add Patch5
214  tamago-canna backend connect to cannaserver using UNIX domain
215  socket by default. (taken from debian package)
216- add Patch30 to change egg-helper path.
217
218* Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
219- modified its/hira.el to add some roma-kana conversion map.
220
221* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
222- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
223
224* Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
225- update to cvs head
226- add egg-anthy
227  http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
228- add documents to %%files
229- use License: instead of Copyright:
230
231* Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
232- update tamago-install.sh
233-   rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
234-   rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
235
236* Fri May  9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
237- update tamago-remove.sh: delete ${SITELISP}/egg
238
239* Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
240- rebuild
241
242* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
243- add patch10 to use with emcws
244
245* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
246- remove conflicts to emacs-dl-*
247- rename canna.el to canna-tamago.el (we use emcws for canna)
248
249* Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
250- modified patch3 for Canna-3.5b2-41
251
252* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
253- added patch4
254
255* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
256- update source3
257
258* Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
259- added patch3
260
261* Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
262- update patch2
263- added source3
264
265* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
266- tamago-el -> tamago again
267- spec file cleaned up
268
269* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
270- fixed install time no-compile bug( edit tamago-{install,remove}.sh )
271
272* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
273- support emacsen
274
275* Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
276- canna support patch upgrade.
277
278* Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
279- version 4.0.6
280- merge  canna support patch.
281
282* Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
283- version 4.0.5
284
Note: See TracBrowser for help on using the repository browser.