source: projects/specs/trunk/t/tamago/tamago-vl.spec @ 3606

Revision 3606, 8.0 KB checked in by iwaim, 13 years ago (diff)

tamago-4.0.6-10.egganthy20070606

RevLine 
[521]1%define _noVersionedDependencies        1
2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'PreReq:%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
3%define _libdir %{_prefix}/lib
4%define       origver       4.0.6
5%define       origname      tamago
[3606]6%define egg_anthy_version  20070606
[521]7
8Summary:      Tamago Version 4 -- EGG Input Method Architecture for Emacsen
9Summary(ja):  たまご第4版
10Name:         %{origname}
11Version:      %{origver}
[3606]12Release:      10.egganthy%{egg_anthy_version}%{?_dist_release}
[521]13
14Source0:      ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
15Source1:      %{origname}-install.sh
16Source2:      %{origname}-remove.sh
17Source3:      http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
18Source4:      egg-anthy.tar.gz
19
20Source10:     vine-default-%{origname}.el
21Source11:     %{origname}-init.el
22
23Patch0:       tamago-4.0.6-cvshead.patch
24Patch3:       tamago-4.0.6-eggrc.patch
25Patch4:       tamago-4.0.6-makefile.patch
26Patch5:       tamago-4.0.6-canna-unix-domain-socket.patch
27
28Patch10:      tamago-emcws.patch
29Patch20:      tamago-4.0.6-vine-romakana.patch
30Patch30:      tamago-4.0.6-egg-helper-path.patch
31Patch40:      tamago-4.0.6-wnn8_rev2.patch
32
33### for emacs
34### from  http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
35Patch50:      tamago-4.0.6-emacs23.patch
36
37License:      GPL
38Group:        Applications/Editors/Emacs
39BuildRoot:    %{_tmppath}/%{name}-%{version}-root
40
41Requires:     emacsen
42Requires:     emacsen-common
43BuildPreReq:  apel
44%prereq_ge    apel
45Obsoletes:    tamago-el
46
47Vendor:       Project Vine
48Distribution: Vine Linux
49
50%description
51EGG Emacs20(Emacs21) Input Method Architecture.
52Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
53character string conversion with the back end.
54
[3606]55And this package includes egg-anthy. Egg can use Anthy.
[521]56
57%description -l ja
[3606]58GNU Emacs 20.5 以降で多言語入力環境を提供します。
59バックエンドサーバとしては、FreeWnn (jserver,
60cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応。
[521]61
[3606]62また、本パッケージには egg-anthy も同梱しているため、Anthy にも対応。
[521]63
64
65%prep
66%setup -n %{origname}-%{origver} -a 4
67%patch0 -p1
68%patch3 -p1
69#% patch4 -p1
70%patch5 -p1
71# cp %{SOURCE3} .
72%__cp -a %{SOURCE10} %{SOURCE11} .
73
74#% patch10 -p1
75%patch20 -p1
76%patch30 -p1
77%patch40 -p1
78%patch50 -p1
79
80# rename canna stuff
81#mv egg/canna.el egg/canna-tamago.el
82
83# copy egg-anthy stuff
84cp egg-anthy-%{egg_anthy_version}/*.el egg/
85
86%build
87
88%configure
89
90gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
91
92
93%install
94
95[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
96[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
97
98mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
99mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
100mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
101
102
103#
104# install el files
105#
106
107cp -r eggrc *.el egg its* Makefile \
108        $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
109
110#
111# install egg-helper
112#
113install -d $RPM_BUILD_ROOT%{_libexecdir}
114install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
115
116
117#
118# install  script( bytecompile el and install elc , remove )   
119#
120
121%_installemacsenscript %{origname} %{SOURCE1}
122
123%_removeemacsenscript  %{origname} %{SOURCE2}
124
125
126#
127# install info file
128#
129
130mkdir -p ${RPM_BUILD_ROOT}/usr/info
131
132
133%post
134#
135# bytecompile and install
136#
137
138if [ "$1" = 2 ]; then
139
140%_emacsenPackageRemove %{origname}
141
142fi
143
144%_addemacsenlist %{origname}
145
146%_emacsenPackageInstall %{origname}
147
148
149%preun
150
151if [ "$1" = 0 ]; then
152
153%_emacsenPackageRemove %{origname}
154
155%_removeemacsenlist %{origname}
156
157fi
158
159
160
161%clean
162[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
163
164
165%files
166%defattr(-,root,root)
167%doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
168%doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
169%{_datadir}/emacs/site-lisp/%{origname}/
170%{_libdir}/emacsen-common/packages/install/%{origname}
171%{_libdir}/emacsen-common/packages/remove/%{origname}
172%{_libexecdir}/egg-helper
173 
174
175%changelog
[3606]176* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.6-10.egganthy20070606
177- new release number for RPM package
178- update description
179
[1149]180* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 4.0.6-9
181- update to egg-anthy 20070606
182- update vine-default-tamago.el: connect to anthy with utf-8
183
[965]184* Sat May 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-8
185- update vine-default-tamago.el to support emacs >= 23.1.96
186
[521]187* Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
188- update patch40 (tamago-4.0.6--wnn8_rev2.patch)
189  - fix bugs on 64bit architecture.
190
191* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
192- applied tamago-4.0.6-emacs23.patch
193
194* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
195- updated tamago-install.sh
196  - *-init.el: changed from hard copy to symbolic link
197    on /etc/emacs-XX.YY/site-start.d
198
199* Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
200- no applied:
201  - egg-canna.el
202  - tamago-4.0.6-makefile.patch
203  - tamago-emcws.patch
204- added vine-default-tamago.el and tamago-init.el
205- updated tamago-install.sh for vine-default-tamago.el
206
207* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
208- change from noarch to per-arch for egg-helper.
209
210* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
211- applied new versioning policy
212- added %%define _libdir %%{_prefix}/lib
213
214* Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
215- add Patch40 to support wnn7 and wnn8 (taken from debian package)
216
217* Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
218- restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
219
220* Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
221- add Patch5
222  tamago-canna backend connect to cannaserver using UNIX domain
223  socket by default. (taken from debian package)
224- add Patch30 to change egg-helper path.
225
226* Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
227- modified its/hira.el to add some roma-kana conversion map.
228
229* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
230- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
231
232* Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
233- update to cvs head
234- add egg-anthy
235  http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
236- add documents to %%files
237- use License: instead of Copyright:
238
239* Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
240- update tamago-install.sh
241-   rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
242-   rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
243
244* Fri May  9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
245- update tamago-remove.sh: delete ${SITELISP}/egg
246
247* Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
248- rebuild
249
250* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
251- add patch10 to use with emcws
252
253* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
254- remove conflicts to emacs-dl-*
255- rename canna.el to canna-tamago.el (we use emcws for canna)
256
257* Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
258- modified patch3 for Canna-3.5b2-41
259
260* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
261- added patch4
262
263* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
264- update source3
265
266* Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
267- added patch3
268
269* Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
270- update patch2
271- added source3
272
273* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
274- tamago-el -> tamago again
275- spec file cleaned up
276
277* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
278- fixed install time no-compile bug( edit tamago-{install,remove}.sh )
279
280* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
281- support emacsen
282
283* Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
284- canna support patch upgrade.
285
286* Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
287- version 4.0.6
288- merge  canna support patch.
289
290* Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
291- version 4.0.5
292
Note: See TracBrowser for help on using the repository browser.