source: projects/specs/trunk/t/tamago/tamago-vl.spec @ 3723

Revision 3723, 8.2 KB checked in by shaolin, 13 years ago (diff)
  • tamago: add a patch for emacs24
RevLine 
[521]1%define _noVersionedDependencies        1
[3723]2%define prereq_ge()  %(LC_ALL="C" rpm -q --queryformat 'Requires(pre):%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
[521]3%define _libdir %{_prefix}/lib
4%define       origver       4.0.6
5%define       origname      tamago
[3606]6%define egg_anthy_version  20070606
[521]7
8Summary:      Tamago Version 4 -- EGG Input Method Architecture for Emacsen
9Summary(ja):  たまご第4版
10Name:         %{origname}
11Version:      %{origver}
[3723]12Release:      11.egganthy%{egg_anthy_version}%{?_dist_release}
[521]13
14Source0:      ftp://ftp.m17n.org/pub/%{origname}/%{origname}-%{origver}.tar.gz
15Source1:      %{origname}-install.sh
16Source2:      %{origname}-remove.sh
17Source3:      http://cgi18.plala.or.jp/nyy/canna/egg-canna.el
18Source4:      egg-anthy.tar.gz
19
20Source10:     vine-default-%{origname}.el
21Source11:     %{origname}-init.el
22
23Patch0:       tamago-4.0.6-cvshead.patch
24Patch3:       tamago-4.0.6-eggrc.patch
25Patch4:       tamago-4.0.6-makefile.patch
26Patch5:       tamago-4.0.6-canna-unix-domain-socket.patch
27
28Patch10:      tamago-emcws.patch
29Patch20:      tamago-4.0.6-vine-romakana.patch
30Patch30:      tamago-4.0.6-egg-helper-path.patch
31Patch40:      tamago-4.0.6-wnn8_rev2.patch
32
33### for emacs
34### from  http://www.m17n.org/mlarchive/mule-ja/200703/msg00018.html
35Patch50:      tamago-4.0.6-emacs23.patch
36
[3723]37Patch60:      tamago-4.0.6-make-local-hook-obsoleted.patch
38
[521]39License:      GPL
40Group:        Applications/Editors/Emacs
41BuildRoot:    %{_tmppath}/%{name}-%{version}-root
42
43Requires:     emacsen
44Requires:     emacsen-common
[3723]45BuildRequires:  apel
[521]46%prereq_ge    apel
47Obsoletes:    tamago-el
48
49Vendor:       Project Vine
50Distribution: Vine Linux
51
52%description
53EGG Emacs20(Emacs21) Input Method Architecture.
54Egg can use FreeWnn (jserver, cserver, tserver) and Wnn6 as server doing
55character string conversion with the back end.
56
[3606]57And this package includes egg-anthy. Egg can use Anthy.
[521]58
59%description -l ja
[3606]60GNU Emacs 20.5 以降で多言語入力環境を提供します。
61バックエンドサーバとしては、FreeWnn (jserver,
62cserver, tserver), Wnn6, SJ3 Ver.2,canna に対応。
[521]63
[3606]64また、本パッケージには egg-anthy も同梱しているため、Anthy にも対応。
[521]65
66
67%prep
68%setup -n %{origname}-%{origver} -a 4
69%patch0 -p1
70%patch3 -p1
71#% patch4 -p1
72%patch5 -p1
73# cp %{SOURCE3} .
74%__cp -a %{SOURCE10} %{SOURCE11} .
75
76#% patch10 -p1
77%patch20 -p1
78%patch30 -p1
79%patch40 -p1
80%patch50 -p1
[3723]81%patch60 -p1
[521]82
83# rename canna stuff
84#mv egg/canna.el egg/canna-tamago.el
85
86# copy egg-anthy stuff
87cp egg-anthy-%{egg_anthy_version}/*.el egg/
88
89%build
90
91%configure
92
93gcc %{optflags} -o helper/egg-helper helper/egg-helper.c
94
95
96%install
97
98[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
99[ "${RPM_BUILD_ROOT}" != "/" ] && mkdir -p ${RPM_BUILD_ROOT}
100
101mkdir -p $RPM_BUILD_ROOT/%{_datadir}/emacs/site-lisp/%{origname}
102mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/install
103mkdir -p $RPM_BUILD_ROOT/%{_libdir}/emacsen-common/packages/remove
104
105
106#
107# install el files
108#
109
110cp -r eggrc *.el egg its* Makefile \
111        $RPM_BUILD_ROOT/usr/share/emacs/site-lisp/%{origname}/
112
113#
114# install egg-helper
115#
116install -d $RPM_BUILD_ROOT%{_libexecdir}
117install -m 755 helper/egg-helper $RPM_BUILD_ROOT%{_libexecdir}
118
119
120#
121# install  script( bytecompile el and install elc , remove )   
122#
123
124%_installemacsenscript %{origname} %{SOURCE1}
125
126%_removeemacsenscript  %{origname} %{SOURCE2}
127
128
129#
130# install info file
131#
132
133mkdir -p ${RPM_BUILD_ROOT}/usr/info
134
135
136%post
137#
138# bytecompile and install
139#
140
141if [ "$1" = 2 ]; then
142
143%_emacsenPackageRemove %{origname}
144
145fi
146
147%_addemacsenlist %{origname}
148
149%_emacsenPackageInstall %{origname}
150
151
152%preun
153
154if [ "$1" = 0 ]; then
155
156%_emacsenPackageRemove %{origname}
157
158%_removeemacsenlist %{origname}
159
160fi
161
162
163
164%clean
165[ "${RPM_BUILD_ROOT}" != "/" ] && rm -rf ${RPM_BUILD_ROOT}
166
167
168%files
169%defattr(-,root,root)
170%doc README.ja.txt COPYING AUTHORS ChangeLog* PROBLEMS TODO
171%doc egg-anthy-%{egg_anthy_version}/egg-anthy.readme doc/
172%{_datadir}/emacs/site-lisp/%{origname}/
173%{_libdir}/emacsen-common/packages/install/%{origname}
174%{_libdir}/emacsen-common/packages/remove/%{origname}
175%{_libexecdir}/egg-helper
176 
177
178%changelog
[3723]179* Fri Apr 29 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-11.egganthy20070606
180- added Patch60, as 'make-local-hook' is obsoleted on emacs24
181
[3606]182* Sun Apr 17 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.6-10.egganthy20070606
183- new release number for RPM package
184- update description
185
[1149]186* Sun Jun  6 2010 IWAI, Masaharu <iwai@alib.jp> 4.0.6-9
187- update to egg-anthy 20070606
188- update vine-default-tamago.el: connect to anthy with utf-8
189
[965]190* Sat May 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-8
191- update vine-default-tamago.el to support emacs >= 23.1.96
192
[521]193* Mon Nov 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-7
194- update patch40 (tamago-4.0.6--wnn8_rev2.patch)
195  - fix bugs on 64bit architecture.
196
197* Sat May 09 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-6
198- applied tamago-4.0.6-emacs23.patch
199
200* Wed May 06 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-5
201- updated tamago-install.sh
202  - *-init.el: changed from hard copy to symbolic link
203    on /etc/emacs-XX.YY/site-start.d
204
205* Wed Apr 22 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 4.0.6-4
206- no applied:
207  - egg-canna.el
208  - tamago-4.0.6-makefile.patch
209  - tamago-emcws.patch
210- added vine-default-tamago.el and tamago-init.el
211- updated tamago-install.sh for vine-default-tamago.el
212
213* Sun Aug 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-3
214- change from noarch to per-arch for egg-helper.
215
216* Sat Aug 16 2008 Shu KONNO <owa@bg.wakwak.com> 4.0.6-2vl5
217- applied new versioning policy
218- added %%define _libdir %%{_prefix}/lib
219
220* Sat Apr 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl26
221- add Patch40 to support wnn7 and wnn8 (taken from debian package)
222
223* Fri Dec 29 2006 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl25
224- restration(cp %{SOURCE3} .)for compilation complete(and use it for emacs-21.4)
225
226* Sat Nov 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl24
227- add Patch5
228  tamago-canna backend connect to cannaserver using UNIX domain
229  socket by default. (taken from debian package)
230- add Patch30 to change egg-helper path.
231
232* Thu Sep 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl23
233- modified its/hira.el to add some roma-kana conversion map.
234
235* Tue Sep 12 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 4.0.6-1vl22
236- changed Group to Appliations/Editors/Emacs <BTS:VineLinux:163>
237
238* Sat Jun 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl21
239- update to cvs head
240- add egg-anthy
241  http://anthy.sourceforge.jp/cgi-bin/hiki/hiki.cgi?Emacs%A4%AB%A4%E9
242- add documents to %%files
243- use License: instead of Copyright:
244
245* Fri May 16 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 4.0.6-1vl20
246- update tamago-install.sh
247-   rm -f ${ELDIR}/*.elc, egg/*.elc, its/*.elc
248-   rm -f ${ELCDIR}/*.el, egg/*.el, its/*.el
249
250* Fri May  9 2003 IWAI Masaharu <iwai@alib.jp> 4.0.6-1vl19
251- update tamago-remove.sh: delete ${SITELISP}/egg
252
253* Wed Apr 30 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 4.0.6-1vl18
254- rebuild
255
256* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl17
257- add patch10 to use with emcws
258
259* Tue Dec 10 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.6-1vl16
260- remove conflicts to emacs-dl-*
261- rename canna.el to canna-tamago.el (we use emcws for canna)
262
263* Wed Sep 11 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl14
264- modified patch3 for Canna-3.5b2-41
265
266* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl13
267- added patch4
268
269* Tue Jul 09 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl12
270- update source3
271
272* Mon Jul 08 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl11
273- added patch3
274
275* Fri Jun 21 2002 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 4.0.6-1vl10
276- update patch2
277- added source3
278
279* Mon Dec 31 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 4.0.6-1vl9
280- tamago-el -> tamago again
281- spec file cleaned up
282
283* Mon Jul 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl8
284- fixed install time no-compile bug( edit tamago-{install,remove}.sh )
285
286* Wed Jul 18 2001 Kazuhisa TAKEI <takei@vinelinux.org> 4.0.6-1vl5
287- support emacsen
288
289* Sun Dec 17 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl3
290- canna support patch upgrade.
291
292* Sat Dec 16 2000 Kazuhisa TAKEI<takei@vinelinux.org> 4.0.6-1vl2
293- version 4.0.6
294- merge  canna support patch.
295
296* Fri Jan 14 2000 Kazuhisa TAKEI<ktakei@jaist.ac.jp>
297- version 4.0.5
298
Note: See TracBrowser for help on using the repository browser.