source: projects/specs/trunk/t/taglib-sharp/taglib-sharp-vl.spec @ 6270

Revision 6270, 4.6 KB checked in by Takemikaduchi, 12 years ago (diff)

NEW: banshee and C# binding packages

Line 
1%define debug_package %{nil}
2
3Name:    taglib-sharp
4Version: 2.0.3.7
5Release: 1%{?_dist_release}
6Summary: Provides tag reading and writing for Banshee and other Mono apps
7
8Group:   System Environment/Libraries
9License: LGPLv2+
10URL:     http://download.banshee-project.org/taglib-sharp/
11Source0: http://download.banshee-project.org/taglib-sharp/%{version}/%{name}-%{version}.tar.bz2
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
13
14# Mono only available on these:
15ExclusiveArch: %ix86 x86_64 ppc ppc64 ia64 %{arm} sparcv9 alpha s390x
16
17BuildRequires: mono-devel, monodoc, gnome-sharp2
18
19%description
20TagLib# is a FREE and Open Source library for the .NET 2.0 and Mono frameworks
21which will let you tag your software with as much or as little detail as you
22like without slowing you down. It supports a large variety of movie and music
23formats which abstract away the work, handling all the different cases, so all
24you have to do is access file.Tag.Title, file.Tag.Lyrics, or my personal
25favorite file.Tag.Pictures. But don't think all this abstraction is gonna keep
26you from tagging's greatest gems. You can still get to a specific tag type's
27features with just a few lines of code.
28
29%package devel
30Summary: Provides tag reading and writing for Banshee and other Mono apps
31Group: Development/Libraries
32Requires: %{name} = %{version}-%{release}
33Requires: pkgconfig
34
35%description devel
36Development files for taglib-sharp.
37
38%prep
39%setup -q
40
41%build
42# Docs are broken.
43%configure --disable-docs
44make %{?_smp_mflags}
45
46%install
47make DESTDIR=$RPM_BUILD_ROOT install
48
49mkdir -p %{buildroot}%{_libdir}/pkgconfig
50mv %{buildroot}%{_datadir}/pkgconfig/*.pc %{buildroot}%{_libdir}/pkgconfig/
51
52%files
53%defattr(-,root,root,-)
54%doc COPYING
55%{_prefix}/lib/mono/gac/*/
56%{_prefix}/lib/mono/taglib-sharp/
57
58%files devel
59%defattr(-,root,root,-)
60# %%doc %{_libdir}/monodoc/sources/taglib-sharp-docs*
61%{_libdir}/pkgconfig/taglib-sharp.pc
62
63%changelog
64* Sun Jun 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.3.7-1
65- initial build for VIne Linux
66
67
68* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3.7-5
69- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
70
71* Sat Oct 29 2011 Christian Krause <chkr@fedoraproject.org> - 2.0.3.7-4
72- Change paths for mono assemblies according to updated packaging
73  guidelines (http://fedoraproject.org/wiki/Packaging:Mono)
74
75* Mon Mar 21 2011 Dan Horák <dan[at]danny.cz> - 2.0.3.7-3
76- updated the supported arch list
77
78* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3.7-2
79- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
80
81* Wed Mar 24 2010 Christian Krause <chkr@fedoraproject.org> - 2.0.3.7-1
82- Update to 2.0.3.7
83
84* Sun Feb 28 2010 Christian Krause <chkr@fedoraproject.org> - 2.0.3.6-2
85- Fix compilation on x86_64
86
87* Sat Feb 27 2010 Christian Krause <chkr@fedoraproject.org> - 2.0.3.6-1
88- Update to 2.0.3.6
89
90* Thu Feb 18 2010 Karsten Hopp <karsten@redhat.com> 2.0.3.2-5.1
91- enable s390, s390x where we have mono now
92
93* Mon Oct 26 2009 Dennis Gilmore <dennis@ausil.us> - 2.0.3.2-5
94- switch sparc to sparcv9
95
96* Thu Aug 20 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 2.0.3.2-4
97- Build for ppc64
98
99* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3.2-3
100- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
101
102* Sun May 31 2009 Xavier Lamien <laxathom@fedoraproject.org> - 2.0.3.2-3
103- Build arches ppc.
104
105* Wed Feb 25 2009 David Nielsen <dnielsen@fedoraproject.org> - 2.0.3.2-2
106- fix pkgconfig file
107
108* Tue Feb 24 2009 David Nielsen <dnielsen@fedoraproject.org> - 2.0.3.2-1
109- Update to 2.0.3.2
110- The Banshee project has now taking over upstream responsibilities
111- Remove patches
112- Enable threaded build in accordance to Fedora guidelines
113
114* Mon Feb 16 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-8
115- disable doc generation
116
117* Mon Nov 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-7
118- apply mimetypes fix recommended by banshee upstream
119
120* Thu Jun 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-6
121- fix docs generation
122
123* Thu Jun 5 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-5
124- Rebuild against new mono bits
125
126* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-4
127- don't need to specify pkgconfig as a BR, it gets pulled in
128
129* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-3
130- BR: monodoc-devel
131
132* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-2
133- just fix noInjectMenuItem
134
135* Sat Apr 12 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 2.0.3.0-1
136- initial package
Note: See TracBrowser for help on using the repository browser.