source: projects/specs/trunk/s/systemtap/systemtap-vl.spec @ 7115

Revision 7115, 25.3 KB checked in by Takemikaduchi, 11 years ago (diff)

QEMU-1.2.0

Line 
1%{!?with_sqlite: %global with_sqlite 1}
2%{!?with_docs: %global with_docs 0}
3# crash is not available
4%ifarch ppc ppc64 %{sparc}
5%{!?with_crash: %global with_crash 0}
6%else
7%{!?with_crash: %global with_crash 1}
8%endif
9%{!?with_rpm: %global with_rpm 1}
10%{!?with_bundled_elfutils: %global with_bundled_elfutils 0}
11%{!?elfutils_version: %global elfutils_version 0.142}
12%{!?pie_supported: %global pie_supported 1}
13%{!?with_boost: %global with_boost 0}
14%{!?with_publican: %global with_publican 0}
15%{!?publican_brand: %global publican_brand fedora}
16
17Name: systemtap
18Version: 2.0
19Release: 1%{?_dist_release}
20# for version, see also configure.ac
21
22
23# Packaging abstract:
24#
25# systemtap              empty req:-client req:-devel
26# systemtap-server       /usr/bin/stap-server*, req:-devel
27# systemtap-devel        /usr/bin/stap, runtime, tapset, req:kernel-devel
28# systemtap-runtime      /usr/bin/staprun, /usr/bin/stapsh
29# systemtap-client       /usr/bin/stap, samples, docs, tapset(bonus), req:-runtime
30# systemtap-initscript   /etc/init.d/systemtap, req:systemtap
31# systemtap-sdt-devel    /usr/include/sys/sdt.h /usr/bin/dtrace
32# systemtap-testsuite    /usr/share/systemtap/testsuite*, req:systemtap, req:sdt-devel
33#
34# Typical scenarios:
35#
36# stap-client:           systemtap-client
37# stap-server:           systemtap-server
38# local user:            systemtap
39#
40# Unusual scenarios:
41#
42# intermediary stap-client for --remote:       systemtap-client (-runtime unused)
43# intermediary stap-server for --use-server:   systemtap-server (-devel unused)
44
45Summary: Programmable system-wide instrumentation system
46Group: Development/System
47License: GPLv2+
48URL: http://sourceware.org/systemtap/
49Source: ftp://sourceware.org/pub/%{name}/releases/%{name}-%{version}.tar.gz
50
51# Build*
52BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
53BuildRequires: gcc-c++
54BuildRequires: gettext-devel
55BuildRequires: nss-devel avahi-devel pkgconfig
56%if %{with_sqlite}
57BuildRequires: sqlite-devel
58%endif
59# Needed for libstd++ < 4.0, without <tr1/memory>
60%if %{with_boost}
61BuildRequires: boost-devel
62%endif
63%if %{with_crash}
64BuildRequires: crash-devel zlib-devel
65%endif
66%if %{with_rpm}
67BuildRequires: rpm-devel glibc-headers
68%endif
69%if %{with_bundled_elfutils}
70Source1: elfutils-%{elfutils_version}.tar.gz
71Patch1: elfutils-portability.patch
72BuildRequires: m4
73%global setup_elfutils -a1
74%else
75BuildRequires: elfutils-devel >= %{elfutils_version}
76%endif
77%if %{with_docs}
78BuildRequires: texlive-common
79BuildRequires: latex2html
80%if %{with_publican}
81BuildRequires: publican
82BuildRequires: /usr/share/publican/Common_Content/%{publican_brand}/defaults.cfg
83%endif
84%endif
85
86# Install requirements
87Requires: systemtap-client = %{version}-%{release}
88Requires: systemtap-devel = %{version}-%{release}
89
90%description
91SystemTap is an instrumentation system for systems running Linux.
92Developers can write instrumentation scripts to collect data on
93the operation of the system.  The base systemtap package contains/requires
94the components needed to locally develop and execute systemtap scripts.
95
96# ------------------------------------------------------------------------
97
98%package server
99Summary: Instrumentation System Server
100Group: Development/System
101License: GPLv2+
102URL: http://sourceware.org/systemtap/
103Requires: systemtap-devel = %{version}-%{release}
104# On RHEL[45], /bin/mktemp comes from the 'mktemp' package.  On newer
105# distributions, /bin/mktemp comes from the 'coreutils' package.  To
106# avoid a specific RHEL[45] Requires, we'll do a file-based require.
107Requires: nss /bin/mktemp
108Requires: zip unzip
109Requires(pre): shadow-utils
110Requires(post): chkconfig
111Requires(preun): chkconfig
112Requires(preun): initscripts
113Requires(postun): initscripts
114Requires(post): %{name}-runtime
115BuildRequires: nss-devel avahi-devel
116
117%description server
118This is the remote script compilation server component of systemtap.
119It announces itself to nearby clients with avahi (if available), and
120compiles systemtap scripts to kernel objects on their demand.
121
122
123%package devel
124Summary: Programmable system-wide instrumentation system - development headers, tools
125Group: Development/System
126License: GPLv2+
127URL: http://sourceware.org/systemtap/
128Requires: kernel >= 2.6.9-11
129# Alternate kernel packages kernel-PAE-devel et al. have a virtual
130# provide for kernel-devel, so this requirement does the right thing,
131# at least past RHEL4.
132Requires: kernel-devel
133Requires: gcc make
134# Suggest: kernel-debuginfo
135
136%description devel
137This package contains the components needed to compile a systemtap
138script from source form into executable (.ko) forms.  It may be
139installed on a self-contained developer workstation (along with the
140systemtap-client and systemtap-runtime packages), or on a dedicated
141remote server (alongside the systemtap-server package).  It includes
142a copy of the standard tapset library and the runtime library C files.
143
144
145%package runtime
146Summary: Programmable system-wide instrumentation system - runtime
147Group: Development/System
148License: GPLv2+
149URL: http://sourceware.org/systemtap/
150Requires: kernel >= 2.6.9-11
151Requires(pre): shadow-utils
152
153%description runtime
154SystemTap runtime contains the components needed to execute
155a systemtap script that was already compiled into a module
156using a local or remote systemtap-devel installation.
157
158
159%package client
160Summary: Programmable system-wide instrumentation system - client
161Group: Development/System
162License: GPLv2+
163URL: http://sourceware.org/systemtap/
164Requires: zip unzip
165Requires: systemtap-runtime = %{version}-%{release}
166Requires: coreutils grep sed unzip zip
167Requires: openssh-clients
168
169%description client
170This package contains/requires the components needed to develop
171systemtap scripts, and compile them using a local systemtap-devel
172or a remote systemtap-server installation, then run them using a
173local or remote systemtap-runtime.  It includes script samples and
174documentation, and a copy of the tapset library for reference.
175
176
177%package initscript
178Summary: Systemtap Initscripts
179Group: Development/System
180License: GPLv2+
181URL: http://sourceware.org/systemtap/
182Requires: systemtap = %{version}-%{release}
183Requires(post): chkconfig
184Requires(preun): chkconfig
185Requires(preun): initscripts
186Requires(postun): initscripts
187
188%description initscript
189Sysvinit scripts to launch selected systemtap scripts at system startup.
190
191
192%package sdt-devel
193Summary: Static probe support tools
194Group: Development/System
195License: GPLv2+ and Public Domain
196URL: http://sourceware.org/systemtap/
197
198%description sdt-devel
199This package includes the <sys/sdt.h> header file used for static
200instrumentation compiled into userspace programs and libraries, along
201with the optional dtrace-compatibility preprocessor to process related
202.d files into tracing-macro-laden .h headers.
203
204
205%package testsuite
206Summary: Instrumentation System Testsuite
207Group: Development/System
208License: GPLv2+
209URL: http://sourceware.org/systemtap/
210Requires: systemtap = %{version}-%{release}
211Requires: systemtap-sdt-devel = %{version}-%{release}
212Requires: systemtap-server = %{version}-%{release}
213Requires: dejagnu which prelink elfutils grep
214Requires: gcc gcc-c++ make glibc-devel
215# testsuite/systemtap.server/client.exp needs avahi
216Requires: avahi
217%if %{with_crash}
218# testsuite/systemtap.base/crash.exp needs crash
219Requires: crash
220%endif
221%ifarch x86_64
222Requires: compat32-glibc-devel
223%endif
224
225%description testsuite
226This package includes the dejagnu-based systemtap stress self-testing
227suite.  This may be used by system administrators to thoroughly check
228systemtap on the current system.
229
230
231# ------------------------------------------------------------------------
232
233%prep
234%setup -q %{?setup_elfutils}
235
236%if %{with_bundled_elfutils}
237cd elfutils-%{elfutils_version}
238%patch1 -p1
239sleep 1
240find . \( -name Makefile.in -o -name aclocal.m4 \) -print | xargs touch
241sleep 1
242find . \( -name configure -o -name config.h.in \) -print | xargs touch
243cd ..
244%endif
245
246
247%build
248
249%if %{with_bundled_elfutils}
250# Build our own copy of elfutils.
251%global elfutils_config --with-elfutils=elfutils-%{elfutils_version}
252
253# We have to prevent the standard dependency generation from identifying
254# our private elfutils libraries in our provides and requires.
255%global _use_internal_dependency_generator      0
256%global filter_eulibs() /bin/sh -c "%{1} | sed '/libelf/d;/libdw/d;/libebl/d'"
257%global __find_provides %{filter_eulibs /usr/lib/rpm/find-provides}
258%global __find_requires %{filter_eulibs /usr/lib/rpm/find-requires}
259
260# This will be needed for running stap when not installed, for the test suite.
261%global elfutils_mflags LD_LIBRARY_PATH=`pwd`/lib-elfutils
262%endif
263
264# Enable/disable the sqlite coverage testing support
265%if %{with_sqlite}
266%global sqlite_config --enable-sqlite
267%else
268%global sqlite_config --disable-sqlite
269%endif
270
271# Enable/disable the crash extension
272%if %{with_crash}
273%global crash_config --enable-crash
274%else
275%global crash_config --disable-crash
276%endif
277
278# Enable/disable the code to find and suggest needed rpms
279%if %{with_rpm}
280%global rpm_config --with-rpm
281%else
282%global rpm_config --without-rpm
283%endif
284
285%if %{with_docs}
286%global docs_config --enable-docs
287%else
288%global docs_config --disable-docs
289%endif
290
291# Enable pie as configure defaults to disabling it
292%if %{pie_supported}
293%global pie_config --enable-pie
294%else
295%global pie_config --disable-pie
296%endif
297
298%if %{with_publican}
299%global publican_config --enable-publican --with-publican-brand=%{publican_brand}
300%else
301%global publican_config --disable-publican
302%endif
303
304
305%configure %{?elfutils_config} %{sqlite_config} %{crash_config} %{docs_config} %{pie_config} %{publican_config} %{rpm_config} --disable-silent-rules
306make %{?_smp_mflags}
307
308%install
309rm -rf ${RPM_BUILD_ROOT}
310make DESTDIR=$RPM_BUILD_ROOT install
311%find_lang %{name}
312
313# We want the examples in the special doc dir, not the build install dir.
314# We build it in place and then move it away so it doesn't get installed
315# twice. rpm can specify itself where the (versioned) docs go with the
316# %doc directive.
317mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/examples examples
318
319# Fix paths in the example & testsuite scripts
320find examples testsuite -type f -name '*.stp' -print0 | xargs -0 sed -i -r -e '1s@^#!.+stap@#!%{_bindir}/stap@'
321
322# To make rpmlint happy, remove any .gitignore files in the testsuite.
323find testsuite -type f -name '.gitignore' -print0 | xargs -0 rm -f
324
325# Because "make install" may install staprun with whatever mode, the
326# post-processing programs rpmbuild runs won't be able to read it.
327# So, we change permissions so that they can read it.  We'll set the
328# permissions back to 04110 in the %files section below.
329chmod 755 $RPM_BUILD_ROOT%{_bindir}/staprun
330
331#install the useful stap-prep script
332install -c -m 755 stap-prep $RPM_BUILD_ROOT%{_bindir}/stap-prep
333
334# Copy over the testsuite
335cp -rp testsuite $RPM_BUILD_ROOT%{_datadir}/systemtap
336
337%if %{with_docs}
338# We want the manuals in the special doc dir, not the generic doc install dir.
339# We build it in place and then move it away so it doesn't get installed
340# twice. rpm can specify itself where the (versioned) docs go with the
341# %doc directive.
342mkdir docs.installed
343mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/*.pdf docs.installed/
344mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/tapsets docs.installed/
345%if %{with_publican}
346mv $RPM_BUILD_ROOT%{_datadir}/doc/systemtap/SystemTap_Beginners_Guide docs.installed/
347%endif
348%endif
349
350mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
351install -m 755 initscript/systemtap $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
352mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap
353mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/conf.d
354mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/script.d
355install -m 644 initscript/config.systemtap $RPM_BUILD_ROOT%{_sysconfdir}/systemtap/config
356mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/cache/systemtap
357mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/run/systemtap
358
359install -m 755 initscript/stap-server $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/
360mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server
361mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stap-server/conf.d
362mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig
363install -m 644 initscript/config.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/stap-server
364mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server
365touch $RPM_BUILD_ROOT%{_localstatedir}/log/stap-server/log
366mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
367install -m 644 initscript/logrotate.stap-server $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/stap-server
368
369%clean
370rm -rf ${RPM_BUILD_ROOT}
371
372%pre runtime
373getent group stapusr >/dev/null || groupadd -g 156 -r stapusr || groupadd -r stapusr
374getent group stapsys >/dev/null || groupadd -g 157 -r stapsys || groupadd -r stapsys
375getent group stapdev >/dev/null || groupadd -g 158 -r stapdev || groupadd -r stapdev
376exit 0
377
378%pre server
379getent group stap-server >/dev/null || groupadd -g 155 -r stap-server || groupadd -r stap-server
380getent passwd stap-server >/dev/null || \
381  useradd -c "Systemtap Compile Server" -u 155 -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server || \
382  useradd -c "Systemtap Compile Server" -g stap-server -d %{_localstatedir}/lib/stap-server -m -r -s /sbin/nologin stap-server
383test -e ~stap-server && chmod 755 ~stap-server
384
385if [ ! -f ~stap-server/.systemtap/rc ]; then
386  mkdir -p ~stap-server/.systemtap
387  chown stap-server:stap-server ~stap-server/.systemtap
388  echo "--rlimit-as=614400000 --rlimit-cpu=60 --rlimit-nproc=20 --rlimit-stack=1024000 --rlimit-fsize=51200000" > ~stap-server/.systemtap/rc
389  chown stap-server:stap-server ~stap-server/.systemtap/rc
390fi
391exit 0
392
393%post server
394test -e %{_localstatedir}/log/stap-server/log || {
395     touch %{_localstatedir}/log/stap-server/log
396     chmod 664 %{_localstatedir}/log/stap-server/log
397     chown stap-server:stap-server %{_localstatedir}/log/stap-server/log
398}
399
400# If it does not already exist, as stap-server, generate the certificate
401# used for signing and for ssl.
402if test ! -e ~stap-server/.systemtap/ssl/server/stap.cert; then
403   runuser -s /bin/sh - stap-server -c %{_libexecdir}/%{name}/stap-gen-cert >/dev/null
404   # Authorize the certificate as a trusted ssl peer and as a trusted signer
405   # on the local host.
406   %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/ssl/client >/dev/null
407   %{_libexecdir}/%{name}/stap-authorize-cert ~stap-server/.systemtap/ssl/server/stap.cert %{_sysconfdir}/systemtap/staprun >/dev/null
408fi
409
410# Activate the service
411/sbin/chkconfig --add stap-server
412exit 0
413
414%preun server
415# Check that this is the actual deinstallation of the package, as opposed to
416# just removing the old package on upgrade.
417if [ $1 = 0 ] ; then
418    /sbin/service stap-server stop >/dev/null 2>&1
419    /sbin/chkconfig --del stap-server
420fi
421exit 0
422
423%postun server
424# Check whether this is an upgrade of the package.
425# If so, restart the service if it's running
426if [ "$1" -ge "1" ] ; then
427    /sbin/service stap-server condrestart >/dev/null 2>&1 || :
428fi
429exit 0
430
431%post initscript
432/sbin/chkconfig --add systemtap
433exit 0
434
435%preun initscript
436# Check that this is the actual deinstallation of the package, as opposed to
437# just removing the old package on upgrade.
438if [ $1 = 0 ] ; then
439    /sbin/service systemtap stop >/dev/null 2>&1
440    /sbin/chkconfig --del systemtap
441fi
442exit 0
443
444%postun initscript
445# Check whether this is an upgrade of the package.
446# If so, restart the service if it's running
447if [ "$1" -ge "1" ] ; then
448    /sbin/service systemtap condrestart >/dev/null 2>&1 || :
449fi
450exit 0
451
452%post
453# Remove any previously-built uprobes.ko materials
454(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
455(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
456
457%preun
458# Ditto
459(make -C %{_datadir}/%{name}/runtime/uprobes clean) >/dev/null 2>&1 || true
460(/sbin/rmmod uprobes) >/dev/null 2>&1 || true
461
462# ------------------------------------------------------------------------
463
464%files -f %{name}.lang
465# The master "systemtap" rpm doesn't include any files.
466
467%files server -f %{name}.lang
468%defattr(-,root,root)
469%{_bindir}/stap-server
470%dir %{_libexecdir}/%{name}
471%{_libexecdir}/%{name}/stap-serverd
472%{_libexecdir}/%{name}/stap-start-server
473%{_libexecdir}/%{name}/stap-stop-server
474%{_libexecdir}/%{name}/stap-gen-cert
475%{_libexecdir}/%{name}/stap-sign-module
476%{_mandir}/man7/stappaths.7*
477%{_mandir}/man8/stap-server.8*
478%{_sysconfdir}/rc.d/init.d/stap-server
479%config(noreplace) %{_sysconfdir}/logrotate.d/stap-server
480%dir %{_sysconfdir}/stap-server
481%dir %{_sysconfdir}/stap-server/conf.d
482%config(noreplace) %{_sysconfdir}/sysconfig/stap-server
483%dir %attr(0755,stap-server,stap-server) %{_localstatedir}/log/stap-server
484%ghost %config(noreplace) %attr(0644,stap-server,stap-server) %{_localstatedir}/log/stap-server/log
485%ghost %attr(0755,stap-server,stap-server) %{_localstatedir}/run/stap-server
486%doc initscript/README.stap-server
487%doc README README.unprivileged AUTHORS NEWS COPYING
488
489
490%files devel -f %{name}.lang
491%{_bindir}/stap
492%{_bindir}/stap-prep
493%{_bindir}/stap-report
494%dir %{_datadir}/%{name}/runtime
495%{_datadir}/%{name}/runtime
496%dir %{_datadir}/%{name}/tapset
497%{_datadir}/%{name}/tapset
498%{_mandir}/man1/stap.1*
499%{_mandir}/man7/stappaths.7*
500%doc README README.unprivileged AUTHORS NEWS COPYING
501%if %{with_bundled_elfutils}
502%dir %{_libdir}/%{name}
503%{_libdir}/%{name}/lib*.so*
504%endif
505
506%files runtime -f %{name}.lang
507%defattr(-,root,root)
508%attr(4110,root,stapusr) %{_bindir}/staprun
509%{_bindir}/stapsh
510%{_bindir}/stap-merge
511%{_bindir}/stap-report
512%dir %{_libexecdir}/%{name}
513%{_libexecdir}/%{name}/stapio
514%{_libexecdir}/%{name}/stap-env
515%{_libexecdir}/%{name}/stap-authorize-cert
516%if %{with_crash}
517%dir %{_libdir}/%{name}
518%{_libdir}/%{name}/staplog.so*
519%endif
520%{_mandir}/man7/stappaths.7*
521%{_mandir}/man8/staprun.8*
522%doc README README.security AUTHORS NEWS COPYING
523
524
525%files client -f %{name}.lang
526%defattr(-,root,root)
527%doc README README.unprivileged AUTHORS NEWS COPYING examples
528%if %{with_docs}
529%doc docs.installed/*.pdf
530%doc docs.installed/tapsets/*.html
531%if %{with_publican}
532%doc docs.installed/SystemTap_Beginners_Guide
533%endif
534%endif
535%{_bindir}/stap
536%{_bindir}/stap-prep
537%{_bindir}/stap-report
538%{_mandir}/man1/stap.1*
539%{_mandir}/man1/stap-merge.1*
540%{_mandir}/man3/*
541%{_mandir}/man7/stappaths.7*
542%dir %{_datadir}/%{name}
543%{_datadir}/%{name}/tapset
544
545
546
547%files initscript
548%defattr(-,root,root)
549%{_sysconfdir}/rc.d/init.d/systemtap
550%dir %{_sysconfdir}/systemtap
551%dir %{_sysconfdir}/systemtap/conf.d
552%dir %{_sysconfdir}/systemtap/script.d
553%config(noreplace) %{_sysconfdir}/systemtap/config
554%dir %{_localstatedir}/cache/systemtap
555%ghost %{_localstatedir}/run/systemtap
556%doc initscript/README.systemtap
557
558
559%files sdt-devel -f %{name}.lang
560%defattr(-,root,root)
561%{_bindir}/dtrace
562%{_includedir}/sys/sdt.h
563%{_includedir}/sys/sdt-config.h
564%{_mandir}/man1/dtrace.1*
565%doc README AUTHORS NEWS COPYING
566
567
568%files testsuite
569%defattr(-,root,root)
570%dir %{_datadir}/%{name}
571%{_datadir}/%{name}/testsuite
572
573
574# ------------------------------------------------------------------------
575
576%changelog
577* Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0-1
578- initial build for Vine Linux
579
580
581
582* Wed Jul 18 2012 Josh Stone <jistone@redhat.com> - 1.8-5
583- bz840902 ppc build fix (related to bz837641)
584
585* Fri Jul 13 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.8-4
586- Fix ifarch statement
587- use file based requires for glibc-devel on x86_64 so that we work in koji
588
589* Wed Jul 11 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-3
590- PR14348 task_work_add race condition fix
591
592* Mon Jul 09 2012 Josh Stone <jistone@redhat.com>
593- bz837641 build fix
594
595* Sun Jun 17 2012 Frank Ch. Eigler <fche@redhat.com> - 1.8-1
596- Upstream release.
597
598* Mon Apr 30 2012 Peter Robinson <pbrobinson@fedoraproject.org> - 1.7-7
599- Enable crash support on ARM, cleanup spec
600
601* Thu Apr 19 2012 Karsten Hopp <karsten@redhat.com> - 1.7-6.1
602- rebuild on PPC(64) without crash, publican
603
604* Thu Mar 29 2012 Richard W.M. Jones <rjones@redhat.com> - 1.7-6
605- Rebuild for rpm soname bump.
606
607* Fri Mar 16 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-5
608- dbhole advises ARM publican/fop/java is a go for launch.
609
610* Thu Mar 01 2012 Mark Wielaard <mjw@redhat.com> - 1.7-4
611- ARM currently doesn't have publican/fop/java and no prelink.
612
613* Tue Feb 28 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
614- Rebuilt for c++ ABI breakage
615
616* Wed Feb 22 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-2
617- CVE-2012-0875 (kernel panic when processing malformed DWARF unwind data)
618
619* Wed Feb 01 2012 Frank Ch. Eigler <fche@redhat.com> - 1.7-1
620- Upstream release.
621
622* Fri Jan 13 2012 David Smith <dsmith@redhat.com> - 1.6-2
623- Fixed /bin/mktemp require.
624
625* Mon Jul 25 2011 Stan Cox <scox@redhat.com> - 1.6-1
626- Upstream release.
627
628* Tue May 23 2011 Stan Cox <scox@redhat.com> - 1.5-1
629- Upstream release.
630
631* Mon Jan 17 2011 Frank Ch. Eigler <fche@redhat.com> - 1.4-1
632- Upstream release.
633
634* Wed Jul 21 2010 Josh Stone <jistone@redhat.com> - 1.3-1
635- Upstream release.
636
637* Mon Mar 22 2010 Frank Ch. Eigler <fche@redhat.com> - 1.2-1
638- Upstream release.
639
640* Mon Dec 21 2009 David Smith <dsmith@redhat.com> - 1.1-1
641- Upstream release.
642
643* Tue Sep 22 2009 Josh Stone <jistone@redhat.com> - 1.0-1
644- Upstream release.
645
646* Tue Aug  4 2009 Josh Stone <jistone@redhat.com> - 0.9.9-1
647- Upstream release.
648
649* Thu Jun 11 2009 Josh Stone <jistone@redhat.com> - 0.9.8-1
650- Upstream release.
651
652* Thu Apr 23 2009 Josh Stone <jistone@redhat.com> - 0.9.7-1
653- Upstream release.
654
655* Fri Mar 27 2009 Josh Stone <jistone@redhat.com> - 0.9.5-1
656- Upstream release.
657
658* Wed Mar 18 2009 Will Cohen <wcohen@redhat.com> - 0.9-2
659- Add location of man pages.
660
661* Tue Feb 17 2009 Frank Ch. Eigler <fche@redhat.com> - 0.9-1
662- Upstream release.
663
664* Thu Nov 13 2008 Frank Ch. Eigler <fche@redhat.com> - 0.8-1
665- Upstream release.
666
667* Tue Jul 15 2008 Frank Ch. Eigler <fche@redhat.com> - 0.7-1
668- Upstream release.
669
670* Fri Feb  1 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-3
671- Add zlib-devel to buildreq; missing from crash-devel
672- Process testsuite .stp files for #!stap->#!/usr/bin/stap
673
674* Fri Jan 18 2008 Frank Ch. Eigler <fche@redhat.com> - 0.6.1-1
675- Add crash-devel buildreq to build staplog.so crash(8) module.
676- Many robustness & functionality improvements:
677
678* Wed Dec  5 2007 Will Cohen <wcohen@redhat.com> - 0.6-2
679- Correct Source to point to location contain code.
680
681* Thu Aug  9 2007 David Smith <dsmith@redhat.com> - 0.6-1
682- Bumped version, added libcap-devel BuildRequires.
683
684* Wed Jul 11 2007 Will Cohen <wcohen@redhat.com> - 0.5.14-2
685- Fix Requires and BuildRequires for sqlite.
686
687* Tue Jul  2 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.14-1
688- Many robustness improvements: 1117, 1134, 1305, 1307, 1570, 1806,
689  2033, 2116, 2224, 2339, 2341, 2406, 2426, 2438, 2583, 3037,
690  3261, 3282, 3331, 3428 3519, 3545, 3625, 3648, 3880, 3888, 3911,
691  3952, 3965, 4066, 4071, 4075, 4078, 4081, 4096, 4119, 4122, 4127,
692  4146, 4171, 4179, 4183, 4221, 4224, 4254, 4281, 4319, 4323, 4326,
693  4329, 4332, 4337, 4415, 4432, 4444, 4445, 4458, 4467, 4470, 4471,
694  4518, 4567, 4570, 4579, 4589, 4609, 4664
695
696* Mon Mar 26 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.13-1
697- An emergency / preliminary refresh, mainly for compatibility
698  with 2.6.21-pre kernels.
699
700* Mon Jan  1 2007 Frank Ch. Eigler <fche@redhat.com> - 0.5.12-1
701- Many changes, see NEWS file.
702
703* Tue Sep 26 2006 David Smith <dsmith@redhat.com> - 0.5.10-1
704- Added 'systemtap-runtime' subpackage.
705
706* Wed Jul 19 2006 Roland McGrath <roland@redhat.com> - 0.5.9-1
707- PRs 2669, 2913
708
709* Fri Jun 16 2006 Roland McGrath <roland@redhat.com> - 0.5.8-1
710- PRs 2627, 2520, 2228, 2645
711
712* Fri May  5 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.7-1
713- PRs 2511 2453 2307 1813 1944 2497 2538 2476 2568 1341 2058 2220 2437
714  1326 2014 2599 2427 2438 2465 1930 2149 2610 2293 2634 2506 2433
715
716* Tue Apr  4 2006 Roland McGrath <roland@redhat.com> - 0.5.5-1
717- Many changes, affected PRs include: 2068, 2293, 1989, 2334,
718  1304, 2390, 2425, 953.
719
720* Wed Feb  1 2006 Frank Ch. Eigler <fche@redhat.com> - 0.5.4-1
721- PRs 1916, 2205, 2142, 2060, 1379
722
723* Mon Jan 16 2006 Roland McGrath <roland@redhat.com> - 0.5.3-1
724- Many changes, affected PRs include: 2056, 1144, 1379, 2057,
725  2060, 1972, 2140, 2148
726
727* Mon Dec 19 2005 Roland McGrath <roland@redhat.com> - 0.5.2-1
728- Fixed build with gcc 4.1, various tapset changes.
729
730* Wed Dec  7 2005 Roland McGrath <roland@redhat.com> - 0.5.1-1
731- elfutils update, build changes
732
733* Fri Dec 02 2005  Frank Ch. Eigler  <fche@redhat.com> - 0.5-1
734- Many fixes and improvements: 1425, 1536, 1505, 1380, 1329, 1828, 1271,
735  1339, 1340, 1345, 1837, 1917, 1903, 1336, 1868, 1594, 1564, 1276, 1295
736
737* Mon Oct 31 2005 Roland McGrath <roland@redhat.com> - 0.4.2-1
738- Many fixes and improvements: PRs 1344, 1260, 1330, 1295, 1311, 1368,
739  1182, 1131, 1332, 1366, 1456, 1271, 1338, 1482, 1477, 1194.
740
741* Wed Sep 14 2005 Roland McGrath <roland@redhat.com> - 0.4.1-1
742- Many fixes and improvements since 0.2.2; relevant PRs include:
743  1122, 1134, 1155, 1172, 1174, 1175, 1180, 1186, 1187, 1191, 1193, 1195,
744  1197, 1205, 1206, 1209, 1213, 1244, 1257, 1258, 1260, 1265, 1268, 1270,
745  1289, 1292, 1306, 1335, 1257
746
747* Wed Sep  7 2005 Frank Ch. Eigler <fche@redhat.com>
748- Bump version.
749
750* Wed Aug 16 2005 Frank Ch. Eigler <fche@redhat.com>
751- Bump version.
752
753* Wed Aug  3 2005 Martin Hunt <hunt@redhat.com> - 0.2.2-1
754- Add directory /var/cache/systemtap
755- Add stp_check to /usr/libexec/systemtap
756
757* Wed Aug  3 2005 Roland McGrath <roland@redhat.com> - 0.2.1-1
758- New version 0.2.1, various fixes.
759
760* Fri Jul 29 2005 Roland McGrath <roland@redhat.com> - 0.2-1
761- New version 0.2, requires elfutils 0.111
762
763* Mon Jul 25 2005 Roland McGrath <roland@redhat.com>
764- Clean up spec file, build bundled elfutils.
765
766* Thu Jul 21 2005 Martin Hunt <hunt@redhat.com>
767- Set Version to use version from autoconf.
768- Fix up some of the path names.
769- Add Requires and BuildRequires.
770
771* Wed Jul 19 2005 Will Cohen <wcohen@redhat.com>
772- Initial creation of RPM.
Note: See TracBrowser for help on using the repository browser.