source: projects/specs/trunk/s/system-tools-backends/system-tools-backends-vl.spec @ 521

Revision 521, 3.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# Note that this is NOT a relocatable package
2%define ver             2.6.0
3%define rel             1%{?_dist_release}
4
5Summary:        System Tools Backends
6Summary(ja):    システムツールバックエンド
7Name:           system-tools-backends
8Version:        %ver
9Release:        %rel
10License:        LGPL
11Group:          Applications/System
12Source:         %{name}-%{version}.tar.bz2
13Source1:        system-tools-backends.init
14Patch0:         %{name}-2.6.0-vine.patch
15URL:            http://www.gnome.org/projects/gst/
16
17BuildRoot:      %{_tmppath}/%{name}-%{version}-root
18BuildRequires:  dbus-glib-devel
19BuildRequires:  perl-XML-Parser
20BuildRequires:  PolicyKit-devel >= 0.7
21Requires:       vine-release >= 3.0
22Requires:       perl, coreutils
23Conflicts:      gnome-system-tools < 1.2.0
24
25%description
26The System Tools Backends are a set of cross-platform scripts for Linux and
27other Unix systems. The backends provide an standard XML interface for
28modifying the configuration regarless of the distribution that's being used.
29
30%description -l ja
31システムツールバックエンドは Linux および Unix 用のクロスプラットフォーム
32スクリプトの集合です。このバックエンドスクリプトはディストリビューション
33の設定を尊重しつつ変更を行うための標準的な XML インタフェースを提供します。
34
35%prep
36%setup -q
37%patch0 -p1 -b .vine
38
39%build
40%configure
41CFLAGS="$RPM_OPT_FLAGS" make %{?_smp_mflags}
42
43%install
44%__make DESTDIR=$RPM_BUILD_ROOT install
45
46mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d
47install -m755 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/system-tools-backends
48
49%clean
50rm -rf %{buildroot}
51
52%preun
53if [ "$1" = "0" ] ; then
54    /sbin/service system-tools-backends stop > /dev/null 2>&1
55    /sbin/chkconfig --del system-tools-backends
56fi
57 
58%postun
59if [ "$1" -ge "1" ]; then
60    service system-tools-backends condrestart > /dev/null 2>&1
61fi
62   
63%post
64/sbin/chkconfig --add system-tools-backends
65
66
67%files
68%defattr(-,root,root)
69%doc README AUTHORS COPYING NEWS ChangeLog
70%{_sysconfdir}/rc.d/init.d/system-tools-backends
71%{_sysconfdir}/dbus-1/system.d/*
72%{_bindir}/*
73%{_datadir}/dbus-1/system-services/*
74%{_datadir}/PolicyKit/policy/*
75%dir %{_datadir}/system-tools-backends-2.0
76%{_datadir}/system-tools-backends-2.0/*
77%{_libdir}/pkgconfig/*
78
79
80%changelog
81* Thu Jul  3 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.6.0-1
82- updated to newest upstream release
83- new versioning policy; spec in UTF-8
84
85* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl2
86- add initscript for system-tools-backends
87
88* Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-0vl1
89- new upstream release
90
91* Sat Dec 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl5
92- move system-tools-backends.pc to %%{_datadir}/pkgconfig
93
94* Thu Oct 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-0vl4
95- update Patch0
96  - add some services
97
98* Sat Aug 26 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-0vl3
99- update Patch0
100  - fix Vine Linux 4.x support
101
102* Tue Jun 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-0vl2
103- update Patch0
104  - support Vine Linux 4.[01]
105  - support {disks,shares}-conf
106
107* Tue Mar 07 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.2-0vl1
108- new upstream release
109
110* Thu Sep 22 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-0vl1
111- new upstream release
112- support Vine Linux 3.2
113
114* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.0-0vl1
115- new upstream release
116
117* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
118- initial build for Vine Linux
Note: See TracBrowser for help on using the repository browser.