source: projects/specs/trunk/s/system-config-users/system-config-users-vl.spec @ 521

Revision 521, 21.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A graphical interface for administering users and groups
2Summary(ja): ユーザとグループを管理するためのグラフィカルインタフェース
3
4Name: system-config-users
5Version: 1.2.87
6Release: 1%{?_dist_release}
7URL: http://fedora.redhat.com/projects/config-tools/
8License: GPL
9ExclusiveOS: Linux
10Group: Applications/System
11
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13BuildArch: noarch
14Source: %{name}-%{version}.tar.bz2
15BuildRequires: desktop-file-utils
16BuildRequires: gettext
17BuildRequires: intltool
18BuildRequires: python
19Requires: libuser
20Requires: python
21Requires: pygtk2
22Requires: pygtk2-libglade
23Requires: usermode-gtk
24Requires: xdg-utils
25Requires: rpm-python
26Requires: /usr/bin/pgrep
27Requires: rhpl
28Requires: hicolor-icon-theme
29
30%description
31system-config-users is a graphical utility for administrating
32users and groups.  It depends on the libuser library.
33
34%prep
35%setup -q
36
37sed -i -e 's|/usr/bin/python2|/usr/bin/python|g' \
38    src/system-config-users src/*.py
39
40%build
41make
42
43%install
44make DESTDIR=$RPM_BUILD_ROOT install
45
46desktop-file-install --vendor system --delete-original       \
47  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
48  $RPM_BUILD_ROOT%{_datadir}/applications/%{name}.desktop
49
50%find_lang %name
51find $RPM_BUILD_ROOT%{_datadir} -name "*.mo" | xargs ./utf8ify-mo
52
53%clean
54rm -rf $RPM_BUILD_ROOT
55
56%post
57touch --no-create %{_datadir}/icons/hicolor
58if [ -x /usr/bin/gtk-update-icon-cache ]; then
59  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
60fi
61
62%postun
63touch --no-create %{_datadir}/icons/hicolor
64if [ -x /usr/bin/gtk-update-icon-cache ]; then
65  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
66fi
67
68%files -f %{name}.lang
69%defattr(-,root,root)
70%doc COPYING
71%doc doc/*
72/usr/bin/system-config-users
73%dir /usr/share/system-config-users
74/usr/share/system-config-users/*
75%{_mandir}/man8/system-config-users*
76%attr(0644,root,root) %{_datadir}/applications/%{name}.desktop
77%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-users.png
78%attr(0644,root,root) %config /etc/security/console.apps/system-config-users
79%attr(0644,root,root) %config /etc/pam.d/system-config-users
80%attr(0644,root,root) %config (noreplace) /etc/sysconfig/system-config-users
81
82%changelog
83* Sat Jun 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.87-1
84- new upstream release
85- add R: xdg-utils instead of htmlview
86
87* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.51-1
88- initial build for Vine Linux
89
90* Fri Feb 22 2008 Nils Philippsen <nphilipp@redhat.com> - 1.2.51-4
91- fix workaround for libuser < 0.56 (#427504)
92
93* Mon Dec 03 2007 Nils Philippsen <nphilipp@redhat.com> - 1.2.51-3
94- workaround bug with purely numerical user/group names in libuser < 0.56
95
96* Thu Nov 15 2007 Nils Philippsen <nphilipp@redhat.com> - 1.2.51-2
97- fix warnings about numerical user- and groupnames (#250213)
98
99* Thu Dec 21 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.51
100- pick up updated translations (#216396)
101
102* Wed Dec 13 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.50
103- pick up updated translations (#216396)
104
105* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.49
106- pick up updated translations (#216396)
107
108* Sat Oct 14 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.48
109- pick up updated translations
110
111* Sat Oct 14 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.47
112- pick up updated translations (#210731)
113
114* Mon Jul 24 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.46
115- ask user when hitting duplicate group name or gid (#199836)
116
117* Mon Jul 17 2006 Nils Philippsen <nphilipp@redhat.com>
118- clarify comments, add new variables in /etc/sysconfig/system-config-users
119- use new method to choose GID when creating groups as well
120- actually set new user's GID
121- remove debugging statements
122
123* Thu Jul 13 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.45
124- revamp uid/gid number selection to honor preferences and avoid primary
125  group/created group discrepancies (#198152)
126- use disttag if available
127
128* Mon Jun 12 2006 Nils Philippsen <nphilipp@redhat.com>
129- detect inconsistencies between /etc/group and /etc/gshadow at startup
130  (#174716)
131
132* Wed Jun 07 2006 Nils Philippsen <nphilipp@redhat.com>
133- change some label texts
134- fix indentation
135
136* Tue May 16 2006 Nils Philippsen <nphilipp@redhat.com>
137- fix localization markings (#191846, patch by Roozbeh Pournader)
138
139* Fri May 05 2006 Nils Philippsen <nphilipp@redhat.com>
140- pull out preferences handling into Preferences class
141- implement preferences dialog
142
143* Wed Apr 05 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.44
144- rephrase some error messages to ease translation (#154204)
145
146* Mon Mar 27 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.43
147- pick up translation updates
148
149* Fri Mar 03 2006 Nils Philippsen <nphilipp@redhat.com> - 1.2.42
150- require hicolor-icon-theme (#182882, #182883)
151
152* Fri Oct 14 2005 Nils Philippsen <nphilipp@redhat.com>
153- don't use pam_stack (#170649)
154
155* Tue Oct 04 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.41
156- fix variable names to prevent hangs when adding a group (#169730)
157
158* Fri Sep 30 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.40
159- initialize shadow variables only if shadow passwords are used
160  (#168524, #168529, patch by Josef Whiter)
161
162* Fri Sep 23 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.39
163- require rhpl (#168921)
164
165* Fri Jun 10 2005 Nils Philippsen <nphilipp@redhat.com>
166- allow punctation in user names (#141273)
167
168* Mon May 09 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.38
169- pick up updated translations
170
171* Fri May 06 2005 Nils Philippsen <nphilipp@redhat.com>
172- make desktop file rebuild consistently
173
174* Fri May 06 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.37
175- make About menu entry translate (#156793)
176
177* Fri May 06 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.36
178- use DESTDIR consistently
179
180* Wed May 04 2005 Nils Philippsen <nphilipp@redhat.com>
181- make desktop file translatable (#156793)
182
183* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.2.35-2
184- silence %%post
185
186* Thu Apr 07 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.35-1
187- correct setting shadow values if password doesn't expire
188
189* Mon Apr 04 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.34-1
190- don't crash when displaying non-shadow accounts (#152960)
191
192* Mon Apr 04 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.33-1
193- don't use GNOME stock stuff for About menu entry (#153227)
194
195* Fri Apr 01 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.32-1
196- don't require gnome (#152960)
197- revive about dialog
198
199* Fri Apr 01 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.31-1
200- fix deprecation warnings (#153054) with (modified) patch by Colin Charles
201
202* Wed Mar 30 2005 Nils Philippsen <nphilipp@redhat.com> - 1.2.30-1
203- use os.lstat() to test ownership of files to be deleted
204- update the GTK+ theme icon cache on (un)install
205
206* Fri Dec 03 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.29-1
207- use variable max length for user/group names (prepare fix for #141273)
208
209* Wed Nov 10 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.28-1
210- check for running processes of a user about to be deleted (#132902)
211
212* Mon Nov 08 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.27-1
213- some sanity testing to avoid deleting system directories when deleting a user
214  (#138093)
215- eventually delete mail spool (#102637) and temporary files (#126756)
216
217* Fri Nov 05 2004 Nils Philippsen <nphilipp@redhat.com>
218- set password and confirm password entries (in)sensitive based on whether
219  account is locked or not (#131180)
220
221* Tue Nov 02 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.26-1
222- use libuser defaults for password aging (#130379, original patch by Dave
223  Lehman)
224
225* Wed Oct 13 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.25-1
226- when renaming users, ensure that groups forget about the old user name
227  (#135280)
228
229* Mon Oct 11 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.24-1
230- use user/group names for indexing, avoid unnecessary user/group lookups
231  (#135223, original patch by Miloslav Trmac)
232- remove some debugging statements
233- updated translations
234
235* Fri Oct 08 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.23-1
236- try to fix 32bit uids/gids (#134803)
237- fix gtk.main*() related DeprecationWarnings
238- byte-compile python files in "make install"
239- updated translations
240
241* Mon Oct 04 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.22-1
242- updated translations
243
244* Sun Sep 26 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.21-1
245- updated translations
246
247* Fri Sep 24 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.20-1
248- allow UTF-8 in user's full name (#133137)
249- require new libuser version so that fix for #80624 doesn't throw exception
250  (#133479)
251- admit complicity
252
253* Wed Sep 15 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.19-1
254- try to use gid as specified in /etc/libuser.conf, only if that fails use next
255  free (#80624)
256
257* Mon Sep 13 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.18-1
258- use F1 instead of Ctrl+H as accelerator for Help/Contents (#132163)
259- use "mkdir -p" to fix make install glitch
260- use absolute paths in *.glade to fix pygtk/pyglade subtleties
261
262* Sun Sep 05 2004 Nils Philippsen <nphilipp@redhat.com> - 1.2.15-1
263- add manpage (Chris Spencer, #115316)
264- add Slovenian translation to desktop file (Roman Maurer, #131835)
265
266* Mon Jun 21 2004 Brent Fox <bfox@redhat.com> - 1.2.14-1
267- fix password expiration bug (bug #125234)
268
269* Wed Apr 21 2004 Brent Fox <bfox@redhat.com> 1.2.13-1
270- allow columns to be resized (bug #121174)
271
272* Tue Apr 20 2004 Brent Fox <bfox@redhat.com> 1.2.12-5
273- call self.ready() if no is clicked (bug #121364)
274
275* Mon Apr 19 2004 Brent Fox <bfox@redhat.com> 1.2.12-4
276- apply patch from bug #72058 to localize pw last changed time
277
278* Mon Apr 19 2004 Brent Fox <bfox@redhat.com> 1.2.12-3
279- hide SELinux widgets for now (bug #119941)
280
281* Mon Apr 19 2004 Brent Fox <bfox@redhat.com> 1.2.12-2
282- remove *pyc files on ininstall
283
284* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.2.12-1
285- fix bug #120669
286
287* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.2.11-6
288- remove print statements in mainWindow.py
289
290* Mon Apr 12 2004 Brent Fox <bfox@redhat.com> 1.2.11-5
291- fix icon path (bug #120186)
292
293* Wed Apr  7 2004 Brent Fox <bfox@redhat.com> 1.2.11-4
294- disable SELinux widgets if it isn't running or isn't enabled (bug #120193)
295
296* Tue Apr  6 2004 Brent Fox <bfox@redhat.com> 1.2.11-3
297- remove Requires on policy-sources and setools (bug #120193)
298
299* Mon Apr  5 2004 Brent Fox <bfox@redhat.com> 1.2.11-2
300- rebuild for SELinux
301- add Requires on policy-sources
302
303* Wed Mar 31 2004 Brent Fox <bfox@redhat.com> 1.2.11-1
304- first stab at SELinux bits
305
306* Wed Mar 24 2004 Brent Fox <bfox@redhat.com> 1.2.10-1
307- reset user home dir check button (bug #119068)
308
309* Tue Feb  3 2004 Brent Fox <bfox@redhat.com> 1.2.9-1
310- remove comparison to gtk.TRUE (bug #114266)
311
312* Mon Jan 12 2004 Brent Fox <bfox@redhat.com> 1.2.8-1
313- rename redhat-config-users.png to system-config-users.png (bug #113311)
314
315* Mon Dec  1 2003 Brent Fox <bfox@redhat.com> 1.2.7-1
316- preserve existing group selection in userProperties.py (bug #111199)
317- handle munged config file (bug #108400)
318
319* Mon Nov 24 2003 Brent Fox <bfox@redhat.com> 1.2.6-1
320- remove Red Hat reference in the window title
321
322* Wed Nov 19 2003 Brent Fox <bfox@redhat.com> 1.2.5-1
323- rename from redhat-config-users
324- add Obsoletes for redhat-config-users
325- make changes for Python2.3
326
327* Mon Oct 27 2003 Brent Fox <bfox@redhat.com> 1.2.4-1
328- call self.ready() if the user clicks cancel in the existing group dialog (bug #107991)
329
330* Mon Oct 20 2003 Brent Fox <bfox@redhat.com> 1.2.3-1
331- use htmlview to find default browser (bug #107604)
332
333* Mon Oct  6 2003 Brent Fox <bfox@redhat.com> 1.2.2-1
334- don't allow the root's username to be changed (bug #105632)
335
336* Tue Sep 23 2003 Brent Fox <bfox@redhat.com> 1.2.1-1
337- rebuild with latest docs
338
339* Tue Sep 16 2003 Brent Fox <bfox@redhat.com> 1.1.17-4
340- bump release
341
342* Tue Sep 16 2003 Brent Fox <bfox@redhat.com> 1.1.17-3
343- turn off SELinux
344
345* Tue Sep 16 2003 Brent Fox <bfox@redhat.com> 1.1.17-2
346- bump release
347
348* Tue Sep 16 2003 Brent Fox <bfox@redhat.com> 1.1.17-1
349- if shadow passwords are not enabled, do not show certain widgets (bug #104536)
350- don't modify password expiration data by accident (bug #88190)
351
352* Thu Sep 4 2003 Dan Walsh <dwalsh@redhat.com> 1.1.16-3
353- Turn off SELinux
354
355* Thu Sep 4 2003 Dan Walsh <dwalsh@redhat.com> 1.1.16-2.sel
356- add SELinux support
357
358* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.1.16-1
359- clarify error dialog message (bug #101607)
360- allow underscores and dashes in usernames and groupnames (bug #99115)
361
362* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.1.15-1
363- tag on every build
364
365* Wed Aug 13 2003 Brent Fox <bfox@redhat.com> 1.1.14-2
366- bump relnum and rebuild
367
368* Wed Aug 13 2003 Brent Fox <bfox@redhat.com> 1.1.14-1
369- use UTC instead of GMT (bug #102251)
370
371* Wed Aug 13 2003 Brent Fox <bfox@redhat.com> 1.1.13-1
372- add BuildRequires on gettext
373
374* Wed Jul 23 2003 Brent Fox <bfox@redhat.com> 1.1.12-2
375- bump relnum and rebuild
376
377* Wed Jul 23 2003 Brent Fox <bfox@redhat.com> 1.1.12-1
378- use GMT time on password last changed (bug #89759)
379
380* Wed Jul 23 2003 Brent Fox <bfox@redhat.com> 1.1.11-2
381- bump relnum and rebuild
382
383* Wed Jul 23 2003 Brent Fox <bfox@redhat.com> 1.1.11-1
384- don't create new user with an existing uid (bug #90911)
385- use the messageDialog module in groupWindow.py
386- don't create group with an existing gid (bug #90911)
387
388* Fri Jul 11 2003 Brent Fox <bfox@redhat.com> 1.1.10-2
389- bump relnum and rebuild
390
391* Fri Jul 11 2003 Brent Fox <bfox@redhat.com> 1.1.10-1
392- display an error if no X server is running (bug #97148)
393
394* Mon Jun  2 2003 Brent Fox <bfox@redhat.com> 1.1.9-1
395- popup a confirmation dialog when deleting groups
396- popup a confirmation dialog when deleting users
397
398* Tue May 27 2003 Brent Fox <bfox@redhat.com> 1.1.8-1
399- don't require a full user name (bug #91718)
400
401* Fri May 23 2003 Brent Fox <bfox@redhat.com> 1.1.7-1
402- don't allow colons in username or homedir names (bug #90481)
403- check for zero length in usernames, groupnames, gecos, and homedirs
404
405* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.1.6-1
406- change label in glade file (bug #86323)
407
408* Mon May 19 2003 Brent Fox <bfox@redhat.com> 1.1.5-9
409- create a 'users' group if a new user is getting added to a non-existing users group (bug #89895)
410
411* Thu Apr  3 2003 Brent Fox <bfox@redhat.com> 1.1.5-8
412- don't automatically delete system groups (bug #78620)
413
414* Wed Feb 26 2003 Jeremy Katz <katzj@redhat.com> 1.1.5-7
415- use rm for rmrf instead (#85175)
416
417* Mon Feb 17 2003 Brent Fox <bfox@redhat.com> 1.1.5-6
418- update desktop file (bug #84360)
419
420* Thu Feb 13 2003 Brent Fox <bfox@redhat.com> 1.1.5-5
421- make double-click launch properties box (#84231)
422
423* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 1.1.5-4
424- call self.rmrf
425
426* Mon Feb 10 2003 Brent Fox <bfox@redhat.com> 1.1.5-3
427- rebuild to pull in fix for bug #83341
428
429* Fri Feb  7 2003 Brent Fox <bfox@redhat.com> 1.1.5-2
430- fix bug #83341 for real this time
431
432* Wed Feb  5 2003 Brent Fox <bfox@redhat.com> 1.1.5-1
433- don't allow root account to be locked
434- make default values for SHADOW* on user creation so we can do password aging properly later
435
436* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 1.1.4-2
437- fix bug with deleting user homeDir (bug #83341)
438
439* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 1.1.4-1
440- bump and build
441
442* Fri Jan 24 2003 Brent Fox <bfox@redhat.com> 1.1.3-4
443- better error checking for user names and group names (bug #82607)
444* Thu Jan 16 2003 Brent Fox <bfox@redhat.com> 1.1.3-3
445- force ascii input (bug #74058)
446- make sure that groupWindow calls self.ready() after showing dialogs
447- remove sentence hacks in asciiCheck.py (bug #82015)
448- fix typo in about box (bug #82016)
449- do not create homedir if they user doesn't want to
450- only offer to delete homedirs if they actually exist  (bug #78619)
451- if the user is the only member of their group, delete the group automatically (bug #78620)
452* Wed Jan 15 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
453- don't try to delete the group if the groupEnt is None (bug #68950)
454* Tue Jan 14 2003 Tammy Fox <tfox@redhat.com> 1.1.2-2
455- update help with new screenshots and tweak content
456* Wed Jan  8 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
457- ask if they want to delete the home directory
458* Tue Jan  7 2003 Brent Fox <bfox@redhat.com> 1.1.1-9
459- handle window delete-events correctly
460- call ready() after dialog is destroyed (bug #80625)
461- if a deleted user is the only user in his primary group, offer to delete the group too (bug #78620)
462* Mon Dec 23 2002 Brent Fox <bfox@redhat.com> 1.1.1-6
463- replace some message dialogs with calls to show_message_dialog
464* Tue Dec 17 2002 Brent Fox <bfox@redhat.com> 1.1.1-5
465- Do a lot of input checking on the userWindow.py and userProperties.py (bug #79246)
466* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.1.1-4
467- Rebuild with latest translations
468* Thu Oct 10 2002 Brent Fox <bfox@redhat.com> 1.1.1-3
469- Make the upper limit on UIDs and GIDs  (pow(2, 32)).  Fixes bug 75605
470* Mon Sep 16 2002 Brent Fox <bfox@redhat.com>
471- groupWindow.py, groupProperties.py, userProperties.py...desensitize when performing actions
472* Fri Sep 13 2002 Brent Fox <bfox@redhat.com>
473- Make the window insensitive when adding a user to prevent double clicks
474* Tue Sep 10 2002 Brent Fox <bfox@redhat.com>
475- Applied patch for Norwegian translation to desktop file
476* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.1.1-2
477- Pull in latest translations
478* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.1.1-1
479- Pull in latest translations
480* Thu Aug 22 2002 Dan Walsh <dwalsh@redhat.com> 1.1-16
481- Fix traceback bug, caused by unitialized variable
482- Fix traceback bug, caused by primary gid missing from /etc/group
483* Tue Aug 20 2002 Brent Fox <bfox@redhat.com> 1.1-15
484- Convert desktop file to UTF8
485- Pull in new translations into desktop file
486* Mon Aug 19 2002 Brent Fox <bfox@redhat.com> 1.1-14
487- Apply patch from twaugh to fix bug 68778
488- Change widths on account expriation widgets
489* Thu Aug 15 2002 Brent Fox <bfox@redhat.com> 1.1-13
490- enlarge window startup size for verbose langs
491* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 1.1-12
492- rebuild to pull in latest translations
493* Mon Aug 12 2002 Tammy Fox <tfox@redhat.com> 1.1-11
494- replace System with SystemSetup in desktop file categories
495* Wed Aug 07 2002 Tammy Fox <tfox@redhat.com>
496- UI tweaks
497* Tue Aug 06 2002 Brent Fox <bfox@redhat.com> 1.1-10
498- Increase default window size
499* Tue Aug 06 2002 Brent Fox <bfox@redhat.com> 1.1-9
500- fix bug 70783
501* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 1.1-8
502- Use new pam timestamp rules
503* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 1.1-7
504- Use new icons from garrett
505* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 1.1-6
506- Fix glade path typo
507* Wed Jul 24 2002 Tammy Fox <tfox@redhat.com> 1.1-4
508- Fix desktop file (bug #69488)
509* Thu Jul 18 2002 Karsten Hopp <karsten@redhat.de> 1.1-3
510- prepare for new pygtk2
511* Sat Jul 13 2002 Brent Fox <bfox@redhat.com> 1.1-2
512- Fixed bug #68639
513- Make properties and delete widgets desensitized when necessary
514* Fri Jul 12 2002 Tammy Fox <tfox@redhat.com>
515- Updated docs
516- Moved desktop file to /usr/share/applications only
517* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 1.1-1
518- Add a "Search Filter" label
519* Fri Jun 14 2002 Brent Fox <bfox@redhat.com> 1.0.2-3
520- Typo bug on my part
521* Thu Jun 13 2002 Brent Fox <bfox@redhat.com> 1.0.2-1
522- Use spiffy new toolbar icons
523* Thu May 2 2002 Brent Fox <bfox@redhat.com> 1.0.1-7
524- Update translations
525* Mon Apr 22 2002 Brent Fox <bfox@redhat.com> 1.0.1-6
526- Bring in the latest translations and rebuild in the latest dist
527* Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-5
528- Convert .mo files to UTF-8 at install-time, fixing #63815 correctly (probably)
529* Thu Apr 18 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-4
530- Don't bail on LookupErrors when recoding strings, just punt (#63815)
531* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-3
532- Don't bail on IOErrors when saving preferences to /etc/sysconfig
533* Tue Apr 16 2002 Brent Fox <bfox@redhat.com> 1.0.1-2
534- Add set_transient_for calls to bring dialogs to the front in KDE (#61590)
535* Tue Apr 16 2002 Nalin Dahyabhai <nalin@redhat.com> 1.0.1-1
536- Handle cases where translations are encoded in non-UTF8 encodings (#63334)
537* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0-14
538- Update translations
539* Tue Apr 09 2002 Brent Fox <bfox@redhat.com>
540- Added workaround for bug 62919
541* Fri Apr 05 2002 Brent Fox <bfox@redhat.com>
542- Added changes to use a new icon
543* Thu Mar 28 2002 Brent Fox <bfox@redhat.com>
544- Finished port to Python2.2/Gtk2
545* Wed Feb 27 2002 Brent Fox <bfox@redhat.com>
546- Added sortable columns
547* Fri Jan 25 2002 Nalin Dahyabhai <nalin@redhat.com> 0.9.2-7
548- rebuild for completeness
549* Wed Aug 29 2001 Brent Fox <bfox@redhat.com>
550- Fixed desktop file problem
551- Nakai added Japanese support to the desktop file
552* Thu Aug 9 2001 Tammy Fox <tfox@redhat.com>
553- added documentation
554* Thu Aug 9 2001 Nalin Dahyabhai <nalin@redhat.com>
555- Attempt to minimize enumerations where possible
556- Always use defined constants for attribute names
557* Thu Aug 9 2001 Brent Fox <bfox@redhat.com>
558- fixes for password aging
559* Wed Aug  8 2001 Nalin Dahyabhai <nalin@redhat.com>
560- byte-compile python modules in %%install and include them in the package
561* Wed Jul 26 2001 Yukihiro Nakai <ynakai@redhat.com>
562- Add Japanese translation
563* Wed Jul 26 2001  Yukihiro Nakai <ynakai@redhat.com>
564- Directory restructure for i18n
565* Tue Jul 10 2001 Brent Fox <bfox@redhat.com>
566- some glade fixups and packaging work
567* Mon Jul 09 2001 Tammy Fox <tfox@redhat.com>
568- added usermode files to spec file
569* Tue Jul 05 2001 Brent Fox <bfox@redhat.com>
570- initial packaging
571* Wed Jun 13 2001 Brent Fox <bfox@redhat.com>
572- mainWindow.glade: Changed GUI per jrb's recommendations
573- mainWindow.py: added interfacing with libuser backend
574* Wed Jun 6 2001 Jonathan Blandford  <jrb@redhat.com>
575- mainWindow.glade: Cleaned up glade file a bunch.
576- mainWindow.py: modified to deal with updated glade.
577
578
Note: See TracBrowser for help on using the repository browser.