source: projects/specs/trunk/s/system-config-services/system-config-services-vl.spec @ 521

Revision 521, 16.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: An initscript and xinetd configuration utility
2Summary(ja): initscript と xinetd の設定ユーティリティ
3
4Name: system-config-services
5Version: 0.9.4
6Release: 1%{?_dist_release}
7URL: http://fedoraproject.org/wiki/SystemConfig/services
8Source0: %{name}-%{version}.tar.bz2
9Patch10: %{name}-0.9.4-desktop-file.patch
10License: GPL
11Group: Applications/System
12BuildArch: noarch
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
14AutoReq: no
15Requires: chkconfig
16Requires: python
17Requires: pygtk2, pygtk2-libglade, rhpl
18Requires: usermode
19Requires: htmlview
20Requires: python
21Requires(post): hicolor-icon-theme, gtk2
22Requires(postun): hicolor-icon-theme, gtk2
23BuildRequires: intltool, sed, desktop-file-utils
24BuildRequires: perl(XML::Parser)
25BuildRequires: gettext
26
27
28%description
29system-config-services is a utility which allows you to configure which services
30should be enabled on your machine.
31
32%description -l ja
33%{name} は initscript と xinetd でどのサービスを起動させるかを設定する
34ユーティリティです。
35
36%prep
37%setup -q
38%patch10 -p1 -b .desktop-file
39
40%build
41make
42
43%install
44rm -rf %{buildroot}
45make DESTDIR=%buildroot install
46
47desktop-file-install --vendor system --delete-original      \
48  --dir %{buildroot}%{_datadir}/applications                \
49  %{buildroot}%{_datadir}/applications/%{name}.desktop
50
51find %{buildroot}%{_sysconfdir} -type f -exec chmod a-x \{\} \;
52chmod a-x %{buildroot}%{_mandir}/*/*
53
54%find_lang %name
55
56%post
57touch --no-create %{_datadir}/icons/hicolor
58if [ -x /usr/bin/gtk-update-icon-cache ]; then
59  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
60fi
61
62%postun
63touch --no-create %{_datadir}/icons/hicolor
64if [ -x /usr/bin/gtk-update-icon-cache ]; then
65  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
66fi
67
68%clean
69rm -rf %{buildroot}
70
71%files -f %{name}.lang
72%defattr(-,root,root)
73%doc COPYING
74%doc docs/*
75%{_sbindir}/*
76%{_bindir}/*
77%{_datadir}/applications/system-config-services.desktop
78%{_datadir}/icons/hicolor/48x48/apps/system-config-services.png
79%{_datadir}/system-config-services
80%config %{_sysconfdir}/pam.d/system-config-services
81%config %{_sysconfdir}/security/console.apps/system-config-services
82%config %{_sysconfdir}/security/console.apps/serviceconf
83%config %{_sysconfdir}/pam.d/serviceconf
84%{_mandir}/*/system-config-services.8*
85
86%changelog
87* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.9.4-1
88- initial build for Vine Linux
89
90* Wed Dec  6 2006 Harald Hoyer <harald@redhat.com> - 0.9.4
91- fixed service start/stop (#218429)
92- translation update (#216558)
93- Resolves: rhbz#216558, rhbz#218429
94
95* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> - 0.9.3
96- pick up updated translations (#216558)
97
98* Fri Oct 20 2006 Nils Philippsen <nphilipp@redhat.com> - 0.9.2
99- use intltool-extract for i18n of glade files (#211248) and desktop file
100  (#207345)
101
102* Tue Sep 05 2006 Nils Philippsen <nphilipp@redhat.com> - 0.9.1
103- don't disable Start/Stop/Restart upon reverting changes (#202722)
104- add dist tag
105- install po files (again)
106- require gettext for building
107- fix tagging for make archive
108- fix circular make dependency
109- remove duplicate message definitions
110
111* Fri Aug 18 2006 Nils Philippsen <nphilipp@redhat.com>
112- make revert work again (#202467)
113- don't show all runlevels when starting
114
115* Mon Jun 05 2006 Jesse Keating <jkeating@redhat.com> - 0.9.0-2
116- Added BuildRequires perl-XML-Parser (#194179)
117- Added Requires(post) and (postun) gtk2
118
119* Fri May 19 2006 Nils Philippsen <nphilipp@redhat.com>
120- rip out autofoo
121- use bzip2'ed tarballs
122
123* Fri Mar 03 2006 Nils Philippsen <nphilipp@redhat.com> - 0.9.0
124- require hicolor-icon-theme (#182878, #182879)
125
126* Wed Feb 28 2006 Florian Festi <ffesti@redhat.com>
127- rewrote large parts of servicemethods (OO design, better handling of old/new
128  settings, read headers of init scripts completely)
129- first implementation of widgets to control services (intended for tools
130  configuring single services like nfs, samba, bind, ...), still missing: i18n,
131  dependencies on other services (like portmap)
132
133* Fri Jan 27 2006 Nils Philippsen <nphilipp@redhat.com> - 0.8.99.2
134- fix saving xinetd services
135
136* Fri Jan 27 2006 Nils Philippsen <nphilipp@redhat.com> - 0.8.99.1
137- implement daemons and xinetd services on separate tabs
138
139* Mon Jan 09 2006 Nils Philippsen <nphilipp@redhat.com>
140- separate daemons and xinetd based services
141- enable Serbian translation files
142
143* Fri Oct 14 2005 Nils Philippsen <nphilipp@redhat.com>
144- don't use pam_stack (#170645)
145
146* Tue Aug 16 2005 Nils Philippsen <nphilipp@redhat.com> - 0.8.26
147- revamp getting output from external commands (#162884)
148- package %%{_bindir}/serviceconf symlink (#165099)
149
150* Mon May 09 2005 Nils Philippsen <nphilipp@redhat.com> - 0.8.25
151- pick up updated translations
152
153* Fri May 06 2005 Nils Philippsen <nphilipp@redhat.com> - 0.8.24
154- make "make update-po" pick up translatable strings in desktop file (#156801)
155
156* Fri May 06 2005 Nils Philippsen <nphilipp@redhat.com> - 0.8.23
157- pick up new translations
158
159* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 0.8.22-2
160- silence %%post
161
162* Fri Apr 01 2005 Nils Philippsen <nphilipp@redhat.com> 0.8.22-1
163- fix deprecation warnings (#153052) with patch by Colin Charles
164- update the GTK+ theme icon cache on (un)install (Christopher Aillon)
165
166* Thu Mar 24 2005 Nils Philippsen <nphilipp@redhat.com> 0.8.21-1
167- connect toggled signals of service/runlevel checkboxes to enable saving again
168  (#151982)
169- consolidate on_optRL*_toggled
170- connect delete_event of mainWindow to ask whether things should be saved
171  before quitting
172- tab -> space indentation to avoid ambiguity
173- change some typos
174
175* Fri Mar 18 2005 Nils Philippsen <nphilipp@redhat.com> 0.8.20-1
176- don't read from /dev/null when restarting xinetd/services to prevent hangs
177- build toolbar in glade to avoid DeprecationWarnings (#134978)
178- dynamic, translated column titles for runlevel columns
179
180* Thu Feb 17 2005 Daniel J Walsh <dwalsh@redhat.com> 0.8.19-1
181- Added patch from Charlie Brej
182
183* Fri Jan 28 2005 Nils Philippsen <nphilipp@redhat.com> 0.8.18-1
184- fix off-by-one which prevented saving changes to the last service in the list
185  (#139456)
186
187* Tue Jan 04 2005 Nils Philippsen <nphilipp@redhat.com> 0.8.17-1
188- throw away stderr to not be confused by error messages (#142983)
189
190* Wed Dec 08 2004 Nils Philippsen <nphilipp@redhat.com> 0.8.16-1
191- don't hardcode python 2.3 (#142246)
192- remove some cruft from configure.in
193
194* Wed Oct 20 2004 Nils Philippsen <nphilipp@redhat.com> 0.8.15-1
195- include all languages (#136460)
196
197* Tue Oct 12 2004 Nils Philippsen <nphilipp@redhat.com> 0.8.14-1
198- actually install nonblockingreader module (#135445)
199
200* Mon Oct 11 2004 Nils Philippsen <nphilipp@redhat.com> 0.8.12-1
201- really update UI when reading from pipes (#120579, #135215)
202
203* Fri Oct 08 2004 Nils Philippsen <nphilipp@redhat.com> 0.8.11-1
204- fix gtk.main*() related DeprecationWarnings (#134978)
205
206* Fri Oct 01 2004 Daniel J Walsh <dwalsh@redhat.com> 0.8.10-1
207- Update translations
208
209* Mon Sep 27 2004 Nils Philippsen <nphilipp@redhat.com> - 0.8.9-1
210- enable Arabic translation (#133722)
211
212* Thu Sep 23 2004 Nils Philippsen <nphilipp@redhat.com> - 0.8.8.1-1
213- get in updated translations (#133137)
214- appease make distcheck
215- pick up updated autofoo scripts
216
217* Wed Jun 16 2004 Brent Fox <bfox@redhat.com> - 0.8.8-9
218- use watch cursor when starting and stopping services (bug #122425)
219
220* Mon Apr 12 2004 Brent Fox <bfox@redhat.com> 0.8.8-8
221- fix icon path (bug #120184)
222
223* Tue Apr  6 2004 Brent Fox <bfox@redhat.com> 0.8.8-7
224- remove extra strip (bug #119624)
225
226* Mon Apr  5 2004 Brent Fox <bfox@redhat.com> 0.8.8-6
227- code around new verbosity in libglade (bug #119622)
228
229* Wed Mar 31 2004 Brent Fox <bfox@redhat.com> 0.8.8-5
230- fix typo (bug #119559)
231
232* Wed Mar 24 2004 Brent Fox <bfox@redhat.com> 0.8.8-4
233- increase default size of the main window
234
235* Fri Mar 19 2004 Brent Fox <bfox@redhat.com> 0.8.8-3
236- make app exit properly on window close (bug #118762)
237
238* Wed Mar 17 2004 Brent Fox <bfox@redhat.com> 0.8.8-2
239- bump release
240
241* Tue Mar 16 2004 Brent Fox <bfox@redhat.com> 0.8.8-1
242- work around problem with libglade
243
244* Wed Mar  3 2004 Brent Fox <bfox@redhat.com> 0.8.7-2
245- add a BuildRequires on automake17
246
247* Tue Mar  2 2004 Brent Fox <bfox@redhat.com> 0.8.7-1
248- remove dependency on gnome-python2 and gnome-python2-canvas
249- try to load glade file in the cwd, if not, pull from /usr/share/
250- apply patch from bug #117277
251
252* Tue Jan 6 2004 Daniel J Walsh <dwalsh@redhat.com> 0.8.6-3
253- Fix console app so it launches properly
254
255* Tue Jan 6 2004 Daniel J Walsh <dwalsh@redhat.com> 0.8.6-2
256- remove requirement for 2.2
257
258* Thu Nov 11 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.6-1
259- Rename system-config-services
260
261* Wed Oct 17 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-23
262- Add all translated languages
263
264* Fri Oct 17 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-22
265- Remove /dev/null from status
266
267* Mon Oct 6 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-21
268- Fix crash on about
269
270* Wed Oct 1 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-20
271- bump
272
273* Wed Oct 1 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-19
274- Fix pathing problem on Hammer
275
276* Fri Sep 5 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-18
277- bump
278
279* Fri Sep 5 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-17
280- bump
281* Fri Sep 5 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-16
282- Eliminate debugging message
283
284* Mon Aug 25 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-15
285-  For some reason this did not make it to RHN Trying again. By Bumping version.
286
287* Tue Aug 5 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-14
288- Bumped version for rhl
289
290* Tue Aug 5 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-13
291- Remove depracated call
292
293* Wed Jul 30 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-12
294- Bumped version for rhl
295
296* Wed Jul 30 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-11
297- Changed handling of xinetd services to show xinetd service status
298
299* Wed Jul 30 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-10
300- Bumped version for rhl
301
302* Tue Jul 29 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-9
303- Allow services to have ':'s in them.
304
305* Wed Jul 9 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-8
306- Bumped version for rhl
307
308* Wed Jul 9 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-7
309- Add ability to add and delete services
310
311* Tue Jun 17 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-6
312- Bumped version for rhel
313
314* Thu Jun 5 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-5
315- Minor fixes to match GUI users guide and fix icon
316
317* Tue May  27 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-4
318- Bumped version for rhel
319
320* Tue May  27 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-3
321- Moved system-config-service.png to /usr/share/system-config-services
322
323* Fri Mar  7 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-2
324- Bumped version for rhel
325
326* Tue Mar  4 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.5-1
327- Fix swiching runlevels on modified screens.
328
329* Tue Feb  25 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.4-2
330- Fix dissapearing text on selecting toggle.
331
332* Tue Jan  28 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.4-1
333- Release Candidate
334- Fix Icon
335
336* Tue Jan  28 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-12
337- Fix Language Problems
338
339* Tue Jan  28 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-11
340- Fix handling of errors in /etc/init.d directory
341
342* Tue Jan  14 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-10
343- Update documentation
344
345* Thu Jan  9 2003 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-9
346- Added StartupNotify=true
347- Added accellerators
348
349* Thu Dec  12 2002 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-8
350- Update help docs
351
352* Fri Dec  6 2002 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-7
353- Fix error catching on invalid display
354
355* Tue Dec  3 2002 Daniel J Walsh <dwalsh@redhat.com> 0.8.3-6
356- Fix DISPLAY error handling
357- Stretch Screen size
358- Update status box after Start/Stop/Restart
359- Fix Icon error
360
361* Thu Nov 14 2002 Dan Walsh <dwalsh@redhat.com> 0.8.3-5
362- Fix reading of descriptions from startup scripts to ignore blank lines
363
364* Thu Nov 14 2002 Dan Walsh <dwalsh@redhat.com> 0.8.3-4
365- Add scrollbar to description and status
366
367* Thu Oct 24 2002 Dan Walsh <dwalsh@redhat.com> 0.8.3-3
368- Fix internal handling of version number.
369
370* Thu Oct 10 2002 Dan Walsh <dwalsh@redhat.com> 0.8.3-2
371- Remove buttons from screen to match GNOME standards
372
373* Tue Oct 1 2002 Dan Walsh <dwalsh@redhat.com> 0.8.3-1
374- Change GUI Presentation and add service status
375
376* Wed Sep 4 2002 Bill Nottingham <notting@redhat.com> 0.8.2-1
377- fix startup in some locales
378
379* Tue Sep 3 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-13
380- Update translations
381
382* Tue Aug 27 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-12
383- Update translations
384- Fix multi-processor problem with popen
385
386* Tue Aug 20 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-11
387- Use gnome url_show for help
388- fix legal notice
389
390* Mon Aug 19 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-10
391- Fix word wrap
392- Fix initial startup to select first row
393- Update languages
394
395* Sat Aug 10 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-9
396- eliminate extra python files not intended for release
397
398* Wed Aug 7 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-8
399- Update dependencies
400
401* Mon Aug 5 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-7
402- Updated internationalization stuff
403
404* Wed Jul 31 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-6
405- Updated internationalization stuff
406
407* Fri Jul 26 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-5
408- Updated to use intltool and new build environment.
409- Added with pam changes for timestamp
410- New internationalization stuff
411
412* Tue Jul 23 2002 Dan Walsh <dwalsh@redhat.com>
413- Fix the desktop file, using new naming standards.
414- Fix the error outpur
415
416* Mon Jul 22 2002 Dan Walsh <dwalsh@redhat.com>
417- Fix clock cursor, set app insensitive until services loaded"
418
419* Mon Jul 22 2002 Tammy Fox <tfox@redhat.com>
420- Updated docs
421
422* Wed Jul  17 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-1
423- Fix internationalization problems.  Clean up glade port.
424
425* Thu Jul  11 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-1
426- complete rename to system-config-services
427
428* Tue Jul  9 2002 Dan Walsh <dwalsh@redhat.com> 0.8.1-1
429- complete gtk2 port, Fix Help, About, fix minor bugs
430
431* Wed May 29 2002 Bill Nottingham <notting@redhat.com> 0.8.0-1
432- initial hack gtk2 port
433
434* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 0.7.0-3
435- Update translations
436
437* Wed Apr 10 2002 Bill Nottingham <notting@redhat.com> 0.7.0-2
438- fix docs (#63179)
439
440* Tue Apr  9 2002 Bill Nottingham <notting@redhat.com>
441- add some more cases to #60384 fix
442
443* Sun Apr  7 2002 Jeremy Katz <katzj@redhat.com>
444- don't show rpmsave, rpmnew, rpmorig, or .swp files (#60384)
445
446* Tue Apr  2 2002 Nalin Dahyabhai <nalin@redhat.com>
447- set up userhelper for system-config-services
448
449* Fri Jan 25 2002 Bill Nottingham <notting@redhat.com>
450- add patch to fix startup when there are services with 'hide' set
451
452* Fri Aug 24 2001 Tim Powers <timp@redhat.com>
453- fixed typo in Requires /;sbin/chkconfig
454
455* Fri Aug 24 2001 Bill Nottingham <notting@redhat.com>
456- build with new translations
457- move system-config-services link to /usr/bin
458
459* Fri Aug 17 2001 Bill Nottingham <notting@redhat.com>
460- translation typos (#51774, #51776)
461- add system-config-services link
462- if we're using find_lang, don't specify the .mo files explicitly
463
464* Mon Aug 13 2001 Tim Powers <timp@redhat.com>
465- updated serviceconf.gladestrings
466
467* Fri Aug 10 2001 Tim Powers <timp@redhat.com>
468- languified specfile for additional translations
469
470* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com> 0.6.1-1
471- Add an icon
472
473* Thu Aug  9 2001 Alexander Larsson <alexl@redhat.com>
474- Install in sysconfig.
475
476* Tue Aug  7 2001 Tim Powers <timp@redhat.com>
477- gnomified
478- work around parsing languified chkconfig output so that we can get accurate information displayed
479
480* Tue Jul 31 2001 Tim Powers <timp@redhat.com>
481- languified since we now serve multiple languages
482
483* Mon Jul 30 2001 Yukihiro Nakai <ynakai@redhat.com>
484- User %%fine_lang
485- Add Japanese translation.
486
487* Mon Jul 30 2001 Preston Brown <pbrown@redhat.com>
488- clean up title display
489- make sure initial highlighted entry also displays description info
490
491* Wed Jul 18 2001 Tammy Fox <tfox@redhat.com>
492- added help doc
493- moved man page into man directory
494- added Makefile for man page
495- added man page to spec file
496
497* Mon Jul  9 2001 Tim Powers <timp@redhat.com>
498- languify to shutup rpmlint
499
500* Thu Jul  5 2001 Tim Powers <timp@redhat.com>
501- removed TODO and README, added COPYING file to docs
502
503* Tue May 15 2001 Tim Powers <timp@redhat.com>
504- Initial build.
505
506
Note: See TracBrowser for help on using the repository browser.