source: projects/specs/trunk/s/system-config-securitylevel/system-config-securitylevel-vl.spec @ 521

Revision 521, 21.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A graphical interface for modifying the system security level
2Summary(ja): システムのセキュリティレベルを変更するグラフィカルインタフェース
3Name: system-config-securitylevel
4Version: 1.6.29.1
5Release: 3%{?_dist_release}
6URL: http://fedora.redhat.com/projects/config-tools/
7License: GPL
8ExclusiveOS: Linux
9Group: System Environment/Base
10Source0: %{name}-%{version}.tar.bz2
11Patch0: system-config-securitylevel-1.6.29.1-gu_IN.patch
12Patch1: system-config-securitylevel-1.6.29.1-insecure.patch
13Patch2: system-config-securitylevel-1.6.29.1-honour_exit_code.patch
14Patch3: system-config-securitylevel-1.6.29.1-dialog_center.patch
15Patch4: system-config-securitylevel-1.6.29.1-expand.patch
16Patch5: system-config-securitylevel-1.6.29.1-port_check.patch
17Patch6: system-config-securitylevel-1.6.29.1-nfs4.patch
18Patch10: %{name}-1.6.23-vine.patch
19Patch11: system-config-securitylevel-1.6.29.1-enable-start.patch
20Patch12: system-config-securitylevel-1.6.29.1-lokkit-noselinux.patch
21
22BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
23Obsoletes: gnome-lokkit
24BuildRequires: desktop-file-utils newt-devel slang-devel popt
25BuildRequires: gettext
26BuildRequires: intltool
27Obsoletes: redhat-config-securitylevel
28Requires: pygtk2
29Requires: python
30Requires: usermode
31Requires: rhpl
32Requires: system-config-securitylevel-tui
33Requires: hicolor-icon-theme
34Requires: pygtk2-libglade
35Requires: libxml2-python
36Prereq: gtk2 >= 2.6
37
38%description
39system-config-securitylevel is a graphical user interface for
40setting basic firewall rules.
41
42%package tui
43Summary: A text interface for modifying the system security level
44Summary(ja): システムのセキュリティレベルを変更するテキストインタフェース
45Group: System Environment/Base
46Obsoletes: lokkit
47Obsoletes: redhat-config-securitylevel-tui
48Requires: iptables
49#Requires: iptables-ipv6
50
51%description tui
52system-config-securitylevel-tui is a text and commandline user
53interface for setting basic firewall rules.
54
55%prep
56%setup -q
57%patch0 -p1 -b .gu_IN
58%patch1 -p1 -b .insecure
59%patch2 -p1 -b .honour_exit_code
60%patch3 -p1 -b .dialog_center
61%patch4 -p1 -b .expand
62%patch5 -p1 -b .port_check
63%patch6 -p1 -b .nfs4_udp
64%patch10 -p1 -b .vine
65%patch11 -p1 -b .start
66%patch12 -p1 -b .no_selinux
67
68perl -pi -e 's|/usr/bin/python2.2|/usr/bin/python|g, \
69             s|/usr/bin/python2|/usr/bin/python|g' src/system-config-securitylevel*
70
71%build
72make
73
74%install
75make INSTROOT=$RPM_BUILD_ROOT install
76
77desktop-file-install --vendor system --delete-original     \
78  --dir $RPM_BUILD_ROOT%{_datadir}/applications            \
79  --add-category System                                    \
80  --add-category Settings                                  \
81  --remove-category Applications                           \
82  --remove-category SystemSetup                            \
83  $RPM_BUILD_ROOT%{_datadir}/applications/system-config-securitylevel.desktop
84
85%find_lang %name
86
87%clean
88rm -rf $RPM_BUILD_ROOT
89
90%post
91touch --no-create %{_datadir}/icons/hicolor
92if [ -x /usr/bin/gtk-update-icon-cache ]; then
93  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
94fi
95
96%postun
97touch --no-create %{_datadir}/icons/hicolor
98if [ -x /usr/bin/gtk-update-icon-cache ]; then
99  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
100fi
101
102%files -f %{name}.lang
103%defattr(-,root,root)
104%doc COPYING
105/usr/bin/system-config-securitylevel
106%dir /usr/share/system-config-securitylevel
107/usr/share/system-config-securitylevel/*
108%dir /usr/share/firstboot/
109%dir /usr/share/firstboot/modules
110/usr/share/firstboot/modules/firstboot_selinux.py*
111/usr/share/firstboot/modules/securitylevel.py*
112%attr(0644,root,root) %{_datadir}/applications/system-config-securitylevel.desktop
113%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-securitylevel.png
114%attr(0644,root,root) %config /etc/security/console.apps/system-config-securitylevel
115%attr(0644,root,root) %config /etc/pam.d/system-config-securitylevel
116%attr(0644,root,root) %config /etc/sysconfig/system-config-securitylevel
117
118%files -f %{name}.lang tui
119%defattr(-,root,root)
120%doc COPYING-lokkit
121/usr/sbin/lokkit
122/usr/bin/system-config-securitylevel-tui
123
124%changelog
125* Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-3
126- rebuilt to sign package
127
128* Sun Aug 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.6.29.1-2
129- add Patch6: open udp port for nfs4 (rhbz#250916)
130- add Patch11: start iptables after enabled (<BTS:VineLinux:0712>)
131- add Patch12: don't show selinux items for tui
132
133* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-1
134- new upstream release
135- import patch[0-5] from upstream
136
137* Fri Aug 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.23-3
138- sorry my fault - rebuilt once more on all archs
139
140* Thu Aug 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.23-2
141- rebuilt again with new newt on ppc
142
143* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.23-1
144- rebuild with new newt
145- new versioning policy
146
147* Thu Aug 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.23-0vl1
148- initial build for Vine Linux
149- disable/hide SELinux tab
150
151* Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 1.6.23-1
152- Add NFSv4 as a trusted service (#138138).
153
154* Mon Jul 17 2006 Chris Lumens <clumens@redhat.com> 1.6.22-2
155- Don't remove .pyc files (#198950).
156- Pick up new translations.
157
158* Tue Jul 11 2006 Chris Lumens <clumens@redhat.com> 1.6.22-1
159- Tweak regular expression used to distinguish ranges from words.
160
161* Mon Jul 10 2006 Chris Lumens <clumens@redhat.com> 1.6.21-1
162- Correctly mark messages for translation (#195013).
163- Remove /etc/sysconfig/ip6tables when firewall is disabled (#195786).
164
165* Mon Jun 05 2006 Chris Lumens <clumens@redhat.com> 1.6.20-1
166- Be more careful when determining if something is a range or service with
167  a dash in it (#192933).
168
169* Thu May 11 2006 Chris Lumens <clumens@redhat.com> 1.6.19-2
170- Require iptables-ipv6.
171
172* Tue May 02 2006 Chris Lumens <clumens@redhat.com> 1.6.19-1
173- Add a patch to support writing out a default IPv6 firewall
174  (Brad Smith, #140305).
175
176* Tue May 02 2006 Chris Lumens <clumens@redhat.com> 1.6.18-2
177- Require glade (#190440).
178
179* Wed Apr 19 2006 Dan Walsh <dwalsh@redhat.com> 1.6.18-1
180- Update booleand/tunable descriptions
181
182* Fri Mar 31 2006 Chris Lumens <clumens@redhat.com> 1.6.17-1
183- Be smarter about if strings are valid ports (#183964).
184- Fix typo in firstboot (#186110).
185- Disable SELinux page if there's no policy installed (#186554).
186
187* Tue Feb 28 2006 Chris Lumens <clumens@redhat.com> 1.6.16-1
188- Add requirement for scriptlets (#182876, #182877).
189- Add glade UI strings to translations (#182181).
190- Reorder service checkboxes to make the screen fit for Italian (#182447).
191
192* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.6.15-1.1
193- bump again for double-long bug on ppc(64)
194
195* Tue Feb 07 2006 Chris Lumens <clumens@redhat.com> 1.6.15-1
196- Fix firstboot warnings.
197- Make other services box look better.
198- Force reboot if SELinux is changed from enabled to disabled in
199  firstboot (#177639).
200
201* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.6.14-1.1
202- rebuilt for new gcc4.1 snapshot and glibc changes
203
204* Fri Jan 27 2006 Chris Lumens <clumens@redhat.com> 1.6.14-1
205- Fix sorting on trusted services list.
206
207* Wed Jan 25 2006 Chris Lumens <clumens@redhat.com> 1.6.13-1
208- Sort trusted services by service name (#178467).
209- Use a combo box for the other services list instead of just a text entry
210  (#178108).
211
212* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
213- rebuilt
214
215* Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 1.6.12-1
216- Write out selinux config file (#174104).
217
218* Fri Dec 02 2005 Chris Lumens <clumens@redhat.com> 1.6.11-1
219- Support port ranges (#164187, #174281).
220- Restore longer description of https (#174249).
221
222* Tue Nov 29 2005 Dan Walsh <dwalsh@redhat.com> 1.6.10-1
223- Change getsebool to work with on as well as active
224
225* Wed Nov 23 2005 Chris Lumens <clumens@redhat.com> 1.6.9-2
226- Rebuild for new slang.
227
228* Fri Nov 08 2005 Chris Lumens <clumens@redhat.com> 1.6.9-1
229- Open the tcp IPP port as well (#90946).
230- SELinux policy directory grab fix (dwalsh).
231
232* Fri Nov 04 2005 Chris Lumens <clumens@redhat.com> 1.6.8-1
233- Always load the ip_conntrack_netbios_ns module in lokkit (#113918).
234
235* Mon Nov 01 2005 Chris Lumens <clumens@redhat.com> 1.6.7-1
236- Let lokkit load iptables modules (#113918, #145242).
237
238* Thu Oct 27 2005 Chris Lumens <clumens@redhat.com> 1.6.6-1
239- Add explanatory text to firewall and SELinux firstboot modules (#171022).
240- Fix a grammar error in lokkit help text (#152273).
241- Mark name in .desktop file for translation (#171819).
242- Remove support for modifying tunables since policy source will be
243  disappearing in the future (#160896).
244
245* Fri Oct 14 2005 Chris Lumens <clumens@redhat.com> 1.6.5-1
246- Remove the SELinux policy type combo box if there's only one policy
247  installed.
248- Use a new pam configuration (#170644).
249- Don't pop up relabel warning during firstboot if the user did something
250  like disabled->enabled->disabled before clicking next (#170549, #170550).
251
252* Tue Sep 27 2005 Petr Rockai <prockai@redhat.com> - 1.6.4-3
253- rebuild against newt 0.52.0
254
255* Tue Aug 23 2005 Chris Lumens <clumens@redhat.com> 1.6.4-1
256- Fix checking for the -f flag in lokkit (markmc, #166568).
257- Sync up order of enable/disable options between UI and what gets written
258  to the file (#166390).
259
260* Mon Aug 22 2005 Dan Walsh <dwalsh@redhat.com> 1.6.3-1
261- Move location of the setdirty flag in selinuxPage
262
263* Wed Aug 17 2005 Dan Walsh <dwalsh@redhat.com> 1.6.2-1
264- Fix setenforce call  (Currently turning off if enabled
265
266* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.6.1-2
267- Fix packaging.
268
269* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.6.1-1
270- Fix a typo in SELinux booleans (#164889).
271- Remove trusted devices section from firewall page.
272- Simplify choices on SELinux page (#164701).
273- Split firewall and SELinux into separate firstboot pages.
274- Require reboot after firstboot is done if SELinux options were changed.
275
276* Tue Jul 26 2005 Chris Lumens <clumens@redhat.com> 1.6.0-1
277- Convert UI to using glade instead of handwritten code.
278- Lots of updated translations.
279
280* Mon Jul 11 2005 Dan Walsh <dwalsh@redhat.com> 1.5.11-1
281- Add additional booleans
282
283* Sat Jun 18 2005 Dan Walsh <dwalsh@redhat.com> 1.5.10-1
284- Add additional booleans
285
286* Thu Jun 09 2005 Chris Lumens <clumens@redhat.com> 1.5.9-1
287- Handle ports that are not listed in /etc/services (#157620).
288- Add an option to allow Samba browsing - enables several ports, so use
289  with care (#133478).
290- Mark updated menu option and comment for translation (#156800).
291- Rebuilt .pot file.
292
293* Wed May 18 2005 Chris Lumens <clumens@redhat.com> 1.5.8-1
294- Revert .desktop file changes since they weren't properly marked for
295  translation.
296
297* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.5.7-2
298- silence %%post
299
300* Thu Apr 14 2005 Dan Walsh <dwalsh@redhat.com> 1.5.7-1
301- Handle relabeling better.
302
303* Tue Apr 12 2005 Dan Walsh <dwalsh@redhat.com> 1.5.6-1
304- Add additional booleans
305
306* Mon Apr 4 2005 Dan Walsh <dwalsh@redhat.com> 1.5.5-1
307- Add relabel button to selinux system-config-securitylevel
308- More booleans
309
310* Tue Mar 29 2005 Chris Lumens <clumens@redhat.com> 1.5.4-1
311- Add HTTPS as a separate option instead of implying it with HTTP.
312  (#145628).
313- Have the menu option and comment mention firewalling (#124266).
314- When reading in the config, use service names instead of port numbers in
315  the other ports field (#128541).
316- Rebuild .pot file for string changes.
317
318* Mon Mar 28 2005 Christopher Aillon <caillon@redhat.com> 1.5.3-3
319- rebuilt
320
321* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com> 1.5.3-2
322- Update the GTK+ theme icon cache on (un)install
323
324* Thu Mar 24 2005 Chris Lumens <clumens@redhat.com> 1.5.3-1
325- Rebuild .pot file.
326- Return translatable strings for SELinux page (Ronny Buchmann, #152059).
327- Fix GTK deprecation warnings.
328
329* Tue Mar 15 2005 Dan Walsh <dwalsh@redhat.com> 1.5.2-1
330- Update booleand/tunable descriptions
331
332* Fri Mar 04 2005 Chris Lumens <clumens@redhat.com> 1.5.0-2
333- Rebuilt for gcc4.
334- Fixed a msgid typo (#150193), rebuilt .pot file.
335
336* Thu Feb 10 2005 Chris Lumens <clumens@redhat.com> 1.5.0-1
337- Added a patch to easily configure connection sharing via trusted
338  interfaces (#83704).
339
340* Wed Jan 26 2005 Dan Walsh <dwalsh@redhat.com> 1.4.22-1
341- Update booleand/tunable descriptions
342
343* Mon Jan 03 2005 Chris Lumens <clumens@redhat.com> 1.4.21-1
344- Fixed import of scs_checklist module (#143776).
345
346* Thu Dec 23 2004 Chris Lumens <clumens@redhat.com> 1.4.20-1
347- Fixed a UI initialization bug on the selinux screen.
348
349* Tue Dec 21 2004 Chris Lumens <clumens@redhat.com> 1.4.19-1
350- Fixed namespace conflict with a firstboot module (#143260).
351
352* Sat Nov 13 2004 Dan Walsh <dwalsh@redhat.com> 1.4.18-1
353- Fix to match libselinux-1.19.1
354
355* Thu Nov 04 2004 Dan Walsh <dwalsh@redhat.com> 1.4.17-1
356- Call setsebool properly, change location of selinux stuff to /usr/sbin
357
358* Thu Nov 04 2004 Dan Walsh <dwalsh@redhat.com> 1.4.16-1
359- Fix boolean descriptions
360
361* Tue Oct 26 2004 Dan Walsh <dwalsh@redhat.com> 1.4.15-1
362- Fix many labels and add a couple of booleans
363
364* Mon Oct 25 2004 Dan Walsh <dwalsh@redhat.com> 1.4.14-1
365- Fix creation of /.autorelabel
366
367* Wed Oct 20 2004 Dan Walsh <dwalsh@redhat.com> 1.4.13-1
368- Add description for httpd_unified
369
370* Fri Oct 15 2004 Dan Walsh <dwalsh@redhat.com> 1.4.12-1
371- Fix lokkit to handle config file that is missing params
372
373* Thu Oct 14 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.11-1
374- GTK deprecation messages
375
376* Wed Oct 13 2004 Bill Nottingham <notting@redhat.com> 1.4.10-1
377- fix cups browsing line (#131745)
378
379* Tue Oct 12 2004 Dan Walsh <dwalsh@redhat.com> 1.4.9-1
380- Don't apply if selinux not installed
381
382* Fri Oct 08 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.8-1
383- Firstboot bug fix
384
385* Fri Oct 01 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.7-1
386- mDNS
387- Translations
388
389* Wed Sep 29 2004 Dan Walsh <dwalsh@redhat.com> 1.4.6-1
390- Fix handling of booleans
391
392* Thu Sep 23 2004 Dan Walsh <dwalsh@redhat.com> 1.4.5-1
393- Fix for missing /etc/selinux
394
395* Tue Sep 21 2004 Dan Walsh <dwalsh@redhat.com> 1.4.4-1
396- Fix for bad /etc/selinux/config
397
398* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.3-1
399- Translatable desktop
400
401* Thu Aug 12 2004 Dan Walsh <dwalsh@redhat.com> 1.4.2-2
402- Bug fix Boolean support
403
404* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.4.2-1
405- Add Boolean support
406
407* Tue Jul 27 2004 Dan Walsh <dwalsh@redhat.com> 1.4.1-4
408- Fix so only changes made if gui activated.
409- Save backup copies of configs
410
411* Tue Jul 27 2004 Dan Walsh <dwalsh@redhat.com> 1.4.1-3
412- Fix several problems including Tunables being reported incorrectly.
413- Allow tool to reload policy if tunables change
414- Allow tool to change enforcing mode
415
416* Fri Jul 16 2004 Dan Walsh <dwalsh@redhat.com> 1.3.14-2
417- Remove checkbox from toplevel menu of tunables
418
419* Thu Jul 15 2004 Dan Walsh <dwalsh@redhat.com> 1.3.14-1
420- Turn on SELinux support
421
422* Thu May 27 2004 Dan Walsh <dwalsh@redhat.com> 1.3.13-2
423- Change lokkit to support new SELinux mode
424
425* Fri May 21 2004 Bill Nottingham <notting@redhat.com> 1.3.13-1
426- fix typo (#122907)
427
428* Fri Apr 30 2004 Brent Fox <bfox@redhat.com> 1.3.12-1
429- turn off SELinux widgets for FC2 (bug #122046)
430
431* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.11-1
432- comment out SELinux tunable widgets for now
433
434* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.10-6
435- test if self.doc is None in read_tunable_file, not read_selinux_file
436
437* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.3.10-5
438- don't write out xml file if it doesn't exist
439
440* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.3.10-4
441- don't try to write tunable.xml if the file doesn't exist
442
443* Mon Apr 12 2004 Brent Fox <bfox@redhat.com> 1.3.10-3
444- fix icon path (bug #120183)
445
446* Mon Apr  5 2004 Brent Fox <bfox@redhat.com> 1.3.10-2
447- more work on SELinux code
448
449* Thu Apr  1 2004 Brent Fox <bfox@redhat.com> 1.3.10-1
450- add SELinux widgets and restructure UI accordingly
451
452* Thu Mar 25 2004 Brent Fox <bfox@redhat.com> 1.3.9-1
453- replace the other ports widgets (bug #111930)
454
455* Wed Mar 24 2004 Bill Nottingham <notting@redhat.com> 1.3.8-1
456- fix writing of config file if neither of --disabled or --enabled are
457  passed (#118667, redux)
458
459* Fri Mar 19 2004 Bill Nottingham <notting@redhat.com> 1.3.7-1
460- prefer commandline arguments to config file arguments (#118667)
461
462* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.3.6-1
463- fix segfault in config reading if config files don't exist
464- don't flush iptables chains if run with --nostart
465
466* Thu Mar 11 2004 Bill Nottingham <notting@redhat.com > 1.3.5-1
467- read in old config in the TUI (#25510)
468- have https tag along with http (#61958)
469- fix segfault (#88533)
470
471* Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 1.3.4-1
472- don't do strlen() on random pointer (bug #117183)
473
474* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 1.3.3-1
475- fix tab ordering bug (bug #116913)
476
477* Tue Feb  3 2004 Brent Fox <bfox@redhat.com> 1.3.2-1
478- F12 functionality fixed
479
480* Mon Jan 12 2004 Brent Fox <bfox@redhat.com> 1.3.1-1
481- break up really long strings (bug #102455)
482
483* Tue Nov 18 2003 Brent Fox <bfox@aspen.chinfox.net> 1.3.0-1
484- rename to system-config-securitylevel
485- obsoletes redhat-config-securitylevel
486- convert to Python2.3
487
488* Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 1.2.11-1
489- require iptables >=1.2.8 (bug #104777)
490
491* Fri Oct  3 2003 Bill Nottingham <notting@redhat.com> 1.2.10-1
492- minor code cleanup
493
494* Fri Oct  3 2003 Bill Nottingham <notting@redhat.com> 1.2.9-1
495- fix interactive disabling of firewall in TUI (#106243)
496
497* Wed Sep 17 2003 Bill Nottingham <notting@redhat.com> 1.2.8-2
498- rebuild
499
500* Wed Sep 17 2003 Bill Nottingham <notting@redhat.com> 1.2.8-1
501- allow ICMP in general (#104561)
502
503* Mon Sep 15 2003 Brent Fox <bfox@redhat.com> 1.2.7-2
504- bump release number
505
506* Mon Sep 15 2003 Brent Fox <bfox@redhat.com> 1.2.7-1
507- add Requires for rhpl
508
509* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.2.6-1
510- fix typo (bug #101802)
511
512* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.2.5-1
513- tag on every build
514
515* Tue Aug 12 2003 Brent Fox <bfox@redhat.com> 1.2.3-2
516- bump relnum and rebuild
517
518* Tue Aug 12 2003 Brent Fox <bfox@redhat.com> 1.2.3-1
519- some string changes
520
521* Mon Aug 11 2003 Brent Fox <bfox@redhat.com> 1.2.2-2
522- bump relnum and rebuild
523
524* Mon Aug 11 2003 Brent Fox <bfox@redhat.com> 1.2.2-1
525- reorder some UI elements
526
527* Thu Aug  7 2003 Bill Nottingham <notting@redhat.com> 1.2.1-1
528- fix rules (#101841)
529
530* Tue Aug  5 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
531- woops, RPM 101 (#101708)
532
533* Mon Aug  4 2003 Bill Nottingham <notting@redhat.com> 1.2.0-1
534- add patch for stateful firewalling (#87585, <dax@gurulabs.com>)
535- tweak tools appropriately (katzj@redhat.com), obsolete lokkit/gnome-lokkit
536
537* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.3-2
538- bump relnum and rebuild
539
540* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
541- use rhpl translation module
542
543* Tue May 27 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
544- bump rev and rebuild
545
546* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 1.1.1-3
547- fix return codes for firstboot reconfig mode
548- read config file in launch mode
549
550* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 1.1.1-1
551- bump and build
552
553* Mon Jan 27 2003 Brent Fox <bfox@redhat.com> 1.1.0-4
554- remove typo
555
556* Wed Jan 22 2003 Jeremy Katz <katzj@redhat.com> 1.1.0-3
557- match dhcp handling of anaconda and lokkit
558
559* Tue Dec 10 2002 Brent Fox <bfox@redhat.com> 1.1.0-2
560- fix bug 74913
561
562* Tue Dec 10 2002 Brent Fox <bfox@redhat.com> 1.1.0-1
563- save configuration in a config file in /etc/sysconfig/ so we remember settings
564
565* Mon Nov 18 2002 Brent Fox <bfox@redhat.com>
566- add a Requires for gnome-lokkit (bug #78057)
567
568* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
569- Latest translations
570
571* Thu Oct 10 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
572- Mark the word Mail for translation.  Fixes bug 75592
573
574* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-1
575- Convert to noarch
576
577* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.0-3
578- pull in latest German translations
579
580* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.0.0-2
581- Rebuild for translations
582
583* Mon Aug 26 2002 Brent Fox <bfox@redhat.com> 1.0.0-1
584- connect window to destroy signal
585
586* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-4
587- pull translations into desktop file
588
589* Mon Aug 12 2002 Tammy Fox <tfox@redhat.com> 0.9.9-3
590- replace System with SystemSetup in desktop file categories
591
592* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.9.9-2
593- fix bug 71187
594
595* Tue Aug 06 2002 Brent Fox <bfox@redhat.com>
596- Mark strings for translation
597
598* Mon Aug 05 2002 Brent Fox <bfox@redhat.com> 0.9.9-1
599- convert combo widget into an OptionMenu
600
601* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 0.9.8-1
602- Make changes for new pam timestamp policy
603
604* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-3
605- fix Makefiles and spec files so that translations get installed
606
607* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-2
608- update spec file for public beta 2
609
610* Wed Jul 24 2002 Tammy Fox <tfox@redhat.com> 0.9.4-3
611- Fix desktop file (bug #69484)
612
613* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.9.4-2
614- bump rev num and rebuild
615
616* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-2
617- Update changelogs and rebuild
618
619* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-1
620- Update changelogs and rebuild
621
622* Mon Jul 01 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
623- Bump rev number
624
625* Thu Jun 27 2002 Brent Fox <bfox@redhat.com> 0.9.1-2
626- Changed window title
627
628* Wed Jun 26 2002 Brent Fox <bfox@redhat.com> 0.9.1-1
629- Fixed description
630
631* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.9.0-5
632- Create pot file
633
634* Mon Jun 24 2002 Brent Fox <bfox@redhat.com> 0.9.0-4
635- Fix spec file
636
637* Fri Jun 21 2002 Brent Fox <bfox@redhat.com> 0.9.0-3
638- init doDebug
639- reverse ok/cancel buttons
640
641* Thu Jun 20 2002 Brent Fox <bfox@redhat.com> 0.9.0-2
642- Pass doDebug into launch, not init
643- Add snapsrc to Makefile
644
645* Sun May 26 2002 Brent Fox <bfox@redhat.com> 0.1.0-7
646- Add debug flag
647
648* Tue Nov 27 2001 Brent Fox <bfox@redhat.com>
649- initial coding and packaging
650
Note: See TracBrowser for help on using the repository browser.