source: projects/specs/trunk/s/system-config-securitylevel/system-config-securitylevel-vl.spec @ 7132

Revision 7132, 22.2 KB checked in by daisuke, 11 years ago (diff)

system-config-securitylevel: use conntrack instead of state match

Line 
1Summary: A graphical interface for modifying the system security level
2Summary(ja): システムのセキュリティレベルを変更するグラフィカルインタフェース
3Name: system-config-securitylevel
4Version: 1.6.29.1
5Release: 7%{?_dist_release}
6URL: http://fedora.redhat.com/projects/config-tools/
7License: GPL
8ExclusiveOS: Linux
9Group: System Environment/Base
10Source0: %{name}-%{version}.tar.bz2
11Patch0: system-config-securitylevel-1.6.29.1-gu_IN.patch
12Patch1: system-config-securitylevel-1.6.29.1-insecure.patch
13Patch2: system-config-securitylevel-1.6.29.1-honour_exit_code.patch
14Patch3: system-config-securitylevel-1.6.29.1-dialog_center.patch
15Patch4: system-config-securitylevel-1.6.29.1-expand.patch
16Patch5: system-config-securitylevel-1.6.29.1-port_check.patch
17Patch6: system-config-securitylevel-1.6.29.1-nfs4.patch
18Patch10: system-config-securitylevel-1.6.29.1-vine.patch
19Patch11: system-config-securitylevel-1.6.29.1-enable-start.patch
20Patch12: system-config-securitylevel-1.6.29.1-lokkit-noselinux.patch
21Patch13: system-config-securitylevel-1.6.29.1-use-conntrack.patch
22
23BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
24Obsoletes: gnome-lokkit
25BuildRequires: desktop-file-utils newt-devel slang-devel popt-devel
26BuildRequires: gettext
27BuildRequires: intltool
28Obsoletes: redhat-config-securitylevel
29Requires: pygtk2
30Requires: python
31Requires: usermode
32Requires: rhpl
33Requires: system-config-securitylevel-tui
34Requires: hicolor-icon-theme
35Requires: pygtk2-libglade
36Requires: libxml2-python
37Requires(post): gtk2 >= 2.6
38Requires(postun): gtk2 >= 2.6
39
40%description
41system-config-securitylevel is a graphical user interface for
42setting basic firewall rules.
43
44%package tui
45Summary: A text interface for modifying the system security level
46Summary(ja): システムのセキュリティレベルを変更するテキストインタフェース
47Group: System Environment/Base
48Obsoletes: lokkit
49Obsoletes: redhat-config-securitylevel-tui
50Requires: iptables
51#Requires: iptables-ipv6
52
53%description tui
54system-config-securitylevel-tui is a text and commandline user
55interface for setting basic firewall rules.
56
57%prep
58%setup -q
59%patch0 -p1 -b .gu_IN
60%patch1 -p1 -b .insecure
61%patch2 -p1 -b .honour_exit_code
62%patch3 -p1 -b .dialog_center
63%patch4 -p1 -b .expand
64%patch5 -p1 -b .port_check
65%patch6 -p1 -b .nfs4_udp
66%patch10 -p1 -b .vine
67%patch11 -p1 -b .start
68%patch12 -p1 -b .no_selinux
69%patch13 -p1 -b .use-conntrack
70
71perl -pi -e 's|/usr/bin/python2.2|/usr/bin/python|g, \
72             s|/usr/bin/python2|/usr/bin/python|g' src/system-config-securitylevel*
73
74%build
75make
76
77%install
78make INSTROOT=$RPM_BUILD_ROOT install
79
80desktop-file-install --vendor system --delete-original     \
81  --dir $RPM_BUILD_ROOT%{_datadir}/applications            \
82  --add-category System                                    \
83  --add-category Settings                                  \
84  --remove-category Applications                           \
85  --remove-category SystemSetup                            \
86  $RPM_BUILD_ROOT%{_datadir}/applications/system-config-securitylevel.desktop
87
88%find_lang %name
89
90%clean
91rm -rf $RPM_BUILD_ROOT
92
93%post
94touch --no-create %{_datadir}/icons/hicolor
95if [ -x /usr/bin/gtk-update-icon-cache ]; then
96  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
97fi
98
99%postun
100touch --no-create %{_datadir}/icons/hicolor
101if [ -x /usr/bin/gtk-update-icon-cache ]; then
102  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
103fi
104
105%files -f %{name}.lang
106%defattr(-,root,root)
107%doc COPYING
108%{_bindir}/system-config-securitylevel
109%dir %{_datadir}/system-config-securitylevel
110%{_datadir}/system-config-securitylevel/*
111%dir %{_datadir}/firstboot/
112%dir %{_datadir}/firstboot/modules
113%{_datadir}/firstboot/modules/firstboot_selinux.py*
114%{_datadir}/firstboot/modules/securitylevel.py*
115%attr(0644,root,root) %{_datadir}/applications/system-config-securitylevel.desktop
116%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-securitylevel.png
117%attr(0644,root,root) %config %{_sysconfdir}/security/console.apps/system-config-securitylevel
118%attr(0644,root,root) %config %{_sysconfdir}/pam.d/system-config-securitylevel
119%attr(0644,root,root) %config %{_sysconfdir}/sysconfig/system-config-securitylevel
120
121%files -f %{name}.lang tui
122%defattr(-,root,root)
123%doc COPYING-lokkit
124%{_sbindir}/lokkit
125%{_bindir}/system-config-securitylevel-tui
126
127%changelog
128* Mon Nov 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-7
129- use conntrack instead of state match
130
131* Sun Feb 19 2012 Yoji TOYODA <bsymaato@sea.plala.or.jp> 1.6.29.1-6
132- rebuild with python-2.7.2
133
134* Thu Apr 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-5
135- merge with tomop-san's change
136  - modified BR: from popt to popt-devel.
137  - replaced "Prereq:" with "Requires(post): and Requires:(postun):".
138- use macros in %%files
139
140* Sat Apr 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-4
141- rebuild for Vine 6
142
143* Sun Aug 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-3
144- rebuilt to sign package
145
146* Sun Aug 23 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 1.6.29.1-2
147- add Patch6: open udp port for nfs4 (rhbz#250916)
148- add Patch11: start iptables after enabled (<BTS:VineLinux:0712>)
149- add Patch12: don't show selinux items for tui
150
151* Tue Sep 30 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.29.1-1
152- new upstream release
153- import patch[0-5] from upstream
154
155* Fri Aug 29 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.23-3
156- sorry my fault - rebuilt once more on all archs
157
158* Thu Aug 28 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.6.23-2
159- rebuilt again with new newt on ppc
160
161* Sun Aug 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.23-1
162- rebuild with new newt
163- new versioning policy
164
165* Thu Aug 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.23-0vl1
166- initial build for Vine Linux
167- disable/hide SELinux tab
168
169* Thu Jul 20 2006 Chris Lumens <clumens@redhat.com> 1.6.23-1
170- Add NFSv4 as a trusted service (#138138).
171
172* Mon Jul 17 2006 Chris Lumens <clumens@redhat.com> 1.6.22-2
173- Don't remove .pyc files (#198950).
174- Pick up new translations.
175
176* Tue Jul 11 2006 Chris Lumens <clumens@redhat.com> 1.6.22-1
177- Tweak regular expression used to distinguish ranges from words.
178
179* Mon Jul 10 2006 Chris Lumens <clumens@redhat.com> 1.6.21-1
180- Correctly mark messages for translation (#195013).
181- Remove /etc/sysconfig/ip6tables when firewall is disabled (#195786).
182
183* Mon Jun 05 2006 Chris Lumens <clumens@redhat.com> 1.6.20-1
184- Be more careful when determining if something is a range or service with
185  a dash in it (#192933).
186
187* Thu May 11 2006 Chris Lumens <clumens@redhat.com> 1.6.19-2
188- Require iptables-ipv6.
189
190* Tue May 02 2006 Chris Lumens <clumens@redhat.com> 1.6.19-1
191- Add a patch to support writing out a default IPv6 firewall
192  (Brad Smith, #140305).
193
194* Tue May 02 2006 Chris Lumens <clumens@redhat.com> 1.6.18-2
195- Require glade (#190440).
196
197* Wed Apr 19 2006 Dan Walsh <dwalsh@redhat.com> 1.6.18-1
198- Update booleand/tunable descriptions
199
200* Fri Mar 31 2006 Chris Lumens <clumens@redhat.com> 1.6.17-1
201- Be smarter about if strings are valid ports (#183964).
202- Fix typo in firstboot (#186110).
203- Disable SELinux page if there's no policy installed (#186554).
204
205* Tue Feb 28 2006 Chris Lumens <clumens@redhat.com> 1.6.16-1
206- Add requirement for scriptlets (#182876, #182877).
207- Add glade UI strings to translations (#182181).
208- Reorder service checkboxes to make the screen fit for Italian (#182447).
209
210* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.6.15-1.1
211- bump again for double-long bug on ppc(64)
212
213* Tue Feb 07 2006 Chris Lumens <clumens@redhat.com> 1.6.15-1
214- Fix firstboot warnings.
215- Make other services box look better.
216- Force reboot if SELinux is changed from enabled to disabled in
217  firstboot (#177639).
218
219* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.6.14-1.1
220- rebuilt for new gcc4.1 snapshot and glibc changes
221
222* Fri Jan 27 2006 Chris Lumens <clumens@redhat.com> 1.6.14-1
223- Fix sorting on trusted services list.
224
225* Wed Jan 25 2006 Chris Lumens <clumens@redhat.com> 1.6.13-1
226- Sort trusted services by service name (#178467).
227- Use a combo box for the other services list instead of just a text entry
228  (#178108).
229
230* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
231- rebuilt
232
233* Thu Dec 08 2005 Chris Lumens <clumens@redhat.com> 1.6.12-1
234- Write out selinux config file (#174104).
235
236* Fri Dec 02 2005 Chris Lumens <clumens@redhat.com> 1.6.11-1
237- Support port ranges (#164187, #174281).
238- Restore longer description of https (#174249).
239
240* Tue Nov 29 2005 Dan Walsh <dwalsh@redhat.com> 1.6.10-1
241- Change getsebool to work with on as well as active
242
243* Wed Nov 23 2005 Chris Lumens <clumens@redhat.com> 1.6.9-2
244- Rebuild for new slang.
245
246* Fri Nov 08 2005 Chris Lumens <clumens@redhat.com> 1.6.9-1
247- Open the tcp IPP port as well (#90946).
248- SELinux policy directory grab fix (dwalsh).
249
250* Fri Nov 04 2005 Chris Lumens <clumens@redhat.com> 1.6.8-1
251- Always load the ip_conntrack_netbios_ns module in lokkit (#113918).
252
253* Mon Nov 01 2005 Chris Lumens <clumens@redhat.com> 1.6.7-1
254- Let lokkit load iptables modules (#113918, #145242).
255
256* Thu Oct 27 2005 Chris Lumens <clumens@redhat.com> 1.6.6-1
257- Add explanatory text to firewall and SELinux firstboot modules (#171022).
258- Fix a grammar error in lokkit help text (#152273).
259- Mark name in .desktop file for translation (#171819).
260- Remove support for modifying tunables since policy source will be
261  disappearing in the future (#160896).
262
263* Fri Oct 14 2005 Chris Lumens <clumens@redhat.com> 1.6.5-1
264- Remove the SELinux policy type combo box if there's only one policy
265  installed.
266- Use a new pam configuration (#170644).
267- Don't pop up relabel warning during firstboot if the user did something
268  like disabled->enabled->disabled before clicking next (#170549, #170550).
269
270* Tue Sep 27 2005 Petr Rockai <prockai@redhat.com> - 1.6.4-3
271- rebuild against newt 0.52.0
272
273* Tue Aug 23 2005 Chris Lumens <clumens@redhat.com> 1.6.4-1
274- Fix checking for the -f flag in lokkit (markmc, #166568).
275- Sync up order of enable/disable options between UI and what gets written
276  to the file (#166390).
277
278* Mon Aug 22 2005 Dan Walsh <dwalsh@redhat.com> 1.6.3-1
279- Move location of the setdirty flag in selinuxPage
280
281* Wed Aug 17 2005 Dan Walsh <dwalsh@redhat.com> 1.6.2-1
282- Fix setenforce call  (Currently turning off if enabled
283
284* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.6.1-2
285- Fix packaging.
286
287* Tue Aug 02 2005 Chris Lumens <clumens@redhat.com> 1.6.1-1
288- Fix a typo in SELinux booleans (#164889).
289- Remove trusted devices section from firewall page.
290- Simplify choices on SELinux page (#164701).
291- Split firewall and SELinux into separate firstboot pages.
292- Require reboot after firstboot is done if SELinux options were changed.
293
294* Tue Jul 26 2005 Chris Lumens <clumens@redhat.com> 1.6.0-1
295- Convert UI to using glade instead of handwritten code.
296- Lots of updated translations.
297
298* Mon Jul 11 2005 Dan Walsh <dwalsh@redhat.com> 1.5.11-1
299- Add additional booleans
300
301* Sat Jun 18 2005 Dan Walsh <dwalsh@redhat.com> 1.5.10-1
302- Add additional booleans
303
304* Thu Jun 09 2005 Chris Lumens <clumens@redhat.com> 1.5.9-1
305- Handle ports that are not listed in /etc/services (#157620).
306- Add an option to allow Samba browsing - enables several ports, so use
307  with care (#133478).
308- Mark updated menu option and comment for translation (#156800).
309- Rebuilt .pot file.
310
311* Wed May 18 2005 Chris Lumens <clumens@redhat.com> 1.5.8-1
312- Revert .desktop file changes since they weren't properly marked for
313  translation.
314
315* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.5.7-2
316- silence %%post
317
318* Thu Apr 14 2005 Dan Walsh <dwalsh@redhat.com> 1.5.7-1
319- Handle relabeling better.
320
321* Tue Apr 12 2005 Dan Walsh <dwalsh@redhat.com> 1.5.6-1
322- Add additional booleans
323
324* Mon Apr 4 2005 Dan Walsh <dwalsh@redhat.com> 1.5.5-1
325- Add relabel button to selinux system-config-securitylevel
326- More booleans
327
328* Tue Mar 29 2005 Chris Lumens <clumens@redhat.com> 1.5.4-1
329- Add HTTPS as a separate option instead of implying it with HTTP.
330  (#145628).
331- Have the menu option and comment mention firewalling (#124266).
332- When reading in the config, use service names instead of port numbers in
333  the other ports field (#128541).
334- Rebuild .pot file for string changes.
335
336* Mon Mar 28 2005 Christopher Aillon <caillon@redhat.com> 1.5.3-3
337- rebuilt
338
339* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com> 1.5.3-2
340- Update the GTK+ theme icon cache on (un)install
341
342* Thu Mar 24 2005 Chris Lumens <clumens@redhat.com> 1.5.3-1
343- Rebuild .pot file.
344- Return translatable strings for SELinux page (Ronny Buchmann, #152059).
345- Fix GTK deprecation warnings.
346
347* Tue Mar 15 2005 Dan Walsh <dwalsh@redhat.com> 1.5.2-1
348- Update booleand/tunable descriptions
349
350* Fri Mar 04 2005 Chris Lumens <clumens@redhat.com> 1.5.0-2
351- Rebuilt for gcc4.
352- Fixed a msgid typo (#150193), rebuilt .pot file.
353
354* Thu Feb 10 2005 Chris Lumens <clumens@redhat.com> 1.5.0-1
355- Added a patch to easily configure connection sharing via trusted
356  interfaces (#83704).
357
358* Wed Jan 26 2005 Dan Walsh <dwalsh@redhat.com> 1.4.22-1
359- Update booleand/tunable descriptions
360
361* Mon Jan 03 2005 Chris Lumens <clumens@redhat.com> 1.4.21-1
362- Fixed import of scs_checklist module (#143776).
363
364* Thu Dec 23 2004 Chris Lumens <clumens@redhat.com> 1.4.20-1
365- Fixed a UI initialization bug on the selinux screen.
366
367* Tue Dec 21 2004 Chris Lumens <clumens@redhat.com> 1.4.19-1
368- Fixed namespace conflict with a firstboot module (#143260).
369
370* Sat Nov 13 2004 Dan Walsh <dwalsh@redhat.com> 1.4.18-1
371- Fix to match libselinux-1.19.1
372
373* Thu Nov 04 2004 Dan Walsh <dwalsh@redhat.com> 1.4.17-1
374- Call setsebool properly, change location of selinux stuff to /usr/sbin
375
376* Thu Nov 04 2004 Dan Walsh <dwalsh@redhat.com> 1.4.16-1
377- Fix boolean descriptions
378
379* Tue Oct 26 2004 Dan Walsh <dwalsh@redhat.com> 1.4.15-1
380- Fix many labels and add a couple of booleans
381
382* Mon Oct 25 2004 Dan Walsh <dwalsh@redhat.com> 1.4.14-1
383- Fix creation of /.autorelabel
384
385* Wed Oct 20 2004 Dan Walsh <dwalsh@redhat.com> 1.4.13-1
386- Add description for httpd_unified
387
388* Fri Oct 15 2004 Dan Walsh <dwalsh@redhat.com> 1.4.12-1
389- Fix lokkit to handle config file that is missing params
390
391* Thu Oct 14 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.11-1
392- GTK deprecation messages
393
394* Wed Oct 13 2004 Bill Nottingham <notting@redhat.com> 1.4.10-1
395- fix cups browsing line (#131745)
396
397* Tue Oct 12 2004 Dan Walsh <dwalsh@redhat.com> 1.4.9-1
398- Don't apply if selinux not installed
399
400* Fri Oct 08 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.8-1
401- Firstboot bug fix
402
403* Fri Oct 01 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.7-1
404- mDNS
405- Translations
406
407* Wed Sep 29 2004 Dan Walsh <dwalsh@redhat.com> 1.4.6-1
408- Fix handling of booleans
409
410* Thu Sep 23 2004 Dan Walsh <dwalsh@redhat.com> 1.4.5-1
411- Fix for missing /etc/selinux
412
413* Tue Sep 21 2004 Dan Walsh <dwalsh@redhat.com> 1.4.4-1
414- Fix for bad /etc/selinux/config
415
416* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> 1.4.3-1
417- Translatable desktop
418
419* Thu Aug 12 2004 Dan Walsh <dwalsh@redhat.com> 1.4.2-2
420- Bug fix Boolean support
421
422* Fri Jul 30 2004 Dan Walsh <dwalsh@redhat.com> 1.4.2-1
423- Add Boolean support
424
425* Tue Jul 27 2004 Dan Walsh <dwalsh@redhat.com> 1.4.1-4
426- Fix so only changes made if gui activated.
427- Save backup copies of configs
428
429* Tue Jul 27 2004 Dan Walsh <dwalsh@redhat.com> 1.4.1-3
430- Fix several problems including Tunables being reported incorrectly.
431- Allow tool to reload policy if tunables change
432- Allow tool to change enforcing mode
433
434* Fri Jul 16 2004 Dan Walsh <dwalsh@redhat.com> 1.3.14-2
435- Remove checkbox from toplevel menu of tunables
436
437* Thu Jul 15 2004 Dan Walsh <dwalsh@redhat.com> 1.3.14-1
438- Turn on SELinux support
439
440* Thu May 27 2004 Dan Walsh <dwalsh@redhat.com> 1.3.13-2
441- Change lokkit to support new SELinux mode
442
443* Fri May 21 2004 Bill Nottingham <notting@redhat.com> 1.3.13-1
444- fix typo (#122907)
445
446* Fri Apr 30 2004 Brent Fox <bfox@redhat.com> 1.3.12-1
447- turn off SELinux widgets for FC2 (bug #122046)
448
449* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.11-1
450- comment out SELinux tunable widgets for now
451
452* Thu Apr 15 2004 Brent Fox <bfox@redhat.com> 1.3.10-6
453- test if self.doc is None in read_tunable_file, not read_selinux_file
454
455* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.3.10-5
456- don't write out xml file if it doesn't exist
457
458* Tue Apr 13 2004 Brent Fox <bfox@redhat.com> 1.3.10-4
459- don't try to write tunable.xml if the file doesn't exist
460
461* Mon Apr 12 2004 Brent Fox <bfox@redhat.com> 1.3.10-3
462- fix icon path (bug #120183)
463
464* Mon Apr  5 2004 Brent Fox <bfox@redhat.com> 1.3.10-2
465- more work on SELinux code
466
467* Thu Apr  1 2004 Brent Fox <bfox@redhat.com> 1.3.10-1
468- add SELinux widgets and restructure UI accordingly
469
470* Thu Mar 25 2004 Brent Fox <bfox@redhat.com> 1.3.9-1
471- replace the other ports widgets (bug #111930)
472
473* Wed Mar 24 2004 Bill Nottingham <notting@redhat.com> 1.3.8-1
474- fix writing of config file if neither of --disabled or --enabled are
475  passed (#118667, redux)
476
477* Fri Mar 19 2004 Bill Nottingham <notting@redhat.com> 1.3.7-1
478- prefer commandline arguments to config file arguments (#118667)
479
480* Tue Mar 16 2004 Jeremy Katz <katzj@redhat.com> 1.3.6-1
481- fix segfault in config reading if config files don't exist
482- don't flush iptables chains if run with --nostart
483
484* Thu Mar 11 2004 Bill Nottingham <notting@redhat.com > 1.3.5-1
485- read in old config in the TUI (#25510)
486- have https tag along with http (#61958)
487- fix segfault (#88533)
488
489* Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 1.3.4-1
490- don't do strlen() on random pointer (bug #117183)
491
492* Thu Mar  4 2004 Brent Fox <bfox@redhat.com> 1.3.3-1
493- fix tab ordering bug (bug #116913)
494
495* Tue Feb  3 2004 Brent Fox <bfox@redhat.com> 1.3.2-1
496- F12 functionality fixed
497
498* Mon Jan 12 2004 Brent Fox <bfox@redhat.com> 1.3.1-1
499- break up really long strings (bug #102455)
500
501* Tue Nov 18 2003 Brent Fox <bfox@aspen.chinfox.net> 1.3.0-1
502- rename to system-config-securitylevel
503- obsoletes redhat-config-securitylevel
504- convert to Python2.3
505
506* Thu Oct 16 2003 Brent Fox <bfox@redhat.com> 1.2.11-1
507- require iptables >=1.2.8 (bug #104777)
508
509* Fri Oct  3 2003 Bill Nottingham <notting@redhat.com> 1.2.10-1
510- minor code cleanup
511
512* Fri Oct  3 2003 Bill Nottingham <notting@redhat.com> 1.2.9-1
513- fix interactive disabling of firewall in TUI (#106243)
514
515* Wed Sep 17 2003 Bill Nottingham <notting@redhat.com> 1.2.8-2
516- rebuild
517
518* Wed Sep 17 2003 Bill Nottingham <notting@redhat.com> 1.2.8-1
519- allow ICMP in general (#104561)
520
521* Mon Sep 15 2003 Brent Fox <bfox@redhat.com> 1.2.7-2
522- bump release number
523
524* Mon Sep 15 2003 Brent Fox <bfox@redhat.com> 1.2.7-1
525- add Requires for rhpl
526
527* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.2.6-1
528- fix typo (bug #101802)
529
530* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.2.5-1
531- tag on every build
532
533* Tue Aug 12 2003 Brent Fox <bfox@redhat.com> 1.2.3-2
534- bump relnum and rebuild
535
536* Tue Aug 12 2003 Brent Fox <bfox@redhat.com> 1.2.3-1
537- some string changes
538
539* Mon Aug 11 2003 Brent Fox <bfox@redhat.com> 1.2.2-2
540- bump relnum and rebuild
541
542* Mon Aug 11 2003 Brent Fox <bfox@redhat.com> 1.2.2-1
543- reorder some UI elements
544
545* Thu Aug  7 2003 Bill Nottingham <notting@redhat.com> 1.2.1-1
546- fix rules (#101841)
547
548* Tue Aug  5 2003 Bill Nottingham <notting@redhat.com> 1.2.0-2
549- woops, RPM 101 (#101708)
550
551* Mon Aug  4 2003 Bill Nottingham <notting@redhat.com> 1.2.0-1
552- add patch for stateful firewalling (#87585, <dax@gurulabs.com>)
553- tweak tools appropriately (katzj@redhat.com), obsolete lokkit/gnome-lokkit
554
555* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.3-2
556- bump relnum and rebuild
557
558* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
559- use rhpl translation module
560
561* Tue May 27 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
562- bump rev and rebuild
563
564* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 1.1.1-3
565- fix return codes for firstboot reconfig mode
566- read config file in launch mode
567
568* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 1.1.1-1
569- bump and build
570
571* Mon Jan 27 2003 Brent Fox <bfox@redhat.com> 1.1.0-4
572- remove typo
573
574* Wed Jan 22 2003 Jeremy Katz <katzj@redhat.com> 1.1.0-3
575- match dhcp handling of anaconda and lokkit
576
577* Tue Dec 10 2002 Brent Fox <bfox@redhat.com> 1.1.0-2
578- fix bug 74913
579
580* Tue Dec 10 2002 Brent Fox <bfox@redhat.com> 1.1.0-1
581- save configuration in a config file in /etc/sysconfig/ so we remember settings
582
583* Mon Nov 18 2002 Brent Fox <bfox@redhat.com>
584- add a Requires for gnome-lokkit (bug #78057)
585
586* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
587- Latest translations
588
589* Thu Oct 10 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
590- Mark the word Mail for translation.  Fixes bug 75592
591
592* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-1
593- Convert to noarch
594
595* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.0-3
596- pull in latest German translations
597
598* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.0.0-2
599- Rebuild for translations
600
601* Mon Aug 26 2002 Brent Fox <bfox@redhat.com> 1.0.0-1
602- connect window to destroy signal
603
604* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-4
605- pull translations into desktop file
606
607* Mon Aug 12 2002 Tammy Fox <tfox@redhat.com> 0.9.9-3
608- replace System with SystemSetup in desktop file categories
609
610* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.9.9-2
611- fix bug 71187
612
613* Tue Aug 06 2002 Brent Fox <bfox@redhat.com>
614- Mark strings for translation
615
616* Mon Aug 05 2002 Brent Fox <bfox@redhat.com> 0.9.9-1
617- convert combo widget into an OptionMenu
618
619* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 0.9.8-1
620- Make changes for new pam timestamp policy
621
622* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-3
623- fix Makefiles and spec files so that translations get installed
624
625* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-2
626- update spec file for public beta 2
627
628* Wed Jul 24 2002 Tammy Fox <tfox@redhat.com> 0.9.4-3
629- Fix desktop file (bug #69484)
630
631* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.9.4-2
632- bump rev num and rebuild
633
634* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-2
635- Update changelogs and rebuild
636
637* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-1
638- Update changelogs and rebuild
639
640* Mon Jul 01 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
641- Bump rev number
642
643* Thu Jun 27 2002 Brent Fox <bfox@redhat.com> 0.9.1-2
644- Changed window title
645
646* Wed Jun 26 2002 Brent Fox <bfox@redhat.com> 0.9.1-1
647- Fixed description
648
649* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.9.0-5
650- Create pot file
651
652* Mon Jun 24 2002 Brent Fox <bfox@redhat.com> 0.9.0-4
653- Fix spec file
654
655* Fri Jun 21 2002 Brent Fox <bfox@redhat.com> 0.9.0-3
656- init doDebug
657- reverse ok/cancel buttons
658
659* Thu Jun 20 2002 Brent Fox <bfox@redhat.com> 0.9.0-2
660- Pass doDebug into launch, not init
661- Add snapsrc to Makefile
662
663* Sun May 26 2002 Brent Fox <bfox@redhat.com> 0.1.0-7
664- Add debug flag
665
666* Tue Nov 27 2001 Brent Fox <bfox@redhat.com>
667- initial coding and packaging
668
Note: See TracBrowser for help on using the repository browser.