source: projects/specs/trunk/s/system-config-lvm/system-config-lvm-vl.spec @ 521

Revision 521, 10.0 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1# -*- RPM-SPEC -*-
2Summary: A utility for graphically configuring Logical Volumes
3Summary(ja): LVM をグラフィカルに設定するためのユーティリティ
4Name: system-config-lvm
5Version: 1.1.4
6Release: 1%{?_dist_release}
7URL: http://www.redhat.com/
8License: GPLv2
9Group: Applications/System
10
11Vendor: Project Vine
12Distribution: Vine Linux
13Packager: daisuke
14
15Source0: %{name}-%{version}.tar.gz
16
17BuildArch: noarch
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19Requires: usermode-gtk, /sbin/chkconfig
20Requires: gnome-python, pygtk2, pygtk2-libglade
21Requires: urw-fonts
22Requires: lvm2
23Requires: rhpl
24Requires: python
25BuildRequires: perl(XML::Parser)
26BuildRequires: gettext
27BuildRequires: intltool
28BuildRequires: desktop-file-utils
29
30%description
31system-config-lvm is a utility for graphically configuring Logical Volumes
32
33%prep
34%setup -q
35
36for i in src/* ;do
37  perl -pi -e 's|python2|python|g' $i
38done
39
40%build
41%configure
42make %{?_smp_mflags}
43
44%install
45rm -rf %{buildroot}
46make DESTDIR=%{buildroot} install
47
48desktop-file-install --vendor system --delete-original          \
49  --dir %{buildroot}%{_datadir}/applications                    \
50  --remove-category Application                                 \
51 --remove-category SystemSetup                                  \
52  --remove-category X-Red-Hat-Base                              \
53  --add-category Settings                                       \
54  --add-category System                                         \
55  %{buildroot}%{_datadir}/applications/system-config-lvm.desktop
56
57%find_lang %name
58
59%clean
60rm -rf %{buildroot}
61
62#Replace the files line with the one commented out when translations are done
63%files -f %{name}.lang
64#%files
65
66%defattr(-,root,root)
67%doc COPYING
68#%doc docs/ReleaseNotes
69#%doc docs/html/*
70%{_sbindir}/*
71%{_bindir}/*
72%{_datadir}/applications/system-config-lvm.desktop
73%{_datadir}/system-config-lvm
74%config(noreplace) %{_sysconfdir}/pam.d/system-config-lvm
75%config(noreplace) %{_sysconfdir}/security/console.apps/system-config-lvm
76
77%changelog
78* Tue Jun 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.4-1
79- initial build for Vine Linux
80
81* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.4-5.1
82- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
83
84* Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.1.4-4.1
85- Rebuild for Python 2.6
86
87* Mon Oct 27 2008 Matthias Clasen  <mclasen@redhat.com> 1.1.4-3.1
88- Require usermode-gtk
89
90* Fri Oct 10 2008 Matthias Clasen  <mclasen@redhat.com> 1.1.4-3.0
91- Fix up BuildRequires
92
93* Thu Oct  9 2008 Matthias Clasen  <mclasen@redhat.com> 1.1.4-2.0
94- Properly install the desktop file (#442910)
95
96* Tue Apr 25 2008 Jim Parsons <jparsons@redhat.com> 1.1.4-1.0
97- Build for fedora
98
99* Tue Mar 25 2008 Ryan McCabe <rmccabe@redhat.com> 1.1.3-2.0
100- Fix for bz247325
101- Restore missing translations.
102
103* Wed Feb 06 2008 Ryan McCabe <rmccabe@redhat.com> 1.1.3-1.0
104- Fix for bz332651
105
106* Fri Sep 28 2007 Ryan McCabe <rmccabe@redhat.com> 1.1.2-1.0
107- Update the spec, configure.in, and Makefile.am files
108- Some other minor build tweaks
109- Bump the version number
110
111* Tue May 01 2007 Stanko Kupcevic <kupcevic@redhat.com> 1.1.1-1.0
112- Update pam file
113- Update translation files
114
115* Mon Jan 22 2007 Stanko Kupcevic <kupcevic@redhat.com> 1.0.22-1.0
116- Fixed 223518 (s-c-lvm fails to probe CS5 properly)
117- fixes bz223518
118
119* Mon Dec 18 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.21-1.0
120- Fixed 216569 (some messages not localized)
121- Fixed 218126 (Can't resize ext3 fs online)
122- fixes bz216569, bz218126
123
124* Mon Oct 16 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.20-1.0
125- Updated translation files
126
127* Mon Jul 10 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.19-1.0
128- Version bump
129
130* Thu Jun 01 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.18-1.0
131- Version bump
132
133* Fri May 12 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.17-1.0
134- Fixes for 175077, 171117, 175131, 176967, enable mirroring, 159455, 159456
135
136* Thu Feb 16 2006 Jim Parsons <jparsons@redhat.com> 1.0.16-1.0
137- Disabled mirroring support in UI.
138
139* Mon Feb 14 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.14-1.0
140- Fixes for bz180281, 159457, 180269. Mirroring support available with
141  constants in lvmui_constants file by setting MIRRORING_UI_SUPPORT to True
142
143* Fri Feb 10 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.13-1.0
144- Fix failure to display all unused space
145
146* Mon Feb 06 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.12-1.0
147- Under certain conditions, labels might show partially
148
149* Fri Feb 03 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.11-1.0
150- Fixes for bz175077,169860,178128,161917,171117,175131,178195
151
152* Thu Jan 05 2006 Stanko Kupcevic <kupcevic@redhat.com> 1.0.10-1.0
153- Fix for bz176967
154
155* Fri Dec 2 2005 Jim Parsons <jparsons@redhat.com> 1.0.9-1.0
156- Removed cLVM test.
157
158* Mon Nov 14 2005 Jim Parsons <jparsons@redhat.com> 1.0.8-1.0
159- Fixes for bz171744,171746,171747,171751,171753,171754,171755,171758,159457
160
161* Mon Sep 26 2005 Jim Parsons <jparsons@redhat.com> 1.0.7-1.0
162- Version bump.
163
164* Mon Sep 26 2005 Jim Parsons <jparsons@redhat.com> 1.0.6-1.0
165- Version bump for FC.
166
167* Wed Sep 13 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.5-1.0
168- Fix for bz167671.
169
170* Wed Sep 08 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.4-1.0
171- Fix for bz167662, 167643.
172
173* Mon Aug 15 2005 Stanko Kupcevic <kupcevic@redhat.com> 1.0.3-1.0
174- Fix for bz159457: Temporary removal of mirroring support.
175
176* Tue Aug 02 2005 Jim Parsons <jparsons@redhat.com> 1.0.2-1.0
177- Major new release that supports snapshotting, mirroring, and resizing.
178
179* Mon Jul 26 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.52-1.0
180- Alpha release: Strings, minor bugs, GFS, GFS2, mirrors on diff HDs
181
182* Fri Jul 15 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.51-1.0
183- Alpha release: mirroring, multipath, GPT, zoom, ...
184
185* Tue Jun 21 2005 Stanko Kupcevic <kupcevic@redhat.com> 0.9.50-1.0
186- Alpha release: snapshotting, resizing, lv properties
187
188* Thu May 26 2005 Jim Parsons <jparsons@redhat.com> 0.9.33-1.0
189- Version bump for rhel
190
191* Thu May 26 2005 Jim Parsons <jparsons@redhat.com> 0.9.32-1.0
192- Fix for 158872; x86_64 pam file path
193
194* Mon May 23 2005 Jim Parsons <jparsons@redhat.com> 0.9.31-1.0
195- Version bump for RHEL4
196
197* Mon May 23 2005 Jim Parsons <jparsons@redhat.com> 0.9.30-1.0
198- Fixed bz157744
199
200* Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.29-1.0
201- Version Bump
202
203* Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.28-1.0
204- Version Bump
205
206* Tue May 17 2005 Jim Parsons <jparsons@redhat.com> 0.9.27-1.0
207- Fix for bz154458,153042,155438,157743
208
209* Thu May 05 2005 Jim Parsons <jparsons@redhat.com> 0.9.26-1.0
210- Fix for bz156957
211
212* Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.25-1.0
213- Version bump.
214
215* Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.24-1.0
216- Changed permissions on Icon file.
217
218* Thu Apr 14 2005 Jim Parsons <jparsons@redhat.com> 0.9.23-1.0
219- Subtle change to .desktop file moves app launcher to system settings
220
221* Wed Apr 06 2005 Jim Parsons <jparsons@redhat.com> 0.9.22-1.0
222- Version Bump.
223
224* Wed Apr 06 2005 Jim Parsons <jparsons@redhat.com> 0.9.21-1.0
225- Changed path to lvm command for Fedora.
226
227* Mon Feb 21 2005 Jim Parsons <jparsons@redhat.com> 0.9.20-1.0
228- Added desktop icon file.
229
230* Mon Feb 21 2005 Jim Parsons <jparsons@redhat.com> 0.9.19-1.0
231- Added desktop file.
232
233* Wed Nov 24 2004 Jim Parsons <jparsons@redhat.com> 0.9.18-1.0
234- Adjustments to configure.in so this builds in fedora as well as RHEL.
235
236* Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.17-1.0
237- Fixes for bz140413 and bz 140562
238
239* Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.16-1.0
240- Strips whitespace off of all incoming command handler args.
241
242* Tue Nov 23 2004 Jim Parsons <jparsons@redhat.com> 0.9.15-1.0
243- Fixes for two small nits.
244
245* Mon Nov 22 2004 Jim Parsons <jparsons@redhat.com> 0.9.14-1.0
246- Fixes for bz140413, 140386, 140355, 140359, 140419, 138103, 140529.
247
248* Thu Nov 18 2004 Jim Parsons <jparsons@redhat.com> 0.9.12-1.0
249- Fix for bz137041, 139711 plus require for new RHPL pkg.
250
251* Tue Nov 16 2004 Jim Parsons <jparsons@redhat.com> 0.9.11-1.0
252- Fix for bz138019 -- extent segs correct for stripe corner case
253
254* Mon Nov 15 2004 Jim Parsons <jparsons@redhat.com> 0.9.10-1.0
255- Fixes for bz137291, 138008, and 137122
256
257* Thu Nov 11 2004 Jim Parsons <jparsons@redhat.com> 0.9.9-1.0
258- Fixes for bz137111, 138887, 138006,138097. Also removed fstab checkbox
259  and added it as a feature at 138831 for next release.
260
261* Wed Nov 10 2004 Jim Parsons <jparsons@redhat.com> 0.9.8-1.0
262- Fixes for bz137930, 137872, 137292, 137052, 137054
263
264* Tue Nov 9 2004 Jim Parsons <jparsons@redhat.com> 0.9.7-1.0
265- Improved handling of garbage in the size string -- try catch in place
266  now that traps for ValueError
267- Improved handling of sizes/units for new LV creation
268- Now 'Unused' sections in Logical View of VGs, are unselectable. Also,
269  if there are no LVs associated with a VG, the Logical view buttonpanel
270  button for "Remove selected extents" is set to not be sensitive, as
271  there is nothing to remove from this case.
272- Revamped PV removal code, so that proper checking is done before moving
273  extents.
274- Added new method that checks if dm-mirror mod is loaded in kernel. If not,
275  an appropriate error message is generated.
276- Fixed tree selection mechanism by preventing multiple VG selection.
277- Handle delete-event on VG creation dialog, so it is hidden.
278- Fixed bz137099, 137071, 137869, 137434, 138085
279
280* Mon Nov 1 2004 Jim Parsons <jparsons@redhat.com> 0.9.6-1.0
281- Changed gtk.mainloop to gtk.main to address bz137288.
282
283* Mon Nov 1 2004 Jim Parsons <jparsons@redhat.com> 0.9.5-1.0
284- Added Menubar to address bz137293.
285
286* Fri Oct 29 2004 Jim Parsons <jparsons@redhat.com> 0.9.4-1.0
287- Fixes for bz137190 empty vg name field validation,
288- bz137048 removes resizable checkbox for vgcreate,
289- bz137208 unique vg name checking fixed,
290- bz137107 remove autobackup checkbox,
291- bz137231 warn on extend vg when init'ing a new entity.
292
293* Tue Oct 26 2004 Jim Parsons <jparsons@redhat.com> 0.9.3-1.0
294- Version bump.
295
296* Tue Oct 26 2004 Jim Parsons <jparsons@redhat.com> 0.9.2-1.0
297- Fixed bz137118 warningMessage error. This is a critical mustfix.
298
299* Wed Oct 20 2004 Jim Parsons <jparsons@redhat.com> 0.9.1-2.5
300- Fixed size selection issue, bz136217.
301
302* Wed Sep 01 2004 Jim Parsons <jparsons@redhat.com> 0.9.1-1
303- Initial copy
Note: See TracBrowser for help on using the repository browser.