source: projects/specs/trunk/s/system-config-keyboard/system-config-keyboard-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A graphical interface for modifying the keyboard
2Summary(ja): キーボードを変更するためのグラフィカルインタフェース
3Name: system-config-keyboard
4Epoch: 1
5Version: 1.2.11
6Release: 2%{?_dist_release}
7URL: https://fedorahosted.org/system-config-keyboard/
8License: GPL
9ExclusiveOS: Linux
10Group: System Environment/Base
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13Source0: %{name}-%{version}.tar.bz2
14BuildRequires: desktop-file-utils
15BuildRequires: gettext
16BuildRequires: intltool
17Obsoletes: kbdconfig
18Obsoletes: redhat-config-keyboard
19ExcludeArch: s390 s390x ppc64
20Requires: python
21Requires: usermode >= 1.36
22Requires: rhpl >= 0.53
23Requires: pyxf86config
24Requires: firstboot
25Prereq: gtk2 >= 2.6
26
27%description
28system-config-keyboard is a graphical user interface that allows
29the user to change the default keyboard of the system.
30
31%description -l ja
32%{name} はシステムのデフォルトのキーボードを変更するための
33グラフィカルユーザインタフェースです。
34
35%prep
36%setup -q
37
38%install
39make INSTROOT=$RPM_BUILD_ROOT install
40desktop-file-install --vendor system --delete-original      \
41  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
42  --add-category System \
43  --add-category Settings \
44  $RPM_BUILD_ROOT%{_datadir}/applications/system-config-keyboard.desktop
45
46%find_lang %name
47
48%clean
49rm -rf $RPM_BUILD_ROOT
50
51%post
52touch --no-create %{_datadir}/icons/hicolor
53if [ -x /usr/bin/gtk-update-icon-cache ]; then
54  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
55fi
56
57%postun
58touch --no-create %{_datadir}/icons/hicolor
59if [ -x /usr/bin/gtk-update-icon-cache ]; then
60  gtk-update-icon-cache -q %{_datadir}/icons/hicolor
61fi
62
63%files -f %{name}.lang
64%defattr(-,root,root)
65#%doc COPYING
66%{_bindir}/system-config-keyboard
67%dir %{_datadir}/system-config-keyboard
68%{_datadir}/system-config-keyboard/*
69%dir %{_datadir}/firstboot/
70%dir %{_datadir}/firstboot/modules
71%{_datadir}/firstboot/modules/*
72%attr(0644,root,root) %{_datadir}/applications/system-config-keyboard.desktop
73%attr(0644,root,root) %config /etc/security/console.apps/system-config-keyboard
74%attr(0644,root,root) %config /etc/pam.d/system-config-keyboard
75%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-keyboard.png
76
77%changelog
78* Sat Aug 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:1.2.11-2
79- revert to 1.2.11
80
81* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.15-1
82- new upstream release, add upstream patches
83
84* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.11-1
85- initial build for Vine Linux
86
87* Tue Nov 21 2006 Paul Nasrat <pnasrat@redhat.com> - 1.2.11-1
88- Update translations
89
90* Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> - 1.2.10-1
91- use valid charset for translations (#210720)
92
93* Wed Oct 04 2006 Chris Lumens <clumens@redhat.com> - 1.2.9-1
94- Fix type ahead order to use displayed names (#209218).
95
96* Mon Oct  2 2006 Jeremy Katz <katzj@redhat.com> - 1.2.8-1
97- update translations
98
99* Mon Jul 17 2006 Paul Nasrat <pnasrat@redhat.com> - 1.2.7-2
100- Don't nuke *.pyc in preun (#198952)
101
102* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2.7-1.1.1
103- rebuild
104
105* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
106- rebuilt
107
108* Thu Oct 20 2005 Paul Nasrat <pnasrat@redhat.com> - 1.2.7-1
109- Update pam file (#170630)
110- New firstboot module
111- Compiled python
112
113* Thu Sep 15 2005 Jeremy Katz <katzj@redhat.com> - 1.2.6-3
114- exclude ppc64 since we don't have X stuff there
115
116* Wed Apr 27 2005 Jeremy Katz <katzj@redhat.com> - 1.2.6-2
117- silence %%post
118
119* Fri Apr 01 2005 Paul Nasrat <pnasrat@redhat.com> - 1.2.6-1
120- Translations
121- Gtk deprecations
122
123* Mon Mar 28 2005 Christopher Aillon <caillon@redhat.com>
124- rebuilt
125
126* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com> 1.2.5-2
127- Update the GTK+ theme icon cache on (un)install
128
129* Fri Oct 08 2004 Paul Nasrat <pnasrat@redhat.com> - 1.2.5-1
130- Firstboot fix for xorg.conf
131
132* Fri Oct 01 2004 Paul Nasrat <pnasrat@redhat.com> - 1.2.4-1
133- Translations
134
135* Wed Sep 22 2004 Jeremy Katz <katzj@redhat.com> - 1.2.3-1
136- fix traceback when using treeview typeahead (#133178)
137
138* Tue Sep 07 2004 Paul Nasrat <pnasrat@redhat.com> 1.2.2-1
139- i18n desktop
140
141* Thu Apr  8 2004 Brent Fox <bfox@redhat.com> 1.2.1-2
142- fix icon path (bug #120175)
143
144* Wed Nov 12 2003 Brent Fox <bfox@redhat.com> 1.2.1-1
145- renamed from redhat-config-keyboard
146- add Obsoletes for redhat-config-keyboard
147- make changes for Python2.3
148
149* Mon Oct 13 2003 Brent Fox <bfox@redhat.com> 1.1.5-2
150- pull in Croatian translation (bug #106617)
151
152* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.1.5-1
153- tag on every build
154
155* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.3-2
156- bump release and rebuild
157
158* Wed Jul  2 2003 Brent Fox <bfox@redhat.com> 1.1.3-1
159- mark string for translation
160
161* Tue Jul  1 2003 Brent Fox <bfox@redhat.com> 1.1.2-2
162- bump version and rebuild
163
164* Tue Jul  1 2003 Brent Fox <bfox@redhat.com> 1.1.2-1
165- fix formatting problem (bug #97873)
166- create an XkbOption if it doesn't exist (bug #97877)
167
168* Wed May 21 2003 Brent Fox <bfox@redhat.com> 1.1.1-2
169- made a typo in redhat-config-keyboard.py
170
171* Wed May 21 2003 Brent Fox <bfox@redhat.com> 1.1.1-1
172- Created a command line interface
173- updated all copyright dates
174
175* Wed Apr  2 2003 Brent Fox <bfox@redhat.com> 1.0.5-1
176- pass window size into rhpl
177
178* Wed Mar  5 2003 Brent Fox <bfox@redhat.com> 1.0.4-1
179- add functions in keyboard_gui.py for anaconda popup mode
180
181* Wed Feb 12 2003 Jeremy Katz <katzj@redhat.com> 1.0.3-4
182- fixes for tui cjk (#83518)
183
184* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 1.0.3-3
185- change packing order a little for firstboot reconfig mode
186
187* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 1.0.3-2
188- bump and build
189
190* Wed Jan 22 2003 Brent Fox <bfox@redhat.com> 1.0.3-1
191- add a us keymap to keymaps with non-latin chars (bug #82440)
192- write out the XkbVariant line if it is present
193- handle XkbOptions to allow toggling between keymaps
194
195* Mon Dec 23 2002 Brent Fox <bfox@redhat.com> 1.0.2-1
196- add a textdomain for rhpl so we pull in translations (bug #78831)
197
198* Thu Dec 12 2002 Brent Fox <bfox@redhat.com> 1.0.1-9
199- remove requires for pygtk2 since we have a text mode now
200
201* Wed Dec 11 2002 Brent Fox <bfox@redhat.com> 1.0.1-8
202- fall back to text mode if gui mode fails
203
204* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.0.1-7
205- pam path changes
206
207* Thu Nov 07 2002 Brent Fox <bfox@redhat.com> 1.0.1-6
208- Add keyboard_backend.py to cvs
209
210* Thu Oct 31 2002 Brent Fox <bfox@redhat.com> 1.0.1-5
211- Obsolete kbdconfig
212
213* Wed Oct 09 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
214- Added a tui mode - keyboard_tui.py
215- Moved some non-UI code to keyboard_backend.py
216
217* Fri Oct 04 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
218- Add a window icon
219- set selection mode to browse
220
221* Wed Aug 28 2002 Brent Fox <bfox@redhat.com> 1.0.1-1
222- Make no arch
223
224* Wed Aug 14 2002 Brent Fox <bfox@redhat.com> 0.9.9-6
225- rebuild for translations
226
227* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-5
228- fix textdomain so translations show up correctly
229
230* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 0.9.9-4
231- pull translations into desktop file
232
233* Mon Aug 12 2002 Tammy Fox <tfox@redhat.com> 0.9.9-3
234- Replace System with SystemSetup in desktop file categories
235
236* Sun Aug 11 2002 Brent Fox <bfox@redhat.com> 0.9.9-2
237- Fix ordering of layout and model.  Fixes bug 71067
238
239* Thu Aug 08 2002 Brent Fox <bfox@redhat.com> 0.9.9-1
240- Added Requires for pyxf86config
241
242* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 0.9.8-1
243- Make changes for new pam timestamp policy
244
245* Thu Aug 01 2002 Brent Fox <bfox@redhat.com> 0.9.7-2
246- sort the list by the full keyboard name, not the keymap
247
248* Thu Aug 01 2002 Brent Fox <bfox@redhat.com> 0.9.7-1
249- make calls to pyxf86config to update XF86Config file
250
251* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-3
252- fix Makefiles and spec files so that translations get installed
253
254* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 0.9.6-2
255- update spec file for public beta 2
256
257* Tue Jul 23 2002 Brent Fox <bfox@redhat.com> 0.9.6-1
258- put desktop file in correct location
259
260* Mon Jul 22 2002 Jeremy Katz <katzj@redhat.com> 0.9.5-2
261- add scrollto hack back
262
263* Fri Jul 19 2002 Brent Fox <bfox@redhat.com> 0.9.5-1
264- add version dependency for pygtk2 API change
265
266* Thu Jul 18 2002 Jeremy Katz <katzj@redhat.com> 0.9.4-3
267- add fix for list store changes in new pygtk2
268
269* Tue Jul 16 2002 Brent Fox <bfox@redhat.com> 0.9.4-2
270- bump rev num and rebuild
271
272* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 0.9.3-2
273- Update changelogs and rebuild
274
275* Mon Jul  1 2002 Jeremy Katz <katzj@redhat.com> 0.9.3-1
276- add wacky scrollto hack so that the screen in the installer scrolls properly
277
278* Mon Jul 01 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
279- Bump rev number
280
281* Mon Jul 1 2002 Brent Fox <bfox@redhat.com> 0.9.2-1
282- Wrap the destroy call in a try/except because there is no self.mainWindow in firstboot reconfig mode
283
284* Wed Jun 26 2002 Brent Fox <bfox@redhat.com> 0.9.1-1
285- Fixed description
286
287* Tue Jun 25 2002 Brent Fox <bfox@redhat.com> 0.9.0-5
288- Create pot file
289
290* Mon Jun 24 2002 Brent Fox <bfox@redhat.com> 0.9.0-4
291- Fix spec file
292
293* Fri Jun 21 2002 Brent Fox <bfox@redhat.com> 0.9.0-3
294- Print init message on debug mode
295
296* Thu Jun 20 2002 Brent Fox <bfox@redhat.com> 0.9.0-2
297- Pass doDebug into launch instead of setupScreen
298- Add snapsrc to Makefile
299
300* Tue Jun 18 2002 Brent Fox <bfox@redhat.com> 0.9.0-1
301- Create a way to pass keymap name back to firstboot
302
303* Wed May 29 2002 Brent Fox <bfox@redhat.com> 0.2.0-3
304- Make symbolic link in /usr/share/firstboot/modules point to keyboard_gui.py
305
306* Tue May 28 2002 Jeremy Katz <katzj@redhat.com>
307- changes to be usable within an anaconda context
308
309* Tue Dec 05 2001 Brent Fox <bfox@redhat.com>
310- initial coding and packaging
311
Note: See TracBrowser for help on using the repository browser.