source: projects/specs/trunk/s/system-config-date/system-config-date-vl.spec @ 521

Revision 521, 25.7 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A graphical interface for modifying system date and time
2Summary(ja): システムの時刻と日付を設定するグラフィカルインタフェース
3
4Name: system-config-date
5Version: 1.8.12
6Release: 1%{?_dist_release}
7URL: http://fedora.redhat.com/projects/config-tools/
8License: GPL
9ExclusiveOS: Linux
10Group: System Environment/Base
11Source0: %{name}-%{version}.tar.bz2
12Source1: system-config-date-1.8.12-doc.tar
13Patch0: system-config-date-1.8.12-doc.patch
14Patch100: system-config-date-vine.patch
15Patch110: system-config-date-1.8.12-desktop-file.patch
16
17BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
18BuildArch: noarch
19Obsoletes: timetool
20Obsoletes: dateconfig
21Obsoletes: timeconfig
22BuildRequires: desktop-file-utils
23BuildRequires: gettext
24BuildRequires: intltool
25BuildRequires: python
26#BuildRequires: anaconda
27Requires: ntp
28Requires: python
29Requires: pygtk2-libglade
30Requires: gnome-python
31Requires: usermode
32Requires: chkconfig
33Requires: rhpl
34Requires: newt
35Requires: yelp
36Requires(post): hicolor-icon-theme
37Requires(postun): hicolor-icon-theme
38
39
40%description
41system-config-date is a graphical interface for changing the system date and
42time, configuring the system time zone, and setting up the NTP daemon to
43synchronize the time of the system with an NTP time server.
44
45%prep
46%setup -q -a 1
47%patch0 -p1 -b .doc
48
49%patch100 -p1 -b .vine
50%patch110 -p1 -b .desktop-file
51
52sed -i -e 's|/usr/bin/python2|/usr/bin/python|g' \
53    system-config-date timeconfig src/*.py
54
55%build
56make
57
58%install
59rm -rf $RPM_BUILD_ROOT
60make DESTDIR=$RPM_BUILD_ROOT install
61desktop-file-install --vendor system --delete-original       \
62  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
63  $RPM_BUILD_ROOT%{_datadir}/applications/system-config-date.desktop
64
65%find_lang %name
66
67%clean
68rm -rf $RPM_BUILD_ROOT
69
70%post
71touch --no-create %{_datadir}/icons/hicolor
72if [ -x /usr/bin/gtk-update-icon-cache ]; then
73  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
74fi
75
76%postun
77touch --no-create %{_datadir}/icons/hicolor
78if [ -x /usr/bin/gtk-update-icon-cache ]; then
79  gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
80fi
81
82%files -f %{name}.lang
83%defattr(-,root,root)
84%doc COPYING
85%doc doc/*
86/usr/bin/system-config-date
87/usr/bin/system-config-time
88/usr/bin/dateconfig
89/usr/sbin/timeconfig
90%dir /usr/share/system-config-date
91/usr/share/system-config-date/*.py
92/usr/share/system-config-date/*.pyc
93/usr/share/system-config-date/*.glade
94%dir /usr/share/system-config-date/pixmaps/
95%attr(0644,root,root) %{_mandir}/man8/system-config-date*
96%attr(0644,root,root) %{_mandir}/fr/man8/system-config-date*
97%attr(0644,root,root) %{_mandir}/ja/man8/system-config-date*
98%attr(0644,root,root) %{_datadir}/applications/system-config-date.desktop
99%attr(0644,root,root) %{_datadir}/system-config-date/pixmaps/system-config-date.png
100%attr(0644,root,root) %{_datadir}/icons/hicolor/48x48/apps/system-config-date.png
101%attr(0644,root,root) %{_datadir}/system-config-date/pixmaps/map1440.png
102%attr(0644,root,root) %{_datadir}/system-config-date/regions
103%attr(0644,root,root) %config(noreplace) /etc/security/console.apps/system-config-date
104%attr(0644,root,root) %config(noreplace) /etc/pam.d/system-config-date
105%attr(0644,root,root) %config(noreplace) /etc/security/console.apps/system-config-time
106%attr(0644,root,root) %config(noreplace) /etc/pam.d/system-config-time
107%attr(0644,root,root) %config(noreplace) /etc/security/console.apps/dateconfig
108%attr(0644,root,root) %config(noreplace) /etc/pam.d/dateconfig
109%attr(0644,root,root) %config(noreplace) /etc/ntp/ntpservers
110%attr(0644,root,root) %config(noreplace) /usr/share/system-config-date/ntp.template
111
112%changelog
113* Wed Oct 01 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.12-1
114- initial build for Vine Linux
115
116* Tue Jun 10 2008 Karanbir Singh <kbsingh@centos.org> 1.8.12-3.el5.centos.2
117- change ntpservers as well ( Ralph Angenendt )
118
119* Mon Jun  9 2008 Karanbir Singh <kbsingh@centos.org> 1.8.12-3.el5.centos.1
120- roll in CentOS ntp servers ( Ralph Angenendt )
121
122* Wed Nov 28 2007 Nils Philippsen <nphilipp@redhat.com> 1.8.12-3
123- use '#' instead of '?' to access sections of XML documents with older yelp
124  versions (#250215)
125
126* Mon Nov 26 2007 Nils Philippsen <nphilipp@redhat.com> 1.8.12-2
127- use updated help documents from the deployment guide, use yelp for displaying
128  them (#250215)
129
130* Tue Jan 16 2007 Nils Philippsen <nphilipp@redhat.com> 1.8.12
131- pick up updated translations (#220952)
132
133* Mon Jan 08 2007 Nils Philippsen <nphilipp@redhat.com>
134- ask whether the configuration should be revisited on NTP problems (#220952)
135
136* Fri Jan 05 2007 Nils Philippsen <nphilipp@redhat.com>
137- don't attempt to show error dialog from signal handler (#220952)
138
139* Fri Dec 15 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.11
140- provide more info when encountering bad timezone translations (i.e. not split
141  into Region,Continent/Location) (#219773)
142- pick up updated translations (#216073)
143
144* Wed Dec 13 2006 Nils Philippsen <nphilipp@redhat.com>
145- fix keyboard shortcuts in Czech translation (#190355)
146
147* Wed Dec 13 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.10
148- pick up updated translations (#216073)
149
150* Fri Nov 24 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.9
151- pick up updated translations (#216073)
152
153* Tue Nov 21 2006 Nils Philippsen <nphilipp@redhat.com>
154- revamp timezone potfile generation a bit
155- pick up new timezones for translation (#216073)
156
157* Tue Oct 17 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.8
158- enable Hebrew, Marathi and Urdu translations
159- pick up updated translations (#211074)
160- add dist tag
161
162* Fri Oct 13 2006 Bill Nottingham <notting@redhat.com> 1.8.7
163- use valid charsets for translation (#210720)
164
165* Fri Sep 15 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.6
166- pick up updated strings and translations (#192075, #204441)
167
168* Fri Aug 25 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.5
169- hide 'Enable NTP Broadcast' checkbutton as more action is needed than a mere
170  change in ntp.conf
171
172* Mon Jul 17 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.4
173- pick up updated translations
174
175* Tue Mar 14 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.3
176- feed timezone po files from anaconda (#131528, patch by Andrew Martynov)
177
178* Mon Mar 06 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.2
179- don't write into /tmp
180- make synchronizing with time servers configurable (#157485)
181
182* Fri Mar 03 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.1
183- require hicolor-icon-theme (#182859, #182860)
184
185* Mon Jan 30 2006 Nils Philippsen <nphilipp@redhat.com> 1.8.0
186- bump minor version
187- add requirements for pygtk2-libglade, gnome-python2-canvas (#179215)
188
189* Fri Jan 20 2006 Nils Philippsen <nphilipp@redhat.com> 1.7.99.17
190- zoom out in TZ map on Escape (#178093)
191
192* Wed Jan 18 2006 Nils Philippsen <nphilipp@redhat.com> 1.7.99.16
193- don't crash when selecting a timezone (#178086, patch by Chris Lumens)
194
195* Tue Jan 17 2006 Nils Philippsen <nphilipp@redhat.com> 1.7.99.15
196- fix setting timezone from firstboot (#177779, patch by Chris Lumens)
197
198* Mon Jan 16 2006 Nils Philippsen <nphilipp@redhat.com> 1.7.99.14
199- put Etc/... timezones into "Non-geographic timezones" (#148025)
200- default to already set timezone on startup (#177815)
201
202* Tue Jan 10 2006 Nils Philippsen <nphilipp@redhat.com>
203- Add translation string for UTC-relative and other non-geographic timezones
204
205* Mon Jan 09 2006 Chris Lumens <clumens@redhat.com> 1.7.99.13-1
206- Rename mainWindow to scdMainWindow to avoid import problems in firstboot.
207
208* Wed Jan 04 2006 Nils Philippsen <nphilipp@redhat.com> 1.7.99.12
209- show actually chosen region, not just something that's in the vicinity
210
211* Fri Dec 30 2005 Nils Philippsen <nphilipp@redhat.com>
212- fix highlighted regions when leaving and entering the timeone map canvas
213- make timezone list a treeview
214- update timezone po source file
215
216* Thu Dec 15 2005 Jeremy Katz <katzj@redhat.com> - 1.7.99.11-1
217- fix timezone map to not be painfully slow
218
219* Wed Dec 14 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.10
220- make TimezoneMap more easily subclassable (Chris Lumens), use uniform
221  paren-spacing
222
223* Thu Dec 08 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.9
224- draw frame around highlighted region
225
226* Thu Nov 24 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.8
227- reshow shaded map when reentering map widget from outside
228- clear status line when outside region area in zoomed mode
229
230* Thu Nov 24 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.7
231- only select region if pointer is inside region
232- replace aa-based shading to avoid aa-related deficiencies of GnomeCanvas
233- show shaded border around zoomed in region to zoom out without selecting a
234  city
235
236* Wed Nov 23 2005 Nils Philippsen <nphilipp@redhat.com>
237- don't let cities get miraculously lost (#173944, patch by Chris Lumens)
238
239* Mon Nov 21 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.6
240- fix zooming problems with enlarged window (#172982)
241- apply workaround by Alex Larsson to avoid hanging when clicking on Asia
242  region (#172977)
243- add Middle America region, make Antarctica regions overlapping
244
245* Thu Nov 10 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.5
246- when choosing a region, shade off the rest of the map when hovering over a
247  region
248
249* Wed Nov 09 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.4
250- implement simple timezone zooming
251
252* Fri Oct 21 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.3
253- revamp pot file generation (#171330)
254
255* Fri Oct 14 2005 Nils Philippsen <nphilipp@redhat.com>
256- don't use pam_stack (#170623)
257
258* Fri Oct 07 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.2
259- write comment about the ZONE parameter into /etc/sysconfig/clock (#123101)
260- handle comments when reading /etc/sysconfig/clock
261- consistently use spaces for indentation in timezoneBackend.py
262
263* Thu Sep 22 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.1
264- check whether NTP server is reachable on changes (#135747)
265
266* Tue Aug 09 2005 Nils Philippsen <nphilipp@redhat.com>
267- remove workaround causing deprecation warnings for bug that doesn't exist
268  anymore (#162840)
269
270* Thu Aug 04 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.99.0
271- add and edit NTP servers inline in the list
272- always display clock left-to-right (#165109)
273- try to be smart about restrict lines when changing or deleting hosts
274- include *.pyo files (#165097)
275- don't remove *.pyc files in %%preun because they're in the file list
276- don't include timetool symlink anymore
277- don't install firstboot module symlink, this is dealt with in the firstboot
278  package for quite a while
279
280* Wed Aug 03 2005 Nils Philippsen <nphilipp@redhat.com>
281- implement --help, catch unrecognized options (#164791)
282
283* Fri May 06 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.18
284- make desktop file translatable (#156792)
285- avoid DeprecationWarnings
286- use DESTDIR consistently (#156782)
287
288* Tue Apr 19 2005 Matthias Clasen <mclasen@redhat.com> 1.7.17-2
289- Silence %%post
290
291* Fri Apr 15 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.17
292- make more strings translatable (#154873)
293
294* Fri Apr 01 2005 Nils Philippsen <nphilipp@redhat.com> 1.7.16-2
295- use True, False instead of gtk.TRUE, gtk.FALSE to avoid deprecation warnings
296  (#153037, patch by Colin Charles)
297
298* Mon Mar 28 2005 Christopher Aillon <caillon@redhat.com>
299- rebuilt
300
301* Fri Mar 25 2005 Christopher Aillon <caillon@redhat.com> 1.7.15-2
302- Update the GTK+ theme icon cache on (un)install
303
304* Sat Jan 15 2005 Nils Philippsen <nphilipp@redhat.com>
305- use current default ntp.conf as template (#132787, #135142)
306
307* Mon Dec 13 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.15-1
308- don't lookup names or IP addresses as this may result in hangs (#142583)
309
310* Mon Nov 29 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.14-1
311- bump version
312
313* Fri Nov 26 2004 Nils Philippsen <nphilipp@redhat.com>
314- don't use duplicate accelerators (#134172, #140241)
315
316* Fri Nov 26 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.13-1
317- enable Gujarati and Tamil translations (#140881)
318
319* Mon Nov 22 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.12-1
320- remove wrongly encoded character (#140318) and duplicate word from French
321  man page
322
323* Wed Sep 29 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.11-1
324- avoid GtkDeprecationWarning on gtk.mainquit on new pygtk (#134043)
325
326* Tue Sep 28 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.10-1
327- make timezone page contents actually be shown in firstboot
328
329* Tue Sep 28 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.9-1
330- enable choosing which notebook page(s) to show (for firstboot, #133748)
331- some minor firstboot API changes, conflict with firstboot <= 1.3.26
332- some minor UI tweaks
333- remove pool.ntp.org from list of NTP server choices as system-config-date
334  doesn't handle multi-IP machines really well ATM
335
336* Fri Sep 17 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.8-1
337- use pool.ntp.org as first choice of NTP servers (#132787)
338
339* Thu Sep 16 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.7-2
340- buildrequire python
341
342* Tue Sep 14 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.7-1
343- byte-compile python files
344- first shot at something like an interface for firstboot
345
346* Mon Sep 13 2004 Nils Philippsen <nphilipp@redhat.com>
347- get widget sensitivity correct on startup (#132431)
348
349* Thu Sep 03 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.5-1
350- actually display time zone map (#131641)
351- put NTP stuff into own tab to better accommodate firstboot (#131314)
352- add accelerators to Date & Time tab
353
354* Fri Aug 27 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.4-1
355- handle multiple servers, broadcastclient (#115148),
356  local time source (#72110)
357
358* Tue Aug 03 2004 Nils Philippsen <nphilipp@redhat.com> 1.7.3.1-1
359- fix Japanese man page (#128766)
360
361* Wed Apr 14 2004 Brent Fox <bfox@redhat.com> 1.7.3-3
362- update desktop file (bug #120709)
363
364* Tue Apr  6 2004 Brent Fox <bfox@redhat.com> 1.7.3-2
365- fix desktop file icon path (bug #120176)
366
367* Wed Mar 24 2004 Brent Fox <bfox@redhat.com> 1.7.3-1
368- just copy over file, don't remove it (bug #119076)
369
370* Fri Mar  5 2004 Brent Fox <bfox@redhat.com> 1.7.2-1
371- preserve old restrict lines (bug #72110)
372
373* Tue Feb  3 2004 Brent Fox <bfox@redhat.com> 1.7.1-2
374- correct typo in URL in specfile
375
376* Thu Jan  8 2004 Brent Fox <bfox@redhat.com> 1.7.1-1
377- apply patch from bug #109803
378
379* Wed Nov 19 2003 Brent Fox <bfox@redhat.com> 1.6.1-1
380- rebuild
381
382* Wed Nov 12 2003 Brent Fox <bfox@redhat.com> 1.6.0-1
383- rename to system-config-date
384- add Obsoletes for redhat-config-date
385- adapt to Python2.3
386
387* Mon Nov  3 2003 Brent Fox <bfox@redhat.com> 1.5.27-1
388- add flag to allow timezone page to come up first
389
390* Wed Oct 29 2003 Brent Fox <bfox@redhat.com> 1.5.26-1
391- add French translation for man page from Frederic.Hornain@GB.BE
392
393* Sun Oct 26 2003 Brent Fox <bfox@redhat.com> 1.5.25-1
394- fix some other timezone po file encoding problems
395
396* Sun Oct 26 2003 Brent Fox <bfox@redhat.com> 1.5.24-1
397- make sure is.po file is UTF-8 encoded.  (bug #107439) Similar to bug #107033
398
399* Wed Oct 15 2003 Brent Fox <bfox@redhat.com> 1.5.23-1
400- UTF8-ify po/timezones/de.po (bug #107033)
401
402* Fri Sep 19 2003 Brent Fox <bfox@redhat.com> 1.5.22-2
403- rebuild
404
405* Fri Sep 19 2003 Brent Fox <bfox@redhat.com> 1.5.22-1
406- call timeconfig if the GUI cannot be started (bug #104718)
407
408* Thu Sep 11 2003 Brent Fox <bfox@redhat.com> 1.5.21-2
409- bump relnum and rebuild
410
411* Thu Sep 11 2003 Brent Fox <bfox@redhat.com> 1.5.21-1
412- rebuild with fixed po file encodings (bug #104019)
413
414* Wed Sep 10 2003 Brent Fox <bfox@redhat.com> 1.5.20-1
415- add a Requires for newt (bug #104148)
416
417* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.5.19-2
418- bump relnum and rebuild
419
420* Fri Aug 29 2003 Brent Fox <bfox@redhat.com> 1.5.19-1
421- if timezone in /etc/sysconfig/clock is not in zone.tab, default to America/New_York (bug #101575)
422
423* Thu Aug 14 2003 Brent Fox <bfox@redhat.com> 1.5.18-1
424- tag on every build
425
426* Wed Jun 25 2003 Brent Fox <bfox@redhat.com> 1.5.15-2
427- bump version number and rebuild
428
429* Wed Jun 25 2003 Brent Fox <bfox@redhat.com> 1.5.15-1
430- don't move /usr/share/zoneinfo/UTC into /etc/localtime (#91228)
431
432* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.5.14-2
433- bump number and rebuild
434
435* Mon Jun 16 2003 Brent Fox <bfox@redhat.com> 1.5.14-1
436- Add a function to get timezone date page (bug #91984)
437
438* Tue May 27 2003 Brent Fox <bfox@redhat.com> 1.5.13-1
439- if /var/spool/postfix/etc/localtime exists, copy the new timezone file there (bug #88249)
440
441* Tue May 27 2003 Brent Fox <bfox@redhat.com> 1.5.12-1
442- add a header comment to ntpservers file (bug #91619)
443
444* Tue May 27 2003 Brent Fox <bfox@redhat.com> 1.5.11-2
445- bump rel num and rebuild
446
447* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.5.11-1
448- check for the existence of hwclock before running (bug #91323)
449
450* Thu May 22 2003 Brent Fox <bfox@redhat.com> 1.5.10-1
451- pull zonetab classes out into separate file to fix bug (#90185)
452
453* Tue May 20 2003 Brent Fox <bfox@redhat.com> 1.5.9-11
454- copy actual timezone into /etc/localtime instead of making a symlink (bug #91228)
455
456* Fri May 16 2003 Brent Fox <bfox@redhat.com> 1.5.9-10
457- when using UTC, make /etc/localtime point to /usr/share/zoneinfo/UTC (bug #89132)
458
459* Fri May 16 2003 Brent Fox <bfox@redhat.com> 1.5.9-9
460- Added mnemonics to widgets that didn't have them (bug #91026)
461- convert some timezone po files to utf-8 (bug #88461)
462
463* Wed Feb 26 2003 Brent Fox <bfox@redhat.com> 1.5.9-8
464- add requires for ntp (bug #85229)
465
466* Fri Feb 21 2003 Brent Fox <bfox@redhat.com> 1.5.9-7
467- remove dependency for gnome-python2-canvas, pygtk and ntp (bug #84837)
468
469* Wed Feb 12 2003 Jeremy Katz <katzj@redhat.com> 1.5.9-6
470- set codeset so that textmode works (#83518)
471
472* Tue Feb 11 2003 Brent Fox <bfox@redhat.com> 1.5.9-5
473- rebuild with latest docs
474
475* Tue Feb 11 2003 Tammy Fox <tfox@redhat.com>
476- updated docs
477
478* Tue Feb  4 2003 Brent Fox <bfox@redhat.com> 1.5.9-4
479- fall back to IP if we can't resolve it back to a hostname (bug #83463)
480
481* Mon Feb  3 2003 Brent Fox <bfox@redhat.com> 1.5.9-3
482- catch bogus ntp server names and raise a dialog
483
484* Mon Feb  3 2003 Brent Fox <bfox@redhat.com> 1.5.9-2
485- don't change value of ARC accidentally (bug #82281)
486
487* Thu Jan 30 2003 Brent Fox <bfox@redhat.com> 1.5.9-1
488- bump and build
489
490* Wed Jan 29 2003 Brent Fox <bfox@redhat.com> 1.5.8-1
491- use the new Red Hat ntp servers
492
493* Thu Jan 16 2003 Brent Fox <bfox@redhat.com> 1.5.7-6
494- catch error with no NTP server
495
496* Wed Jan 15 2003 Brent Fox <bfox@redhat.com> 1.5.7-5
497- write IPs to the server line instead of domain names (bug #70557)
498
499* Tue Jan 14 2003 Brent Fox <bfox@redhat.com> 1.5.7-4
500- list only stratum 2 ntp servers (bug #81629)
501
502* Fri Jan 10 2003 Brent Fox <bfox@redhat.com> 1.5.7-3
503- better check on ntp status by looking at initscrip return code
504- sent ntp initscript output to /dev/null when calling os.system()
505
506* Thu Jan  9 2003 Brent Fox <bfox@redhat.com> 1.5.7-2
507- change to condrestart
508
509* Fri Jan  3 2003 Brent Fox <bfox@redhat.com> 1.5.7-1
510- create a TUI to replace timeconfig
511- obsolete timeconfig
512
513* Thu Jan  2 2003 Brent Fox <bfox@redhat.com> 1.5.6-3
514- write an ipaddress for the restrict line (bug #80593)
515
516* Mon Dec 23 2002 Brent Fox <bfox@redhat.com> 1.5.6-2
517- handle missing ntpservers file
518- don't pass in parent, it breaks firstboot
519- handle busted ntp initscript
520
521* Fri Dec 13 2002 Brent Fox <bfox@redhat.com> 1.5.5-2
522- Print an error message if run from the console
523
524* Fri Nov 15 2002 Brent Fox <bfox@redhat.com> 1.5.5-1
525- Handle empty server lines in /etc/ntp.conf
526
527* Tue Nov 12 2002 Brent Fox <bfox@redhat.com> 1.5.4-2
528- Rebuild with latest translations
529
530* Wed Oct 30 2002 Brent Fox <bfox@redhat.com>
531- Add a build requires for python-tools
532
533* Fri Oct 25 2002 Brent Fox <bfox@redhat.com> 1.5.4-1
534- Write out an appropriate restrict line to /etc/ntp.conf
535- Fixes bug 70557
536
537* Tue Oct 22 2002 Brent Fox <bfox@redhat.com> 1.5.3-1
538- Apply patch from katzj to fix bug 76313
539- Fix bug 72149 correctly this time (hopefully)
540
541* Mon Oct 14 2002 Brent Fox <bfox@redhat.com> 1.5.2-12
542- Move ntpservers file into /etc/ntp.  Fixes bug 74339
543
544* Thu Oct 10 2002 Brent Fox <bfox@redhat.com> 1.5.2-11
545- Fix bug 72149.  Always apply timezone changes
546- Fix bug 73498.  Apply UTC changes properly
547
548* Tue Sep 03 2002 Brent Fox <bfox@redhat.com> 1.5.2-10
549- convert desktop file to UTF8
550- pull in latest translations
551
552* Fri Aug 30 2002 Brent Fox <bfox@redhat.com> 1.5.2-9
553- run chkconfig on starting/stopping ntpd
554
555* Thu Aug 29 2002 Brent Fox <bfox@redhat.com> 1.5.2-8
556- set the flag to close parent on non-NTP setups
557- create an updateSpinButton function
558
559* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.5.2-7
560- Retrieve the only the first NTP server if there's more than one
561- Only modify the first server entry if there's more than one
562
563* Tue Aug 27 2002 Brent Fox <bfox@redhat.com> 1.5.2-6
564- Handle the case of having no server line in ntp.conf
565
566* Mon Aug 26 2002 Brent Fox <bfox@redhat.com> 1.5.2-5
567- Raise error dialogs if NTP servers can't be contacted
568
569* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.5.2-4
570- pull translation domains from rhpl
571
572* Wed Aug 21 2002 Brent Fox <bfox@redhat.com> 1.5.2-3
573- Fix timezone selection bug
574
575* Mon Aug 19 2002 Brent Fox <bfox@redhat.com> 1.5.2-2
576- Convert desktop file to UTF-8
577
578* Mon Aug 19 2002 Brent Fox <bfox@redhat.com> 1.5.2-1
579- Limit ping timeout to 5 seconds.  We need a better solution for this in the future
580
581* Tue Aug 13 2002 Brent Fox <bfox@redhat.com> 1.5.1-2
582- Make spin buttons keyboard sensitive.  Fixes bug 68967
583
584* Mon Aug 12 2002 Tammy Fox <tfox@redhat.com> 1.5.1-1
585- replace System with SystemSetup in desktop file categories
586
587* Tue Aug 06 2002 Brent Fox <bfox@redhat.com> 1.5-2
588- use template ntp.conf file if the original has been removed for some reason
589
590* Mon Aug 05 2002 Brent Fox <bfox@redhat.com> 1.5-1
591- Fix translations for timezone list
592
593* Fri Aug 02 2002 Brent Fox <bfox@redhat.com> 1.4-8
594- Use new pam timestamp rules
595
596* Wed Jul 31 2002 Brent Fox <bfox@redhat.com>1.4-7
597- Put an end-of-line in /etc/ntp/step-tickers
598
599* Thu Jul 25 2002 Brent Fox <bfox@redhat.com> 1.4-6
600- Default to New York if the timezone in /etc/sysconfig/clock is bogus
601
602* Wed Jul 24 2002 Brent Fox <bfox@redhat.com> 1.4-5
603- Fixed console file bad link
604
605* Tue Jul 23 2002 Tammy Fox <tfox@redhat.com> 1.4-4
606- Change desktop file name (bug #69470)
607- Spec file fixes
608
609* Thu Jul 18 2002 Brent Fox <bfox@redhat.com> 1.4-3
610- Update for pygtk2 API change
611
612* Wed Jul 17 2002 Brent Fox <bfox@redhat.com> 1.4-2
613- Fix padding problem
614
615* Fri Jul 12 2002 Tammy Fox <tfox@redhat.com> 1.4-1
616- Updated docs for gtk2 interface
617- Add note about security level and ntpd (bug #68039)
618- Move desktop file to /usr/share/applications only
619
620* Thu Jul 11 2002 Brent Fox <bfox@redhat.com> 1.3-4
621- Remove some lingering references to dateconfig
622- Create symbolic link from dateconfig to redhat-config-date
623
624* Wed Jul 10 2002 Brent Fox <bfox@redhat.com> 1.3-1
625- Rename dateconfig to redhat-config-date
626- Check to see if we can ping ntp server before starting ntpd
627
628* Tue Jul 9 2002 Brent Fox <bfox@redhat.com> 1.2-1
629- Pull out ntp servers into a separate file
630- Write /etc/ntp/step-tickers file
631
632* Mon Jul 1 2002 Brent Fox <bfox@redhat.com> 1.1-3
633- If an NTP server is already specified, add it to the combo list
634
635* Fri Jun 28 2002 Brent Fox <bfox@redhat.com> 1.1-2
636- Changed spacing of buttons on bottom of the window
637
638* Thu Jun 27 2002 Tammy Fox <tfox@redhat.com> 1.1-2
639- Added border widths to clean up interface
640- Hooked up help
641- Removed Apply button
642
643* Thu Jun 27 2002 Brent Fox <bfox@redhat.com> 1.1-1
644- Updated pot file and respective po files
645
646* Sat Jun 22 2002 Brent Fox <bfox@redhat.com> 1.0.3-1
647- Fixed bug 66655
648- Fixed problem with selecting the current timezone in timezone_gui
649
650* Mon Jun 17 2002 Brent Fox <bfox@redhat.com> 1.0.2-1
651- Reenable the icon
652
653* Thu May 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-5
654- Fixed translation bug
655
656* Thu May 30 2002 Brent Fox <bfox@redhat.com> 1.0.1-4
657- Removed Requires for pygnome
658
659* Mon May 20 2002 Brent Fox <bfox@redhat.com> 1.0.1-3
660- Pulled in documentation bugfix for bug #65228
661
662* Mon May 13 2002 Brent Fox <bfox@redhat.com>
663- Added Swedish translations to desktop file from menthos@menthos.com
664
665* Thu May 2 2002 Brent Fox <bfox@redhat.com> 1.0.1-2
666- Update for timezone translations
667
668* Mon Apr 15 2002 Trond Eivind Glomsrød <teg@redhat.com> 1.0.1-1
669- Update for translations
670
671* Mon Feb 25 2002 Brent Fox <bfox@redhat.com>
672- Bump version to 1.0
673
674* Tue Feb 12 2002 Brent Fox <bfox@redhat.com>
675- Finished port to Python2.2/GTK2
676- Handle starting ntpd more gracefully
677- Made variable naming more consistent
678
679* Tue Jan 22 2002 Brent Fox <bfox@redhat.com>
680- Replaced C code for timezone map with Python from anaconda
681- Remove timezonemapmodule from /usr/lib/dateconfig
682
683* Thu Oct 18 2001 Brent Fox <bfox@redhat.com>
684- Put timezonemapmodule in /usr/lib/dateconfig
685
686* Thu Aug 30 2001 Trond Eivind Glomsrød <teg@redhat.com> 0.7.4-6
687- Fix some character sets for translations (#52851)
688- dateconfig.png isn't a config file, mark the config files as noreplace
689
690* Mon Aug 27 2001 Tammy Fox <tfox@redhat.com>
691- Updated docs for UTC button
692
693* Thu Aug 16 2001 Brent Fox <bfox@redhat.com>
694- Fix sizing for non-US languages
695
696* Mon Aug 6 2001 Brent Fox <bfox@redhat.com>
697- added redhat-config-time and redhat-config-date scripts
698
699* Fri Aug 3 2001 Brent Fox <bfox@redhat.com>
700- created an icon
701- fixed install process to install icon and drop a file in /etc/X11/sysconfig
702
703* Fri Aug  3 2001 Preston Brown <pbrown@redhat.com>
704- set hardware clock as well.
705
706* Fri Jul 27 2001 Yukihiro Nakai <ynakai@redhat.com>
707- Add Japanese translation.
708
709* Fri Jul 20 2001 Tammy Fox <tfox@redhat.com>
710- added i18n stuff
711* Wed Jul 04 2001 Karsten Hopp <karsten@redhat.de>
712- fix install-path (INSTROOT)
713* Tue Jun 27 2001 Tammy Fox <tfox@redhat.com>
714- added help and help button
715* Sun Jun 24 2001 Brent Fox <bfox@redhat.com>
716- got starting and stopping of ntpd working
717- enabled detection of whether ntpd is currently running
718- added msf to author list
719* Thu Jun 21 2001 Brent Fox <bfox@redhat.com>
720- fixed problem with system path in timezone_gui.py
721* Wed Jun 13 2001 Tammy Fox <tfox@redhat.com>
722- improved man page
723* Tue Jun 12 2001 Tammy Fox <tfox@redhat.com>
724- added console access, fixed Makefile and spec file
725* Mon Jun 11 2001 Brent Fox <bfox@redhat.com>
726- added ntp section and timezone section
727* Sun Jan 28 2001 Brent Fox <bfox@redhat.com>
728- initial coding and packaging
729
Note: See TracBrowser for help on using the repository browser.