source: projects/specs/trunk/s/system-config-boot/system-config-boot-vl.spec @ 521

Revision 521, 5.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: A graphical interface for configuring the boot loader
2Summary(ja): ブートローダの設定をするためのグラフィカルインタフェース
3Name: system-config-boot
4Version: 0.3.0
5Release: 1%{?_dist_release}
6URL: http://fedoraproject.org/wiki/SystemConfig/boot
7License: GPLv2
8ExclusiveOS: Linux
9Group: Applications/System
10BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
11# This is a Red Hat maintained package which is specific to
12# our distribution.  Thus the source is only available from
13# within this srpm.
14Source0: %{name}-%{version}.tar.bz2
15Requires: pygtk2 python usermode >= 1.36 rhpl
16Requires: usermode-gtk
17ExclusiveArch: %{ix86} x86_64
18BuildRequires: python, gettext, glib2-devel, desktop-file-utils
19BuildRequires: perl-XML-Parser, intltool
20
21%description
22system-config-boot is a graphical user interface that allows
23the user to change the default boot entry of the system.
24
25%prep
26%setup -q
27
28%build
29%configure
30make %{?_smp_mflags}
31
32%install
33rm -rf $RPM_BUILD_ROOT
34
35make install DESTDIR=$RPM_BUILD_ROOT
36
37mkdir $RPM_BUILD_ROOT%{_datadir}/applications
38for i in %{name}.desktop; do \
39  desktop-file-install --vendor system --delete-original       \
40    --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
41    --add-category Settings                                   \
42    --remove-category Application                             \
43    --remove-category SystemSetup                             \
44    $i; \
45done;
46
47
48%find_lang %name
49
50%clean
51rm -rf $RPM_BUILD_ROOT
52
53%files -f %{name}.lang
54%defattr(-,root,root,-)
55%doc COPYING
56%attr(0755,root,root) /usr/bin/system-config-boot
57%attr(0755,root,root) /usr/sbin/system-config-boot
58%dir /usr/share/system-config-boot
59%attr(0644,root,root) /usr/share/system-config-boot/*
60%attr(0644,root,root) /usr/share/pixmaps/*.png
61%attr(0644,root,root) %{_datadir}/applications/*
62%attr(0644,root,root) %config(noreplace) /etc/security/console.apps/system-config-boot
63%attr(0644,root,root) %config(noreplace) /etc/pam.d/system-config-boot
64
65%changelog
66* Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.3.0-1
67- initial build for Vine Linux
68
69* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-4
70- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
71
72* Mon Dec 01 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.3.0-3
73- Rebuild for Python 2.6
74
75* Tue Oct 28 2008 Harald Hoyer <harald@redhat.com> 0.3.0-2
76- reapplied changes by spot
77
78* Tue Oct 28 2008 Harald Hoyer <harald@redhat.com> 0.3.0-1
79- version 0.3.0
80
81* Mon Oct 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.2.21-3
82- add Requires: usermode-gtk
83
84* Mon Sep 08 2008 Harald Hoyer <harald@redhat.com> - 0.2.21-1
85- removed .png from icon entry in the desktop file
86
87* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.2.20-2
88- fix license tag, %%configure and %%files
89
90* Tue Apr 08 2008 Harald Hoyer <harald@redhat.com> - 0.2.20-1
91- translation update
92
93* Tue Feb 26 2008 Harald Hoyer <harald@redhat.com> - 0.2.19-1
94- moved boot_gui.py to /usr/share/system-config-boot/
95
96* Tue Feb 26 2008 Harald Hoyer <harald@redhat.com> - 0.2.18-1
97- removed firstboot dependency
98
99* Thu Sep 20 2007 Harald Hoyer <harald@redhat.com> - 0.2.17-1
100- translation update
101
102* Mon Aug 13 2007 Harald Hoyer <harald@redhat.com> - 0.2.16-1
103- translation update
104- updated URL
105- changed desktop file categories
106
107* Fri Mar 23 2007 Harald Hoyer <harald@redhat.com> - 0.2.15-1
108- specfile cleanups
109
110* Mon Jan 29 2007 Harald Hoyer <harald@redhat.com> - 0.2.14-1
111- more build requirements
112
113* Mon Oct 09 2006 Harald Hoyer <harald@redhat.com> - 0.2.13-1
114- translation update
115- Resolves: rhbz#216607
116
117* Mon Oct 09 2006 Harald Hoyer <harald@redhat.com> - 0.2.12-1
118- translation update (bug #208886, #209188)
119
120* Thu Oct 13 2005 Harald Hoyer <harald@redhat.com> - 0.2.11-1
121- use new config tool pam configuration file
122
123* Thu Oct 13 2005 Harald Hoyer <harald@redhat.com> - 0.2.10-1
124- use firstboot instead of deprecated functions in rhpl
125
126* Thu Mar 31 2005 Harald Hoyer <harald@redhat.com> - 0.2.9-1
127- s/gtk\.TRUE/True/g
128- s/gtk\.FALSE/False/g
129
130* Tue Nov 23 2004 Harald Hoyer <harald@redhat.com> - 0.2.8-1
131- s/gtk.mainquit/gtk.main_quit/g
132
133* Fri Jul 30 2004 Harald Hoyer <harald@redhat.com> - 0.2.7-1
134- added build requirements: Perl-XML-Parser desktop-file-utils
135
136* Wed Apr 21 2004 Harald Hoyer <harald@redhat.com> - 0.2.6-1
137- translation updates (118804)
138
139* Fri Apr  2 2004 Harald Hoyer <harald@redhat.com> - 0.2.5-1
140- translation updates
141- renaming of desktop file
142
143* Mon Mar 15 2004 Harald Hoyer <harald@redhat.com> - 0.2.4-1
144- translation update
145
146* Thu Nov  6 2003 Harald Hoyer <harald@redhat.de> 0.2.0-1
147- changed python version
148
149* Thu Nov 06 2003 Harald Hoyer <harald@redhat.de> 0.1.7-1
150- fixed #109266
151
152* Thu Oct 30 2003 Harald Hoyer <harald@redhat.de> 0.1.6-1
153- fixed #106796
154- added exception handling
155
156* Mon Oct 27 2003 Harald Hoyer <harald@redhat.de> 0.1.5-1
157- fixed conf loading (#106796)
158- i18n update
159
160* Tue Oct 14 2003 Harald Hoyer <harald@redhat.de> 0.1.4-1
161- autofooed and intltoolized r-c-boot
162
163* Wed Oct  8 2003 Harald Hoyer <harald@redhat.de> 0.1.3-1
164- added po files
165
166* Wed Oct  2 2003 Harald Hoyer <harald@redhat.de> 0.1.2-1
167- fixed desktop file
168
169* Fri Aug 22 2003 Harald Hoyer <harald@redhat.de> 0.1.1-1
170- first version
171
Note: See TracBrowser for help on using the repository browser.