source: projects/specs/trunk/s/sysklogd/sysklogd-vl.spec @ 521

Revision 521, 9.5 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:     System logging and kernel message trapping daemons.
2Summary(ja): システムとカーネルのログをログ記録するデーモン
3Name:        sysklogd
4Version:     1.5
5Release:     1%{?_dist_release}
6License:     GPL
7Group:       System Environment/Daemons
8URL:         http://www.infodrom.org/projects/sysklogd/
9Source:      sysklogd-%{version}.tar.gz
10Source1:     sysklogd-%{version}.conf
11Source2:     sysklogd-%{version}.init
12Source3:     sysklogd-%{version}.logrotate
13Source4:     sysklogd-%{version}.sysconfig
14
15BuildRoot:   %{_tmppath}/%{name}-%{version}-root
16PreReq:      coreutils /sbin/chkconfig /etc/init.d
17Requires:    logrotate bash >= 2.0
18Provides:    syslog
19Conflicts:   rsyslog, syslog-ng
20
21%description
22The sysklogd package contains two system utilities (syslogd and klogd)
23which provide support for system logging.  Syslogd and klogd run as
24daemons (background processes) and log system messages to different
25places, like mail logs, security logs, error logs, etc.
26
27%description -l ja
28sysklogd パッケージには syslogd と klogd の 2つのシステムユーティリティが
29収められており,システムロギングの機能を提供します.syslogd と klogd は
30共にデーモン (バックグラウンドプロセス) として動作し,メイル/セキュリティ/
31エラー といった,様々なシステムメッセージを個別のログファイルに出力します.
32
33
34%prep
35%setup -q
36
37
38%build
39make %{?_smp_mflags}
40
41
42%install
43rm -rf $RPM_BUILD_ROOT
44mkdir -p $RPM_BUILD_ROOT{/etc,%{_mandir}/man{5,8},/sbin}
45
46make install prefix=$RPM_BUILD_ROOT \
47        TOPDIR=$RPM_BUILD_ROOT \
48        MANDIR=$RPM_BUILD_ROOT%{_mandir} \
49        BINDIR=$RPM_BUILD_ROOT/sbin \
50        MAN_USER=`id -nu` MAN_GROUP=`id -ng`
51
52mkdir -p $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig}
53
54install -p -m644 %SOURCE1 $RPM_BUILD_ROOT/%{_sysconfdir}/syslog.conf
55install -p -m755 %SOURCE2 $RPM_BUILD_ROOT/etc/rc.d/init.d/syslog
56install -p -m644 %SOURCE3 $RPM_BUILD_ROOT/etc/logrotate.d/sysklogd
57install -p -m644 %SOURCE4 $RPM_BUILD_ROOT/etc/sysconfig/sysklogd
58
59chmod 755 $RPM_BUILD_ROOT/sbin/syslogd
60chmod 755 $RPM_BUILD_ROOT/sbin/klogd
61
62%clean
63rm -rf $RPM_BUILD_ROOT
64
65
66%post
67/sbin/chkconfig --add syslog
68for n in /var/log/{messages,secure,maillog,spooler}
69do
70        [ -f $n ] && continue
71        umask 066 && touch $n
72done
73exit 0
74
75%preun
76if [ $1 = 0 ]; then
77        [ -f /var/lock/subsys/syslog ] &&
78                /sbin/service syslog stop >/dev/null 2>&1 || :
79        /sbin/chkconfig --del syslog
80fi
81exit 0
82
83%postun
84if [ "$1" -ge "1" ]; then
85        /sbin/service syslog condrestart > /dev/null 2>&1 || :
86fi
87exit 0
88
89%triggerpostun -- sysklogd < 1.3.31-17
90/sbin/chkconfig --add syslog || :
91
92%triggerpostun -- sysklogd < 1.3.33-5
93/sbin/chkconfig syslog reset || :
94
95%files
96%defattr(-,root,root)
97%doc ANNOUNCE CHANGES README* NEWS INSTALL COPYING
98%config(noreplace) %{_sysconfdir}/syslog.conf
99%config(noreplace) %{_sysconfdir}/sysconfig/sysklogd
100%config(noreplace) %{_sysconfdir}/logrotate.d/sysklogd
101%{_sysconfdir}/rc.d/init.d/syslog
102/sbin/*
103%{_mandir}/*/*
104
105
106%changelog
107* Sat Mar 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5-1
108- new upstream release
109- drop patch2 (merged in upstream)
110- add Provides: syslog
111- add Conflicts: rsyslog, syslog-ng
112
113* Fri Aug 15 2008 Shu KONNO <owa@bg.wakwak.com> 1.4.1-13vl5
114- applied new versioning policy, spec in utf-8
115
116* Thu Apr 05 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.4.1-13vl3
117- rebuilt with current environment
118- explicitly PreReq: coreutils instead of fileutils
119
120* Sat Jun 05 2004 NISHIMURA Daisuke <nishi@graco.c.u-tokyo.ac.jp> 1.4.1-13vl2
121- bug fix (Patch2) from Mandrake MDKSA-2004:038
122- add URL tag
123- %%description =~ s/sendmail/mail/
124
125* Sat Sep 20 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.1-13vl1
126- based on Redhat Rawhide 1.4.1-13
127- rebuild with new toolchains
128- s/Copyright/License/
129
130* Mon Sep 03 2001 Toru Sagami <sagami@vinelinux.org>
131- 1.4-7vl3: put cron logs in /var/log/cron by disabling the patch
132
133* Sat Jun 16 2001 <sagami@vinelinux.org>
134- 1.4-7vl2: added patch for duplicate log entry for /var/log/cron
135
136* Mon Jun 11 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
137- 1.4-7vl1
138- added Japanese summary and description
139- removed Requires: /etc/init.d for better compatibility with apt
140
141* Wed Feb  7 2001 Bill Nottingham <notting@redhat.com>
142- i18n tweaks
143
144* Tue Jan 23 2001 Bill Nottingham <notting@redhat.com>
145- new translation stuff
146
147* Fri Jan 19 2001 Bill Nottingham <notting@redhat.com>
148- adapt /etc/sysconfig/syslog for specification of arbitrary options (#23171)
149- fix translation string slightly (#24088)
150
151* Mon Dec 18 2000 Bill Nottingham <notting@redhat.com>
152- don't set owner/group on manpages on install
153- read /etc/sysconfig/syslog if present for some configuration paramters
154- fix build with new kernel headers
155
156* Tue Dec 12 2000 Bill Nottingham <notting@redhat.com>
157- start klogd with '-2'
158
159* Mon Dec 11 2000 Bill Nottingham <notting@redhat.com>
160- update to 1.4
161
162* Fri Dec 01 2000 Bill Nottingham <notting@redhat.com>
163- rebuild because of broken fileutils
164
165* Mon Oct 13 2000 Bill Nottingham <notting@redhat.com>
166- don't log cron in two separate places (#18122)
167
168* Thu Sep 14 2000 Bill Nottingham <notting@redhat.com>
169- more fixes from solar@false.com, dan@debian.org; fix the security fix
170
171* Tue Sep 12 2000 Jakub Jelinek <jakub@redhat.com>
172- never ever call syslog with a user supplied string as second argument
173
174* Mon Aug  7 2000 Bill Nottingham <notting@redhat.com>
175- put cron logs in /var/log/cron; rotate them
176
177* Wed Aug  2 2000 Bill Nottingham <notting@redhat.com>
178- start at position 12, not 30 (we *need* to be before nfslock now)
179
180* Fri Jul 28 2000 Bill Nottingham <notting@redhat.com>
181- um, how did %preun get tacked onto %post?
182- fix condrestart stuff
183
184* Fri Jul 21 2000 Bill Nottingham <notting@redhat.com>
185- add a umask call to the initscript
186
187* Fri Jul 14 2000 Bill Nottingham <notting@redhat.com>
188- move initscript back
189
190* Fri Jul 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
191- update to 1.3.33
192
193* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
194- automatic rebuild
195
196* Tue Jul 11 2000 Bill Nottingham <notting@redhat.com>
197- fix logrotate script (#13698)
198
199* Thu Jul  6 2000 Bill Nottingham <notting@redhat.com>
200- prereq /etc/init.d
201
202* Thu Jun 29 2000 Bill Nottingham <notting@redhat.com>
203- fix init script
204
205* Tue Jun 27 2000 Bill Nottingham <notting@redhat.com>
206- require, not prereq new initscripts
207
208* Mon Jun 26 2000 Bill Nottingham <notting@redhat.com>
209- initscript munging
210
211* Wed Jun 14 2000 Nalin Dahyabhai <nalin@redhat.com>
212- modify logrotate configuration to use the PID file
213
214* Sun Jun 11 2000 Bill Nottingham <notting@redhat.com>
215- rebuild in new environment, FHS fixes
216
217* Mon Mar 27 2000 Bill Nottingham <notting@redhat.com>
218- handle bad directories passed to '-a' without behaving strangely (#10363)
219- remove compatibility chkconfig links
220
221* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
222- handle compressed man pages
223
224* Wed Dec  1 1999 Bill Nottingham <notting@redhat.com>
225- add patch to fix segfaults in ksym-less cases from HP
226
227* Mon Nov 15 1999 Bill Nottingham <notting@redhat.com>
228- fix ECONNRESETs from security patch (olaf)
229
230* Fri Sep 25 1999 Bill Nottingham <notting@redhat.com>
231- eek. The security patch broke *two* things...
232
233* Wed Sep 22 1999 Bill Nottingham <notting@redhat.com>
234- make klogd actually work.
235
236* Wed Sep  8 1999 Bill Nottingham <notting@redhat.com>
237- rotate boot.log
238
239* Tue Sep 07 1999 Cristian Gafton <gafton@redhat.com>
240- add patch to fix a possible DoS (thanks Olaf Kirch)
241
242* Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
243- initscript munging
244
245* Mon Aug  9 1999 Bill Nottingham <notting@redhat.com>
246- patch to fix non-null terminated stuff in klogd
247
248* Mon Jun 21 1999 Bill Nottingham <notting@redhat.com>
249- move (sys|k)logd to /sbin
250
251* Tue Apr 13 1999 Bill Nottingham <notting@redhat.com>
252- log boot messages to boot.log
253- actually put the sysklogd links in the new place
254
255* Mon Apr 05 1999 Cristian Gafton <gafton@redhat.com>
256- disable mark ticks by default
257
258* Thu Apr  1 1999 Bill Nottingham <notting@redhat.com>
259- stop klogd/syslogd as late as possible.
260
261* Fri Mar 26 1999 Bill Nottingham <notting@redhat.com>
262- twiddle initscript to avoid confusion
263
264* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
265- auto rebuild in the new build environment (release 2)
266
267* Wed Feb 24 1999 Bill Nottingham <notting@redhat.com>
268- update to sysklogd-1.3-31
269- stop klogd *before* syslogd
270
271* Tue Feb  9 1999 Jeff Johnson <jbj@redhat.com>
272- escape naked percent chars in kernel messages (#1088).
273
274* Thu Dec 17 1998 Jeff Johnson <jbj@redhat.com>
275- rework last-gasp address-in-module oops trace for both 2.0.x/2.1.x modules.
276
277* Mon Dec  7 1998 Jakub Jelinek <jj@ultra.linux.cz>
278- make klogd translate SPARC register dumps and oopses.
279
280* Tue Aug 11 1998 Jeff Johnson <jbj@redhat.com>
281- add %clean
282
283* Tue Aug  4 1998 Chris Adams <cadams@ro.com>
284- only log to entries that are USER_PROCESS (fix #822)
285
286* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
287- remove RPM_BUILD_ROOT from %post
288
289* Wed Apr 29 1998 Cristian Gafton <gafton@redhat.com>
290- patch to support Buildroot
291- package is now buildrooted
292
293* Wed Apr 29 1998 Michael K. Johnson <johnsonm@redhat.com>
294- Added exit patch so that a normal daemon exit is not flagged as an error.
295
296* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
297- translations modified for de, fr, tr
298
299* Wed Oct 29 1997 Donnie Barnes <djb@redhat.com>
300- added (missingok) to init symlinks
301
302* Thu Oct 23 1997 Donnie Barnes <djb@redhat.com>
303- added status|restart support to syslog.init
304- added chkconfig support
305- various spec file cleanups
306
307* Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
308- built against glibc
Note: See TracBrowser for help on using the repository browser.