source: projects/specs/trunk/s/synfig/synfig-vl.spec @ 11362

Revision 11362, 4.2 KB checked in by ara_t, 6 years ago (diff)

rebuild under libboost-1.66.0

Line 
1%define pkg_version 1.0.2
2%define pkg_release 2%{?_dist_release}
3
4Summary:        Vector animation rendere
5Name:           synfig
6Version:        %{pkg_version}
7Release:        %{pkg_release}
8
9Source0:        %{name}-%{version}.tar.gz
10
11# imported from debian sid
12Patch0:         c++11.patch
13Patch1:         no-mod_ffmpeg.patch
14
15License:        GPLv2
16Group:          Applications/Graphics
17URL:            http://www.synfig.org/cms/
18
19BuildRoot:      %{_tmppath}/%{name}-%{version}-root
20
21BuildRequires:  ETL-devel >= 0.04.17
22BuildRequires:  cairo-devel
23BuildRequires:  pango-devel
24BuildRequires:  fontconfig-devel
25BuildRequires:  freetype2-devel
26BuildRequires:  ImageMagick-c++-devel
27BuildRequires:  libxml++-devel
28BuildRequires:  libjpeg-turbo-devel
29BuildRequires:  libmng-devel
30BuildRequires:  libpng-devel
31BuildRequires:  libtool-ltdl-devel
32BuildRequires:  libtool
33BuildRequires:  libboost-devel
34BuildRequires:  libboost-program-options
35BuildRequires:  libboost-system
36BuildRequires:  libboost-filesystem
37BuildRequires:  libboost-chrono
38BuildRequires:  libsigc++-devel
39BuildRequires:  libtiff-devel
40BuildRequires:  OpenEXR-devel
41BuildRequires:  autoconf automake gettext-devel
42BuildRequires:  mlt-devel fftw3-devel
43# FIXME: Lack of this causes synfig to segfault
44Requires:       urw-fonts
45
46Vendor: Project Vine
47Distribution: Vine Linux
48Packager: Takemikaduchi
49
50
51%description
52synfig is a vector based 2D animation package. It is designed to be
53capable of producing feature-film quality animation. It eliminates the
54need for tweening, preventing the need to hand-draw each frame. synfig
55features spatial and temporal resolution independence (sharp and smooth
56at any resolution or framerate), high dynamic range images, and a
57flexible plugin system.
58
59This package contains the renderer used to convert synfig .sif files to
60raster images, videos and other formats. Layer types include geometric,
61gradient, filter, distortion, transformation, fractal and others. Output
62targets include JPEG, PNG, GIF, BMP, PPM, DV, OpenEXR, ffmpeg (MPEG1),
63libavcodec (AVI), imagemagick (MIFF), yuv420p, MNG and others.
64
65
66%package                devel
67Summary:        Development files for synfig
68Group:          Development/Libraries
69Requires:       %{name} = %{version}-%{release}
70Requires:       pkgconfig
71
72%description    devel
73This package contains the libraries and header files that are needed
74for writing applications that are using synfig.
75
76
77%prep
78%setup -q
79%patch0 -p1
80%patch1 -p1
81
82%build
83export CXXFLAGS="%{optflags} -std=c++11"
84%configure \
85        --disable-static
86
87%{__make} %{?_smp_mflags}
88
89%install
90%{__rm} -rf $RPM_BUILD_ROOT
91%{__make} install DESTDIR=$RPM_BUILD_ROOT
92
93find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
94
95%find_lang %{name}
96
97%clean
98%{__rm} -rf $RPM_BUILD_ROOT
99
100%post -p /sbin/ldconfig
101
102%postun -p/sbin/ldconfig
103
104%files -f %{name}.lang
105%defattr(-,root,root,-)
106%license COPYING
107%doc AUTHORS ChangeLog NEWS README
108%{_sysconfdir}/synfig_modules.cfg
109%{_bindir}/synfig
110%{_libdir}/libsynfig.so.*
111%{_libdir}/synfig/modules/*.so
112
113%files devel
114%defattr(-,root,root,-)
115%{_bindir}/synfig-config
116%{_includedir}/synfig-1.0
117%{_libdir}/libsynfig.so
118%{_libdir}/pkgconfig/synfig.pc
119
120
121%changelog
122* Mon Jan 08 2018 Toshiaki Ara <ara_t@384.jp> 1.0.2-2
123- rebuild with libboost-1.66.0
124
125* Sun Jul 10 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.2-1
126- new upstream release.
127
128* Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.64.2-2
129- rebuild with ImageMagick-6.9.1.4
130
131* Mon Dec 01 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.64.2-1
132- new upstream release
133
134* Wed Jul 02 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.64.1-3
135- rebuild with ImageMagick-6.8.9.5
136- add Patch0 (synfig-0.64.1-mod_png.patch)
137
138* Tue Dec 31 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.64.1-2
139- rebuild with icu-52.1
140
141* Sun Dec 08 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.64.1-1
142- new upstream release
143
144* Wed Aug 14 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.64.0-1
145- new upstream release
146- add BuildRequires: pango-devel, libboost-devel, libboost-program-options
147
148* Mon Apr 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.63.05-1
149- new upstream release
150
151* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.63.04-1
152- new upstream release
153
154* Sun Dec 25 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.63.03-1
155- new upstream release
156
157* Sat Oct 08 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.63.02-1
158- initial build for Vine Linux
159
Note: See TracBrowser for help on using the repository browser.