source: projects/specs/trunk/s/synaptic/synaptic-vl.spec @ 521

Revision 521, 15.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Name: synaptic
2Version: 0.57.2
3Release: 11%{?_dist_release}
4Summary: GTK based graphical front-end for APT
5Summary(ja): GTK ベースの APT グラフィカルフロントエンド
6Group: Applications/Administration
7License: GPL
8
9Source0: %{name}-%{version}.tar.gz
10Source10: synaptic-0.57.2-ja.po
11Source20: synaptic-dummy-grouplist.txt
12Source30: package-supported.png
13
14Patch1: synaptic-0.57.2-gcc41.patch
15Patch2: synaptic-0.57.2-repomd-1.patch
16Patch3: synaptic-0.57.2-showprog.patch
17Patch4: synaptic-0.57.2-progressapi-hack.patch
18Patch5: synaptic-0.57.2-gcc43.patch
19Patch6: synaptic-0.57.2-gcc44.patch
20
21Patch10: synaptic-0.56-desktopfile.patch
22Patch11: synaptic-0.57.2-no-utf8-help.patch
23Patch13: synaptic-0.57.2-apt-cdrom.patch
24Patch14: synaptic-0.57.2-prefer-normal-upgrade.patch
25Patch15: synaptic-0.57.2-default-size.patch
26Patch16: synaptic-0.57.2-firefox.patch
27Patch20: synaptic-dummy-grouplist.patch
28
29Patch21: synaptic-0.57.2-convert-eucjp-to-utf8.patch
30Patch22: synaptic-0.57.2-fix-memory-corruption.patch
31Patch23: synaptic-0.57.2-fix-assertion-failure.patch
32Patch24: synaptic-0.57.2-no-skip-taskbar.patch
33Patch25: synaptic-0.57.2-add-default-filters.patch
34Patch26: synaptic-0.57.2-fix-repository-updown.patch
35Patch27: synaptic-0.57.2-fix-crash-on-font-change.patch
36
37Requires: apt >= 0.5.15lorg3.93-0vl1
38Requires: usermode >= 1.69
39BuildRequires: bzip2-devel, zlib-devel
40BuildRequires: rpm-devel >= 4.8
41BuildRequires: apt-devel >= 0.5.15lorg3.95
42BuildRequires: gtk2-devel >= 2.4.0
43BuildRequires: libglade2-devel >= 2.0.1
44BuildRequires: vte-devel >= 0.11.10
45BuildRequires: xmlto
46BuildRequires: scrollkeeper
47BuildRequires: perl-XML-Parser
48BuildRoot: %{_tmppath}/%{name}-%{version}-root
49
50Vendor: Project Vine
51Distribution: Vine Linux
52Packager: daisuke
53
54
55%description
56Synaptic is a graphical front-end for APT (Advanced Package Tool). This
57version is written with the Gtk toolkit.
58
59Instead of using trees to display packages, Synaptic is heavily based on a
60powerful package filtering system. That greatly simplifies the interface
61while giving a lot more flexibility to browse through very long package
62lists.
63
64%description -l ja
65Synaptic は APT(Advanced Package Tool) の Gtk+ ベースのグラフィカル
66フロントエンドです。Synaptic はパッケージを単純にツリー表示するのでは
67なく、強力なパッケージフィルタリングシステムを用いてパッケージを表示
68しています。
69
70
71%prep
72%setup -q
73%patch1 -p1
74%patch2 -p1
75%patch3 -p1
76%patch4 -p1
77%patch5 -p1
78%patch6 -p1
79%patch10 -p1
80%patch11 -p1
81#%patch12 -p1
82%patch13 -p1
83%patch14 -p1
84%patch15 -p1
85%patch16 -p1
86%patch20 -p1
87%patch21 -p1
88%patch22 -p1
89%patch23 -p1
90%patch24 -p1
91%patch25 -p1
92%patch26 -p1
93%patch27 -p1
94
95cp -f po/ja.po po/ja.po.orig
96cp -f %{SOURCE10} po/ja.po
97
98cp -f %{SOURCE20} .
99
100cp -f %{SOURCE30} pixmaps/
101
102%build
103%configure --with-pkg-hold --with-vte --enable-scripts --disable-dependency-tracking
104make -C po update-po
105make %{?_smp_mflags}
106
107%install
108rm -fr %{buildroot}
109%makeinstall
110
111# usermode setting
112mkdir -p %{buildroot}%{_bindir}
113mkdir -p %{buildroot}%{_sysconfdir}/security/console.apps
114mkdir -p %{buildroot}%{_sysconfdir}/pam.d
115ln -s %{_bindir}/consolehelper %{buildroot}%{_bindir}/synaptic
116cat << EOF > %{buildroot}%{_sysconfdir}/security/console.apps/synaptic
117USER=root
118PROGRAM=%{_sbindir}/synaptic
119SESSION=true
120FALLBACK=false
121EOF
122cat << EOF > %{buildroot}%{_sysconfdir}/pam.d/synaptic
123#%PAM-1.0
124auth       sufficient   pam_rootok.so
125auth       sufficient   pam_timestamp.so
126auth       include      system-auth
127session    required     pam_permit.so
128session    optional     pam_xauth.so
129session    optional     pam_timestamp.so
130account    required     pam_permit.so
131EOF
132
133desktop-file-install --vendor=synaptic          \
134  --delete-original                             \
135  --dir %{buildroot}%{_datadir}/applications    \
136  --remove-key MultipleArgs                     \
137  --add-category Application                    \
138  --add-category System                         \
139  --add-category Settings                       \
140  %{buildroot}%{_datadir}/applications/%{name}.desktop
141
142# install japanese manpage
143mkdir -p %{buildroot}%{_mandir}/ja/man8/
144install man/synaptic.ja.8 %{buildroot}%{_mandir}/ja/man8/synaptic.8
145
146# remove uninstalled files
147rm -rf %{buildroot}/%{_localstatedir}/scrollkeeper
148rm -rf %{buildroot}/%{_sysconfdir}/X11
149rm -rf %{buildroot}/%{_datadir}/applications/%{name}-kde.desktop
150
151%clean
152rm -rf %{buildroot}
153
154
155%files
156%defattr(-,root,root)
157%doc COPYING* README* TODO
158%attr(755,root,root) %{_sbindir}/synaptic
159%attr(755,root,root) %{_bindir}/synaptic
160%{_sysconfdir}/security/console.apps/synaptic
161%{_sysconfdir}/pam.d/synaptic
162%{_datadir}/locale/*/LC_MESSAGES/%{name}.mo
163%{_datadir}/%{name}
164%{_datadir}/applications/%{name}.desktop
165%{_datadir}/pixmaps/%{name}.png
166%{_datadir}/omf/synaptic/*.omf
167%{_datadir}/gnome/help/synaptic
168%{_mandir}/man8/*
169%{_mandir}/ja/man8/*
170
171%changelog
172* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.57.2-11
173- rebuilt with rpm-4.8.0-3 (on ppc)
174
175* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-10
176- rebuild with rpm-4.8.0
177
178* Fri Aug 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-9
179- add %Patch26: fix segfault when changing repository order
180  <BTS:VineLinux:0645>
181- add %Patch27: fix crash when changing fonts <BTS:VineLinux:0751>
182
183* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-8
184- add %Patch25: add custom filter for multiple verision package
185- update Source10: add translation in ja.po
186- update Patch24: not to skip multiple version warning dialog
187
188* Sat Jul 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-7
189- add Patch24: don't skip taskbar when main window is hidden
190
191* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-6
192- add Patch23: fix assertion failure on gtk_widget_hide
193
194* Sun Jun 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-5
195- add Patch21: fix memory corruption bug.
196- add Patch22: convert EUC text to UTF-8
197
198* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-4
199- update ja.po
200- don't apply patch12
201
202* Tue Jul 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-3
203- update pam.d/synaptic for pam-1.0
204
205* Fri May 16 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.57.2-2
206- add BuildRequires perl-XML-Parser
207
208* Sat May 10 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-1
209- apply new versioning policy
210- rebuild with apt-0.5.15lorg3.94a
211
212* Wed Nov 21 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl18
213- add "Applications/Accessories" and "Restricted Software" to grouplist
214- update ja.po
215
216* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl17
217- add Patch2,3,4 to support apt-0.5.15lorg3.93
218- renumber Patch16 to Patch1
219- add Patch16 to use firefox instead of mozilla
220
221* Sun Oct 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl16
222- rebuild with apt-0.5.15lorg3.93
223
224* Sun Oct 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl15
225- rebuild with rpm-4.4.2.2
226
227* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl14
228- rebuild with new environment
229- add patch16 to build with gcc4
230- add SOURCE30 to use vine icon for package-supported.png
231
232* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl13
233- rebuild with vte-0.16
234
235* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl12
236- add Patch15 to modify default windows size and treeview font size
237
238* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl11
239- add Patch14 to change default upgrade method to normal upgrade
240  instead of dist-upgrade.
241
242* Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.57.2-0vl10
243- update required-version of apt (>= 0.5.15lorg3.2-0vl7)
244  - comes from libapt-pkg(MountCdrom) API change
245
246* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl9
247- add Patch13 for libapt-pkg(MountCdrom) API change.
248
249* Tue Sep 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl8
250- add Patch12 to fix broken summary and descriptions on UTF-8 locale.
251  - convert rpm summaries and descriptions to UTF-8 from EUC-JP.
252
253* Wed Aug 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.57.2-0vl7
254- add BuildRequires: scrollkeeper
255
256* Sun May 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.57.2-0vl6
257- rebuilt with apt-0.5.15org3.1
258
259* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl5
260- add Patch11 to use locale to show help messages instead of utf-8.
261
262* Tue Apr 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl4
263- rebuild with new apt
264- change Group to Applications/Administration
265
266* Sat Feb 11 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-0vl3
267- update ja.po from [VineSeed:10523] etc...
268
269* Sat Feb 11 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-0vl2
270- update ja.po
271
272* Fri Dec 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl1
273- new upstream release
274- update ja.po
275- build with rpm-4.4
276
277* Sun May 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56-0vl1
278- new upstream release
279
280* Thu Apr 07 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56-0vl0
281- new upstream version (0.56beta)
282
283* Thu Nov 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.55.1-0vl1
284- new upstream release
285
286* Tue Nov 02 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.55-0vl1
287- new upstream release
288- update ja.po
289
290* Mon Nov 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.4-0vl1
291- new upstream release
292- update ja.po
293
294* Sun Aug 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53-0vl1
295- new upstream release
296- update ja.po
297
298* Tue Jul 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52-0vl1
299- new upstream release
300
301* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl3
302- do not run automake/autoconf in %%build
303
304* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl2
305- add japanese man page.
306
307* Wed Jun 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl1
308- new upstream release
309
310* Tue Jun 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl2
311- more update ja.po
312
313* Tue Jun 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
314- new upstream release
315- update ja.po (merged cvs head)
316- add patch10 to fix 'filter' on non-UTF8 locale (merged in cvs head)
317
318* Sat Apr 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48.2-0vl1
319- new upstream release
320- remove obsolete ja.po that is included in upstream
321
322* Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48.1-0vl1
323- new upstream release
324- update ja.po
325- add BuildRequires: xmlto to build manuals.
326
327* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48-0vl0.2
328- new upstream test release
329  - fix desktopfile to use usermode instead of gksu.
330
331* Thu Dec 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0vl1
332- new upstream release
333  - Fixed many i18n issues (thanks to Ales Kapica and Jean-Michel Poure)
334  - New Czech, Arabic translation
335  - Updated Polish,Spanish,French,Japanese,Chinese,German translation
336  - Minor documentation updates
337  - Reworked the context menu for packages
338  - Some ui improvements in the common tab
339  - Use units according to the SI spec now
340  - New summary window
341  - A lot of minor bug and typo fixes
342
343* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0vl0
344- new upstream pre release
345
346* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-0vl1
347- new upstream release
348  - font selection added for default interface font and terminal
349  - better support for translated descriptions (thanks johnnybgate)
350  - dist-upgrade is gone from the menu, the user is asked what kind of
351    upgrade he wants now
352  - toolbar has a new style (text beside buttons) now
353  - real docbook help added (yeah! thanks SEBASTIAN)
354  - "hold" button gone from the gui, moved to menü
355  - sections can translated and a more descriptive description is used
356  - rpm-src-dir support added (thanks to Panu Matilainen)
357
358* Sun Oct 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45-0vl1
359- fixed kanji code in spec file..
360- new upstream release
361  - proxy can be configured with the gui now
362  - new preferences dialog layout (thanks Sebastian Heinlein)
363  - new filter dialog layout  (thanks Sebastian Heinlein)
364  - when adding filter, they are called "New Filter 1", "New Filter 2" etc
365  - added "search lack", so that the interactive search does not start
366    immediately
367  - new quit dialog
368  - speedup for the pattern filters
369  - small ui-enhancements in the filter dialog
370  - basic support for distribution selection (if you have more than one
371    distro in your sources.list, you can choose which to use by default)
372  - new about dialog (thanks Sebastian)
373  - support to choose between different versions of a given package
374  - updated japanese, chinese, polish, spanish, russian, frensh, german
375    and italian translations
376               
377* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.44-0vl1
378- new upstream release
379  - two alternative main layouts can be choosen now
380  - "clean cache now" implemented" in preferences window
381  - the search entry in the main window is interactive again
382  - much improved preferences dialog (thanks to Sebastian Heinlein)
383  - new italian, spanish, russian, chinese translation
384  - new belarussian translation
385  - improved main window design (thanks Sebastian Heinlein)
386  - added "rpm-dir" repository support (thanks Panu)
387  - prepeared a lot of strings for better i18n (thanks Jean-Michel POURE)
388
389* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.44-0vl0.pre3
390- new upstream snapshot release
391
392* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43.1-0vl1
393- new upstream release
394  - the descriptionParser for rpm has changed
395    (the actuall parser is configurable now)
396  - new find and changes dialog layout, more HIG compliant
397  - more bugfixes in the PkgTreeView and the new sorting code
398
399* Tue Aug 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.42-0vl1
400- new upstream release
401  - download percentage is now always calculated correctly
402  - save selection on "pin", "update" and "proceed" now
403  - some bugs fixed in the new sortable tree/list
404  - the order of the columns in the treeview is configurable now
405  - updated german/spanish/japanese/russian translation
406  - [debian only] debian package tags support
407  - sortable installed size column added
408  - "Information" tab now scrollable
409
410* Wed Jul 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.40-0vl1
411- new upstream release
412
413* Tue Jul  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.39-0vl2
414- remove BuildRequires: libzvt
415
416* Sat Jul  5 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.39-0vl1
417- new upstream release
418- update ja.po
419
420* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.38-0vl2
421- update ja.po
422
423* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.38-0vl1
424- new upstream release
425
426* Thu Jun 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.37-0vl1
427- new upstream release
428
429* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.36.1-0vl1
430- new upstream release
431
432* Thu Apr 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.36-0vl1
433- new upstream release 0.36
434- fixed usermode configuration file.
435
436* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35.1-0vl2
437- rebuild with apt-0.5.5.cnc.5-0vl1
438
439* Wed Apr  2 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35.1-0vl1
440- new upstream release 0.35.1
441- drop obsolete patch0 which included in upstream.
442- add modified synaptic.desktop entry.
443
444* Mon Mar 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35-0vl2
445- add patch0 to fix compilation failure on apt-rpm.
446- add ja.po and patch10.
447
448* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35-0vl1
449- new upstream release
450
451* Fri Mar 28 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32-0vl1
452- initial release.
453
Note: See TracBrowser for help on using the repository browser.