source: projects/specs/trunk/s/synaptic/synaptic-vl.spec @ 6932

Revision 6932, 16.6 KB checked in by daisuke, 12 years ago (diff)

synaptic

  • add patch to fix crash in "Lock package"
Line 
1Name: synaptic
2Version: 0.57.2
3Release: 21%{?_dist_release}
4Summary: GTK based graphical front-end for APT
5Summary(ja): GTK ベースの APT グラフィカルフロントエンド
6Group: Applications/Administration
7License: GPL
8
9Source0: %{name}-%{version}.tar.gz
10Source10: synaptic-0.57.2-ja.po
11Source20: synaptic-dummy-grouplist.txt
12Source30: package-supported.png
13
14Patch1: synaptic-0.57.2-gcc41.patch
15Patch2: synaptic-0.57.2-repomd-1.patch
16Patch3: synaptic-0.57.2-showprog.patch
17Patch4: synaptic-0.57.2-progressapi-hack.patch
18Patch5: synaptic-0.57.2-gcc43.patch
19Patch6: synaptic-0.57.2-gcc44.patch
20Patch7: synaptic-0.57.2-gcc45.patch
21
22Patch10: synaptic-0.56-desktopfile.patch
23Patch11: synaptic-0.57.2-no-utf8-help.patch
24Patch13: synaptic-0.57.2-apt-cdrom.patch
25Patch14: synaptic-0.57.2-prefer-normal-upgrade.patch
26Patch15: synaptic-0.57.2-default-size.patch
27Patch16: synaptic-0.57.2-firefox.patch
28Patch20: synaptic-dummy-grouplist.patch
29
30Patch21: synaptic-0.57.2-convert-eucjp-to-utf8.patch
31Patch22: synaptic-0.57.2-fix-memory-corruption.patch
32Patch23: synaptic-0.57.2-fix-assertion-failure.patch
33Patch24: synaptic-0.57.2-no-skip-taskbar.patch
34Patch25: synaptic-0.57.2-add-default-filters.patch
35Patch26: synaptic-0.57.2-fix-repository-updown.patch
36Patch27: synaptic-0.57.2-fix-crash-on-font-change.patch
37Patch28: synaptic-0.57.2-fix-reinstall.patch
38Patch29: synaptic-0.57.2-fix-crash-in-lock-package.patch
39
40Patch100: synaptic-0.57.2-build-with-rpm-4.9.patch
41
42Requires: apt >= 0.5.15lorg3.93-0vl1
43Requires: usermode >= 1.69
44BuildRequires: bzip2-devel, zlib-devel
45BuildRequires: rpm-devel >= 4.8
46BuildRequires: apt-devel >= 0.5.15lorg3.95
47BuildRequires: gtk2-devel >= 2.4.0
48BuildRequires: libglade2-devel >= 2.0.1
49BuildRequires: vte-devel >= 0.11.10
50BuildRequires: xmlto
51BuildRequires: scrollkeeper
52BuildRequires: perl-XML-Parser
53BuildRequires: desktop-file-utils
54BuildRoot: %{_tmppath}/%{name}-%{version}-root
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60
61%description
62Synaptic is a graphical front-end for APT (Advanced Package Tool). This
63version is written with the Gtk toolkit.
64
65Instead of using trees to display packages, Synaptic is heavily based on a
66powerful package filtering system. That greatly simplifies the interface
67while giving a lot more flexibility to browse through very long package
68lists.
69
70%description -l ja
71Synaptic は APT(Advanced Package Tool) の Gtk+ ベースのグラフィカル
72フロントエンドです。Synaptic はパッケージを単純にツリー表示するのでは
73なく、強力なパッケージフィルタリングシステムを用いてパッケージを表示
74しています。
75
76
77%prep
78%setup -q
79%patch1 -p1
80%patch2 -p1
81%patch3 -p1
82%patch4 -p1
83%patch5 -p1
84%patch6 -p1
85%patch7 -p1
86%patch10 -p1
87%patch11 -p1
88#%patch12 -p1
89%patch13 -p1
90%patch14 -p1
91%patch15 -p1
92%patch16 -p1
93%patch20 -p1
94%patch21 -p1
95%patch22 -p1
96%patch23 -p1
97%patch24 -p1
98%patch25 -p1
99%patch26 -p1
100%patch27 -p1
101%patch28 -p1
102%patch29 -p1
103
104%if "%{_dist_release}" >= "vl7"
105%patch100 -p1
106%endif
107
108cp -f po/ja.po po/ja.po.orig
109cp -f %{SOURCE10} po/ja.po
110
111cp -f %{SOURCE20} .
112
113cp -f %{SOURCE30} pixmaps/
114
115%build
116libtoolize --force --copy
117autoconf
118%configure --with-pkg-hold --with-vte --enable-scripts=yes --disable-dependency-tracking
119make -C po update-po
120make %{?_smp_mflags}
121
122%install
123rm -fr %{buildroot}
124%makeinstall
125
126# usermode setting
127mkdir -p %{buildroot}%{_bindir}
128mkdir -p %{buildroot}%{_sysconfdir}/security/console.apps
129mkdir -p %{buildroot}%{_sysconfdir}/pam.d
130ln -s %{_bindir}/consolehelper %{buildroot}%{_bindir}/synaptic
131cat << EOF > %{buildroot}%{_sysconfdir}/security/console.apps/synaptic
132. config-util
133PROGRAM=%{_sbindir}/synaptic
134SESSION=true
135EOF
136cat << EOF > %{buildroot}%{_sysconfdir}/pam.d/synaptic
137#%PAM-1.0
138auth        include     config-util
139account     include     config-util
140session     include     config-util
141EOF
142
143desktop-file-install --vendor=synaptic          \
144  --delete-original                             \
145  --dir %{buildroot}%{_datadir}/applications    \
146  --remove-key MultipleArgs                     \
147  --add-category Application                    \
148  --add-category System                         \
149  --add-category Settings                       \
150  %{buildroot}%{_datadir}/applications/%{name}.desktop
151
152# install japanese manpage
153mkdir -p %{buildroot}%{_mandir}/ja/man8/
154install man/synaptic.ja.8 %{buildroot}%{_mandir}/ja/man8/synaptic.8
155
156# fixed uri of manual.
157sed -i 's@file://usr@file:///usr@' %{buildroot}%{_datadir}/omf/synaptic/*.omf
158
159# remove uninstalled files
160rm -rf %{buildroot}/%{_localstatedir}/scrollkeeper
161rm -rf %{buildroot}/%{_sysconfdir}/X11
162rm -rf %{buildroot}/%{_datadir}/applications/%{name}-kde.desktop
163
164%clean
165rm -rf %{buildroot}
166
167
168%files
169%defattr(-,root,root)
170%doc COPYING* README* TODO
171%attr(755,root,root) %{_sbindir}/synaptic
172%attr(755,root,root) %{_bindir}/synaptic
173%{_sysconfdir}/security/console.apps/synaptic
174%{_sysconfdir}/pam.d/synaptic
175%{_datadir}/locale/*/LC_MESSAGES/%{name}.mo
176%{_datadir}/%{name}
177%{_datadir}/applications/%{name}.desktop
178%{_datadir}/pixmaps/%{name}.png
179%{_datadir}/omf/synaptic/*.omf
180%{_datadir}/gnome/help/synaptic
181%{_mandir}/man8/*
182%{_mandir}/ja/man8/*
183
184%changelog
185* Sun Oct 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-21
186- add patch29 to fix crash in "Lock package"
187
188* Mon Sep 17 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-20
189- rebuild with rpm-4.10.0
190
191* Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.57.2-19
192- fix Patch100
193
194* Wed Jan 04 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.57.2-18
195- add Patch100 (synaptic-0.57.2-build-with-rpm-4.9.patch) (fix <BTS:1244>)
196
197* Thu Dec 22 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-17
198- rebuild with rpm-4.9.1.2
199
200* Wed Jun 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-16
201- use config-util for pam/usermode settings
202
203* Mon May 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-15
204- rebuild with apt-0.5.15lorg3.95-10.git522
205
206* Mon Apr 18 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-14
207- update Source10 and Source20.
208
209* Wed Apr 13 2011 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-13
210- fixed uri of manual.
211
212* Thu Jan 27 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.57.2-12
213- add Patch28: fix reinstall error (<BTS:VineLinux:356>)
214- add BuildRequires: desktop-file-utils
215
216* Fri Feb  5 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.57.2-11
217- rebuilt with rpm-4.8.0-3 (on ppc)
218
219* Tue Feb 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-10
220- rebuild with rpm-4.8.0
221
222* Fri Aug 21 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-9
223- add %Patch26: fix segfault when changing repository order
224  <BTS:VineLinux:0645>
225- add %Patch27: fix crash when changing fonts <BTS:VineLinux:0751>
226
227* Sun Aug 09 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-8
228- add %Patch25: add custom filter for multiple verision package
229- update Source10: add translation in ja.po
230- update Patch24: not to skip multiple version warning dialog
231
232* Sat Jul 11 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-7
233- add Patch24: don't skip taskbar when main window is hidden
234
235* Mon Jun 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-6
236- add Patch23: fix assertion failure on gtk_widget_hide
237
238* Sun Jun 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-5
239- add Patch21: fix memory corruption bug.
240- add Patch22: convert EUC text to UTF-8
241
242* Mon May 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-4
243- update ja.po
244- don't apply patch12
245
246* Tue Jul 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-3
247- update pam.d/synaptic for pam-1.0
248
249* Fri May 16 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.57.2-2
250- add BuildRequires perl-XML-Parser
251
252* Sat May 10 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.57.2-1
253- apply new versioning policy
254- rebuild with apt-0.5.15lorg3.94a
255
256* Wed Nov 21 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl18
257- add "Applications/Accessories" and "Restricted Software" to grouplist
258- update ja.po
259
260* Fri Oct 19 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl17
261- add Patch2,3,4 to support apt-0.5.15lorg3.93
262- renumber Patch16 to Patch1
263- add Patch16 to use firefox instead of mozilla
264
265* Sun Oct 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl16
266- rebuild with apt-0.5.15lorg3.93
267
268* Sun Oct 14 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl15
269- rebuild with rpm-4.4.2.2
270
271* Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl14
272- rebuild with new environment
273- add patch16 to build with gcc4
274- add SOURCE30 to use vine icon for package-supported.png
275
276* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl13
277- rebuild with vte-0.16
278
279* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl12
280- add Patch15 to modify default windows size and treeview font size
281
282* Sun Nov 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl11
283- add Patch14 to change default upgrade method to normal upgrade
284  instead of dist-upgrade.
285
286* Thu Nov 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.57.2-0vl10
287- update required-version of apt (>= 0.5.15lorg3.2-0vl7)
288  - comes from libapt-pkg(MountCdrom) API change
289
290* Fri Oct 27 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl9
291- add Patch13 for libapt-pkg(MountCdrom) API change.
292
293* Tue Sep 19 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl8
294- add Patch12 to fix broken summary and descriptions on UTF-8 locale.
295  - convert rpm summaries and descriptions to UTF-8 from EUC-JP.
296
297* Wed Aug 23 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.57.2-0vl7
298- add BuildRequires: scrollkeeper
299
300* Sun May 28 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.57.2-0vl6
301- rebuilt with apt-0.5.15org3.1
302
303* Sun May 21 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl5
304- add Patch11 to use locale to show help messages instead of utf-8.
305
306* Tue Apr 11 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl4
307- rebuild with new apt
308- change Group to Applications/Administration
309
310* Sat Feb 11 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-0vl3
311- update ja.po from [VineSeed:10523] etc...
312
313* Sat Feb 11 2006 Yasumichi Akahoshi <yasumichi@vinelinux.org> 0.57.2-0vl2
314- update ja.po
315
316* Fri Dec 16 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.57.2-0vl1
317- new upstream release
318- update ja.po
319- build with rpm-4.4
320
321* Sun May 08 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56-0vl1
322- new upstream release
323
324* Thu Apr 07 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.56-0vl0
325- new upstream version (0.56beta)
326
327* Thu Nov 04 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.55.1-0vl1
328- new upstream release
329
330* Tue Nov 02 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.55-0vl1
331- new upstream release
332- update ja.po
333
334* Mon Nov 01 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53.4-0vl1
335- new upstream release
336- update ja.po
337
338* Sun Aug 15 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.53-0vl1
339- new upstream release
340- update ja.po
341
342* Tue Jul 06 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.52-0vl1
343- new upstream release
344
345* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl3
346- do not run automake/autoconf in %%build
347
348* Fri Jun 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl2
349- add japanese man page.
350
351* Wed Jun 23 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.51-0vl1
352- new upstream release
353
354* Tue Jun 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl2
355- more update ja.po
356
357* Tue Jun 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.50-0vl1
358- new upstream release
359- update ja.po (merged cvs head)
360- add patch10 to fix 'filter' on non-UTF8 locale (merged in cvs head)
361
362* Sat Apr 10 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48.2-0vl1
363- new upstream release
364- remove obsolete ja.po that is included in upstream
365
366* Sat Mar 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48.1-0vl1
367- new upstream release
368- update ja.po
369- add BuildRequires: xmlto to build manuals.
370
371* Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.48-0vl0.2
372- new upstream test release
373  - fix desktopfile to use usermode instead of gksu.
374
375* Thu Dec 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0vl1
376- new upstream release
377  - Fixed many i18n issues (thanks to Ales Kapica and Jean-Michel Poure)
378  - New Czech, Arabic translation
379  - Updated Polish,Spanish,French,Japanese,Chinese,German translation
380  - Minor documentation updates
381  - Reworked the context menu for packages
382  - Some ui improvements in the common tab
383  - Use units according to the SI spec now
384  - New summary window
385  - A lot of minor bug and typo fixes
386
387* Tue Nov 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.47-0vl0
388- new upstream pre release
389
390* Tue Nov 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.46-0vl1
391- new upstream release
392  - font selection added for default interface font and terminal
393  - better support for translated descriptions (thanks johnnybgate)
394  - dist-upgrade is gone from the menu, the user is asked what kind of
395    upgrade he wants now
396  - toolbar has a new style (text beside buttons) now
397  - real docbook help added (yeah! thanks SEBASTIAN)
398  - "hold" button gone from the gui, moved to menü
399  - sections can translated and a more descriptive description is used
400  - rpm-src-dir support added (thanks to Panu Matilainen)
401
402* Sun Oct 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.45-0vl1
403- fixed kanji code in spec file..
404- new upstream release
405  - proxy can be configured with the gui now
406  - new preferences dialog layout (thanks Sebastian Heinlein)
407  - new filter dialog layout  (thanks Sebastian Heinlein)
408  - when adding filter, they are called "New Filter 1", "New Filter 2" etc
409  - added "search lack", so that the interactive search does not start
410    immediately
411  - new quit dialog
412  - speedup for the pattern filters
413  - small ui-enhancements in the filter dialog
414  - basic support for distribution selection (if you have more than one
415    distro in your sources.list, you can choose which to use by default)
416  - new about dialog (thanks Sebastian)
417  - support to choose between different versions of a given package
418  - updated japanese, chinese, polish, spanish, russian, frensh, german
419    and italian translations
420               
421* Wed Sep 24 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.44-0vl1
422- new upstream release
423  - two alternative main layouts can be choosen now
424  - "clean cache now" implemented" in preferences window
425  - the search entry in the main window is interactive again
426  - much improved preferences dialog (thanks to Sebastian Heinlein)
427  - new italian, spanish, russian, chinese translation
428  - new belarussian translation
429  - improved main window design (thanks Sebastian Heinlein)
430  - added "rpm-dir" repository support (thanks Panu)
431  - prepeared a lot of strings for better i18n (thanks Jean-Michel POURE)
432
433* Wed Sep 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.44-0vl0.pre3
434- new upstream snapshot release
435
436* Sun Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.43.1-0vl1
437- new upstream release
438  - the descriptionParser for rpm has changed
439    (the actuall parser is configurable now)
440  - new find and changes dialog layout, more HIG compliant
441  - more bugfixes in the PkgTreeView and the new sorting code
442
443* Tue Aug 12 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.42-0vl1
444- new upstream release
445  - download percentage is now always calculated correctly
446  - save selection on "pin", "update" and "proceed" now
447  - some bugs fixed in the new sortable tree/list
448  - the order of the columns in the treeview is configurable now
449  - updated german/spanish/japanese/russian translation
450  - [debian only] debian package tags support
451  - sortable installed size column added
452  - "Information" tab now scrollable
453
454* Wed Jul 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.40-0vl1
455- new upstream release
456
457* Tue Jul  8 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.39-0vl2
458- remove BuildRequires: libzvt
459
460* Sat Jul  5 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.39-0vl1
461- new upstream release
462- update ja.po
463
464* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.38-0vl2
465- update ja.po
466
467* Sat Jun 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.38-0vl1
468- new upstream release
469
470* Thu Jun 19 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.37-0vl1
471- new upstream release
472
473* Fri Apr 25 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.36.1-0vl1
474- new upstream release
475
476* Thu Apr 17 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.36-0vl1
477- new upstream release 0.36
478- fixed usermode configuration file.
479
480* Tue Apr 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35.1-0vl2
481- rebuild with apt-0.5.5.cnc.5-0vl1
482
483* Wed Apr  2 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35.1-0vl1
484- new upstream release 0.35.1
485- drop obsolete patch0 which included in upstream.
486- add modified synaptic.desktop entry.
487
488* Mon Mar 31 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35-0vl2
489- add patch0 to fix compilation failure on apt-rpm.
490- add ja.po and patch10.
491
492* Sun Mar 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.35-0vl1
493- new upstream release
494
495* Fri Mar 28 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.32-0vl1
496- initial release.
497
Note: See TracBrowser for help on using the repository browser.