source: projects/specs/trunk/s/swig/swig-vl.spec @ 8591

Revision 8591, 5.3 KB checked in by daisuke, 10 years ago (diff)

swig: update to 3.0.2

Line 
1%define tcl 0
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): C/C++/Objective C を高レベル言語から利用するためのツール
6Name: swig
7Version: 3.0.2
8Release: 1%{?_dist_release}
9License: GPLv3+ and BSD
10Group: Development/Tools
11URL: http://swig.sourceforge.net/
12Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
13
14BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
15BuildRequires: perl, python-devel, pcre-devel
16BuildRequires: ruby-devel
17BuildRequires: lua-devel
18%if %{tcl}
19BuildRequires: tcl-devel
20%endif
21%if %{guile}
22BuildRequires: guile-devel
23%endif
24BuildRequires: autoconf, automake, gawk, nkf
25Obsoletes: swig-runtime
26
27%description
28Simplified Wrapper and Interface Generator (SWIG) is a software
29development tool for connecting C, C++ and Objective C programs with a
30variety of high-level programming languages.  SWIG is primarily used
31with Perl, Python and Tcl/TK, but it has also been extended to Java,
32Eiffel and Guile.  SWIG is normally used to create high-level
33interpreted programming environments, systems integration, and as a
34tool for building user interfaces
35
36%package doc
37Summary: Documentation files for SWIG
38Summary(ja): Documentation files for SWIG
39License: BSD
40Group: Development/Tools
41BuildArch: noarch
42
43%description doc
44This package contains documentation for SWIG and useful examples
45
46%prep
47%setup -q -n swig-%{version}
48
49# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
50# (specific req/prov filtering). Before you remove this hack make sure you don't
51# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
52cat << \EOF > %{name}-prov
53#!/bin/sh
54%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
55EOF
56
57%global __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
58chmod +x %{__perl_provides}
59
60cat << \EOF > %{name}-req
61#!/bin/sh
62%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
63EOF
64
65%global __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
66chmod +x %{__perl_requires}
67
68for all in CHANGES README; do
69        iconv -f ISO88591 -t UTF8 < $all > $all.new
70        touch -r $all $all.new
71        mv -f $all.new $all
72done
73
74%build
75./autogen.sh
76%configure
77make %{?_smp_mflags}
78
79# Test suite is currently broken
80#make check
81
82%install
83rm -rf %{buildroot}
84
85make clean-examples
86
87pushd Examples/
88# Remove all arch dependent files in Examples/
89find -type f -name 'Makefile.in' | xargs rm -f --
90
91# We don't want to ship files below.
92rm -rf test-suite
93find -type f -name '*.dsp' | xargs rm -f --
94find -type f -name '*.dsw' | xargs rm -f --
95
96# Convert files to UNIX format
97for all in `find -type f`; do
98        nkf --unix $all
99        chmod -x $all
100done
101popd
102
103make DESTDIR=%{buildroot} install
104
105%clean
106rm -rf %{buildroot}
107
108%files
109%defattr(-,root,root,-)
110%{_bindir}/*
111%{_datadir}/swig
112%{_mandir}/man1/ccache-swig.1*
113%doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
114%doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
115
116%files doc
117%defattr(-,root,root,-)
118%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
119
120%changelog
121* Mon Jun 16 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 3.0.2-1
122- update to 3.0.2
123
124* Fri Apr 18 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.0-1
125- update to 3.0.0
126- add BR: ruby-devel, lua-devel
127
128* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
129- update to 2.0.8
130- build with pcre-8.31
131
132* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
133- rebuild with python-2.7.2
134
135* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
136- update to 2.0.4
137
138* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
139- add missing man file(s) to the filelist
140
141* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
142- new upstream release
143- rebuild with new toolchain
144
145* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
146- new upstream release
147
148* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
149- new upstream release
150- removed php-devel and ruby-devel from BuildPreReq:.
151
152* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
153- new upstream release
154- use %%configure
155- remove runtime subpackage
156
157* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
158- 1.3.21-0vl2
159- un-libtoolize (tarball have already been libtoolized).
160- fix %%clean.
161- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
162
163* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
164- 1.3.21-0vl1
165- update version
166
167* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
168- 1.3.20-0vl1
169- update version
170
171* Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
172- update version
173
174* Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
175- update version
176
177* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
178- import to Vine Linux
179
180* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
181- BM.
182- Clean up specs.
183- 1.3a3.
184
185* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
186- Use makeinstall macros.
187
188* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
189
190- Provides: swig
191
192* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
193- rebuild with new perl
194- cleanup
195
196* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
197
198- Rebuilt on kenobi
199- Don't use prefix
200
201* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
202
203- First RPM for Mandrake
204
Note: See TracBrowser for help on using the repository browser.