source: projects/specs/trunk/s/swig/swig-vl.spec @ 5057

Revision 5057, 5.0 KB checked in by daisuke, 13 years ago (diff)

swig: update to 2.0.4

Line 
1%define tcl 0
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): Connects C/C++/Objective C to some high-level programming languages
6Name: swig
7Version: 2.0.4
8Release: 1%{?_dist_release}
9License: GPLv3+ and BSD
10Group: Development/Tools
11URL: http://swig.sourceforge.net/
12Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
13Patch1: swig-1.3.23-pylib.patch
14Patch4: swig203-rh706140.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: perl, python-devel, pcre-devel
18%if %{tcl}
19BuildRequires: tcl-devel
20%endif
21%if %{guile}
22BuildRequires: guile-devel
23%endif
24BuildRequires: autoconf, automake, gawk, nkf
25Obsoletes: swig-runtime
26
27%description
28Simplified Wrapper and Interface Generator (SWIG) is a software
29development tool for connecting C, C++ and Objective C programs with a
30variety of high-level programming languages.  SWIG is primarily used
31with Perl, Python and Tcl/TK, but it has also been extended to Java,
32Eiffel and Guile.  SWIG is normally used to create high-level
33interpreted programming environments, systems integration, and as a
34tool for building user interfaces
35
36%package doc
37Summary: Documentation files for SWIG
38Summary(ja): Documentation files for SWIG
39License: BSD
40Group: Development/Tools
41BuildArch: noarch
42
43%description doc
44This package contains documentation for SWIG and useful examples
45
46%prep
47%setup -q -n swig-%{version}
48%patch1 -p1 -b .pylib
49%patch4 -p1 -b .rh706140
50
51# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
52# (specific req/prov filtering). Before you remove this hack make sure you don't
53# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
54cat << \EOF > %{name}-prov
55#!/bin/sh
56%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
57EOF
58
59%define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
60chmod +x %{__perl_provides}
61
62cat << \EOF > %{name}-req
63#!/bin/sh
64%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
65EOF
66
67%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
68chmod +x %{__perl_requires}
69
70for all in CHANGES README; do
71        iconv -f ISO88591 -t UTF8 < $all > $all.new
72        touch -r $all $all.new
73        mv -f $all.new $all
74done
75
76%build
77./autogen.sh
78%configure
79make %{?_smp_mflags}
80
81# Test suite is currently broken
82#make check
83
84%install
85rm -rf %{buildroot}
86
87pushd Examples/
88# Remove all arch dependent files in Examples/
89find -type f -name 'Makefile.in' | xargs rm -f --
90
91# We don't want to ship files below.
92rm -rf test-suite
93find -type f -name '*.dsp' | xargs rm -f --
94find -type f -name '*.dsw' | xargs rm -f --
95
96# Convert files to UNIX format
97for all in `find -type f`; do
98        nkf --unix $all
99        chmod -x $all
100done
101popd
102
103make DESTDIR=%{buildroot} install
104
105%clean
106rm -rf %{buildroot}
107
108%files
109%defattr(-,root,root,-)
110%{_bindir}/*
111%{_datadir}/swig
112%{_mandir}/man1/ccache-swig.1*
113%doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
114%doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
115
116%files doc
117%defattr(-,root,root,-)
118%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
119
120%changelog
121* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
122- update to 2.0.4
123
124* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
125- add missing man file(s) to the filelist
126
127* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
128- new upstream release
129- rebuild with new toolchain
130
131* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
132- new upstream release
133
134* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
135- new upstream release
136- removed php-devel and ruby-devel from BuildPreReq:.
137
138* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
139- new upstream release
140- use %%configure
141- remove runtime subpackage
142
143* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
144- 1.3.21-0vl2
145- un-libtoolize (tarball have already been libtoolized).
146- fix %%clean.
147- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
148
149* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
150- 1.3.21-0vl1
151- update version
152
153* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
154- 1.3.20-0vl1
155- update version
156
157* Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
158- update version
159
160* Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
161- update version
162
163* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
164- import to Vine Linux
165
166* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
167- BM.
168- Clean up specs.
169- 1.3a3.
170
171* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
172- Use makeinstall macros.
173
174* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
175
176- Provides: swig
177
178* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
179- rebuild with new perl
180- cleanup
181
182* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
183
184- Rebuilt on kenobi
185- Don't use prefix
186
187* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
188
189- First RPM for Mandrake
190
Note: See TracBrowser for help on using the repository browser.