source: projects/specs/trunk/s/swig/swig-vl.spec @ 7005

Revision 7005, 5.1 KB checked in by daisuke, 12 years ago (diff)

swig: update to 2.0.8, build with pcre-8.31

RevLine 
[5057]1%define tcl 0
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
[7005]5Summary(ja): C/C++/Objective C を高レベル言語から利用するためのツール
[521]6Name: swig
[7005]7Version: 2.0.8
8Release: 1%{?_dist_release}
[5057]9License: GPLv3+ and BSD
10Group: Development/Tools
[521]11URL: http://swig.sourceforge.net/
[5057]12Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
13Patch4: swig203-rh706140.patch
14
15BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
16BuildRequires: perl, python-devel, pcre-devel
17%if %{tcl}
18BuildRequires: tcl-devel
19%endif
20%if %{guile}
[521]21BuildRequires: guile-devel
[5057]22%endif
23BuildRequires: autoconf, automake, gawk, nkf
[521]24Obsoletes: swig-runtime
25
26%description
[5057]27Simplified Wrapper and Interface Generator (SWIG) is a software
28development tool for connecting C, C++ and Objective C programs with a
29variety of high-level programming languages.  SWIG is primarily used
30with Perl, Python and Tcl/TK, but it has also been extended to Java,
31Eiffel and Guile.  SWIG is normally used to create high-level
32interpreted programming environments, systems integration, and as a
33tool for building user interfaces
[521]34
[5057]35%package doc
36Summary: Documentation files for SWIG
37Summary(ja): Documentation files for SWIG
38License: BSD
39Group: Development/Tools
40BuildArch: noarch
[521]41
[5057]42%description doc
43This package contains documentation for SWIG and useful examples
44
[521]45%prep
[5057]46%setup -q -n swig-%{version}
47%patch4 -p1 -b .rh706140
[521]48
[5057]49# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
50# (specific req/prov filtering). Before you remove this hack make sure you don't
51# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
52cat << \EOF > %{name}-prov
53#!/bin/sh
54%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
55EOF
56
57%define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
58chmod +x %{__perl_provides}
59
60cat << \EOF > %{name}-req
61#!/bin/sh
62%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
63EOF
64
65%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
66chmod +x %{__perl_requires}
67
68for all in CHANGES README; do
69        iconv -f ISO88591 -t UTF8 < $all > $all.new
70        touch -r $all $all.new
71        mv -f $all.new $all
72done
73
[521]74%build
[5057]75./autogen.sh
[521]76%configure
[5057]77make %{?_smp_mflags}
[521]78
[5057]79# Test suite is currently broken
80#make check
81
[521]82%install
83rm -rf %{buildroot}
84
[5057]85pushd Examples/
86# Remove all arch dependent files in Examples/
87find -type f -name 'Makefile.in' | xargs rm -f --
[521]88
[5057]89# We don't want to ship files below.
90rm -rf test-suite
91find -type f -name '*.dsp' | xargs rm -f --
92find -type f -name '*.dsw' | xargs rm -f --
93
94# Convert files to UNIX format
95for all in `find -type f`; do
96        nkf --unix $all
97        chmod -x $all
98done
99popd
100
101make DESTDIR=%{buildroot} install
102
[521]103%clean
104rm -rf %{buildroot}
105
106%files
[5057]107%defattr(-,root,root,-)
[521]108%{_bindir}/*
109%{_datadir}/swig
[5057]110%{_mandir}/man1/ccache-swig.1*
111%doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
112%doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
[521]113
[5057]114%files doc
115%defattr(-,root,root,-)
116%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
[521]117
[5057]118%changelog
[7005]119* Thu Oct 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.8-1
120- update to 2.0.8
121- build with pcre-8.31
122
[5701]123* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
124- rebuild with python-2.7.2
125
[5057]126* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
127- update to 2.0.4
128
[521]129* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
130- add missing man file(s) to the filelist
131
132* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
133- new upstream release
134- rebuild with new toolchain
135
136* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
137- new upstream release
138
139* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
140- new upstream release
141- removed php-devel and ruby-devel from BuildPreReq:.
142
143* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
144- new upstream release
145- use %%configure
146- remove runtime subpackage
147
148* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
149- 1.3.21-0vl2
150- un-libtoolize (tarball have already been libtoolized).
151- fix %%clean.
152- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
153
154* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
155- 1.3.21-0vl1
156- update version
157
158* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
159- 1.3.20-0vl1
160- update version
161
162* Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
163- update version
164
165* Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
166- update version
167
168* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
169- import to Vine Linux
170
171* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
172- BM.
173- Clean up specs.
174- 1.3a3.
175
176* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
177- Use makeinstall macros.
178
179* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
180
181- Provides: swig
182
183* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
184- rebuild with new perl
185- cleanup
186
187* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
188
189- Rebuilt on kenobi
190- Don't use prefix
191
192* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
193
194- First RPM for Mandrake
195
Note: See TracBrowser for help on using the repository browser.