source: projects/specs/trunk/s/swig/swig-vl.spec @ 5701

Revision 5701, 5.1 KB checked in by Takemikaduchi, 12 years ago (diff)

python-2.7.2

RevLine 
[5057]1%define tcl 0
2%define guile 0
3
4Summary: Connects C/C++/Objective C to some high-level programming languages
5Summary(ja): Connects C/C++/Objective C to some high-level programming languages
[521]6Name: swig
[5057]7Version: 2.0.4
[5701]8Release: 2%{?_dist_release}
[5057]9License: GPLv3+ and BSD
10Group: Development/Tools
[521]11URL: http://swig.sourceforge.net/
[5057]12Source: http://downloads.sourceforge.net/project/swig/swig/swig-%{version}/swig-%{version}.tar.gz
13Patch1: swig-1.3.23-pylib.patch
14Patch4: swig203-rh706140.patch
15
16BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
17BuildRequires: perl, python-devel, pcre-devel
18%if %{tcl}
19BuildRequires: tcl-devel
20%endif
21%if %{guile}
[521]22BuildRequires: guile-devel
[5057]23%endif
24BuildRequires: autoconf, automake, gawk, nkf
[521]25Obsoletes: swig-runtime
26
27%description
[5057]28Simplified Wrapper and Interface Generator (SWIG) is a software
29development tool for connecting C, C++ and Objective C programs with a
30variety of high-level programming languages.  SWIG is primarily used
31with Perl, Python and Tcl/TK, but it has also been extended to Java,
32Eiffel and Guile.  SWIG is normally used to create high-level
33interpreted programming environments, systems integration, and as a
34tool for building user interfaces
[521]35
[5057]36%package doc
37Summary: Documentation files for SWIG
38Summary(ja): Documentation files for SWIG
39License: BSD
40Group: Development/Tools
41BuildArch: noarch
[521]42
[5057]43%description doc
44This package contains documentation for SWIG and useful examples
45
[521]46%prep
[5057]47%setup -q -n swig-%{version}
48%patch1 -p1 -b .pylib
49%patch4 -p1 -b .rh706140
[521]50
[5057]51# as written on https://fedoraproject.org/wiki/Packaging_talk:Perl, section 2
52# (specific req/prov filtering). Before you remove this hack make sure you don't
53# reintroduce https://bugzilla.redhat.com/show_bug.cgi?id=489421
54cat << \EOF > %{name}-prov
55#!/bin/sh
56%{__perl_provides} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
57EOF
58
59%define __perl_provides %{_builddir}/%{name}-%{version}/%{name}-prov
60chmod +x %{__perl_provides}
61
62cat << \EOF > %{name}-req
63#!/bin/sh
64%{__perl_requires} `perl -p -e 's|\S+%{_docdir}/%{name}-doc-%{version}\S+||'`
65EOF
66
67%define __perl_requires %{_builddir}/%{name}-%{version}/%{name}-req
68chmod +x %{__perl_requires}
69
70for all in CHANGES README; do
71        iconv -f ISO88591 -t UTF8 < $all > $all.new
72        touch -r $all $all.new
73        mv -f $all.new $all
74done
75
[521]76%build
[5057]77./autogen.sh
[521]78%configure
[5057]79make %{?_smp_mflags}
[521]80
[5057]81# Test suite is currently broken
82#make check
83
[521]84%install
85rm -rf %{buildroot}
86
[5057]87pushd Examples/
88# Remove all arch dependent files in Examples/
89find -type f -name 'Makefile.in' | xargs rm -f --
[521]90
[5057]91# We don't want to ship files below.
92rm -rf test-suite
93find -type f -name '*.dsp' | xargs rm -f --
94find -type f -name '*.dsw' | xargs rm -f --
95
96# Convert files to UNIX format
97for all in `find -type f`; do
98        nkf --unix $all
99        chmod -x $all
100done
101popd
102
103make DESTDIR=%{buildroot} install
104
[521]105%clean
106rm -rf %{buildroot}
107
108%files
[5057]109%defattr(-,root,root,-)
[521]110%{_bindir}/*
111%{_datadir}/swig
[5057]112%{_mandir}/man1/ccache-swig.1*
113%doc ANNOUNCE CHANGES CHANGES.current INSTALL LICENSE LICENSE-GPL
114%doc LICENSE-UNIVERSITIES COPYRIGHT README TODO
[521]115
[5057]116%files doc
117%defattr(-,root,root,-)
118%doc Doc Examples LICENSE LICENSE-GPL LICENSE-UNIVERSITIES COPYRIGHT
[521]119
[5057]120%changelog
[5701]121* Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.4-2
122- rebuild with python-2.7.2
123
[5057]124* Sat Oct 29 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.4-1
125- update to 2.0.4
126
[521]127* Tue Mar 02 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.3.40-2
128- add missing man file(s) to the filelist
129
130* Mon Mar 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.3.40-1
131- new upstream release
132- rebuild with new toolchain
133
134* Fri Sep 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.35-1
135- new upstream release
136
137* Wed Mar 28 2007 NAKAMURA Kenta <kenta@vinelinux.org> 1.3.31-0vl1
138- new upstream release
139- removed php-devel and ruby-devel from BuildPreReq:.
140
141* Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.29-0vl1
142- new upstream release
143- use %%configure
144- remove runtime subpackage
145
146* Sun Jan 23 2005 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net>
147- 1.3.21-0vl2
148- un-libtoolize (tarball have already been libtoolized).
149- fix %%clean.
150- add guile-devel, php-devel, python-devel and ruby-devel to BuildPreReq:.
151
152* Wed Mar 03 2004 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
153- 1.3.21-0vl1
154- update version
155
156* Sat Dec 27 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
157- 1.3.20-0vl1
158- update version
159
160* Mon Jun 03 2003 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
161- update version
162
163* Mon Mar 03 2002 Seiya Nishizawa <seiya@kugi.kyoto-u.ac.jp>
164- update version
165
166* Mon Mar 26 2001 Kazuhisa TAKEI <takei@vinelinux.org>
167- import to Vine Linux
168
169* Wed Jul 19 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.3a3-1mdk
170- BM.
171- Clean up specs.
172- 1.3a3.
173
174* Tue Jun 20 2000 Chmouel Boudjnah <chmouel@mandrakesoft.com> 1.1p5-5mdk
175- Use makeinstall macros.
176
177* Mon Apr 10 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-4mdk
178
179- Provides: swig
180
181* Mon Apr  3 2000 Pixel <pixel@mandrakesoft.com> 1.1p5-3mdk
182- rebuild with new perl
183- cleanup
184
185* Wed Mar 22 2000 Francis Galiegue <fg@mandrakesoft.com> 1.1p5-2mdk
186
187- Rebuilt on kenobi
188- Don't use prefix
189
190* Fri Mar 10 2000 Francis Galiegue <francis@mandrakesoft.com> 1.1p5-1mdk
191
192- First RPM for Mandrake
193
Note: See TracBrowser for help on using the repository browser.