source: projects/specs/trunk/s/svgalib/svgalib-vl.spec @ 521

Revision 521, 6.6 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary:        A low-level fullscreen SVGA graphics library.
2Name:           svgalib
3Version:        1.9.25
4Release:        1%{?_dist_release}
5Exclusivearch:  %{ix86} x86_64
6License:        distributable
7Group:          System Environment/Libraries
8Source:         http://www.arava.co.il/matan/svgalib/svgalib-%{version}.tar.gz
9Source1:        svgalib-todo
10Patch0:         svgalib-1.9.21-makefiles.patch
11Patch1:         svgalib-1.4.3-fhs.patch
12Patch2:         svgalib-1.9.21-demos.patch
13Patch3:         svgalib-1.9.21-cfg.patch
14Patch4:         svgalib-1.9.25-kernel-2.6.26.patch
15BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
16
17%description
18The svgalib package provides the SVGAlib low-level graphics library
19for Linux.  SVGAlib is a library which allows applications to use full
20screen graphics on a variety of hardware platforms.  Many games and
21utilities use SVGAlib for their graphics.
22
23You'll need to have the svgalib package installed if you use any of
24the programs which rely on SVGAlib for their graphics support.
25
26#'
27%package devel
28Summary: Development tools for programs using the SVGAlib graphics library.
29Group: Development/Libraries
30Requires: svgalib = %{version}-%{release}
31Provides: libvga-devel = %{version}-%{release}
32
33%description devel
34The svgalib-devel package contains the libraries and header files
35needed to build programs which will use the SVGAlib low-level graphics
36library.
37
38Install the svgalib-devel package if you want to develop applications
39which will use the SVGAlib library.
40
41%prep
42%setup -q
43%patch0 -p1 -b .makefiles
44%patch1 -p1 -b .fhs
45%patch2 -p1
46%patch3 -p1 -b .defaultcfg
47%patch4 -p1
48
49#the testlinear demo needs svgalib's internal libvga header, so copy it to the
50#demo dir
51%__cp src/libvga.h demos
52
53
54%build
55#%{?_smp_mflags} doesn't work on x86_64 chances are it will fail on
56#some i386 machines too.
57%__make OPTIMIZE="$RPM_OPT_FLAGS -Wno-pointer-sign" LDFLAGS= \
58  prefix=%{_prefix} \
59  NO_HELPER=y \
60  INCLUDE_ET4000_DRIVER=y \
61  INCLUDE_OAK_DRIVER=y \
62  INCLUDE_MACH32_DRIVER=y \
63  INCLUDE_ET3000_DRIVER=y \
64  INCLUDE_GVGA6400_DRIVER=y \
65  INCLUDE_ATI_DRIVER=y \
66  INCLUDE_G450C2_DRIVER=y \
67  INCLUDE_ET4000_DRIVER_TEST=y \
68  INCLUDE_FBDEV_DRIVER_TEST=y \
69  INCLUDE_VESA_DRIVER_TEST=y \
70  shared
71%__make -C utils \
72    OPTIMIZE="$RPM_OPT_FLAGS -Wno-pointer-sign" LDFLAGS= \
73    prefix=%{_prefix}
74%__make -C threeDKit \
75    OPTIMIZE="$RPM_OPT_FLAGS -Wno-pointer-sign -I../gl" LDFLAGS= \
76    prefix=%{_prefix} lib3dkit.so.%{version}
77
78
79%install
80rm -rf $RPM_BUILD_ROOT
81mkdir -p $RPM_BUILD_ROOT/etc/vga
82mkdir -p $RPM_BUILD_ROOT/%{_libdir}
83make \
84  TOPDIR=$RPM_BUILD_ROOT \
85  prefix=$RPM_BUILD_ROOT/%{_prefix} \
86  mandir=$RPM_BUILD_ROOT/%{_mandir} \
87  sharedlibdir=$RPM_BUILD_ROOT/%{_libdir} \
88  NO_HELPER=y \
89  MANFORMAT=compressed \
90  "INSTALL_PROGRAM=install -p -m 755" \
91  "INSTALL_SCRIPT=install -p -m 755" \
92  "INSTALL_SHLIB=install -p -m 755" \
93  "INSTALL_DATA=install -p -m 644" \
94  install
95ln -s libvga.so.%{version} $RPM_BUILD_ROOT/%{_libdir}/libvga.so.1
96ln -s libvgagl.so.%{version} $RPM_BUILD_ROOT/%{_libdir}/libvgagl.so.1
97ln -s lib3dkit.so.%{version} $RPM_BUILD_ROOT/%{_libdir}/lib3dkit.so.1
98#for %ghost
99touch $RPM_BUILD_ROOT/etc/vga/fontdata
100touch $RPM_BUILD_ROOT/etc/vga/textregs
101
102
103%clean
104%__rm -fr $RPM_BUILD_ROOT
105
106%post -p /sbin/ldconfig
107
108%postun -p /sbin/ldconfig
109
110%files
111%defattr(-,root,root,-)
112%doc doc/CHANGES doc/README.joystick doc/README.keymap lrmi-0.6m/README
113%doc doc/README.multi-monitor doc/README.vesa doc/TODO doc/dual-head-howto
114%dir %{_sysconfdir}/vga/
115%config(noreplace) %{_sysconfdir}/vga/dvorak-us.keymap
116%config(noreplace) %{_sysconfdir}/vga/libvga.config
117%config(noreplace) %{_sysconfdir}/vga/libvga.et4000
118%config(noreplace) %{_sysconfdir}/vga/null.keymap
119%ghost %{_sysconfdir}/vga/fontdata
120%ghost %{_sysconfdir}/vga/textregs
121%{_bindir}/*
122%{_libdir}/*.so.*
123%{_mandir}/man[^3]/*
124
125%files devel
126%defattr(-,root,root,-)
127%doc demos doc/DESIGN doc/Driver-programming-HOWTO doc/README.patching
128%{_includedir}/*
129%{_libdir}/*.so
130%{_mandir}/man3/*
131
132
133%changelog
134* Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.9.25-1
135- new upstream release
136- dropped/updated all old patches based on Fedora development package
137- added Provides: libvga-devel in devel subpackage
138
139* Tue Oct 26 2004 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.3-0vl1
140- updated Patch0, Patch2, Patch4
141- Patch3 and Patch5 were merged into upstream, dropped
142- added Patch7 to build vga.c correctly
143- s/Copyright/License/
144
145* Sat Aug 18 2001 Toru Sagami <sagami@vinelinux.org>
146- 1.4.1-13vl1: was ported to Vine
147
148* Thu Oct 26 2000 Than Ngo <than@redhat.com>
149- rebuilt for 7.1
150
151* Thu Oct 26 2000 Than Ngo <than@redhat.com>
152- fixed makefile to link vgalib in sharelib instead /usr/lib (Bug #19732)
153- fixed undefined reference to `cli' and 'sti'
154
155* Mon Aug 21 2000 Than Ngo <than@redhat.com>
156- fix for building the utils correct
157
158* Sun Aug 20 2000 Than Ngo <than@redhat.com>
159- fix 800x600 mode messed up on matrox millenium I (Bug #16641)
160
161* Fri Aug 11 2000 Tim Powers <timp@redhat.com>
162- rebuilt
163
164* Mon Jul 24 2000 Prospector <prospector@redhat.com>
165- rebuilt
166
167* Mon Jul 24 2000 Than Ngo <than@redhat.de>
168- fix unclean code to built against gcc-2.96-34
169- set chipset Vesa as default
170
171* Wed Jul 12 2000 Than Ngo <than@redhat.de>
172- clean up specfile
173
174* Mon Jun  4 2000 Bill Nottingham <notting@redhat.com>
175- move to powertools
176
177* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
178- handle compressed man pages
179
180* Tue Jan 18 2000 Bill Nottingham <notting@redhat.com>
181- update to 1.4.1 final
182
183* Wed Dec 08 1999 Michael Maher <mike@lastfoot.com>
184- built pre release of 1.4.1
185
186* Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
187- strip binaries
188
189* Fri Aug 27 1999 Bill Nottingham <notting@redhat.com>
190- update to 1.4.0, sort out patches
191
192* Sun May 16 1999 Jeff Johnson <jbj@redhat.com>
193- don't remove old binaries (not from BUILD_ROOT!) during install (#2735).
194
195* Wed Mar 31 1999 Preston Brown <pbrown@redhat.com>
196- moved temporary svgalib files to /var/lib/svgalib
197
198* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
199- auto rebuild in the new build environment (release 2)
200
201* Sun Aug 23 1998 Jeff Johnson <jbj@redhat.com>
202- verify dumpreg is not setuid (problem #760)
203- specfile fiddles
204
205* Thu Jul 30 1998 Cristian Gafton <gafton@redhat.com>
206- upgraded to 1.3.0
207- security patch
208
209* Thu May 07 1998 Prospector System <bugs@redhat.com>
210- translations modified for de, fr, tr
211
212* Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
213- devel package moved to Development/Libraries
214
215* Mon Apr 06 1998 Erik Troan <ewt@redhat.com>
216- updated to svgalib 1.2.13
217- uses a build root
218
219* Mon Nov  3 1997 Michael Fulbright <msf@redhat.com>
220- removed Mach64 from configuration, as the driver does not work
221
222* Tue Oct 14 1997 Donnie Barnes <djb@redhat.com>
223- spec file cleanups
224
Note: See TracBrowser for help on using the repository browser.