source: projects/specs/trunk/s/suricata/suricata-vl.spec @ 12473

Revision 12473, 17.5 KB checked in by tomop, 4 years ago (diff)

updated 7 packages

colm-0.13.0.7-4

hiredis-1.0.0-1

hyperscan-5.3.0-1

kelbt-0.16-11

libbpf-0.0.9-1

ragel-7.0.0.12-5

suricata-5.0.3-2

Line 
1%bcond_with systemd
2%bcond_with libprelude
3
4Summary:        Intrusion Detection System
5Name:           suricata
6Version:        5.0.3
7Release:        2%{?_dist_release}%{?with_systemd:.systemd}
8Group:          network
9Vendor:         Project Vine
10Distribution:   Vine Linux
11
12License:        GPLv2
13URL:            https://suricata-ids.org/
14Source0:        https://www.openinfosecfoundation.org/download/%{name}-%{version}.tar.gz
15Source1:        suricata.sysconfig
16Source2:        fedora.notes
17Source3:        suricata-tmpfiles.conf
18
19Source1000:     suricata.init
20Source1001:     suricata.logrotate
21
22# Irrelevant docs are getting installed, drop them
23Patch1: suricata-2.0.9-docs.patch
24# Suricata service file needs some options supplied
25Patch2: suricata-4.1.1-service.patch
26# Linux 5.2 headers moved SIOCGSTAMP to linux/sockios.h. Glibc will
27# include it via sys/socket.h in a future release. This is temporary
28# and should not be needed on other kernel/glibc combos.
29Patch3: suricata-4.1.4-socket.patch
30
31BuildRequires: gcc gcc-c++
32BuildRequires: rust cargo
33BuildRequires: libyaml-devel python3-pyyaml
34BuildRequires: libnfnetlink-devel libnetfilter_queue-devel libnet-devel
35BuildRequires: zlib-devel pcre-devel libcap-ng-devel
36BuildRequires: lz4-devel libpcap-devel
37BuildRequires: nspr-devel nss-devel file-devel
38BuildRequires: jansson-devel libmaxminddb-devel python3-devel lua-devel
39BuildRequires: python3-rpm-macros
40# Next line is for eBPF support
41%ifarch x86_64
42BuildRequires: clang llvm libbpf-devel
43%endif
44BuildRequires: autoconf automake libtool
45%if %{with systemd}
46BuildRequires: systemd
47%endif
48BuildRequires: hiredis-devel
49BuildRequires: libevent-devel
50%if %{with libprelude}
51BuildRequires: libprelude-devel
52%endif
53BuildRequires: gnutls-devel
54
55%ifarch x86_64
56BuildRequires: hyperscan-devel
57%endif
58
59Requires:       python3-pyyaml
60
61Requires(pre): /usr/sbin/useradd
62%if %{with systemd}
63Requires(post): systemd
64Requires(preun): systemd
65Requires(postun): systemd
66%endif
67
68%description
69The Suricata Engine is an Open Source Next Generation Intrusion
70Detection and Prevention Engine. This engine is not intended to
71just replace or emulate the existing tools in the industry, but
72will bring new ideas and technologies to the field. This new Engine
73supports Multi-threading, Automatic Protocol Detection (IP, TCP,
74UDP, ICMP, HTTP, TLS, FTP and SMB! ), Gzip Decompression, Fast IP
75Matching, and GeoIP identification.
76
77
78%debug_package
79
80
81%prep
82%setup -q
83install -m 644 %{SOURCE2} doc/
84%patch1 -p1
85%patch2 -p1
86%patch3 -p1
87sed -i 's/(datadir)/(sysconfdir)/' etc/Makefile.am
88%ifarch x86_64
89sed -i 's/-D__KERNEL__/-D__KERNEL__ -D__x86_64__/' ebpf/Makefile.am
90%endif
91autoreconf -fv --install
92
93
94%build
95%configure --enable-gccprotect --enable-pie --disable-gccmarch-native \
96        --disable-coccinelle --enable-nfqueue --enable-af-packet \
97        --with-libnspr-includes=/usr/include/nspr4 \
98        --with-libnss-includes=/usr/include/nss3 \
99        --enable-jansson --enable-geoip --enable-lua --enable-hiredis \
100%if %{with libprelude}
101        --enable-prelude \
102%endif
103        --enable-rust  \
104%ifarch x86_64
105        --enable-ebpf-build --enable-ebpf \
106%endif
107        --enable-python
108
109%make_build
110
111
112%install
113make DESTDIR="%{buildroot}" "bindir=%{_sbindir}" install
114
115# Setup etc directory
116mkdir -p %{buildroot}%{_sysconfdir}/%{name}/rules
117#install -m 640 rules/*.rules %{buildroot}%{_sysconfdir}/%{name}/rules
118for f in rules/*.rules; do
119    touch %{buildroot}%{_sysconfdir}/%{name}/$f
120done
121install -m 600 *.config %{buildroot}%{_sysconfdir}/%{name}
122install -m 600 suricata.yaml %{buildroot}%{_sysconfdir}/%{name}
123%if %{with systemd}
124mkdir -p %{buildroot}%{_unitdir}
125install -m 0644 etc/%{name}.service %{buildroot}%{_unitdir}/
126sed -i -e 's|/var/run/|/run/|' %{buildroot}%{_unitdir}/%{name}.service
127%else
128mkdir -p %{buildroot}%{_initdir}
129install -m 0644 %{SOURCE1000} %{buildroot}%{_initdir}/%{name}
130%endif
131mkdir -p %{buildroot}%{_sysconfdir}/sysconfig
132install -m 0755 %{SOURCE1} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
133
134# Set up logging
135mkdir -p %{buildroot}/%{_var}/log/%{name}
136mkdir -p %{buildroot}%{_sysconfdir}/logrotate.d
137#install -m 644 etc/%{name}.logrotate %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
138#sed -i -e 's|/var/run/%{name}\.pid|/var/run/%{name}/%{name}.pid|' %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
139install -m 644 %{SOURCE1001} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
140
141# Remove a couple things so they don't get picked up
142rm -rf %{buildroot}%{_includedir}
143rm -f %{buildroot}%{_libdir}/libhtp.la
144rm -f %{buildroot}%{_libdir}/libhtp.a
145rm -f %{buildroot}%{_libdir}/libhtp.so
146rm -rf %{buildroot}%{_libdir}/pkgconfig
147
148# Setup suricata-update data directory
149mkdir -p %{buildroot}/%{_var}/lib/%{name}
150
151# Setup tmpdirs
152%if %{with systemd}
153mkdir -p %{buildroot}%{_tmpfilesdir}
154install -m 0644 %{SOURCE3} %{buildroot}%{_tmpfilesdir}/%{name}.conf
155%endif
156mkdir -p %{buildroot}/run
157install -d -m 0755 %{buildroot}/run/%{name}/
158
159cp suricata-update/README.rst doc/suricata-update-README.rst
160
161
162%check
163make check
164
165
166%pre
167getent passwd suricata >/dev/null || useradd -r -M -s /sbin/nologin suricata
168
169%post
170%if %{with systemd}
171%systemd_post suricata.service
172%else
173if [ $1 -gt 0 ]; then
174  /sbin/chkconfig --add suricata
175fi
176%endif
177
178%preun
179%if %{with systemd}
180%systemd_preun suricata.service
181%else
182if [ $1 -eq 0 -o -x /bin/systemctl ]; then
183  /sbin/service suricata stop
184  /sbin/chkconfig suricata off ||:
185  /sbin/chkconfig --del suricata
186fi
187%endif
188
189%postun
190%if %{with systemd}
191%systemd_postun_with_restart suricata.service
192%else
193if [ $1 -gt 0 -a -f /var/run/suricata/suricata.pid -a ! -x /bin/systemctl ]; then
194  /sbin/service suricata restart
195fi
196%endif
197
198
199%files
200%doc doc/Basic_Setup.txt doc/suricata-update-README.rst
201%doc doc/Setting_up_IPSinline_for_Linux.txt doc/fedora.notes
202%{!?_licensedir:%global license %%doc}
203%license COPYING
204%attr(644,root,root) %{_mandir}/man1/*
205%{_sbindir}/suricata
206%{_bindir}/suricatasc
207%{_bindir}/suricatactl
208%{_bindir}/suricata-update
209%{_libdir}/libhtp*
210%{python3_sitelib}/suricatasc/*
211%{python3_sitelib}/suricata/*
212%{python3_sitelib}/*egg-info
213%config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/suricata.yaml
214%config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/*.config
215%ghost %config(noreplace) %attr(0640,suricata,suricata) %{_sysconfdir}/%{name}/rules/*.rules
216%config(noreplace) %attr(0600,suricata,root) %{_sysconfdir}/sysconfig/%{name}
217%config(noreplace) %attr(644,root,root) %{_sysconfdir}/logrotate.d/%{name}
218%attr(750,suricata,suricata) %dir %{_var}/log/%{name}
219%attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}
220%attr(750,suricata,suricata) %dir %{_sysconfdir}/%{name}/rules
221%attr(2770,suricata,suricata) %dir %{_var}/lib/%{name}
222%attr(2770,suricata,suricata) %dir /run/%{name}/
223%if %{with systemd}
224%attr(644,root,root) %{_unitdir}/suricata.service
225%{_tmpfilesdir}/%{name}.conf
226%else
227%attr(0755,root,root) %{_initdir}/%{name}
228%endif
229%{_datadir}/%{name}/rules
230
231
232%changelog
233* Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-2
234- rebuilt with python-3.8.
235
236* Tue May 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.3-1
237- new upstream release.
238
239* Wed Apr 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-2
240- rebuilt with libevent-2.1.11.
241
242* Sat Mar 07 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.2-1
243- new upstream release.
244
245* Wed Oct 30 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.0.0-3
246- initial build for Vine Linux.
247
248* Fri Oct 18 2019 Steve Grubb <sgrubb@redhat.com> 5.0.0-2
249- New feature release (which also fixes a security issue)
250- Enable ebpf on x86_64 only
251- Disable building on ppc64le due to rust problems
252
253* Thu Aug 01 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-4
254- Fix FTBFS bz 1736727
255
256* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.4-3
257- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
258
259* Mon Jul 22 2019 Steve Grubb <sgrubb@redhat.com> 4.1.4-2
260- Rebuild for libprelude so bump
261
262* Tue Apr 30 2019 Jason Taylor <jtfas90@gmail.com> 4.1.4-1
263- Upstream bugfix release
264
265* Thu Mar 07 2019 Steve Grubb <sgrubb@redhat.com> 4.1.3-1
266- Upstream bugfix release
267
268* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 4.1.2-2
269- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
270
271* Fri Dec 21 2018 Jason Taylor <jtfas90@gmail.com> 4.1.2-1
272- Upstream bugfix release
273- Updated source to use official download site
274
275* Thu Dec 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-4
276- Adjust permissions on /run/suricata and /var/lib/suricata to group writable
277
278* Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-2
279- Remove ragel requirement
280
281* Mon Dec 17 2018 Steve Grubb <sgrubb@redhat.com> 4.1.1-1
282- Make log directory group readable
283- Allow users of the suricata group to run suricata-update
284- Add lz4-devel BuildRequires to support pcap compression
285- Update service file for systemd security protections
286- Upstream bugfix update
287
288* Tue Nov 20 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-3
289- Use the upstream service and logrote files (#1330331)
290- Make the log directory readable by members of the suricata group (#1651394)
291
292* Wed Nov 07 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-2
293- Add cargo BuildRequires
294
295* Tue Nov 06 2018 Steve Grubb <sgrubb@redhat.com> 4.1.0-1
296- Latest upstream major release
297- Fixes CVE-2018-18956 Segmentation fault in the ProcessMimeEntity function
298
299* Mon Aug 13 2018 Steve Grubb <sgrubb@redhat.com> - 4.0.5-3
300- Consolidate branches so that everything is in sync (#1614935)
301
302* Fri Aug 10 2018 Jason Taylor <jtfas90@gmail.com> 4.0.5-2
303- fixes bz#1614935
304
305* Wed Jul 18 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.5-1
306- upstream security fix release
307- addresses CVE-2018-10242, CVE-2018-10243, CVE-2018-10244
308
309* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.4-3
310- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
311
312* Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-2
313- bumped release for build against hyperscan 5.0.0
314
315* Mon Jul 09 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
316- added gcc-c++ buildrequires
317
318* Thu Feb 15 2018 Jason Taylor <jtfas90@gmail.com> - 4.0.4-1
319- fixes bz#1543250 and bz#1543251
320- multiple upstream bugfixes
321
322* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 4.0.3-3
323- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
324
325* Mon Dec 11 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-2
326- Added prelude support
327
328* Fri Dec 08 2017 Jason Taylor <jtfas90@gmail.com> 4.0.3-1
329- Upstream bugfix release
330
331* Wed Oct 18 2017 Steve Grubb <sgrubb@redhat.com> 4.0.1-1
332- Upstream bugfix update
333
334* Tue Sep 26 2017 Steve Grubb <sgrubb@redhat.com> 4.0.0-2
335- Make suricata user own /run/suricata (#1396150)
336
337* Mon Jul 31 2017 Jason Taylor <jtfas90@gmail.com> 4.0.0-1
338- Latest upstream major release
339- Build now has hyperscan and redis support
340
341* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.3-2
342- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
343
344* Thu Jul 13 2017 Jason Taylor <jtfas90@gmail.com> 3.2.3-1
345- Upstream bugfix update
346
347* Wed Jun 07 2017 Steve Grubb <sgrubb@redhat.com> 3.2.2-1
348- Upstream bugfix update
349
350* Wed Feb 15 2017 Steve Grubb <sgrubb@redhat.com> 3.2.1-1
351- Upstream security update
352
353* Mon Feb 13 2017 Steve Grubb <sgrubb@redhat.com> 3.2-1
354- New upstream feature release
355- Rotate /var/log/suricata/eve.json (#1396151)
356- Fix ownership of /run/suricata (#1396150)
357
358* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.3-2
359- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
360
361* Tue Nov 01 2016 Steve Grubb <sgrubb@redhat.com> 3.1.3-1
362- New upstream bug fix release
363
364* Wed Sep 07 2016 Steve Grubb <sgrubb@redhat.com> 3.1.2-1
365- New upstream bug fix release
366
367* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.1.1-2
368- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
369
370* Wed Jul 13 2016 Steve Grubb <sgrubb@redhat.com> 3.1.1-1
371- New upstream bug fix release
372
373* Wed Jun 22 2016 Steve Grubb <sgrubb@redhat.com> 3.1-1
374- New upstream bug fix release
375
376* Mon Apr 04 2016 Steve Grubb <sgrubb@redhat.com> 3.0.1-1
377- New upstream bug fix release
378
379* Wed Mar 16 2016 Steve Grubb <sgrubb@redhat.com> 3.0-2
380- Fixed Bug 1227085 - Have Suricata start after the network is online
381
382* Mon Mar 07 2016 Steve Grubb <sgrubb@redhat.com> 3.0-1
383- New upstream bug fix release
384
385* Wed Feb 10 2016 Peter Schiffer <pschiffe@redhat.com> 2.0.11-3
386- Run suricata under suricata user
387
388* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.11-2
389- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
390
391* Mon Dec 28 2015 Steve Grubb <sgrubb@redhat.com> 2.0.11-1
392- New upstream bug fix release
393
394* Wed Nov 25 2015 Steve Grubb <sgrubb@redhat.com> 2.0.10-1
395- New upstream bug fix release
396
397* Sat Oct 03 2015 Steve Grubb <sgrubb@redhat.com> 2.0.9-1
398- New upstream bug fix release
399
400* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.8-2
401- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
402
403* Wed May 06 2015 Steve Grubb <sgrubb@redhat.com> 2.0.8-1
404- New upstream security bug fix release
405
406* Thu Feb 26 2015 Steve Grubb <sgrubb@redhat.com> 2.0.7-1
407- New upstream security bug fix release for CVE-2015-0928
408
409* Thu Jan 15 2015 Steve Grubb <sgrubb@redhat.com> 2.0.6-1
410- New upstream bug fix release
411- Don't use the system libhtp library
412
413* Fri Dec 12 2014 Steve Grubb <sgrubb@redhat.com> 2.0.5-1
414- New upstream bug fix release
415- Use the system libhtp library
416
417* Wed Sep 24 2014 Steve Grubb <sgrubb@redhat.com> 2.0.4-1
418- New upstream bug fix release
419- Fixes CVE-2014-6603 out-of-bounds access in SSH parser
420
421* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-2
422- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
423
424* Fri Aug 08 2014 Steve Grubb <sgrubb@redhat.com> 2.0.3-1
425- New upstream bug fix release
426
427* Sat Jun 28 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-2
428- Specfile cleanups (#1113413)
429
430* Wed Jun 25 2014 Steve Grubb <sgrubb@redhat.com> 2.0.2-1
431- New upstream bug fix release
432- Enable liblua support
433
434* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
435- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
436
437* Wed May 21 2014 Steve Grubb <sgrubb@redhat.com> 2.0.1-1
438- New upstream bug fix release
439
440* Wed Mar 26 2014 Steve Grubb <sgrubb@redhat.com> 2.0-1
441- Major new upstream release with new features
442
443* Tue Jan 21 2014 Dan Horák <dan[at]danny.cz> 1.4.7-3
444- luajit available only on selected arches
445
446* Sat Jan 11 2014 Steve Grubb <sgrubb@redhat.com> 1.4.7-2
447- Enable luajit support
448
449* Wed Dec 18 2013 Steve Grubb <sgrubb@redhat.com> 1.4.7-1
450- New upstream bug fix release
451
452* Fri Oct 04 2013 Steve Grubb <sgrubb@redhat.com> 1.4.6-1
453- New upstream bug fix release
454
455* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.3-3
456- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
457
458* Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-2
459- Drop prelude support
460
461* Fri Jun 21 2013 Steve Grubb <sgrubb@redhat.com> 1.4.3-1
462- New upstream bug fix release
463
464* Mon Jun 03 2013 Steve Grubb <sgrubb@redhat.com> 1.4.2-1
465- New upstream bug fix release
466
467* Sun Mar 10 2013 Steve Grubb <sgrubb@redhat.com> 1.4.1-1
468- New upstream bugfix release
469- Enable libgeoip support
470- Switch to stack-protector-all
471
472* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-2
473- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
474
475* Thu Dec 20 2012 Steve Grubb <sgrubb@redhat.com> 1.4-1
476- New upstream feature enhancement release
477
478* Thu Dec 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3.5-1
479- New upstream bugfix release
480
481* Tue Nov 27 2012 Steve Grubb <sgrubb@redhat.com> 1.3.4-1
482- New upstream release
483
484* Mon Nov 05 2012 Steve Grubb <sgrubb@redhat.com> 1.3.3-1
485- New upstream release
486
487* Tue Oct 09 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-2
488- Add nss-devel build require and systemd macros
489
490* Mon Oct 08 2012 Steve Grubb <sgrubb@redhat.com> 1.3.2-1
491- New upstream release
492
493* Sat Aug 25 2012 Steve Grubb <sgrubb@redhat.com> 1.3.1-1
494- New upstream release
495- Switch startup to use systemd
496
497* Fri Jul 06 2012 Steve Grubb <sgrubb@redhat.com> 1.3-1
498- New upstream release
499
500* Fri Mar 30 2012 Jon Ciesla <limburgher@gmail.com> - 1.2.1-3
501- Rebuild for updated libnet.
502
503* Fri Feb 10 2012 Petr Pisar <ppisar@redhat.com> - 1.2.1-2
504- Rebuild against PCRE 8.30
505
506* Thu Feb 02 2012 Steve Grubb <sgrubb@redhat.com> 1.2.1-1
507- New upstream release
508
509* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.1.1-3
510- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
511
512* Thu Dec 22 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-2
513- Enable AF_PACKET support
514
515* Wed Dec 07 2011 Steve Grubb <sgrubb@redhat.com> 1.1.1-1
516- New upstream release
517
518* Mon Jul 25 2011 Steve Grubb <sgrubb@redhat.com> 1.0.5-1
519- New upstream release
520
521* Fri Jun 24 2011 Steve Grubb <sgrubb@redhat.com> 1.0.4-1
522- New upstream release
523
524* Thu Apr 28 2011 Dan Horák <dan[at]danny.cz> 1.0.3-2
525- don't override -march set by the buildsystem (fixes build on non-x86)
526
527* Sat Apr 23 2011 Steve Grubb <sgrubb@redhat.com> 1.0.3-1
528- New upstream release
529
530* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.2-2
531- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
532
533* Wed Nov 10 2010 Steve Grubb <sgrubb@redhat.com> 1.0.2-1
534- New upstream release (#651978)
535
536* Thu Jul 01 2010 Steve Grubb <sgrubb@redhat.com> 1.0.0-1
537- New upstream release
538
539* Fri May 07 2010 Steve Grubb <sgrubb@redhat.com> 0.9.0-1
540- New upstream release
541
542* Tue Apr 20 2010 Steve Grubb <sgrubb@redhat.com> 0.8.2-1
543- New upstream release
544
545* Sat Feb 27 2010 Steve Grubb <sgrubb@redhat.com> 0.8.1-1
546- Initial packaging
547
Note: See TracBrowser for help on using the repository browser.